CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

I am having trouble with the resource scanner within opm. Has been around Slate and Tekto lately and brought a scanner sat along. When I do the survey within the usual distance and polar orbit everything looks fine: the data is transmitted, science points being added and I see the overlay regarding the ore detection. But then when I switch to the planet resources there is still no line with "ore" available and the standard text tells me to do a survey first. When I return to the tracking room and change to the planet, it disappears in the view, zooming out in deep space. Do I chose the scan sat, it is thrown out off the craft list.

Debugger shows that no science entry like "survey@tekto" was found, followed by repeating error: "NullReferenceException: Object reference not set to an instance of an object".

So, sorry to ask, is this a known opm issue or did I made some common failure regarding the installation?! Your mod works well beside this issue: a rover landed at Tekto already and a probe on Eloo, both doing science on different biomes. I have included your mod in my ongoing career and also tried to get rid of this issue by updating to the latest Kopernikus Beta.

Thanks in advance for any help.

Edit: No other mods present, beside Engineer & Chatterer & TransferWindow

Edited by Schaufel

Share this post


Link to post
Share on other sites

Never heard of that. I'll try to look into it.

On a different note, a month or so ago I announced that there was a big easter egg to find in OPM. Sadly it either flew under the radar or no-one was able to find it. Since an easter egg is useless if no one knows about it, I'm going to narrow it down: the easter egg is in the Urlum system. Go and find it people!

Share this post


Link to post
Share on other sites

Huh, I just spent quite a long time hopping around the Urlum system. Guess I'll have to go back!

Share this post


Link to post
Share on other sites
Never heard of that. I'll try to look into it.!

Thank you in advance. If you want some log or safe for analysing, please tell me. Forgot to mention I also included AstroidDay in the game.

Share this post


Link to post
Share on other sites

Hello!

I am having an issue that seems to be connected to either Kopernicus or OPM. In a lot of cases where I have a craft landed at a surface, then the surface textures begin to shake uncontrollably.

It seems that it is really bad with rovers. Has anybody else had this kind of an issue? Does anybody have any suggestions on what to try?

Share this post


Link to post
Share on other sites
Found this one yesterday during my experiments with surfacedust: SPOILER
So, Tal has a bottomless pit?

* Hides evidence*

Pit? which pit? There is no pit.

Share this post


Link to post
Share on other sites
* Hides evidence*

Pit? which pit? There is no pit.

I did notice something similar, but it wasn't on Tal...

Share this post


Link to post
Share on other sites
Found this one yesterday during my experiments with surfacedust: SPOILER

Yep that's it :D I have to say you couldn't have gotten a better image with it, with that dust and all.

I did notice something similar, but it wasn't on Tal...

Well show me, because I don't know of anything other than this. Easter eggs left behind by dev goofs or engine quirks are the best, as they're easter eggs even to the devs :D

Share this post


Link to post
Share on other sites

A maybe stupid question: Do all landable bodies of OPM have resources, i.e. ore? My current mission planning would depend on the answer.

Thread search came up... inconclusive :P

Share this post


Link to post
Share on other sites

Well show me, because I don't know of anything other than this. Easter eggs left behind by dev goofs or engine quirks are the best, as they're easter eggs even to the devs :D

Here it is :)

WARNING: contains spoiler

Javascript is disabled. View full album

Share this post


Link to post
Share on other sites

All landable bodies should have resources. Only resource setup I did was exclude certain bodies from having resources (like the gas giants for example). That's how normal KSP does it as well.

@Sigma, that's probably a result of polar pinching. On Tekto a similar technique was used on purpose, but on Wal it probably wasn't intentional. Good find.

Share this post


Link to post
Share on other sites
Yep that's it :D I have to say you couldn't have gotten a better image with it, with that dust and all.

Thanks, dust will be integrated in the next update of OPMclouds.

I've always enjoyed the easter-egg hunt in OPM and hope to see more in future updates :D

Share this post


Link to post
Share on other sites
All landable bodies should have resources. Only resource setup I did was exclude certain bodies from having resources (like the gas giants for example). That's how normal KSP does it as well.

Thanks for clearing that up!

One more thing: can KER readouts (current version) be trusted regarding TWR of all the OPM bodies?

Really appreciate the work you put into this mod. This will be my first time exploring all of your planets and moons :)

Share this post


Link to post
Share on other sites
I had that problem with both Hale and Ovok, I tried approaching from numbers directions, but it always just impacted before getting to the SOI.

Was just thinking I had too many mods and it messed something up.

Is this still an issue with the actual release? I'm having the same problem with ovok at the moment.

Share this post


Link to post
Share on other sites

You have to approach Hale and Ovok slowly, as if you're doing a rendezvous with a craft. It's not OPM's problem, it's how KSP behaves with tiny, lightweight bodies near massive ones.

Share this post


Link to post
Share on other sites

Ty, Lajos. Actually I am coming in from behind, being somewhat over it on a nearly identical orbit as Ovok itself. The escape icon stays on the surface, no matter what maneuver i place prior the encounter to correct it: it just circles on the surface showing no line. As with your advice I reduced the speed before encounter below 1 m/s relative to Ovok, same result: I am well inside Ovok as the encounter occurs, resulting in destruction of the craft. Do I maneuver on sight to stay away from the surface, an encounter never happen.

Share this post


Link to post
Share on other sites
Ty, Lajos. Actually I am coming in from behind, being somewhat over it on a nearly identical orbit as Ovok itself. The escape icon stays on the surface, no matter what maneuver i place prior the encounter to correct it: it just circles on the surface showing no line. As with your advice I reduced the speed before encounter below 1 m/s relative to Ovok, same result: I am well inside Ovok as the encounter occurs, resulting in destruction of the craft. Do I maneuver on sight to stay away from the surface, an encounter never happen.

You aren't using any other modifications to planets, like rescales or other packs by any chance? Because OPM sets SOIs manually since one or two versions to prevent what you are experiencing... Have you tried on a clean install with the latest version (and hyperedit)?

Share this post


Link to post
Share on other sites
You aren't using any other modifications to planets, like rescales or other packs by any chance? Because OPM sets SOIs manually since one or two versions to prevent what you are experiencing... Have you tried on a clean install with the latest version (and hyperedit)?

I only use chatterer, engineer, transferwindow, alarm clock and AstroidDay. That's all, no other planet mods or else. Been before on the surface of Eeloo and Slate without any trouble. Other problem is that I am not able to do resource scanning with the scanner, as written befor.

This is a relative new clean 1.0.4 install with including the career I started under 1.0.2. . Played it with being on nearly every standard planet and included OPM as soon 1.7.2 left its beta status. I do not use Hyperedit.

Edit: Reinstalled OPM, no effect. I discovered also, that in my current situation the markers for encounter and escape are in the wrong order: first comes the escape than the encounter. I'm destroyed by reaching the escape note.

Edit2: Error found: somehow sun.bin was not in the kopernicus cache folder. Reinstalled it, reloaded save and i am about to land on Ovok. Sorry and thanks again.

Edit3: Scanner error is still there "[Error]: [R&D]: No Science Subject found with id survey@Slate"

Edited by Schaufel

Share this post


Link to post
Share on other sites
I only use chatterer, engineer, transferwindow, alarm clock and AstroidDay. That's all, no other planet mods or else. Been before on the surface of Eeloo and Slate without any trouble. Other problem is that I am not able to do resource scanning with the scanner, as written befor.

This is a relative new clean 1.0.4 install with including the career I started under 1.0.2. . Played it with being on nearly every standard planet and included OPM as soon 1.7.2 left its beta status. I do not use Hyperedit.

Edit: Reinstalled OPM, no effect. I discovered also, that in my current situation the markers for encounter and escape are in the wrong order: first comes the escape than the encounter. I'm destroyed by reaching the escape note.

Edit2: Error found: somehow sun.bin was not in the kopernicus cache folder. Reinstalled it, reloaded save and i am about to land on Ovok. Sorry and thanks again.

Edit3: Scanner error is still there "[Error]: [R&D]: No Science Subject found with id survey@Slate"

Do you have CrowdSourcedScience installed maybe?

- - - Updated - - -

Also can you give the log file whit the error in it

Share this post


Link to post
Share on other sites
Is this still an issue with the actual release? I'm having the same problem with ovok at the moment.

Just tried an ovok landing, all went well :)

T0b6puc.png

Share this post


Link to post
Share on other sites
Hey friend, CaptRobau, remember me? Yeah, so I need help from you... Maybe you can tell me what causes errors on this planet...


@Kopernicus:AFTER[Kopernicus]
{
Body
{
name = Daphy
flightGlobalsIndex = 709


Orbit
{
referenceBody = Sarvin
inclination = 356.7
eccentricity = 0.04
semiMajorAxis = 42592944
longitudeOfAscendingNode = 55
argumentOfPeriapsis = 0
meanAnomalyAtEpoch = 1.10000002384186
epoch = 1343.91003417969
color = 0.75,0.8,0.82,1
}
Properties
{
description = This moon is covered in large, deep cracks, that may hide water oceans beneath its crust, and eroded mountain ranges mostly covered in fluff-like white dust. Many kerbals dream about a huge yummy ocean of ice cream laying behind Daphy's surface, there could be even more than on Minmus!
radius = 180000
geeASL = 0.22
rotationPeriod = 181803
rotates = true
tidallyLocked = false
initialRotation = 0
isHomeWorld = false
timewarpAltitudeLimits = 0 30000 30000 60000 100000 300000 600000 800000


biomeMap = KerbolPlus/SarvinSystem/Daphy/PluginData/Daphy_biome.png


Biomes
{
Biome
{
name = Surface
value = 1.0
color = 1,0,0,1
}
Biome
{
name = Canyons
value = 1.0
color = 1,1,1,1
}
Biome
{
name = Polar Crater
value = 1.0
color = 0,0,0,1
}
Biome
{
name = Twin Craters
value = 1.0
color = 0,1,0,1
}
}
ScienceValues
{
flyingLowDataValue = 13
flyingHighDataValue = 13
landedDataValue = 14
inSpaceLowDataValue = 12
inSpaceHighDataValue = 11
recoveryValue = 11
flyingAltitudeThreshold = 2000
spaceAltitudeThreshold = 75000
}
}
ScaledVersion
{
type = Atmospheric
fadeStart = 0
fadeEnd = 0


Material
{
texture = KerbolPlus/SarvinSystem/Daphy/Textures/Daphy_color
normals = KerbolPlus/SarvinSystem/Daphy/Textures/Daphy_normal
shininess = 0
specular = 0.00,0.00,0.00,0


rimPower = 2.06
rimBlend = 0.3


Gradient
{
0.0 = 0.75,0.8,0.82,1
0.6 = 0.45,0.5,0.52,1
1.0 = 0.0196,0.0196,0.0196,1
}
}
}

Atmosphere
{
ambientColor = 0.75,0.8,0.82,1.00

lightColor = 0.75, 0.7, 0.68, 1.00


enabled = true
oxygen = false

altitude = 2500.0
atmosphereMolarMass = 0.014
pressureCurve
{
key = 0 20.265 -6.818384E-02 -6.818384E-02
key = 125 11.74202 -5.549224E-02 -5.549224E-02
key = 250 6.39194 -3.396256E-02 -3.396256E-02
key = 375 3.25138 -1.902304E-02 -1.902304E-02
key = 500 1.63618 -9.70584E-03 -9.70584E-03
key = 625 0.82492 -4.85952E-03 -4.85952E-03
key = 750 0.4213 -2.43176E-03 -2.43176E-03
key = 875 0.21698 -1.22624E-03 -1.22624E-03
key = 1000 0.11474 -6.1952E-04 -6.1952E-04
key = 1125 0.0621 -3.1936E-04 -3.1936E-04
key = 1250 0.0349 -1.6904E-04 -1.6904E-04
key = 1375 0.01984 -9.288E-05 -9.288E-05
key = 1500 0.01168 -5.28E-05 -5.28E-05
key = 1625 0.00664 -3.192E-05 -3.192E-05
key = 1750 0.0037 -1.864E-05 -1.864E-05
key = 1875 0.00198 -1.064E-05 -1.064E-05
key = 2000 0.00104 -5.84E-06 -5.84E-06
key = 2125 0.00052 -3.12E-06 -3.12E-06
key = 2250 0.00026 -1.76E-06 -1.76E-06
key = 2375 0.00008 -1.04E-06 -1.04E-06
key = 2500 0 -6.4E-07 -6.4E-07
}
pressureCurveIsNormalized = false

temperatureSeaLevel = 117.2
temperatureCurve
{
key = 0 117.2 -0.25666668 -0.25666668
key = 300 86.41575985 -0.036354352 -0.036242288
key = 525 86.41575985 0.036242288 0.036242288
key = 775 108.4045028 0.019808576 0.019808576
key = 1400 108.4045028 -0.027317132 -0.027317132
key = 2000 74.82169538 -0.036354352 -0.036354352
key = 2250 74.82169538 0.01895098 0.01895098
key = 2500 92.01289442 0.027784164 0.027784164
key = 3750 0 -0.017984364 -0.017984364
}
temperatureCurveIsNormalized = false
temperatureLapseRate = 0.0024
temperatureSunMultCurve
{
key = 0 1 0 0
key = 192.3076923 0.5 -0.0024 -0.004105796
key = 211.9044231 0 0 0
key = 385.8265383 0 0 0
key = 910.5634614 0.2 0 0
key = 1380.772308 0.2 0 0
key = 1755.56923 0 0 0
key = 2500 0.4 0 0
}

albedo = 0.17
adiabaticIndex = 1.20000004768372
gasMassLapseRate = 2.06477390407027
}

PQS
{
maxQuadLengthsPerFrame = 0.03
minLevel = 2
maxLevel = 12
minDetailDistance = 8


materialType = AtmosphericOptimized
Material
{
saturation = 1
contrast = 1.8
tintColor = 1.000,1.000,1.000,0.000


powerNear = 0.6
powerFar = 0.5


groundTexStart = 0
groundTexEnd = 1000


steepPower = 1.25
steepTexStart = 0
steepTexEnd = 50000
steepTex = BUILTIN/terrain_rock00
steepBumpMap = BUILTIN/RockyGround2
steepNearTiling = 100
steepTiling = 60


lowTex = BUILTIN/SandyGround
lowBumpMap = BUILTIN/quiet
lowNearTiling = 2000
lowMultiFactor = 100
lowBumpNearTiling = 2000
lowBumpFarTiling = 4000


midTex = BUILTIN/RockyGround
midBumpMap = BUILTIN/RockyGround2
midNearTiling = 4000
midMultiFactor = 100
midBumpNearTiling = 4000
midBumpFarTiling = 4000


highTex = BUILTIN/RockyGround
highBumpMap = BUILTIN/RockyGround2
highNearTiling = 4000
highMultiFactor = 100
highBumpNearTiling = 8000
highBumpFarTiling = 4000


lowStart = 0
lowEnd = 0.3
highStart = 0.8
highEnd = 1


globalDensity = 0
fogColorRamp = BUILTIN/desert_atmogradient
}


Mods
{
VertexColorMap
{
map = KerbolPlus/SarvinSystem/Daphy/Textures/Daphy_color.png
order = 500
enabled = true
}


VertexHeightMap
{
map = KerbolPlus/SarvinSystem/Daphy/PluginData/Daphy_height.png
offset = 0
deformity = 10000.0
scaleDeformityByRadius = false
order = 20
enabled = true
}


VertexSimplexHeight
{
seed = 98374
deformity = 500.0
octaves = 8.0
persistence = 0.5
frequency = 4.0
enabled = true
order = 59
}


HeightColorMap
{
blend = 0.7
order = 201
enabled = true
LandClasses
{
Class
{
name = AbyPl
altitudeStart = 0.0
altitudeEnd = 0.5
color = 0.0,0.0,0.0,1.0
lerpToNext = true
}
Class
{
name = Beach
altitudeStart = 0.5
altitudeEnd = 0.55
color = 0.164179087,0.164179087,0.164179087,1.0
lerpToNext = true
}
Class
{
name = Beach2
altitudeStart = 0.55
altitudeEnd = 1.0
color = 0.373134315,0.373134315,0.373134315,1.0
lerpToNext = false
}
}
}
AltitudeAlpha
{
atmosphereDepth = 8000
invert = false
enabled = true
order = 999999999
}
VertexSimplexHeightAbsolute
{
seed = 4447895
deformity = 500
octaves = 8
persistence = 0.5
frequency = 24
enabled = true
order = 50
}
VertexHeightNoiseVertHeightCurve2
{
deformity = 500
ridgedAddSeed = 1530393216
ridgedAddFrequency = 12
ridgedAddLacunarity = 2
ridgedAddOctaves = 4
ridgedSubSeed = 1212096256
ridgedSubFrequency = 12
ridgedSubLacunarity = 2
ridgedSubOctaves = 4
ridgedMode = Low
simplexHeightStart = 0
simplexHeightEnd = 9000
simplexSeed = 1909396224
simplexOctaves = 6
simplexPersistence = 0.699999988079071
simplexFrequency = 4
enabled = true
order = 100
}
}
}
}
}

Yeah, so people have reported problems like this:

After you land, your ship is still counted as flying low and if you try to return to KSP view it sais ship is under acceleration even trough it isn't.

Kerbals just lay on the ground, can't move, and theyr orientation doesn't seem to respect planet's shape (like they stay sideways on equator).

Pls help, you're the only expert person I haven't asked and I'm sure you know what's the thing with this config!

If I fix this, I fill all the planets in my pack... Thank you man.

Dude. Ask him in a PM. Please...

Share this post


Link to post
Share on other sites

Amarius, this thread is for OPM, please refrain for other topics such as K+ unless it has at least something to do with this pack. What you're asking is better suited for a PM......

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.