CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

2 hours ago, Sigma88 said:

He is using @Eleusis La Arwall mod (which I helped developing)

That mod is not updated yet so the problem is he was trying to use new EVE with it.

I'm currently thinking about fixing the mod but I can't get a hold on eleusis and I'm still trying to reproduce the effects eleusis was getting.

Anyway, thanks for the pqs tip, that thing made me scratch my head for a while

I'm not using the new EVE. I'm using 7-4.

Share this post


Link to post
Share on other sites
49 minutes ago, TaintedLion said:

I'm not using the new EVE. I'm using 7-4.

oh, then could you send me a list of the mods you use so I can check what's going wrong? thank you

Share this post


Link to post
Share on other sites
4 hours ago, Sigma88 said:

Anyway, thanks for the pqs tip, that thing made me scratch my head for a while

Me too. I tried to add clouds to Sarvin from Kerbol Origins, but the game kept bugging even if I used the in-game GUI, so I asked the dev of E.V.E what the problem was. The 'deactivateDistance' PQS mod sets a certain 'altitude limit', beyond this limit the clouds will disappear.

Share this post


Link to post
Share on other sites

Looks like I've found a bug-- not totally sure if it's in OPM, or Kopernicus, or both.  Has anyone else run into this?

Symptom:  When I'm in map view on Tekto, and I try to switch focus to Tekto itself, the following bad things happen:

First, I get a NullReferenceException:

[Exception]: NullReferenceException: Object reference not set to an instance of an object
ResourceMap.GetResourceItemList (HarvestTypes harvest, .CelestialBody body)
KnowledgeBase.CreateResourceList ()
KnowledgeBase.OnMapFocusChange (.MapObject target)
EventData`1[MapObject].Fire (.MapObject data)
PlanetariumCamera.SetTarget (.MapObject tgt)
PlanetariumCamera.LateUpdate ()


Second (and presumably a result of the first), the info buttons in the map view don't switch to the planet; they're still showing information for the ship I had focused before I switched to Tekto, and there's no "resources" button present.

Other information that may be useful:

  • I don't know if the problem is with Tekto only, or includes other OPM worlds.  This is my first OPM play-through in a long time, and Tekto is the only OPM world I've visited thus far.
  • A possible indication that this may be an OPM issue and not Kopernicus (or, at least, not only Kopernicus):  I'm also running Arkas, another planet mod that also uses Kopernicus.  I encounter no such problem at Arkas (or for stock planets).
  • I'm not running any mods that explicitly affect resources in general.  I'm running Extraplanetary Launchpads, which adds a "MetalOre" resource to the game.

 

Is this a known issue?  Any suggestions?  It's making OPM very hard to play for me, since I've got my whole mission designed around scanning & locating resources so I can replenish & rebuild.

Edited by Snark

Share this post


Link to post
Share on other sites

kerbol origins already moves eeloo, will you make a compatability patch? or maybe just make eeloo 2, a complete copy of eeloo or something, to go were old eeloo went, or where eeloo is moved by kerbol origins?

 

 

On 12/12/2015 at 0:08 PM, AlbertKermin said:

I just made a test landing on Polta, and I noticed the view from there, and couldn't help but share-aT9AEbT.png

nice, using KIS to make links between landed modules. using linux 64bit? also, plan on taking more pics? id love too see the rest of this awesome base :) or maybe progress reports on the landing of new modules, too :) 

Edited by 123nick

Share this post


Link to post
Share on other sites

hey i have a question. does it really only take 40 meters per second of Δv to land on hale? because thats REALLY low.

Share this post


Link to post
Share on other sites
7 minutes ago, 123nick said:

hey i have a question. does it really only take 40 meters per second of Δv to land on hale? because thats REALLY low.

it's the smallest moon in the game, not sure how you feel that doesn't fit. The description in the OP even hints at you being able to land on the sides of cliffs the gravity is so low

Share this post


Link to post
Share on other sites
2 minutes ago, Gaiiden said:

it's the smallest moon in the game, not sure how you feel that doesn't fit. The description in the OP even hints at you being able to land on the sides of cliffs the gravity is so low

i wasnt saying that it should be changed, im just saying that, wow, that is VERY low. i mean, it fits. but thats just amazing, like, i dont think you would even need a landing burn if you were too, say have a sturdy enough part with enough impact resistance. it would be very interesting to, well, do pretty much anything on. landing, base building ,colonizing, orbiting. you could probably land on it, take off, and land again, several times, just on a single EVA.

Share this post


Link to post
Share on other sites
4 hours ago, 123nick said:

nice, using KIS to make links between landed modules. using linux 64bit? also, plan on taking more pics? id love too see the rest of this awesome base :) or maybe progress reports on the landing of new modules, too :) 

 

It's not actually a base. It's a mostly- invisible lander, and a Surface Experiment Package. :)  I was on a test mission when I saw that.

Share this post


Link to post
Share on other sites

By now, is it safe to assume that the next update will be released either today or tomorrow, or that it has some bug that is troubling you and delaying it's release?

Share this post


Link to post
Share on other sites

hey im just posting about how both this mod and kerbol origins both move eeloo, so im certain some sort of patch is needed.

Share this post


Link to post
Share on other sites

Hey, can someone give me a tutorial on making planets and moons? I've been very interested in it and I have no idea how to do it or how it works. Thanks!

Share this post


Link to post
Share on other sites

Update 1.9 is out now!

Merry Christmas everyone: you finally get a Plock system that looks like the amazing stuff we saw as New Horizons passed Pluto in July!

Features

  • Redid Plock, changing it from a Vall look-a-like into a unique body based on New Horizon's look at Pluto in July
  • Added a moon to Plock called Karen based on Charon
  • These two moons by default are in a relationship similar to Duna-Ike (tidally locked to each other, etc.). If you install Sigma Binary, this changes the system in a true binary system like the real Pluto-Charon system. Seeing them dance around each other is very special, so I consider it a very, very recommended mod.

Screenshots

 

Downloads

1. Choose one of the two available mirrors for Outer Planets Mod (the CKAN version should get the update within the day, probably within a few hours)

FRO6RIX.png WhwiS8Y.png

2. Download Kopernicus, which is a third-party mode required for OPM to work

ypskWRz.png

This version of OPM was designed with Kopernicus 0.6.2 in mind. Keep this in mind.

3. (Optional) Download Sigma Binary to make Plock-Karen a true binary system like Pluto-Charon (a really cool effect)

Download Sigma Binary 1.3.2

Here's the full changelog:

-Redid Plock, changing it from a Vall look-a-like into a unique body
-Added a moon to Plock called Karen
-Redid the gas giant's rings to adjust for changes made to the ways rings are rendered now
-Flipped the biome maps of Thatmo and Karen, so that they correctly follow the terrain
-Changed Plock's orbital color, PlanetShine and DistantObject color to a light greenish brown
-Removed the FlightGlobalIndex variables, due to obsolescence
-Fixed an error in Plock's description
-Updated ModuleManager to version 2.6.13
-Updated AVC version file

Excuse the barebones announcement. I really wanted this out for the holidays and I gotta go to Christmas dinner in about about half an hour.

Edited by CaptRobau

Share this post


Link to post
Share on other sites
56 minutes ago, CaptRobau said:

Update 1.9 is out now!

As always, congrats on the release guys ;)

Share this post


Link to post
Share on other sites

Brilliant! After just over a year it seems you've finally completed the initial scope of OPM, CaptRobau. Congratulations on a job exceedingly well done- there really aren't any better planet mods out there.

 

puZT7JF.pngPlock has some beautiful terrain. I landed on the outskirts of a small crop of mountains. I love the color and variety of the surface. Unfortunately I didn't bring along a Karen probe, and the Hohmann transfer is a bit time consuming (haha), so you'll have to wait on somebody else to get images from its surface I suspect.

 

Here's another quick shot from one of those cliffs overlooking the original landing spot.

Lnqjhl0.png

Edited by Jodo42

Share this post


Link to post
Share on other sites

PSA make sure you double-check Curseforge has the latest version approved! Was originally downloading from Kerbalstuff but it was dragging at a few dozen KB/s so I switched to Curseforge and sucked it down at 3.5MB/s but didn't realize I had downloaded 1.8.1 :P Back to Kerbalstuff.... well ~175KB/s is better than before at least

Share this post


Link to post
Share on other sites
8 hours ago, CaptRobau said:

Update 1.9 is out now!

Congrats with the new release but found 2 problems:

  • Typo in CelestialBodies.info on line 193 says "Plock" while it loads the Karen ribbons
  • You are using an outdated SigmaBinary config. You're using v1.2.1 while you say it needs v1.3.2

Share this post


Link to post
Share on other sites

Great news with the 1.9 release. I'm gonna have a fun time landing on New-Plock.

One thing I've always wanted to see from you would be a proper comet utilizing the comet trails in Kopericus Expansion. 

Do you have any other plans for new planets and whatnot? 

Share this post


Link to post
Share on other sites
2 hours ago, Sandworm said:

Has anyone had luck with OPM in 64k?  I've tried the tellion config (link below) but since the last update I've been spawning in deep space outside of kerbin's SOI.

 

https://github.com/Tellion/OPM_64K

The same thing is happening to me, can't launch anything and the 30+ craft I had orbiting Mun and Minmus have vanished entirely. 

Share this post


Link to post
Share on other sites

  Thank you, OPM devs, for the most stockalike mod out there. Why this mod is not integrated already I do not know, maybe SQUAD is just too stubborn to admit they need some mods integrated. Thank you for a truly awesome mod.

  

Edited by Sanic

Share this post


Link to post
Share on other sites

New OPM release, new problems for me:

Picked your newest release, installed Sigma, continued my 10 years ongoing campaign:

All my ships related to Sarnus and especially Tekto are switched over to Urlum:

  • two laboratories in Tekto orbit are found back in an Urlum orbit,
  • a unmanned rover that was on Tekto is now on the surface of Priax,
  • a Wal Rover has landed on Neidon instead!
  • a Wal orbital probe is on collision course with Neidon
  • varius Sarnus' moon related probes in Urlum orbits
  • at least one missing harvester which orbited Hale before

Everything that was placed in the Sarnus system is switched to Urlum, Wal ships to Neidon, other Urlum ships went to "Nirvana"(gone), Eeloo related ships stayed in place.

Again the known "Cannot load preset 'High' " error in log on all OPM objects, now heavy NullReference exceptions: "not set as a instance of an object".

Thanks for support in advance.

Edited by Schaufel

Share this post


Link to post
Share on other sites
On 12/25/2015 at 3:16 PM, CaptRobau said:

Here's the full changelog:


-Removed the FlightGlobalIndex variables, due to obsolescence

 

That'll be why all your crafts have changed planets.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.