CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

Now that i have reusite to make the dds plugin work which DTX5 i must because i had 5 different DTX5 compression format and the BC3/DTX5 format don't work:(

Share this post


Link to post
Share on other sites
6 minutes ago, TheAxel1105 said:

Now that i have reusite to make the dds plugin work which DTX5 i must because i had 5 different DTX5 compression format and the BC3/DTX5 format don't work:(

Please try asking about Kopernicus in the actual Kopernicus thread, instead of spamming other people's mod threads. If you actually want help, advice or support we are more than happy to assist you as much as we can provided that you ask in the correct place. I'm sure @CaptRobau doesnt want people spamming his mod thread with questions about a different mod now.

Link for the lazy

Share this post


Link to post
Share on other sites
29 minutes ago, KillAshley said:

Please try asking about Kopernicus in the actual Kopernicus thread, instead of spamming other people's mod threads. If you actually want help, advice or support we are more than happy to assist you as much as we can provided that you ask in the correct place. I'm sure @CaptRobau doesnt want people spamming his mod thread with questions about a different mod now.

Link for the lazy

I now but since i use outer planet mod config it's won't be accepted by the kopernicus team to help and TheWhiteGuardian give me a good help since i ask for help. :D  

Share this post


Link to post
Share on other sites
44 minutes ago, TheAxel1105 said:

Now that i have reusite to make the dds plugin work which DTX5 i must because i had 5 different DTX5 compression format and the BC3/DTX5 format don't work:(

Huh... you can also use Paint.NET to export to DXT1 and DXT5, but not DXT5_nm. I am willing to convert an eventual normal map for you though.

6 minutes ago, TheAxel1105 said:

TheWhiteGuardian give me a good help since i ask for help. :D  

Happy to help! :)

Share this post


Link to post
Share on other sites
14 hours ago, TheAxel1105 said:

I now but since i use outer planet mod config it's won't be accepted by the kopernicus team to help and TheWhiteGuardian give me a good help since i ask for help. :D  

It is acceptable to use existing cfgs to learn more about kopernicus. It's actually encouraged! Don't worry though, @The White Guardian reads the kopernicus thread too :wink:

Share this post


Link to post
Share on other sites
58 minutes ago, KillAshley said:

It is acceptable to use existing cfgs to learn more about kopernicus. It's actually encouraged! Don't worry though, @The White Guardian reads the kopernicus thread too :wink:

@TheAxel1105

Indeed. I get an e-mail containing the latest posts from the Kopernicus thread every evening, and I always, always read my e-mails. Nevertheless, simply mention me like @KillAshley did in the comment above, and I'll read it.

53 minutes ago, TheAxel1105 said:

I need to thanks KillAshley and The White Guardian for their help my mod is now on is way:D:D:D

Gongratulations! I must ask you though, does it contain textures taken from Space Engine?

Share this post


Link to post
Share on other sites
2 hours ago, The White Guardian said:

@TheAxel1105

Indeed. I get an e-mail containing the latest posts from the Kopernicus thread every evening, and I always, always read my e-mails. Nevertheless, simply mention me like @KillAshley did in the comment above, and I'll read it.

Gongratulations! I must ask you though, does it contain textures taken from Space Engine?

Yep the texture are from space engine.

Share this post


Link to post
Share on other sites
5 minutes ago, TheAxel1105 said:

Yep the texture are from space engine.

Then please do not release it unless they are from hand-made planets. You see, Kopernicus was not designed to fuse S.E. with KSP, and if people start mass-fabricating packs chuck-full of textures taken from S.E. the result will be horrible.

Share this post


Link to post
Share on other sites

Time for an update on the progress for 2.0 and beyond:

There is so much that I want to do for the next phase of OPM that it can't all be done in a single update, without making you guys wait for ages. I've already done work on the two major features: terrain improvements/custom terrain textures and a biome overhaul and now that I know what I can expect of both of these, I've decided to divide the work into two major releases:

  • 2.0 will focus on improvements to the terrain of the OPM bodies. Custom terrain textures, procedural voronoi craters like on the Mun, more variation in terrain detailing (at the moment the OPM terrains still take most of their settings from their templates), better scatter (no custom models yet, but I can use the stock ones in ways that are more varied and fit the OPM bodies better) and more.
  • 2.1 will do a complete overhaul of the biomes. The Squad-inspired way of doing biomes/biome maps is just not creating the best results gameplay and otherwise. The biome maps are hard to look at it, there are few uniquely named features and they don't incentivize exploration all that well. Our new concept will rectify all of that. More on this later. Don't worry that all of those hundreds of custom science blurbs written by you guys will become obsolete. With limited rewriting or re-categorizing I can easily fit the existing in with the new biomes.

Work for 2.0's terrain revamp so far has mostly been about testing texture tools provided by Kopernicus and KSPs inner workings on which it. You don't need 8k textures to make something look good. With variation in textures, textures that tile well and bump maps you can get some results that look more varied and less blurry than what most of the stock KSP texture work has been showing off so far. I've mostly been testing it out on the stock planets and moons, as that was easier. Now that I've gotten the hang of it and I'm slowly narrowing down the types of terrain textures I want, I'm moving onto directly working on OPM bodies.

As you might be able to see in the images below, I'm trying to find a good balance between so blurry, it's almost cartoony (stock KSPs worst examples) and hyper-realistic (KSPRC). I've found that KSPRCs way does give nice pictures if you look at it the right way, but that it makes it hard to make it look good both close by, at a distance and from low orbit. As far as I can tell that approach also results in a higher performance impact (probably because the texture is being tiled more often). The performance impact on my testing install is far less. The amount of RAM the amount of textures I'm aiming for takes up about 50 mb and while KSPRC levels of tiling sometimes made the clock color turn yellow, at the current level it's always green. In KSP 1.1, with its performance/memory improvements, I imagine that these extra textures won't even impact performance in any noticeable way.

There's still a long way to go (everything you see is a WIP), but I like where this is going. Feels nice being able to something that's so undocumented/unexplored. Kind of like the begin days of OPM/Kopernicus.

 

Share this post


Link to post
Share on other sites

Very nice, I especially like the Hale ground texture and the Sand texture is very well tiled. Blurry ground textures have been the bane of KSP for a while.

Share this post


Link to post
Share on other sites

I have a problem with eeloo, when i select the planet in mapview i get exception and the planet button disappear, if i exit from mapview and reenter ships and orbit lines are gone, seems happens only to eeloo

 

Edited by Badsector

Share this post


Link to post
Share on other sites

Could you recreate this, note the time and then send or poste the log? It's called KSP.log and it's in your main KSP folder.

Share this post


Link to post
Share on other sites

What is strange ther'is nothing in the log

Here is the persistent file, i have only 2 probe around slate and eeloo is need only Near Future Solar for the panels

Edit

Log Here

Edit2

I have removed exception detector and started a new save, now seems all work fine, this evening i want try a tekto mission and i can see if after timewarp all work fine again.

Sorry for waste your time and thanks again for this great mod

Regards Luca

Edited by Badsector

Share this post


Link to post
Share on other sites

Glad to see it seems to work again. If anything does happen after that Tekto mission, let me know.

Share this post


Link to post
Share on other sites

Hey, I just downloaded this mod and the planets are there but all the textures seem to be missing. The planets are blank white spheres and the rings are simply textureless white disks as well, and all the moons except eeloo are just completely missing. Is there anything I can do to fix this?

Edited by Jatizso
Nevermind I fixed it

Share this post


Link to post
Share on other sites
1 hour ago, CaptRobau said:

@Jatizso what was the solution?

I don't think "nevermind I fixed it" is part of the message :)

Share this post


Link to post
Share on other sites

I know. Which I why I want to know it. I think it's because he didn't install something correctly, but I want to be sure so I can put it in the FAQ and help people that have this problem in the future.

Edited by CaptRobau
test for editing

Share this post


Link to post
Share on other sites
8 minutes ago, CaptRobau said:

I know. Which I why I want to know it. I think it's because he didn't install something correctly, but I want to be sure so I can put it in the FAQ and help people that have this problem in the future.

I mean that I think the phrase " Nevermind I fixed it " is probably his signature, and he may have not found a solution to this particular issue :)

from the sound of it I would say he has an old version of kopernicus.

I am guessing blank textures for the giants is the result of "loadondemand" not being implemented in the version he is using, and the missing moons could be caused by the same issue (missing loadondemand)

I'm not sure tho, just a shot in the dark

Share this post


Link to post
Share on other sites
1 hour ago, CaptRobau said:

It's not his sig, it's his 'Reason for editing this post'. I tried it out.

Ah I see :)

that makes sense :D

Share this post


Link to post
Share on other sites

The problem was because the mods were in a second gamefolder inside the real gamefolder, so moving them fixed it.

Share this post


Link to post
Share on other sites
On 1/2/2016 at 6:17 PM, CaptRobau said:

Glad to see it seems to work again. If anything does happen after that Tekto mission, let me know.

I still have the problem,

x952LEX.jpg

I'm playing in sandbox mode with ore at 10% and what i do is, build a ship in orbit of Kerbin at day 79 year 1 send it to Sarnus, intercept tekto and in high orbit i build a probe with KIS with orbital survey and scanner.

Send the probe in polar orbit 445Km Ap and 255Km Pe, after the orbital survey the problem happens.

EDIT

I want try a different approach, because seems is always the first planet i scan to give problems, and probably is more a problem of kopernicus than OPM

Edited by Badsector

Share this post


Link to post
Share on other sites

I still have the problem,

 

I'm playing in sandbox mode with ore at 10% and what i do is, build a ship in orbit of Kerbin at day 79 year 1 send it to Sarnus, intercept tekto and in high orbit i build a probe with KIS with orbital survey and scanner.

Send the probe in polar orbit 445Km Ap and 255Km Pe, after the orbital survey the problem happens.

EDIT

I want try a different approach, because seems is always the first planet i scan to give problems, and probably is more a problem of kopernicus than OPM

Could you try this with only Kopernicus, OPM and MM? If it still happens, give us the player.log and MM cache (this can be helpfull to see if every config was loaded)

Edited by Olympic1

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.