CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

On March 6, 2016 at 8:47 PM, Waxing_Kibbous said:

Just a quick stab in the dark here, but in many cases where people create content on Windows that can be used on Unix systems the errors come from the fact that while Win isn't case sensitive, Unix is. So, if a file is named Sarnus_color.dds one place and Sarnus_Color.dds in a different place, it'll work on Windows but not in MacOS/Linux. Would be a good easy place to start IMO.

Mac OS has case sensitive file system functionality too, if you chose it when setting it up. I know... Cause Steam throws a hissy fit with it active.

Edited by richfiles

Share this post


Link to post
Share on other sites
5 hours ago, Danetto said:

Don't know, maybe you should write to the PM, but I think it's not the first time someone has faced this.
Honestly, I don't know what it is - I simply missing the textures of the planets! It looks like a... like a wheat field, lol.
Could this be due to the fact that I use a mod 64K and OPM for the configuration of 10x? The fact that such a terrible species arise only when viewed from orbit, on the surface, everything is fine.
Is there any way to solve this problem? It is impossible to play, constantly seeing such horror...

And Yes, sorry for my curve English :)
Your mod is just gorgeous, I'm serious :D

I don't really understand your problem. Could you post screenshots please?

On 3/18/2016 at 2:10 AM, GregroxMun said:

Alternis Kerbol Rekerjiggered 1.5.2 is now compatible with Outer Planets Mod. It moves and resizes Vall to Eeloo's position, and Eeloo is moved to an orbit similar to Haumea's. It's also worth noting that KillAshley's Uncharted Lands supports OPM as well.

Nice!

Share this post


Link to post
Share on other sites

For some reason, the latest version of the mod doesnt appear to work in a fresh install. None of the planets appear even though I have Kopernicus 0.6.3 installed. I am playing KSP 1.0.5.  

 

\~~~~~~~~~~UPDATE~~~~~~~~~~~~~~

So i found out that i forgot to install Module manager. I installed the latest version, created a new save, and now the camera is showing space rather than the space center. i dont see any of the planets.

Edited by alphaman
clarification

Share this post


Link to post
Share on other sites
13 hours ago, CaptRobau said:

I don't really understand your problem. Could you post screenshots please?

Here is a screenshot of my problem, as you can see, Tekto and Sarnus here look just awful.
They have already increased, if anything. Although, I think it is noticeable)

G0aNGZsuF3o.jpg

7 hours ago, Thomas P. said:

Show us your GameData folder and your OPM folder (screenshot). You installed the mod wrong

Okay, so I show all that are in the same folder.
I hope that I will find some help here, because playing is just unreal :(
Oh! Don't know if it's any help, but I play on a 64-bit version.

avthN8syU-w.jpg

 

Share this post


Link to post
Share on other sites

Screenshot time:

T8ubrKX.png

Development slowed after I hit a few roadblocks. The terrain-related systems are obscure and complex, so I took a bit of a break on this after I couldn't make any headway. Made some progress this week though. I don't have it 100% figured out, but I'm close enough that I got Hale looking the way I want. As you can see I also turned on shadow casting for the terrain scatter. It looks great, but it lagged by (low-end) PC a bit with everything turned up. So I'll make those settings a cfg that those with lower-end PCs can easily remove. Shouldn't be a problem for PCs that aren't from the previous decade.

In time for Easter, here's a shot of Ovok with it's brightly colored developer textures on. The banding is a result of the hacky way that we needed to make it (it's basically a sphere, with a large mountain on the side of it).

hZC3GPB.png

Edited by CaptRobau

Share this post


Link to post
Share on other sites

Good afternoon!  I just ran across this in the New Horizons "news" forum from 3/21/16, commenting on a presentation made by the Pluto investigative team;

'Principal Investigator Stern reporting on evidence that Pluto’s long-term polar axis shifts drive sharp changes in the planet’s atmospheric pressure over time, possibly causing Pluto’s atmosphere to be much more massive than that of even Mars. “In fact,” Stern says, “this opens up the possibility that liquid nitrogen may have once or even many times flowed on Pluto’s surface.”'

Given this fascinating bit of information, would you ever consider putting (small) regions of liquid "something" on Plock?

 

Slide19.png

http://pluto.jhuapl.edu/News-Center/Press-Conferences/March-21-2016.php

Edited by GarrisonChisholm

Share this post


Link to post
Share on other sites

Interesting, though probably not. It was already a lot of work to get a regular ocean moon working (Tekto). Making another one, just for a single puddle is not something I'm looking forward too.

Share this post


Link to post
Share on other sites
10 hours ago, CaptRobau said:

The terrain-related systems are obscure and complex, so I took a bit of a break on this after I couldn't make any headway.

That's strange, I got the hang of it pretty quickly... It's amazing how much more detailed you can make a planet look just by giving it a HD surface texture (though I never use surface texture sizes beyond 1024x1024 pixels).

Share this post


Link to post
Share on other sites

Making textures and applying them to the game is not the problem. I got the hang of that quite quickly. The issue is having all the various textures appear in the places I want them. You can  easily set a variety of textures (low, high, snow, deep, etc.) but unless you know what you're doing most of the time only 1 or 2 of those textures are actually visible. Most of the stock bodies for example only display one texture for cliffs (steep) and one general one for everything else. Kerbin is the only example where textures are used with as much variety as possible and actually display.Same goes for most of the mod planets I've looked at. It's hard to see when you're developing, but it's more notable if  you use dev textures like in the Ovok screenshot above.

I've found the right variables (lowStart, highEnd, etc.), but I haven't figured out the precise logic behind it so it's mostly been trial-and-error.

Share this post


Link to post
Share on other sites
On 3/23/2016 at 2:39 AM, CaptRobau said:

Interesting, though probably not. It was already a lot of work to get a regular ocean moon working (Tekto). Making another one, just for a single puddle is not something I'm looking forward too.

I dunno, it would be one more biome, a unique, "destination place" on Plock!  Think about it, adding to the tension of a 4-5 year voyage with the new necessity & thrill of doing a targeted landing towards a small pool through a slightly hazy sky...  :)

I'm teasing; Lord knows I have no idea how hard this project was, I'm not trying to badger anyone into taking on more work. ...however keen it would be.   ;)

 

Share this post


Link to post
Share on other sites

Dear CaptRobau,

Much respect yet again for making such an outstanding planet pack (literally, my laptop struggles everytime i load up OPM).

But i was wondering: How do you make those absolutely beautiful colour and height maps for your planets and moons? Is it SE or just pure artistic skills?

Edited by Radon86

Share this post


Link to post
Share on other sites

@Eudae55 made them for the mod. He's very artistic and has a lot of great software tools to help him with it.

Edited by CaptRobau

Share this post


Link to post
Share on other sites
9 hours ago, CaptRobau said:

@Eudae55 made them for the mod. He's very artistic and has a lot of great software tools to help him with it.

Nice, thx!

Edited by Radon86

Share this post


Link to post
Share on other sites
On March 20, 2016 at 11:00 AM, Danetto said:

Here is a screenshot of my problem, as you can see, Tekto and Sarnus here look just awful.
They have already increased, if anything. Although, I think it is noticeable)

G0aNGZsuF3o.jpg

 

Use Sigma Dimensions. BEST ALTERNATIVE. I had this issue as well. FIXED with Sigma Dimensions. ;) 

Share this post


Link to post
Share on other sites
2 hours ago, davidy12 said:

Use Sigma Dimensions. BEST ALTERNATIVE. I had this issue as well. FIXED with Sigma Dimensions. ;) 

Just to clear things up:

I think davidy refers to the fact that danetto is using 64k, I am not sure 64k could be the cause of the issue there, to me it looks more like a load on demand issue honestly

but if the 64k configs for OPM mess with the textures, then it's totally possible that the issue could originate from there

Share this post


Link to post
Share on other sites

Just to clarify, should I eventually get contracts generating for these outer planets and their moons?  Including the "Explore such-and-such" contracts?

Share this post


Link to post
Share on other sites
1 hour ago, tsaven said:

Just to clarify, should I eventually get contracts generating for these outer planets and their moons?  Including the "Explore such-and-such" contracts?

Entirely correct. It'll take a while since Sarnus and beyond truly are challenges, they are the outermost planets after all, but you'll get those contracts eventually. As for all the contract types, I truly do not know, but I do know that contracts will also be generated for Kopernicus-planets.

Share this post


Link to post
Share on other sites

This mod is not compatible with 1.1 pre-release. So don't open any treasured OPM saves without backing them up.

Share this post


Link to post
Share on other sites

Got this mod and its amazing. have to say these are really well implemented in the kerbol system, and don't seem to out of place.

i really like slate and wal, they are my favorite, great work!

Edited by Markush100

Share this post


Link to post
Share on other sites

SO, when do you think will be compatible with 1.1?

Share this post


Link to post
Share on other sites
5 minutes ago, Table said:

SO, when do you think will be compatible with 1.1?

erm...1.1 isnt out yet, there is a PRE-RELEASE, but no official 1.1

perhaps waiting until 1.1 is actually released before asking would help

Share this post


Link to post
Share on other sites
21 hours ago, KillAshley said:

erm...1.1 isnt out yet, there is a PRE-RELEASE, but no official 1.1

perhaps waiting until 1.1 is actually released before asking would help

i meant 1.1 prerelease, or whatever

Edited by Val
Removed inappropriate language

Share this post


Link to post
Share on other sites
6 minutes ago, Table said:

SO, when do you think will be compatible with 1.1?

As KillAshley said, wait until 1.1 is released first. Secondly, Kopernicus is the prerequisite mod. It's what needs to be updated first, before OPM or anything else. Kopernicus 1.1 update will probably not change configs though, so we can expect that as soon as updated Kopernicus comes out, all Kopernicus packs will be 1.1 compatible. Only time can tell though.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.