Jump to content

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread


Recommended Posts

1 hour ago, nablabla said:

hi, is there a way to increase the SOI of the Kerbol system?

I want to shoot myself at plock, but when I am no an escape trajectory I cannot see my path, it ends between urlum and neidon

best regards

SOI of the sun is infinite so I don't think that's the problem

Link to post
Share on other sites

I play a heavily modded install, and have been playing around with MemGraph to get an idea of where my massive stuttering lag was coming from. During my testing, I noted that focusing on Sarnus or Neidon's rings in Map view caused massive memory spikes. I confirmed with an install of pure stock + OPM only. Screenshot of memory use follows:

Spoiler

7UeSq6t.jpg

The smooth bit in the middle is the time I spent launching a rocket. Long garbage collector intervals, low memory usage. However, the red (GC initation) and green (memory usage) spikes are when I focused on Sarnus, and rotated the map. The smooth bit in between the green spikes is me halting the map rotation and not moving anything - memory usage seems to drop down to normal, until I start spinning the map again. Neidon's usage shows similar patterns, at the far right edge. Any idea what might be causing the spiking memory usage when looking at ringed planets? 

Here's my log file, if that's useful.

 

Link to post
Share on other sites

Edited -

Hey! I've been testing this mod out with Kerbal Alarm Clock, and while it seems to work, the KAC can only seem to set alarms for transfer windows to the modded planets with 'formula' mode, which I have found to be unreliable. I have asked TriggerAu (KAC's creator) if they can fix this, but you may want to collaborate with them on this.

Just letting you know.

Edited by Toa Aerrow
Link to post
Share on other sites
4 hours ago, Wiseman said:

I play a heavily modded install, and have been playing around with MemGraph to get an idea of where my massive stuttering lag was coming from. During my testing, I noted that focusing on Sarnus or Neidon's rings in Map view caused massive memory spikes. I confirmed with an install of pure stock + OPM only. Screenshot of memory use follows:

  Hide contents

7UeSq6t.jpg

The smooth bit in the middle is the time I spent launching a rocket. Long garbage collector intervals, low memory usage. However, the red (GC initation) and green (memory usage) spikes are when I focused on Sarnus, and rotated the map. The smooth bit in between the green spikes is me halting the map rotation and not moving anything - memory usage seems to drop down to normal, until I start spinning the map again. Neidon's usage shows similar patterns, at the far right edge. Any idea what might be causing the spiking memory usage when looking at ringed planets? 

Here's my log file, if that's useful.

 

Maybe repost this is in the Kopernicus thread. Might be more related to its ring system feature than how I implemented it in OPM. 

Link to post
Share on other sites

OPM comes with a config for Custom Asteroids which adds moonlets to Jool and all the OPM planets.  All very nice.  However, the configs that come with Custom Asteroids itself assume Jool and Eeloo are the edge of the solar system, so put the Kuiper Belt and such things inside Sarnus.  That won't do if you have OPM, so I put together a CA config file that takes OPM into account.  Here it is if anybody wants it.  I'm sure somebody's already done this but why not have another take on it?

OPM_CA_Extras.cfg   Download from Dropbox

BOILERPLATE:  I reserve no rights to this because it all stems from OPM and Custom Asteroids.  A fair amount of OPM_CA_Extras.cfg was either tweaked from or inspired by Trans-Jool.cfg by @Starstrider42.  I, of course, take no responsibility for any damage using this file does to your system although I haven't had any problems with it.  So use at your own risk.

INSTRUCTIONS:

1.  Remove the Trans-Jool.cfg file that comes with Custom Asteroids.  This file totally replaces that.
2.  Edit the Basic Asteroids.cfg file that comes with Custom Asteroids.  Either delete or comment out the last ASTEROIDGROUP (name = oort) in this file, which is for long-period comets without OPM.  My OPM_CA_Extras.cfg file has its own comet mechanism.  This will leave this file making NKOs, the main belt, and the Jool Trojans.
3.  Put the OPM_CA_Extras.cfg in the GameData\CustomAsteroids\config folder.
4.  Enjoy.  Note that you can adjust the spawn rates of the various ASTEROIDGROUPs to get things more to your liking.  Want to visit a Great Comet without having to wait possibly years for one to appear naturally?  Set their spawn rate way up there to create a wad of them, then pick which one you like go back to normal.

WHAT YOU GET

Cis-Neidon:

  • Centaurs mostly living between Neidon and Jool.  A few have Aps out beyond Neidon, being in a transitional state of their evolution from Scattered Disk Objects.
  • Jool Family Comets with Aps mostlky near Jool's orbit and Pes mostly down near Kerbin.  Some are transitional between this state and their previous Centaur state.
  • "Kalley"-type Comets with Aps ranging from beyond Jool to a bit beyond Neidon and Pes in the inner system.  These are relatively rare.

OPM CA Extras Inner

Trans-Neidon:

  • Kuiper Belt Objects:  more or less circular orbits without resonance.
  • Plockinos that are KBOs in 2:3 resonance with Neidon, giving them a more elliptical orbit like Plock itself.
  • Scattered Disk Objects with Pes near Neidon and Aps that can be friggin' huge.  This is the source of the Centaurs
  • Detached Objects and Sednoids with orbits that can vary greatly but all with Pes well beyond Neidon.  Both DOs and SDOs can have periods of thousands of years.
  • Long-period comets from the Oort Cloud with Pes from sun-grazing to 2 KUs and which can have hyperbolic orbits.  Very rare.  So rare that none showed up in the 2.5 years it took to make the pic below.

OPM CA Extras Outer

 

----------------

So there you go.  Few if any of these mostly icy balls will be of any practical value but might be fun to visit.  And you can always maroon Jeb on a Sednoid with a period of over 2000 years :).  But mostly, this just shows what's out there in our own solar system.  

PM me with any suggestions or criticisms.

 

Edited by Geschosskopf
Link to post
Share on other sites

While I was messing with CustomAsteroids configs, I made a ModuleManager file to make the Plock moonlets work if you have SigmaBinary installed.  All it does is change the centralBody of the Plock moonlets from Plock to the Plock-Karen barycenter.  Here it is:

// OPM_CA_SigmaBinary.cfg by Geschosskopf
// Patch for OPM's CA file for if you have Sigma88's SigmaBinary installed.
//
// If you have SigmaBinary, this file will change the centralBody of the Plock moonlets to the
//   Plock-Karen barycenter.  No action required on your part.


// For SigmaBinary
@CustomAsteroids:NEEDS[SigmaBinary]:AFTER[SigmaBinary]
{
	@ASTEROIDGROUP[plockMoonlets]
	{
		@centralBody = Plock-Karen
	}
}

----------------------

UNFORTUNATELY, I have been unable to figure out a way to give Urlum's ring moonlets a 90^ inclination to match that of the rings if you're also using OPMTilt.  If you leave the supplied OPM_CustomAsteroids.cfg file alone, then the ring moonlets are in the ecliptic plane 90^ off from the Tilted Urlum rings.  If you change the inclination of the ring moonlets to 90^ (or something very similar), the moonlets are STILL in the ecliptic plane.  Nothing I can do there has any effect.  I'm off to ask StarStrider42 for help.

For the nonce, therefore, if you use both OPMTilt and CustomAsteroids, I recommend commenting out the part of OPM_CustomAsteroids.cfg that deals with Urlum's ring moonlets.

Link to post
Share on other sites
1 hour ago, Geschosskopf said:

While I was messing with CustomAsteroids configs, I made a ModuleManager file to make the Plock moonlets work if you have SigmaBinary installed.  All it does is change the centralBody of the Plock moonlets from Plock to the Plock-Karen barycenter.  Here it is:

// OPM_CA_SigmaBinary.cfg by Geschosskopf
// Patch for OPM's CA file for if you have Sigma88's SigmaBinary installed.
//
// If you have SigmaBinary, this file will change the centralBody of the Plock moonlets to the
//   Plock-Karen barycenter.  No action required on your part.


// For SigmaBinary
@CustomAsteroids:NEEDS[SigmaBinary]:AFTER[SigmaBinary]
{
	@ASTEROIDGROUP[plockMoonlets]
	{
		@centralBody = Plock-Karen
	}
}

----------------------

UNFORTUNATELY, I have been unable to figure out a way to give Urlum's ring moonlets a 90^ inclination to match that of the rings if you're also using OPMTilt.  If you leave the supplied OPM_CustomAsteroids.cfg file alone, then the ring moonlets are in the ecliptic plane 90^ off from the Tilted Urlum rings.  If you change the inclination of the ring moonlets to 90^ (or something very similar), the moonlets are STILL in the ecliptic plane.  Nothing I can do there has any effect.  I'm off to ask StarStrider42 for help.

For the nonce, therefore, if you use both OPMTilt and CustomAsteroids, I recommend commenting out the part of OPM_CustomAsteroids.cfg that deals with Urlum's ring moonlets.

afer taking a look at the Custom Asteroids configs I believe it's better to not change the central body for plock moonlets.

mainly because barycenters are not designed to have stuff orbiting them, so those moonlets that spawn there might end up in crazy orbits

Link to post
Share on other sites
3 hours ago, Sigma88 said:

afer taking a look at the Custom Asteroids configs I believe it's better to not change the central body for plock moonlets.

mainly because barycenters are not designed to have stuff orbiting them, so those moonlets that spawn there might end up in crazy orbits

Well, I didn't want to do it.  I'm lazy and don't mess with things unless it's necessary.  It seemed necessary here because with the centralBody left as Plock, no Plock moonlets ever spawned with SigmaBinary installed.  So I wrote the patch changing the centralBody to Plock-Karen and the moonlets started spawning.  And they all have more or less circular orbits in the plane of Plock and Karen, so it seems to be working fine.

But of course, you made SigmaBinary, so now I'm feeling like I'm thin ice here :)

 

Link to post
Share on other sites
On 6/2/2016 at 2:58 AM, Wiseman said:

During my testing, I noted that focusing on Sarnus or Neidon's rings in Map view caused massive memory spikes. I confirmed with an install of pure stock + OPM only.

For anyone else suffering with stuttering in map view, I have made some fixes to the on-demand texture loading in Kopernicus that should fix this issue.  I have released a test version over in the main Kopernicus thread here:

Note, this is based on version 1.0.5 of Kopernicus so make sure you have that before replacing the DLLs.  I realise the OP says it works best with 1.0.4.  Are there known issues with 1.0.5 or are you just playing it safe?  I've not noticed any issues so far (except for the ones I've been explicitly trying to fix) but I haven't been doing very much...

Link to post
Share on other sites
38 minutes ago, Mobius1.1 said:

114649-0-90-Kopernicus-Pre-Alpha-%280-0-I can not find kopernicus download thread anywhere, can some one steer me in the right direction please, and thank you.

Yes, it does seem the link in the OP is broken (I believe the maintainer had some problem with their forum account).  However, there's a link to the new thread in the post immediately before yours...

Link to post
Share on other sites
7 hours ago, Padishar said:

Yes, it does seem the link in the OP is broken (I believe the maintainer had some problem with their forum account).  However, there's a link to the new thread in the post immediately before yours..

Going it thanks, now when I added in the gamedata file is not accepting any mods that require it

Link to post
Share on other sites
On ‎12‎/‎21‎/‎2014 at 8:47 AM, CaptRobau said:

 

 

 

Sorry. But, I have everything installed, and all the planets are white, there are no moons, and Doesn't exist and is replaced by Neidon. HELP!

Edited by Edlu Kerman
Link to post
Share on other sites
19 minutes ago, Edlu Kerman said:

Sorry. But, I have everything installed, and all the planets are white, there are no moons, and Doesn't exist and is replaced by Neidon. HELP!

When reporting a bug with either stock KSP or with a mod you really should include a log as this will almost certainly indicate the source of this type of issue.  Details of where to find this log (and other information about what you can do yourself to locate the source of problems) can be found in the sticky threads in the technical support forums.

However, in this case, it sounds like you have simply installed the mod incorrectly.  Make sure that you don't have a GameData folder inside your GameData folder.  If you do then simply move everything in the "inner" GameData folder (the one with the OPM stuff in) into the "outer" GameData folder (the one with the Squad folder in) and then delete the empty "inner" folder.

Link to post
Share on other sites
On 6/5/2016 at 9:26 PM, Padishar said:

Yes, it does seem the link in the OP is broken (I believe the maintainer had some problem with their forum account).  However, there's a link to the new thread in the post immediately before yours...

Correct link now used.

2 minutes ago, Padishar said:

When reporting a bug with either stock KSP or with a mod you really should include a log as this will almost certainly indicate the source of this type of issue.  Details of where to find this log (and other information about what you can do yourself to locate the source of problems) can be found in the sticky threads in the technical support forums.

However, in this case, it sounds like you have simply installed the mod incorrectly.  Make sure that you don't have a GameData folder inside your GameData folder.  If you do then simply move everything in the "inner" GameData folder (the one with the OPM stuff in) into the "outer" GameData folder (the one with the Squad folder in) and then delete the empty "inner" folder.

Padishar is right about the installation.

Link to post
Share on other sites
5 minutes ago, CommanderSmith said:

I'm glad you've got that working, and I hope you're having lots of fun sending probes off everywhere. :)

Yep, Sent one to Jool to, and I am launching an ISS replica (KSS) Right now.

Link to post
Share on other sites

@CaptRobau @Eudae55 I was messing around with OPM and noticed how now the normal maps seem to be much stronger than before

here are a couple of screenshots to show you what I mean:

OLD: https://www.dropbox.com/s/63ln8m3zqa2d7uw/Screenshot 2016-06-08 01.34.25.png
NEW: https://www.dropbox.com/s/o889l0fbmb156m9/Screenshot 2016-06-08 01.58.54.png

they feel a bit weird to be honest, not bad... but they feel a bit less stock-alike now.

I am posting this mostly because I am curious if this was exactly what you were aiming for, or if it's more a result of "trial and error" and may be changed in the future :)

Edited by Sigma88
Link to post
Share on other sites

I'm not completely happy with the results yet, so I will try to get it closer to what I really want in the future. Couple of things to note though:

  • Karen is a really bad comparison, since it's terrain has been massively changed. The old Karen had very noisey terrain and the large terrain changes (like big impact basins) were not very pronounced. This normal looks so different, because it is different.
  • Procedural craters also add a lot of detail to a normal map. Only the Mun has that in stock KSP and you're used to it there.
  • The normal map lighting is not applied in the right direction, so it can look a bit off compared to stock KSP. Trying to fix that.

I don't think the base idea behind these normal maps is not stockalike, just that stockalike has long meant fuzzy and not a lot of detail. If I can tweak it a bit further I think it'll start feeling like the high-quality version stockalike that I want.

Link to post
Share on other sites

Hi, i'm having a big problem: all of the planets and moons with atmospheres have no drag. I am using the galactic neighborhood mod and this bug does not occur with planets from other packs, does anyone know what might be the problem? Thanks

Link to post
Share on other sites
2 minutes ago, Xblackmamba said:

Hi, i'm having a big problem: all of the planets and moons with atmospheres have no drag. I am using the galactic neighborhood mod and this bug does not occur with planets from other packs, does anyone know what might be the problem? Thanks

you should try to reproduce the bug without GN, I don't do anything that affects atmospheres so if you see the bug there you should see it without GN as well

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...