CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

Run into a major bug with OPM-all Kerbol-orbiting bodies (including Kerbol itself, but not Kerbin) get renamed to numerical IDs on installing OPM which, of course, breaks a lot of stuff as everything that relies on them no longer has a name to refer to-for example, my Strategia contract to send probes to Eve failed because Eve has been renamed to "58979". Moho is now "92653", Duna is "32384", Dres is "62643", Jool is "38327", Sarnus is "95028", Urlum is "84197", Neidon is "16939" and Plock is unaffected presumably since it orbits the SB barycenter. I even hard-reinstalled KSP and all mods in GameData, to no avail. Here's the logs.

Share this post


Link to post
Share on other sites

 

27 minutes ago, voicey99 said:

Run into a major bug with OPM-all Kerbol-orbiting bodies (including Kerbol itself, but not Kerbin) get renamed to numerical IDs on installing OPM which, of course, breaks a lot of stuff as everything that relies on them no longer has a name to refer to-for example, my Strategia contract to send probes to Eve failed because Eve has been renamed to "58979". Moho is now "92653", Duna is "32384", Dres is "62643", Jool is "38327", Sarnus is "95028", Urlum is "84197", Neidon is "16939" and Plock is unaffected presumably since it orbits the SB barycenter. I even hard-reinstalled KSP and all mods in GameData, to no avail. Here's the logs.

I believe that is a Sigma Binary Easter egg.

Share this post


Link to post
Share on other sites
7 minutes ago, Merkov said:

 

I believe that is a Sigma Binary Easter egg.

That's the one I just noticed. Figured that since today is Pi day, and that the name for the system primary was now 3.1415... Yeah, figured it was an easter egg. Good to know whose it is, though!

Share this post


Link to post
Share on other sites
30 minutes ago, MaverickSawyer said:

That's the one I just noticed. Figured that since today is Pi day, and that the name for the system primary was now 3.1415... Yeah, figured it was an easter egg. Good to know whose it is, though!

I wish I got to see that. :P Ah well, I got to experience the Mun-iverse.

Share this post


Link to post
Share on other sites
35 minutes ago, JadeOfMaar said:

I wish I got to see that. :P Ah well, I got to experience the Mun-iverse.

just set the date to march 14th and you can experience it any time you want :)

there are also other easter eggs, as far as I know 2 went completely unnoticed :)

Share this post


Link to post
Share on other sites

@Sigma88 I would've gotten to see the Pi day thing actually, but SB with GPP and RemoteTech made for problems so I had to remove it. :( 

I'm eager to see what you have planned for April Fool's. :) 

Spoiler

.......If you don't have something you should be ashamed of yourself!

 

Share this post


Link to post
Share on other sites
18 minutes ago, JadeOfMaar said:

@Sigma88 I would've gotten to see the Pi day thing actually, but SB with GPP and RemoteTech made for problems so I had to remove it. :( 

I'm eager to see what you have planned for April Fool's. :) 

  Reveal hidden contents

.......If you don't have something you should be ashamed of yourself!

 

Spoiler

I'm not

 

Share this post


Link to post
Share on other sites
3 hours ago, Sigma88 said:

just set the date to march 14th and you can experience it any time you want :)

there are also other easter eggs, as far as I know 2 went completely unnoticed :)

Well, I'm still on the 14th here for a few hours, so the hunt is on!

Share this post


Link to post
Share on other sites

disregard, this fix i posted apparently on works when "forcing" OpenGl but the issue remains on actual OpenGl machines.

Edited by Galileo

Share this post


Link to post
Share on other sites

I would suggest a moon that the dev could add (if he wants to). What about something like Pan or Atlas, a "squished ball" with a very huge equatorial ridge? I would love to see that, they are my most favorite moons. Hale is nice but just lacks that beauty :)

Pan_(moon)_edge-on.jpg

Share this post


Link to post
Share on other sites

Hi everyone,

Sorry for disappearing off the face of the planet like that. Been really busy with a game of my own. It's not far enough to show off, but I can tell you it's not space-related à la KSP. This has taken up all my time. But I figured OPM needed a last big update to work out all the kinks. After that it should be much less daunting for me to keep it updated.

I have two questions for you guys:

  1. Did anything in general happen to KSP, Kopernicus, etc. that's worth knowing for me? I know that there's an expansion coming, but other than that I've been pretty out of the loop.
  2. What can I fix/improve for the next update? I have a list of stuff already (see below) but I was wondering if other bugs, etc. have been found recently.

This is what I already have planned for KSP 2.2

  • Corrected the link between the biome cfg and map for Polta and Wal, so that the biomes work correctly
  • Fixed a wrongly colored region on Wal's biome map
  • Redo the CommNet configuration. Remembered this didn't really work well with early career mode. Open to suggestions on how to rebalance it.
  • Remove mention of Urlum's retrograde rotation from its blurb

Share this post


Link to post
Share on other sites
10 minutes ago, CaptRobau said:

Hi everyone,

Sorry for disappearing off the face of the planet like that. Been really busy with a game of my own. It's not far enough to show off, but I can tell you it's not space-related à la KSP. This has taken up all my time. But I figured OPM needed a last big update to work out all the kinks. After that it should be much less daunting for me to keep it updated.

I have two questions for you guys:

  1. Did anything in general happen to KSP, Kopernicus, etc. that's worth knowing for me? I know that there's an expansion coming, but other than that I've been pretty out of the loop.
  2. What can I fix/improve for the next update? I have a list of stuff already (see below) but I was wondering if other bugs, etc. have been found recently.

This is what I already have planned for KSP 2.2

  • Corrected the link between the biome cfg and map for Polta and Wal, so that the biomes work correctly
  • Fixed a wrongly colored region on Wal's biome map
  • Redo the CommNet configuration. Remembered this didn't really work well with early career mode. Open to suggestions on how to rebalance it.
  • Remove mention of Urlum's retrograde rotation from its blurb

I'm interested in what that game is about, but also how you make a game as it's something I'd love to do myself at one point, but to the point: kopernicus.

There has been an update adding new ring shaders, although there is a strange bug with the shaders, if they are applied to more than one set of rings, it will appear on only one set of rings, all other rings with shaders applied will simply disappear.

There is a new PQSMod called MeshScatter - specify a scatter in a similar fashion to LandControl, then provide a 'concentration map'. Similar to a heightmap, the 'whiter' the greater the concentration of that scatter. I have written an example code by looking at the PQSMod loader code.

Other than that there have only been bugfixes if I remember correctly.

Share this post


Link to post
Share on other sites
1 hour ago, CaptRobau said:

Hi everyone,

Sorry for disappearing off the face of the planet like that. Been really busy with a game of my own. It's not far enough to show off, but I can tell you it's not space-related à la KSP. This has taken up all my time. But I figured OPM needed a last big update to work out all the kinks. After that it should be much less daunting for me to keep it updated.

I have two questions for you guys:

  1. Did anything in general happen to KSP, Kopernicus, etc. that's worth knowing for me? I know that there's an expansion coming, but other than that I've been pretty out of the loop.
  2. What can I fix/improve for the next update? I have a list of stuff already (see below) but I was wondering if other bugs, etc. have been found recently.

This is what I already have planned for KSP 2.2

  • Corrected the link between the biome cfg and map for Polta and Wal, so that the biomes work correctly
  • Fixed a wrongly colored region on Wal's biome map
  • Redo the CommNet configuration. Remembered this didn't really work well with early career mode. Open to suggestions on how to rebalance it.
  • Remove mention of Urlum's retrograde rotation from its blurb

Other than that suggestion about new moon/moons, I have nothing to say. OPM seems to work fine even though it's for 1.2.1, I just love the new planets, especially Sarnus.

Share this post


Link to post
Share on other sites
2 hours ago, CaptRobau said:

Hi everyone,

Sorry for disappearing off the face of the planet like that. Been really busy with a game of my own. It's not far enough to show off, but I can tell you it's not space-related à la KSP. This has taken up all my time. But I figured OPM needed a last big update to work out all the kinks. After that it should be much less daunting for me to keep it updated.

I have two questions for you guys:

  1. Did anything in general happen to KSP, Kopernicus, etc. that's worth knowing for me? I know that there's an expansion coming, but other than that I've been pretty out of the loop.
  2. What can I fix/improve for the next update? I have a list of stuff already (see below) but I was wondering if other bugs, etc. have been found recently.

This is what I already have planned for KSP 2.2

  • Corrected the link between the biome cfg and map for Polta and Wal, so that the biomes work correctly
  • Fixed a wrongly colored region on Wal's biome map
  • Redo the CommNet configuration. Remembered this didn't really work well with early career mode. Open to suggestions on how to rebalance it.
  • Remove mention of Urlum's retrograde rotation from its blurb

1. No.

2. Nothing really, everything seems to be working well :)

Share this post


Link to post
Share on other sites
5 hours ago, CaptRobau said:
  • Redo the CommNet configuration. Remembered this didn't really work well with early career mode. Open to suggestions on how to rebalance it.

I would personally suggest to either create a new part based on an existing model (or approach an existing mod author to use their asset) that can reach the outer planets, to some extent. A re-balance of the existing longest range antennas could be done so that they just barely reach Sarnus. That would give you a good transition point between the parts.

On a different approach, a part upgrade could be done to the longest reach antennas way down in the tech tree to increase the power ratings of those antennas so that they reach the outer planets.

I obviously don't know how you'd prefer to approach it but my antenna signal strength calculator sheet has the OPM bodies incorporated into it where you could edit the power of existing antennas or introduce new antennas to give you the results you are looking for. This can be found here: Link - Note that you have to create a copy of the sheet to you own account to be able to edit it for you own use.

If you would like some input, value suggestions or testing to this nature please just say the word and I'll be happy to help.

Share this post


Link to post
Share on other sites

Hi, I'm planning my first trip to Sarnus, so I've posted my ideas for the fleet I'll send in the gameplay questions subforum... but probably not that many people that play with OPM go there. If anyone wants to give me any suggestion or correct something I've planned wrong, here's the thread I've created

 

Share this post


Link to post
Share on other sites
20 hours ago, CaptRobau said:
  • Redo the CommNet configuration. Remembered this didn't really work well with early career mode. Open to suggestions on how to rebalance it.

I'd say the best approach would be to duplicate some of the stock parts to have more antennas and balance them so that you can divide the system in different regions.

the biggest stock antenna would reach up to jool

then one for Sarnus, one for Urlum and one for Neidon/Plock

 

I've done something similar with my OuterSpaceComms (which requires RT) but you could very easily do the same with the stock antennas.

If you are interested I could make something for you, I'll leave the balancing to you since I have no idea how that feature works, but I can get the base system in place, with custom textures and sizes so the antennas don't look just like a bunch of clones

Share this post


Link to post
Share on other sites

Is this compatible with IA revived. They used to work together and IA works, but if i add opm the game does a ctd after loading the game every time. The log shows opm ran a ton of errors.

Edit for clarification- Other then kopernicius those are the only two mods installed

Edited by zachdogg

Share this post


Link to post
Share on other sites

This is really cool.

I like the challenge of going out that far :)

It would be great if time warping was shorter

Share this post


Link to post
Share on other sites
55 minutes ago, UranianBlue said:

This is really cool.

I like the challenge of going out that far :)

It would be great if time warping was shorter

Yes it would, and it truley is challenging. Only put a probe into orbit around Sarnus, have one scheduled to fly around Plock-Karen in about 4 years game time but I don't think that I'll be able to put it into orbit around the system... Still need to try and visit urlum and neidon as well...

Share this post


Link to post
Share on other sites

Does this work in 1.2.2? And this would be great if you could make it compatible with the MechJeb Maneuver Planner.

Edited by Brainpop14

Share this post


Link to post
Share on other sites
On March 19, 2017 at 5:43 AM, CaptRobau said:

fix/improve

Please fix the problem with everything being covered in yellow lines when on a Mac.

 

PS. Happens with 64 bit too, so not a memory error.

Share this post


Link to post
Share on other sites
1 hour ago, Bill the Kerbal said:

Please fix the problem with everything being covered in yellow lines when on a Mac.

 

PS. Happens with 64 bit too, so not a memory error.

You have to change the textures to PNG and make sure the directories in the cfgs are also pointing to PNGs instead of DDS. That is the only true fix I have found so far for this problem. It uses more ram but that's not that big of a deal 

Share this post


Link to post
Share on other sites
On 3/22/2017 at 8:51 PM, Galileo said:

You have to change the textures to PNG and make sure the directories in the cfgs are also pointing to PNGs instead of DDS. That is the only true fix I have found so far for this problem. It uses more ram but that's not that big of a deal 

same thing on linux. how would you go about doing that? anyone have a python script for it, perchance? would someone like to maintain an alternate downloads? (i would, but college is not easy on the spare time)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.