CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

12 hours ago, Drew Kerman said:

if you post logs, someone may be able to tell you.

Um, never mind... This is weird. I've reinstalled Kopernicus (I had a brand new version) and it appeared. Oh well. If it works, don't fix it. :cool:

Edited by lajoswinkler

Share this post


Link to post
Share on other sites
On 7/13/2017 at 4:03 AM, Galileo said:

Here is OPM for 1.3

This is a version of OPM maintained by Galileo
This version of Outer Planets Mod is for KSP version 1.3
I will host this version until CaptRobau takes it over, or if he wants it taken down.

This version works for Macs, Linux, and PC. No yellow moire effect.

Change log

  • Updated for KSP 1.3
  • Completed necessary localization (en-us)
    • Covers displayName, Descriptions and ScienceDefs
    • Does NOT cover ResearchBodies (maybe in the future)
  • Fixed Urlum's and Sarnus' rings for Kopernicus' ring shader
  • Enabled Kopernicus' ring shader ^ hey whatta ya know?
  • Added support for KopernicusExpansions footprints on all rocky bodies

If you want to contribute to the localization effort, it would be greatly appreciated by CaptRobau, no doubt.
I could only do English, because well, I'm a lazy American that only speaks one language! :D 

DOWNLOAD

THANK YOU SO MUCH!!!!

Share this post


Link to post
Share on other sites

Not sure if this is an issue with OPM or another mod, but my solar panels are not rotating to the correct position so my probes always runs out of charge if I don't micro manage them all.

 

It seems like they are pointing to Grannus instead of Kerbol. Maybe there is some issue with having two stars? 

 

Share this post


Link to post
Share on other sites
3 minutes ago, Eiktyrner said:

Maybe there is some issue with having two stars? 

that might be the problem

whats the other star sistem mod?

Share this post


Link to post
Share on other sites
7 minutes ago, KerbolExplorer said:

that might be the problem

whats the other star sistem mod?

I don't have any other mod adding stars. I was referring to the second image where you can see that the solar panels all point to Grannus. I'm wondering if the issue could be that Grannus is a valid target for solar panels even though it can hardly generate any EC. 

Share this post


Link to post
Share on other sites
49 minutes ago, Eiktyrner said:

I don't have any other mod adding stars. I was referring to the second image where you can see that the solar panels all point to Grannus. I'm wondering if the issue could be that Grannus is a valid target for solar panels even though it can hardly generate any EC. 

OPM does not have a "Grannus" body, you are thinking of GPP

Share this post


Link to post
Share on other sites
48 minutes ago, Sigma88 said:

OPM does not have a "Grannus" body, you are thinking of GPP

Wow, I've managed to confuse the two. This save is only using GPP.. Ignore my posts and I'll ask over in the GPP thread instead!

 

edit: Found the github issue about it. I'm probably just doing something wrong if it's resolved for others... Might just try a re-install

Edited by Eiktyrner

Share this post


Link to post
Share on other sites

So I am currently an aspiring modder for planets. My idea for a planet pack involves remaking a lot of planets, and I want to try editing yours such that it fits the "storyline" of my mod. Would you consider giving me permission to do this? If not, I understand :P

Share this post


Link to post
Share on other sites
3 hours ago, The Cuttlefish Empire said:

and I want to try editing yours such that it fits the "storyline" of my mod. Would you consider giving me permission to do this?

This mod's license is permissive enough "CC share-alike" for you to do as you will. But if you're really cautious about crossing lines, I'd suggest you not publish any spinoffs of this mod for wide consumption, at least until you get a clearer answer than mine from someone else like Galileo or Sigma88. If anything, use your story purely for learning purposes as a modder, then when you're skilled enough, change your story so that it doesn't need OPM and let your own new planets fill OPM's places.

Share this post


Link to post
Share on other sites
1 hour ago, JadeOfMaar said:

This mod's license is permissive enough "CC share-alike" for you to do as you will. But if you're really cautious about crossing lines, I'd suggest you not publish any spinoffs of this mod for wide consumption, at least until you get a clearer answer than mine from someone else like Galileo or Sigma88. If anything, use your story purely for learning purposes as a modder, then when you're skilled enough, change your story so that it doesn't need OPM and let your own new planets fill OPM's places.

Alright, thanks. I don't imagine I'll get very many downloads, at least not for a while, but the end goal will eventually be to replace all the bodies I can with my own creations, which will be similar to but different from their analogues.

Share this post


Link to post
Share on other sites

Thanks Galileo and CaptRobau.

BTW love your work. Your planet pack is amazing but too much for my old system. It did however inspire me to look around the modding community again so many many thanks.

In fact I'm here to request/encourage you to add ResearchBodies compatibility to OPM. It is perfect for my outdated system because it has no new sun(s). The only thing I have against New Horizons is that there are no moons around the home world to explore and that messes up the contracts for ResearchBodies. I have not played with OPM and would love to discover its layout with telescopes - a RL scenario thing.

All I can discover with ResearchBodies now is the original solar system that I know so very well already. I haven't found a planet pack that works with ResearchBodies that is small enough for me to use but this looks just about right.

Update;

After some reading and testing OPM does work with Researchbodies as well as TarsierSpaceTech (all updated today BTW).

The only thing missing;

when I find a new body with a telescope the discovery text makes no sense except that it does give the name of the body. I red here, early in the thread, where you mentioned how to fix that but I have had no luck with it.

Thanks again, this is awesome fun.

Unrelated side note: I discovered your Planet Pack and long story short, I'm looking at a new video card.:kiss:

Edited by Capt. Kermit
Update

Share this post


Link to post
Share on other sites

I think I can confirm from a previous commenter that KerbNet is getting degraded by OPM.  I did a test install of no-mods KSP 1.3, launched a stock Viewmatic Survey Sat in Sandbox mode, and the HECS2 probe core had the full range of KerbNet scanning modes when in orbit around Kerbin.

After installing OPM Galileo v1.1 and associated dependencies (Kopernicus 1.3.0.4, CustomBarnKit 1.1.13), the same craft now says the following when I attempt to use KerbNet:

"KerbNet is Offline.  Please ensure that you're accessing KerbNet with a compatible scanning mode."

The Resource scan mode appears to work, when using a scanner such as M4435, but both the Terrain and Biome modes appear to be disabled.  This happens above both OPM and non-OPM planets.

Share this post


Link to post
Share on other sites
34 minutes ago, KSPrynk said:

I think I can confirm from a previous commenter that KerbNet is getting degraded by OPM.  I did a test install of no-mods KSP 1.3, launched a stock Viewmatic Survey Sat in Sandbox mode, and the HECS2 probe core had the full range of KerbNet scanning modes when in orbit around Kerbin.

After installing OPM Galileo v1.1 and associated dependencies (Kopernicus 1.3.0.4, CustomBarnKit 1.1.13), the same craft now says the following when I attempt to use KerbNet:

"KerbNet is Offline.  Please ensure that you're accessing KerbNet with a compatible scanning mode."

The Resource scan mode appears to work, when using a scanner such as M4435, but both the Terrain and Biome modes appear to be disabled.  This happens above both OPM and non-OPM planets.

This will be fixed this evening. I have to enable the display names for the biomes so the latest kopernicus can see them.

Share this post


Link to post
Share on other sites
4 hours ago, KSPrynk said:

I think I can confirm from a previous commenter that KerbNet is getting degraded by OPM.  I did a test install of no-mods KSP 1.3, launched a stock Viewmatic Survey Sat in Sandbox mode, and the HECS2 probe core had the full range of KerbNet scanning modes when in orbit around Kerbin.

After installing OPM Galileo v1.1 and associated dependencies (Kopernicus 1.3.0.4, CustomBarnKit 1.1.13), the same craft now says the following when I attempt to use KerbNet:

"KerbNet is Offline.  Please ensure that you're accessing KerbNet with a compatible scanning mode."

The Resource scan mode appears to work, when using a scanner such as M4435, but both the Terrain and Biome modes appear to be disabled.  This happens above both OPM and non-OPM planets.

You can easily fix it yourself. It's one of the compatibility patches that's messing up.

On 25/07/2017 at 6:40 PM, Ramarren said:

Through the scientific process of deleting things at random I have determined that KerbNet in 1.3 is being broken by something in GameData\OPM\KarboniteConfigs , which I presume are out of date with current Community Resource Pack or something.

 

Share this post


Link to post
Share on other sites

OPM_Galileo v1.2

This is a version of OPM maintained by Galileo
This version of Outer Planets Mod is for KSP version 1.3
I will host this version until CaptRobau takes it over.

Change log

  • Completed necessary localization
    • ResearchBodies is now supported (Thanks @JadeOfMaar)
    • Kopernicus biome displayName enabled
  • Karbonite resource configs have been updated (Thanks @JadeOfMaar again)
  • KerbNet is not functioning correctly.
    • Use ScanSat instead. 
  • Restructured texture paths. Should speed up loading time by a few seconds

This mod retains OPM's original License: Attribution-NonCommercial-ShareAlike 4.0 International

Extensive testing was not done, so let me know if there are any major issues and I will fix them as quickly as I can

DOWNLOAD

Edited by Galileo

Share this post


Link to post
Share on other sites

I have been trying all day to get this mod to work but it just wont. I have the newest release of KSP. I downloaded Kopernicus. I downloaded the Galileo version and original version of the Outer Planets mod and neither worked. No matter how I unpack the game data folders the planets completely refuse to appear.  Is there a special way to download the mod or is there a specific patch that I need? I have module manager installed.

Share this post


Link to post
Share on other sites
2 hours ago, CSRobot said:

I have been trying all day to get this mod to work but it just wont. I have the newest release of KSP. I downloaded Kopernicus. I downloaded the Galileo version and original version of the Outer Planets mod and neither worked. No matter how I unpack the game data folders the planets completely refuse to appear.  Is there a special way to download the mod or is there a specific patch that I need? I have module manager installed.

 

Share this post


Link to post
Share on other sites

Hi, small thing I noticed you might want to know:

When I install in this order:
-ContractConfigurator
-ResearchBodies
-Kopernicus

and finally OPM, all most recent versions,

it doesn't seem to respect the ResearchBodies difficulty settings, hiding all planets regardless, so only the Mun is "discovered".
This happens in all situations, in career and sandbox.
Would you say this falls within the confines of your mod or should I report this elsewhere?

Edited by RHodeidra

Share this post


Link to post
Share on other sites
On 21/08/2017 at 6:02 PM, Galileo said:

OPM_Galileo v1.2

This is a version of OPM maintained by Galileo
This version of Outer Planets Mod is for KSP version 1.3
I will host this version until CaptRobau takes it over.

Change log

  • Completed necessary localization
    • ResearchBodies is now supported (Thanks @JadeOfMaar)
    • Kopernicus biome displayName enabled
  • Karbonite resource configs have been updated (Thanks @JadeOfMaar again)
  • KerbNet is not functioning correctly.
    • Use ScanSat instead. 
  • Restructured texture paths. Should speed up loading time by a few seconds

This mod retains OPM's original License: Attribution-NonCommercial-ShareAlike 4.0 International

Extensive testing was not done, so let me know if there are any major issues and I will fix them as quickly as I can

DOWNLOAD

Sweet, will you get it to CKAN?

Share this post


Link to post
Share on other sites
On 8/25/2017 at 1:54 PM, SupperRobin6394 said:

Sweet, will you get it to CKAN?

I won't, but if someone wants to write up the NetKan/CKAN stuff for it, then sure!

Edited by Galileo

Share this post


Link to post
Share on other sites
On 8/25/2017 at 1:56 PM, Galileo said:

I won't, but if someone wants to write up the NetKan/CKAN stuff for it, then sure!

What, might I ask, are those "Prep for CKAN" commits in the github then? :P

Share this post


Link to post
Share on other sites

So I taught myself tonight how to submit netkan info for indexing my branch on CKAN. Look for it on CKAN soon!

Share this post


Link to post
Share on other sites

Hi Galileo

I noticed this about the time I installed v1.2 but I thought it was probably due to my modding experiments or NewHorizons. I'm not really sure if this is an OPM or ReasearchBodies issue but, I just did a minimal clean install for OPM + Researchbodies and found that Sarnus isn't hidden by RB on any difficulty setting. Kopernicus, RB, and TST all come with MM2.8.1 I'm using the one from Kapernicus-1.3.0-6. This version of Kapurnicus just came out is why I mention it.

 

KSP1.3

Mod list;

ContractConfigurator_1.23.2

CustomBarnKit-1.1.15.0

DistantObject_1.9.1

Kopernicus-1.3.0-6

OPM_Galileo.v1.2

ResearchBodies_V1.9.5.0

TarsierSpaceTech_V7.0.0.0

 

Log; http://jmp.sh/yYSfsRA

Share this post


Link to post
Share on other sites
5 minutes ago, Capt. Kermit said:

Hi Galileo

I noticed this about the time I installed v1.2 but I thought it was probably due to my modding experiments or NewHorizons. I'm not really sure if this is an OPM or ReasearchBodies issue but, I just did a minimal clean install for OPM + Researchbodies and found that Sarnus isn't hidden by RB on any difficulty setting. Kopernicus, RB, and TST all come with MM2.8.1 I'm using the one from Kapernicus-1.3.0-6. This version of Kapurnicus just came out is why I mention it.

 

 

KSP1.3

Mod list;

ContractConfigurator_1.23.2

CustomBarnKit-1.1.15.0

DistantObject_1.9.1

Kopernicus-1.3.0-6

OPM_Galileo.v1.2

ResearchBodies_V1.9.5.0

TarsierSpaceTech_V7.0.0.0

 

 

Log; http://jmp.sh/yYSfsRA

It's intentional. Just like how we can see Uranus and Neptune with the naked eye in optimal conditions :) kerbals know something is there

Edited by Galileo

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.