CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

Congrats on the new patch!

Downloading it right now, can't wait to see your take on sarnus hexagon

Share this post


Link to post
Share on other sites

So the new patch doesn't load the planets for me? Does it have something to do with TextureReplacer?

Share this post


Link to post
Share on other sites

Quickly thrown together configs for OPM 1.5.5 and 64K 1.0.90.5 can be found here; as always, the probability of me having forgotten or screwed up something is absolutely there - so please tell me if that is the case :)

So the new patch doesn't load the planets for me? Does it have something to do with TextureReplacer?

My main install crashes with the latest update, I suspect it does indeed have something to do with TextureReplacer. Shaw was so kind to add exceptions for Kittopia and Kopernicus folders, but the textures were moved into the OPM folder with the latest update; I guess that will trigger the issue again.

Share this post


Link to post
Share on other sites

I did notice that 1.5.5 does not have the gasgiants and tekto cfgs for BoulderCo any longer. I've tried every possible configuration and steps to get this new release to work but it won't :(

Share this post


Link to post
Share on other sites
I did notice that 1.5.5 does not have the gasgiants and tekto cfgs for BoulderCo any longer. I've tried every possible configuration and steps to get this new release to work but it won't :(

Everything you need to know is in the first post or the changelog :)

------------------------------------

Adding an exception for the OPM folder in the @Default.cfg file in the TextureReplacer folder resolves the issue with loading planets. This config might be MM compatible - i think something about other modders was written at the start of it, so maybe you can include a quick patch CptRobau :)

Share this post


Link to post
Share on other sites
Everything you need to know is in the first post or the changelog :)

------------------------------------

Adding an exception for the OPM folder in the @Default.cfg file in the TextureReplacer folder resolves the issue with loading planets. This config might be MM compatible - i think something about other modders was written at the start of it, so maybe you can include a quick patch CptRobau :)

So you've gotten this new release to work?

Share this post


Link to post
Share on other sites
Everything you need to know is in the first post or the changelog :)

------------------------------------

Adding an exception for the OPM folder in the @Default.cfg file in the TextureReplacer folder resolves the issue with loading planets. This config might be MM compatible - i think something about other modders was written at the start of it, so maybe you can include a quick patch CptRobau :)

Do you think you could post the @Default.cfg?

Share this post


Link to post
Share on other sites

Sure! This is the relevant section:

  // Prevent unloading for textures whose paths match the following regular  // expressions. Some mods access and modify textures, so those shouldn't be
// unloaded.
// The list must be space- and/or comma-separated and in one line.
// Duplicated lists are joined.
keepLoaded = ^BoulderCo/(Clouds|Atmosphere)/ ^CommunityResourcePack/
keepLoaded = ^CustomBiomes/PluginData/CustomBiomes/ ^KittopiaSpace/Textures/
keepLoaded = ^Kopernicus/Textures/ ^Romfarer/textures/
keepLoaded = ^WarpPlugin/PlanetResourceData/ ^OPM/

The appended ^OPM/ prevents TextureReplacer from unloading the textures Kopernicus needs.

Share this post


Link to post
Share on other sites

I'm writing science reports for the OPM planets. Sometimes it's helpful to have good maps of the planets to base the reports on, so I went ahead and exported some high res SCANsat altimetry and biome maps for each of Sarnus' moons. The Slate and Tekto maps are 3k X 1.5k, the Hale and Ovok maps are 2k X 1k.

Javascript is disabled. View full album

I noticed a few things while doing this. Tekto's high resolution map appears to be flipped vertically from the standard map, it doesn't match up with the biomes and height map, and I think Hale's is the same (Ovok and Slate seem to be fine), I didn't check the low resolution maps.

nHrImi7.png

You can also see in the biome maps a lot of very fine details. KSP doesn't handle these well. Because the colors at the biome borders bleed into each other KSP reads each these areas as different biomes.

Share this post


Link to post
Share on other sites

Aww, Orbital Science for OPM, this is great news!

On another note, TextureReplacer's settings are indeed open to MM, this laughably little patch should resolve the incompatibility with OPM when inside a .cfg in GameData.

TextureReplacer
{
keepLoaded = ^OPM/
}

---------

So you've gotten this new release to work?

Yes, I have (although my linux install seems to get slightly unstable above 10gb ram :()

The AVP configs are in a separate download as of 1.5.5.

Edited by Tellion

Share this post


Link to post
Share on other sites
Aww, Orbital Science for OPM, this is great news!

On another note, TextureReplacer's settings are indeed open to MM, this laughably little patch should resolve the incompatibility with OPM when inside a .cfg in GameData.

TextureReplacer
{
keepLoaded = ^OPM/
}

---------

Yes, I have (although my linux install seems to get slightly unstable above 10gb ram :()

The AVP configs are in a separate download as of 1.5.5.

lol what in God's name are you running to top over 10gigs!?!?! Every mod, ever? (I don't have tons, but I do run a lot of mods and I barely scratch 3gigs in Mint)

I Found the AVP configs, and can confirm that your MM patch does indeed resolve the issue.

:)

Share this post


Link to post
Share on other sites

Glad you sorted it out!

Well most of the big ones and then some more, no ATM but everything in DDS. And lately I gave up on the windows acquired habit of pruning 60% of stock parts as well... Linux really is a beautiful thing

Share this post


Link to post
Share on other sites

That seems to be have been an oversight (so many mods to check). I'll do an official hotfix tomorrow (it's late), but for the time being, go to @Default.cfg in the TextureReplacer folder and make sure this section:

  // Prevent unloading for textures whose paths match the following regular
// expressions. Some mods access and modify textures, so those shouldn't be
// unloaded.
// The list must be space- and/or comma-separated and in one line.
// Duplicated lists are joined.
keepLoaded = ^BoulderCo/(Clouds|Atmosphere)/ ^CommunityResourcePack/
keepLoaded = ^CustomBiomes/PluginData/CustomBiomes/ ^KittopiaSpace/Textures/
keepLoaded = ^Kopernicus/Textures/ ^Romfarer/textures/
keepLoaded = ^WarpPlugin/PlanetResourceData/

Looks like this:

  // Prevent unloading for textures whose paths match the following regular
// expressions. Some mods access and modify textures, so those shouldn't be
// unloaded.
// The list must be space- and/or comma-separated and in one line.
// Duplicated lists are joined.
keepLoaded = ^BoulderCo/(Clouds|Atmosphere)/ ^CommunityResourcePack/
keepLoaded = ^CustomBiomes/PluginData/CustomBiomes/ ^KittopiaSpace/Textures/
keepLoaded = ^Kopernicus/Textures/ ^Romfarer/textures/
keepLoaded = ^WarpPlugin/PlanetResourceData/ ^OPM/

Ie. add ^OPM/

Share this post


Link to post
Share on other sites
Aww, Orbital Science for OPM, this is great news!

Yep, I've already written reports for everything except a few Tekto biomes that I want to check out myself and Slate. I figure I can come up with an interesting story for that one, since it doesn't have any obvious real-life analogue like the others do.

Share this post


Link to post
Share on other sites
Was Tekto's colors just changed?

The following visual changes were made to Tekto:

- I made the drainage/erosion lines lighter as they were a bit too strong IMO.

- Re-aligned the ocean borders on the texture so they line up with the shores of the actual terrain.

- Added a bit more blue into the skybox/atmosphere gradient as it was too green.

- Toned down the ambient lighting so objects are not fluorescent green at sea-level.

Share this post


Link to post
Share on other sites

Hey Folks,

I'm going to stream the latest update in about ten minutes from now. Please stop by if you can www.twitch.tv/spaceman_spff

I've got a lander I'm going to take down to Slate, and orbital station around Ovok, and I'll be trying out some mining operations.

I'd be great if you could drop by.

Share this post


Link to post
Share on other sites
Made a short test video showing off this and the IXS.

Cool

Hey Folks,

I'm going to stream the latest update in about ten minutes from now. Please stop by if you can www.twitch.tv/spaceman_spff

I've got a lander I'm going to take down to Slate, and orbital station around Ovok, and I'll be trying out some mining operations.

I'd be great if you could drop by.

Ahh, I missed. You were streaming right through my much-needed sleep. Bummer.

Share this post


Link to post
Share on other sites

Awesome mod first off. However, I loaded this up today with the KSPRC compatibility patch but there are no clouds showing on any of the OPM planets that should have clouds. Is there any additional changes that need to be made in order to get this to work with KSPRC?

Share this post


Link to post
Share on other sites

It doesn't work for me. No planets are showing up, it's just the normal stock system for me. I've tried reinstalling it several times, I updated texture replacer, restarted my whole computer, and it still doesn't work. The only mod which is apparently incompatible with this is Engineer Redux. Please help me.

Share this post


Link to post
Share on other sites
It doesn't work for me. No planets are showing up, it's just the normal stock system for me. I've tried reinstalling it several times, I updated texture replacer, restarted my whole computer, and it still doesn't work. The only mod which is apparently incompatible with this is Engineer Redux. Please help me.

Updating TextureReplacer does not suffice anymore; you have to drop a .cfg file into your GameData folder with the following contents:


TextureReplacer
{
keepLoaded = ^OPM/
}

Share this post


Link to post
Share on other sites

Official hotfix is available

People who download the mod from now on will download version 1.5.5.1, which adds a fix for the TextureReplacer problem. It's a tiny little config that fixes it, so for those who already have downloaded 1.5.5 I think it's easier if you download just the config:

Extract this and put it in your GameData folder

Sorry for the inconvenience.

Share this post


Link to post
Share on other sites

Hello CaptRobau,

Just wanted to pop in to give you a big thank you for the mod! I dropped KSP for a little while when it moved to 0.90 as I couldn't get additional planets to expand the stock system to work. You've breathed new life into the game for me (especially with realistic styled planets!! <3).

Cheers!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.