CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

Thank you very much.

Ah, ok that would ensure basic compatibility.

Though I just finished the SETIctt - Sigma config anyway.

Yep, kind of. I just wanted to ensure compatibility. But with the info from Olympic1 and the SETIctt-TechTree-Sigma config, there is no need for me to make upscaled duplicates of RT antennas ;-).

Thank you all!

- - - Updated - - -

Hm, I noticed a problem with Sigma.

It reduces the range of the GigaDish1 from 400Gm to 100Gm. If Sigma is thus installed onto an existing savegame, it would break existing network designs?

Without OPM installed.

I don't think changes will affect craft which are already launched, I think the ranges are saved in the craft file inside the saved game.

my change should just prevent you to send new copies of that antennas farther than 100 Gm

nobody ever complained for now

Edited by Sigma88

Share this post


Link to post
Share on other sites

And I found an issue while installing OPM.

The OPM version file is outside of the OPM folder, which is problematic for installing.

- - - Updated - - -

I don't think changes will affect craft which are already launched, I think the ranges are saved in the craft file inside the saved game.

my change should just prevent you to send new copies of that antennas farther than 100 Gm

nobody ever complained for now

If people reread the descriptions of an existing antenna, which, according to my experience, is rarely the case.

- - - Updated - - -

Also, the range of the GX-256 actually decreases when OPM is installed, while the GX-512 range stays at 300Gm, but the GX1024 jumps from 400Gm to 750Gm.

Share this post


Link to post
Share on other sites
And I found an issue while installing OPM.

The OPM version file is outside of the OPM folder, which is problematic for installing.

- - - Updated - - -

If people reread the descriptions of an existing antenna, which, according to my experience, is rarely the case.

- - - Updated - - -

Also, the range of the GX-256 actually decreases when OPM is installed, while the GX-512 range stays at 300Gm, but the GX1024 jumps from 400Gm to 750Gm.

yeah I should probably put a description for OSC

basically the standard numbers are just an increase in reach of x meters, while if you have OPM the numbers are tailored to fit the planets perfectly

It's still a WIP so numbers may change untill I'm happy with the final result.

for now, noone complained, so I always assumed everything was fine

Share this post


Link to post
Share on other sites

Okay, I'm back from holiday. I'll start work on 1.7.2 this week. Most of the stuff is noted or was already known, so I'll try to fix as much as possible.

Share this post


Link to post
Share on other sites

hi capt, welcome back

a couple of things you may find interesting for 1.7.2

You don't need to set a flightGlobalsIndex anymore. Kopernicus creates / overwrites them after the PSystemManager spawned the edited prefab, so it's nonsensical to define them. ;) This has been implemented in 0.0.6, if I remember correctly
I have a question about how to bundle textures.

can I put just 1 dds colormap file into the mod and use it for both PQS and ScaledVersion?

would this give rise to any problems?

it causes no problems, sigma. It used to be that a higher-res version could be in the PluginData folder, but with dds it's not as necessary.As long as the filepaths are correct it won't make any difference.

Next version of NH only uses 1 texture for both. Had no issues at all.

Plus of course we now have pictures of Pluto's surface

HYPE!

Share this post


Link to post
Share on other sites

Plus of course we now have pictures of Pluto's surface

HYPE!

All aboard!

Also, could someone remind me to make a Hyperion analogue for Sarnus?

Share this post


Link to post
Share on other sites
hi capt, welcome back

a couple of things you may find interesting for 1.7.2

Plus of course we now have pictures of Pluto's surface

HYPE!

The second one I saw, but the first one is news to me. Thanks for the update.

Share this post


Link to post
Share on other sites

This is a very cool mod but it takes a very long time to transfer to any of the planets. Are there any mods that have better engines?

Share this post


Link to post
Share on other sites

Hey guys, sometime ago we had a bug Sarnus' and Urlum's rings would "wipe" any clouds you had from visual mods from behind the rings. Originally the consensus was that it was from ATM, but I don't have that installed and the issue has cropped up. I was wondering if you guys could help me.

If it's any assistance, I'm running on 1.0.4 with this, planetshine, EVE, and Astronomer's Interstellar is the cloud pack.

Share this post


Link to post
Share on other sites
Ooooh, I read it wrong, this is the section in the module manager output that I based it off of:

Non-DLL mods added (:FOR[xxx]):  Tourism
[B] AntennaRange[/B]
AES
HERP
PackRat
FTT
KarbonitePlus
MKS
OKS
SrvPack

So what it's saying is that there is a module manager config *somewhere* in your GameData that is using :FOR[AntennaRange], and that's what's causing ModuleManager to believe that AngennaRange is installed.

From looking closer at the log, it's this line:

Config(@TRACKING_STATION_RANGES
[*]:NEEDS[AntennaRange]:FOR[AntennaRange]) OPM/OPM_AntennaRange/@TRACKING_STATION_RANGES
[*]:NEEDS[AntennaRange]:FOR[AntennaRange]

So assuming you haven't been messing around with stuff, then it looks to me like it might be a bug in the Module Manager config for Outer Planets Mod (they shouldn't have that FOR[AntennaRange] in there).

Nightingale may have found a small bug in the Antenna Range config when helping with an exception I was getting in my debug for the Tourism Contract Pack, just thought I would report it here. I scanned a bunch of pages back and didn't see that it was already reported. Sorry if it was.

Share this post


Link to post
Share on other sites
Hey guys, sometime ago we had a bug Sarnus' and Urlum's rings would "wipe" any clouds you had from visual mods from behind the rings. Originally the consensus was that it was from ATM, but I don't have that installed and the issue has cropped up. I was wondering if you guys could help me.

If it's any assistance, I'm running on 1.0.4 with this, planetshine, EVE, and Astronomer's Interstellar is the cloud pack.

It is caused by Kopernicus and on the list of things to be fixed. A workaround, although a little cumbersome is letting Kittopia handle the rings.

Share this post


Link to post
Share on other sites
It is caused by Kopernicus and on the list of things to be fixed. A workaround, although a little cumbersome is letting Kittopia handle the rings.

Cheers for the help! If it's known then I'm fine to wait.

Share this post


Link to post
Share on other sites
Okay, I'm back from holiday. I'll start work on 1.7.2 this week. Most of the stuff is noted or was already known, so I'll try to fix as much as possible.

Good to hear that :) Have you seen latest images of Pluto BTW?

Rnj7kZj.jpg

Share this post


Link to post
Share on other sites
Good to hear that :) Have you seen latest images of Pluto BTW?

http://i.imgur.com/Rnj7kZj.jpg

Of course I have. Don't expect Plock and Charon analog tomorrow. First I have some bug fixes to do as well as get Neidon's moons up and running.

Share this post


Link to post
Share on other sites
This is a very cool mod but it takes a very long time to transfer to any of the planets. Are there any mods that have better engines?

Atomic Age by Porkjet, for nuclear thermal rockets;

Near Future Propulsion by Nertea, for electric engines.

Share this post


Link to post
Share on other sites
Of course I have. Don't expect Plock and Charon analog tomorrow. First I have some bug fixes to do as well as get Neidon's moons up and running.

Oh, I'm not expecting them to be ready soon, just wanted to share the stunnig photo to be honest :) Tomorrow even better images of Pluto-Charon system should be available. As for the mod, keep up the good work - it's really appreciated :)

Share this post


Link to post
Share on other sites

flJhBt4.png

While I haven't been able to fix the darkening terrain, I have been able to add custom oceans + water textures. So the map view's dark oceans transition into real dark oceans up close too.

Share this post


Link to post
Share on other sites

Well, it looks like my Plock rendition will eventually be out of style. Come on Plock, Chirkin, Gyx, Nin, Kergo, and Hyren, let's go out back.

*racks shotgun*

You coming too, Old Yeller?

Also, there's this.

ttWbc9E.jpg?1

I'm pretty sure this is an error on my side.

http://i.imgur.com/flJhBt4.png

While I haven't been able to fix the darkening terrain, I have been able to add custom oceans + water textures. So the map view's dark oceans transition into real dark oceans up close too.

Very nice.

(I still have to remember to make a Hyperion analogue.)

Share this post


Link to post
Share on other sites
While I haven't been able to fix the darkening terrain, I have been able to add custom oceans + water textures. So the map view's dark oceans transition into real dark oceans up close too.

Great - It really helps to make the place seem unlike any other object in the game!

Also, how far through development are Neidon's moons at this point? You mentioned that you would start work on Plock after Neidon's system is finalized so I'm just wondering what sort of time-frame we're talking about. I look forward to seeing what you have in store! :)

Share this post


Link to post
Share on other sites

Hello! I have been having a problem with outer planets mod, whenever I install it causes solar panels (stock and near-future) to stop supplying direct current when in direct sunlight.

http://i.imgur.com/NQ75CQP.png

I have re-verified my game cache several times and whenever I start ksp something keeps going missing. I have even removed everything except kopernicus and Outer planets mod and it still gives no power. Halp!

KSP version 1.04

Share this post


Link to post
Share on other sites
Hello! I have been having a problem with outer planets mod, whenever I install it causes solar panels (stock and near-future) to stop supplying direct current when in direct sunlight.

http://i.imgur.com/NQ75CQP.png

I have re-verified my game cache several times and whenever I start ksp something keeps going missing. I have even removed everything except kopernicus and Outer planets mod and it still gives no power. Halp!

KSP version 1.04

it's a kopernicus issue, there's a hotfix you can download to partially solve the issue (on kopernicus thread)

Share this post


Link to post
Share on other sites
Great - It really helps to make the place seem unlike any other object in the game!

Also, how far through development are Neidon's moons at this point? You mentioned that you would start work on Plock after Neidon's system is finalized so I'm just wondering what sort of time-frame we're talking about. I look forward to seeing what you have in store! :)

No concrete timeframe. Some long overdue fixes to the existing moons are first. Then I have to get Eudae55 to work on the Nereid based moon, as that's not production quality yet (the concept's there). The Triton based moon has all the resources, but not all of those are in-game yet.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.