CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

I am pleased to announce the existence of Hykek, a Hyperion analogue for Sarnus!

http://imgur.com/a/AyFYW

Awesome. I want it.

Don't worry, I will be posting a thread for Hykek eventually. I have to write science results and make a few minor edits first.

Share this post


Link to post
Share on other sites

So im going to be using OPM with RemoteTech for a nice little added challenge. Can i be confident in saying the larger dishes that come with RT will reach the farther planets in OPM?

Share this post


Link to post
Share on other sites
So im going to be using OPM with RemoteTech for a nice little added challenge. Can i be confident in saying the larger dishes that come with RT will reach the farther planets in OPM?

Opm has a cfg that will boost the biggest antenna so that it can reach all planets

Share this post


Link to post
Share on other sites

edit: Seems I broke the RemoteTech licence, I'll see if I can find alternative antennas.

Hi!

I've written an alternative patch for AntennaRange and OPM. To put it short, I've nerfed the KSC antennas and the Communotron 88-88 to their original state, and I've added two of the [sECRET] dishes and given them enough oomph to reach the outer planets. I did this because the original patch for OPM increased the range for KSC so much, you could go to Sarnus with the DTS. It seemed unbalanced. Also, I do think the bigger [sECRET] dishes look better than the Communotron 88-88.

This is the current max range for the antennas:

[TABLE]

[TR]

[TD][/TD]

[TD]Comm. 88[/TD]

[TD][sECRET ANTENNA 1][/TD]

[TD][sECRET ANTENNA 2][/TD]

[/TR]

[TR]

[TD]KSP L1[/TD]

[TD=bgcolor: #cfe2f3] Kerbin SOI[/TD]

[TD=bgcolor: #93c47d] Jool system[/TD]

[TD=bgcolor: #cfe2f3] Kerbin SOI[/TD]

[/TR]

[TR]

[TD]KSP L2[/TD]

[TD=bgcolor: #38761d] Jool[/TD]

[TD=bgcolor: #741b47] Neidon[/TD]

[TD=bgcolor: #38761d] Jool[/TD]

[/TR]

[TR]

[TD]KSP L3[/TD]

[TD=bgcolor: #dfaf8a] Sarnus[/TD]

[TD=bgcolor: #000000] Everywhere[/TD]

[TD=bgcolor: #1c4587] Urlum[/TD]

[/TR]

[/TABLE]

The [sECRET ANTENNA 1]'s max distance is 1.4TM, but it's nominal distance is out to slightly beyond Urlum (297GM). Beyond this range, you will need to throttle down the dish bandwidth if you don't have an absurd amount of batteries, just like the probes at Saturn and Pluto have low bandwidths. Alternatively, you'll have to timewarp to keep EC generation up. The [sECRET ANTENNA 2] is cheaper and can reach out to Urlum, but it's really not very fast at that range (speeds drop beyond Jool). For fly-bys, if you want to run the same experiments twice, I suggest grabbing a mod with a science hard drive... :)

NSIG2VJ.pngquhLsyF.png

Antennas from [sECRET]: [sECRET ANTENNA 1], [sECRET ANTENNA2]

They are integrated in the Tech Tree and I'm pretty sure they have Community Tech Tree support.

I've tested it, but I'll gladly listen to suggestions if you have any. :)

Just drop this in GameData/OPM/ and replace the original file when asked to do so. <- this used to be a link, and will probably be a link again soon

Edited by makkz
I broke the law

Share this post


Link to post
Share on other sites
Hi!

I've written an alternative patch for AntennaRange and OPM. To put it short, I've nerfed the KSC antennas and the Communotron 88-88 to their original state, and I've added two of the RemoteTech dishes and given them enough oomph to reach the outer planets. I did this because the original patch for OPM increased the range for KSC so much, you could go to Sarnus with the DTS. It seemed unbalanced. Also, I do think the bigger RemoteTech dishes look better than the Communotron 88-88.

This is the current max range for the antennas:

[TABLE]

[TR]

[TD][/TD]

[TD]Comm. 88[/TD]

[TD]CommTech-1[/TD]

[TD]Reflectron KR-14[/TD]

[/TR]

[TR]

[TD]KSP L1[/TD]

[TD=bgcolor: #cfe2f3] Kerbin SOI[/TD]

[TD=bgcolor: #93c47d] Jool system[/TD]

[TD=bgcolor: #cfe2f3] Kerbin SOI[/TD]

[/TR]

[TR]

[TD]KSP L2[/TD]

[TD=bgcolor: #38761d] Jool[/TD]

[TD=bgcolor: #741b47] Neidon[/TD]

[TD=bgcolor: #38761d] Jool[/TD]

[/TR]

[TR]

[TD]KSP L3[/TD]

[TD=bgcolor: #dfaf8a] Sarnus[/TD]

[TD=bgcolor: #000000] Everywhere[/TD]

[TD=bgcolor: #1c4587] Urlum[/TD]

[/TR]

[/TABLE]

The CT-1's max distance is 1.4TM, but it's nominal distance is out to slightly beyond Urlum (297GM). Beyond this range, you will need to throttle down the dish bandwidth if you don't have an absurd amount of batteries, just like the probes at Saturn and Pluto have low bandwidths. Alternatively, you'll have to timewarp to keep EC generation up. The Reflectron KR-14 is cheaper and can reach out to Urlum, but it's really not very fast at that range (speeds drop beyond Jool). For fly-bys, if you want to run the same experiments twice, I suggest grabbing a mod with a science hard drive... :)

http://i.imgur.com/3iorg6L.pnghttp://i.imgur.com/p0q0uRz.png

Antennas from RemoteTech: CommTech-1, Reflectron KR-14

They are integrated in the Tech Tree and I'm pretty sure they have Community Tech Tree support.

I've tested it, but I'll gladly listen to suggestions if you have any. :)

Just drop this in GameData/OPM/ and replace the original file when asked to do so.

hi makkz, I don't know if you were aware of this but the RemoteTech parts have a weird license:

The source code for RemoteTech is licensed under GPL version 2. The part models are not licensed to the general public and may not be redistributed without permission from their original creators.

I'm saying this just to let you know in case you missed that part :)

Share this post


Link to post
Share on other sites
I'm saying this just to let you know in case you missed that part :)

Ooops. I did miss that part. Taking it down. :) Thanks!

Edited by makkz

Share this post


Link to post
Share on other sites
I've been seeing this too. While trying to test my Hyperion analogue for Sarnus, Hykek, this occurs. Upon removing Hykek from my GameData folder, the KSC goes back to normal.

i am currently testing whether this issue has anything to do with using 'slightly' older planet mods with the latest releases of kopernicus. In other words, it could be something about the plugin.

Edit: found solution, just confirmed that using the latest version of kopernicus causes this issue, the plugin from june 26 works

Edited by tychochallenge

Share this post


Link to post
Share on other sites
That's an older bug. AFAIK all non-gas planets can be landed on in the current release. The belts can't be collided with (in reality that'd also be the case as the rings around Saturn are only about 10 meters thick and generally not dense enough to do much damage).

I can't land on Polta. At about 50km, the moon just disappears. Dropping further down, it has me sitting at 1m where the surface should be, but nothing's there. Then I load the quicksave, turn the engines off, and my craft falls and explodes. I'm on 1.0.4, OPM 1.7.2. Another try at loading a quicksave, and KSP itself crashed and exited.

NOTE: Landing on Priax went just fine, so I think it's particular to Polta. If I can get the delta-v I'll try Wal or Tal. I seem to remember this happening with some other moons on an older version, but that could have been Outer Planets Plus. I no longer have that installed. Just a ton of other mods.

Some errors from KSP.log

TONS OF THESE:

[WRN 23:24:59.560] Cannot find preset 'High' for pqs 'Polta'
[EXC 23:24:59.561] NullReferenceException: Object reference not set to an instance of an object
PQSMod_VertexColorMapBlend.OnVertexBuild (.VertexBuildData data)
PQS.Mod_OnVertexBuild (.VertexBuildData data)
PQS.BuildQuad (.PQ quad)
PQ.Build ()
PQ.SetVisible ()

Then the crash:

[WRN 23:40:48.440] Cannot find preset 'High' for pqs 'Polta'
[EXC 23:40:48.465] NullReferenceException: Object reference not set to an instance of an object
PQSMod_VertexColorMapBlend.OnVertexBuild (.VertexBuildData data)
PQS.Mod_OnVertexBuild (.VertexBuildData data)
PQS.BuildQuad (.PQ quad)
PQ.Build ()
PQ.SetVisible ()
PQ.UpdateVisibility ()
PQ.UpdateSubdivision ()
PQ.UpdateSubdivision ()
PQ.UpdateSubdivision ()
PQ.UpdateSubdivision ()
PQ.UpdateSubdivision ()
PQS.UpdateQuadsInit ()
PQS.StartSphere (Boolean force)
PQS.RebuildSphere ()
PQS.Update ()
[WRN 23:40:48.493] Vessel Urlum Landar 5 crashed through terrain on Polta
[LOG 23:40:48.493] [00:25:51]: Urlum Landar 5 crashed into Polta.
[LOG 23:40:48.494] mk3-9pod (Urlum Landar 5) Exploded!! - blast awesomeness: 0.5
[LOG 23:40:48.583] [commDish]: Deactivated
[LOG 23:40:48.609] [mk3-9pod (Urlum Landar 5)]: Deactivated
[LOG 23:40:48.644] [00:25:51]: Glethis Kerman was killed.
[LOG 23:40:48.645] [00:25:51]: Kerdun Kerman was killed.
[LOG 23:40:48.654] Tac.FuelBalanceController[FFE1D334][7367.99]: Rebuilding resource lists.
[WRN 23:40:48.656] Vessel Urlum Landar 5 Probe crashed through terrain on Polta
[LOG 23:40:48.657] [00:25:51]: Urlum Landar 5 Probe crashed into Polta.
[LOG 23:40:48.657] [Explosion] Combined.
[LOG 23:40:48.657] batteryBankLarge Exploded!! - blast awesomeness: 0.5
[LOG 23:40:48.754] [ladder1]: Deactivated
[LOG 23:40:48.777] [batteryBankLarge]: Deactivated
[WRN 23:40:48.788] Vessel Urlum Landar 5 Probe crashed through terrain on Polta
[LOG 23:40:48.788] [Explosion] Combined.
[LOG 23:40:48.788] ServiceBay.250 Exploded!! - blast awesomeness: 0.5
[LOG 23:40:48.825] [spotLight1]: Deactivated
[LOG 23:40:48.828] [spotLight1]: Deactivated
[LOG 23:40:48.830] [spotLight1]: Deactivated
[LOG 23:40:48.832] [spotLight1]: Deactivated
[LOG 23:40:48.952] [ladder1]: Deactivated
[LOG 23:40:48.954] [ladder1]: Deactivated
[LOG 23:40:48.955] [ladder1]: Deactivated
[LOG 23:40:48.957] [ServiceBay.250]: Deactivated
[WRN 23:40:48.959] Vessel Urlum Landar 5 Probe Debris crashed through terrain on Polta
[LOG 23:40:48.959] [00:25:51]: Urlum Landar 5 Probe Debris crashed into Polta.
[LOG 23:40:48.959] [Explosion] Combined.
[LOG 23:40:48.959] B9.Control.RCS.Block.R5 Exploded!! - blast awesomeness: 0.5
[LOG 23:40:48.959] [B9.Control.RCS.Block.R5]: Deactivated
[EXC 23:40:48.960] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
System.Collections.Generic.List`1[Callback`1[IAirstreamShield]].RemoveAt (Int32 index)
ModuleCargoBay.UnShieldEnclosedParts (System.Collections.Generic.List`1 enclosedParts)
ModuleCargoBay.DisableShieldedVolume ()
ModuleCargoBay.EnableShieldedVolume ()
ModuleCargoBay.onVesselModified (.Vessel v)
EventData`1[Vessel].Fire (.Vessel data)
Part.Die ()
Part.explode ()
Vessel.FixedUpdate ()
[WRN 23:40:48.960] Vessel Urlum Landar 5 Probe Debris crashed through terrain on Polta

PQ.UpdateVisibility ()
PQ.Subdivide ()
PQ.UpdateSubdivision ()
PQ.UpdateSubdivision ()
PQS.UpdateQuadsInit ()
PQS.StartSphere (Boolean force)
PQS.RebuildSphere ()
PQS.Update ()

I have the full KSP.log if it would be of help.

Cheers,

-BS

Edited by barfing_skull
mention KSP program crash

Share this post


Link to post
Share on other sites
i am currently testing whether this issue has anything to do with using 'slightly' older planet mods with the latest releases of kopernicus. In other words, it could be something about the plugin.

Edit: found solution, just confirmed that using the latest version of kopernicus causes this issue, the plugin from june 26 works

This is believable to me. I've found Kerbol Plus works fine with its bundled version of Kopernicus, but not with the latest version downloaded separately. Hopefully the Kopernicus devs can avoid breaking compatibility in future.

Share this post


Link to post
Share on other sites

@barfing_skull - can you update to the latest Kopernicus version (0.2.4), making sure to delete the old kopernicus folder before re-installing, and try again? Works perfectly fine for me.

Share this post


Link to post
Share on other sites
How does OPM play with 64K? Any notable conflicts?

Works fine with KScale2 as long as you have the config for it so I should imagine it'd work fine with 64K too. There's a config floating around in the 64K thread iirc

I think Hale and Ovok get a bit messed up on account of having small SoIs that go inside them when you try to scale it but otherwise it's fine

Share this post


Link to post
Share on other sites
@barfing_skull - can you update to the latest Kopernicus version (0.2.4), making sure to delete the old kopernicus folder before re-installing, and try again? Works perfectly fine for me.

Just updated to 0.2.4, I had 0.2.3 before. Not sure I below away all of Kopernicus with 0.2.3, but I made sure to do so this time. Same issue. Though this time I watched without warping. Polta just sorta fades away. I think that happened to a planet in some ST:Voyager episode? Anyway, it decided to become more and more ephemeral the closer I got. This is about 95km, I get this, it disappears completely, then any attempt to load saves eventually ends up with the entire game crashing. When I restart I have to go back to an earlier save where my craft isn't around Polta.

EV92ooU.jpg

Thoughts?

Cheers,

-BS

Share this post


Link to post
Share on other sites

Try to do a fresh install of Kopernicus (0.2.3, as that's what the update was designed for) and OPM 1.7.2.

Share this post


Link to post
Share on other sites
Try to do a fresh install of Kopernicus (0.2.3, as that's what the update was designed for) and OPM 1.7.2.

0.2.3, 1.7.2 reinstalled. The problem didn't go away, same thing, Polta slowly fades from view, then disappears into a haze that's left. Maybe some other mod interfering? I have tons:

000_Toolbar

AtomicAge

B9_Aerospace

BoulderCo

Chatterer

CommunityResourcePack

CommunityTechTree

CrossFeedEnabler

CustomAsteroids

DDSLoader

DistantObject

EnvironmentalVisualEnhancements

Firespitter

InterstellarFuelSwitch

JSI

KAS

KerbalJointReinforcement

Kerbaltek

KineTechAnimation

KIS

KittopiaSpace

Klockheed_Martian_Gimbal

Kopernicus

KWRocketry

LandingHeight

MechJeb2

ModuleAnimateEmissive

MP_Nazari

NearFutureConstruction

NearFutureElectrical

NearFutureProps

NearFuturePropulsion

NearFutureSolar

NearFutureSpacecraft

Nereid

OPM

SmokeScreen

Squad

StockBugFixModules

TacFuelBalancer

TextureReplacer

TweakScale

Virgin Kalactic

Plus some stock bug fixes and a few others that may be out of date. I can try to find the ones I don't need or are outdated and start getting rid of them, but it would be nice to know where the problem is. Priax and Tal don't have the issue, though. Odd.

Cheers,

-BS

Share this post


Link to post
Share on other sites
0.2.3, 1.7.2 reinstalled. The problem didn't go away, same thing, Polta slowly fades from view, then disappears into a haze that's left. Maybe some other mod interfering? I have tons:

000_Toolbar

AtomicAge

B9_Aerospace

BoulderCo

Chatterer

CommunityResourcePack

CommunityTechTree

CrossFeedEnabler

CustomAsteroids

DDSLoader

DistantObject

EnvironmentalVisualEnhancements

Firespitter

InterstellarFuelSwitch

JSI

KAS

KerbalJointReinforcement

Kerbaltek

KineTechAnimation

KIS

KittopiaSpace

Klockheed_Martian_Gimbal

Kopernicus

KWRocketry

LandingHeight

MechJeb2

ModuleAnimateEmissive

MP_Nazari

NearFutureConstruction

NearFutureElectrical

NearFutureProps

NearFuturePropulsion

NearFutureSolar

NearFutureSpacecraft

Nereid

OPM

SmokeScreen

Squad

StockBugFixModules

TacFuelBalancer

TextureReplacer

TweakScale

Virgin Kalactic

Plus some stock bug fixes and a few others that may be out of date. I can try to find the ones I don't need or are outdated and start getting rid of them, but it would be nice to know where the problem is. Priax and Tal don't have the issue, though. Odd.

Cheers,

-BS

Try doing this:

(this is a tip that can be applied to every kind of bug and is very quick to do)

1- go to your KerbalSpaceProgram folder

2- Rename the GameData folder to GameDataOLD (or something similar)

3- create a new folder and name it GameData

4- move the Squad folder from GameDataOLD to the new GameData folder

5- install Kopernicus

6- install OPM

7- make sure you have Module Manager (I always forget this part :D)

8- load into the game and see if you are still experiencing the bug

IF YES:

report it

IF NO:

some of your mods is interfering, you could try adding one mod at a time and check when the bug comes back

then report it

I see a couple of mods in your list that could be doing something, but I would be a wild guess at this point :D

Share this post


Link to post
Share on other sites
How does OPM play with 64K? Any notable conflicts?

I made this and it seems to be working fine, but it is very customized, meaning rescales are not uniform across all bodies. Smaller ones (Gilly, Bop, Hale, Ovok, Tal) kept their radius and only got orbits changed, Minmus, and if I remember correctly most of Urlum's moons are at 3.2x radius. I also made many changes to masses, trying to base the densities of many bodies on their rl counterparts. If you do not mind any of those changes, feel free to give it a try.

Try doing this:

(this is a tip that can be applied to every kind of bug and is very quick to do)

This is great advice and everyone should employ this methodology to sorting out mod issues before ever bugging modders, but most of the times it is not quick to do, not at all :P

Share this post


Link to post
Share on other sites
0.2.3, 1.7.2 reinstalled. The problem didn't go away, same thing, Polta slowly fades from view, then disappears into a haze that's left. Maybe some other mod interfering? I have tons:

000_Toolbar

AtomicAge

B9_Aerospace

BoulderCo

Chatterer

CommunityResourcePack

CommunityTechTree

CrossFeedEnabler

CustomAsteroids

DDSLoader

DistantObject

EnvironmentalVisualEnhancements

Firespitter

InterstellarFuelSwitch

JSI

KAS

KerbalJointReinforcement

Kerbaltek

KineTechAnimation

KIS

KittopiaSpace

Klockheed_Martian_Gimbal

Kopernicus

KWRocketry

LandingHeight

MechJeb2

ModuleAnimateEmissive

MP_Nazari

NearFutureConstruction

NearFutureElectrical

NearFutureProps

NearFuturePropulsion

NearFutureSolar

NearFutureSpacecraft

Nereid

OPM

SmokeScreen

Squad

StockBugFixModules

TacFuelBalancer

TextureReplacer

TweakScale

Virgin Kalactic

Plus some stock bug fixes and a few others that may be out of date. I can try to find the ones I don't need or are outdated and start getting rid of them, but it would be nice to know where the problem is. Priax and Tal don't have the issue, though. Odd.

Cheers,

-BS

Holy f***, how do you run ksp without ATM? I don't even have b9 and mine crashes every 30 minutes

Share this post


Link to post
Share on other sites
Holy f***, how do you run ksp without ATM? I don't even have b9 and mine crashes every 30 minutes

with 64bit on windows or linix

Share this post


Link to post
Share on other sites
This is great advice and everyone should employ this methodology to sorting out mod issues before ever bugging modders, but most of the times it is not quick to do, not at all :P

When I wrote "quick" I meant, quicker than copying your KSP folder and working on the clone. :)

and of course it's quick if you see the bug with KSP + 1 mod. If you have to check all the hundreds of mods for incompatibility, that may take a bit more :D

Share this post


Link to post
Share on other sites
When I wrote "quick" I meant, quicker than copying your KSP folder and working on the clone. :)

and of course it's quick if you see the bug with KSP + 1 mod. If you have to check all the hundreds of mods for incompatibility, that may take a bit more :D

I miss the times in which my bugs were actually traceable to just one mod :D

Edited by Tellion

Share this post


Link to post
Share on other sites
Try doing this:

(this is a tip that can be applied to every kind of bug and is very quick to do)

1- go to your KerbalSpaceProgram folder

2- Rename the GameData folder to GameDataOLD (or something similar)

3- create a new folder and name it GameData

4- move the Squad folder from GameDataOLD to the new GameData folder

5- install Kopernicus

6- install OPM

7- make sure you have Module Manager (I always forget this part :D)

8- load into the game and see if you are still experiencing the bug

IF YES:

report it

IF NO:

some of your mods is interfering, you could try adding one mod at a time and check when the bug comes back

then report it

I see a couple of mods in your list that could be doing something, but I would be a wild guess at this point :D

Good idea, I'll give that a try. However, since a lot of my ships are built with those mods, I'll probably at least need Hyperedit to get my newly created, puny craft out there and be able to try this in any reasonable amount of time.

I'll let you know how it goes.

Cheers,

-BS

- - - Updated - - -

Holy f***, how do you run ksp without ATM? I don't even have b9 and mine crashes every 30 minutes

Probably having 32G of RAM in the machine helps. KSP once ate up about 20 of those. I highly suggest having huge amounts of RAM available.

Cheers,

-BS

- - - Updated - - -

with 64bit on windows or linix

64-bit, Linux. Plus the 32GB.

Cheers,

-BS

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.