• 0
Sign in to follow this  
Beatmaster Hank

CKAN Mod Compatibility

Question

Hello, I'm just a little confused on how the whole CKAN program works. I installed it recently as it looked helpful, but I'm having some trouble.

My mods are: Active Texture Management (Aggressive), Deadly Reentry Continued, FAR, KAE, KAS, KJR, Kethane, Infernal Robotics, MJ2, Module Manager, Procedural Fairings, Procedural Parts, RemoteTech, SCANsat, TweakScale, TAC Life Support, and KW Rocketry.

Most of them are fine, but there's just a couple problems. First, I decided to download Active Texture Management and TweakScale through the CKAN interface. It lists them as "Installed", but not as "Updated" even though it says that its KSP Version is 0.90. I'm not sure if it makes a difference what category it's under it just seemed confusing.

The other problem is that two of my mods, TAC Life Support and KW Rocketry are "Incompatible". I'm not really sure what that means or how to fix it. Both Kethane and RemoteTech have not been updated to 0.90 yet but they are still listed under the "Updated" category. I've installed TAC and KW correctly into the GameData folder and they worked fine before the update.

Obviously, as of right now I am unable to play KSP, which isn't a huge problem since it is due to mods not updating, but I just want to fix the problems with CKAN as it seems like a very helpful program if I can figure it out.

Thanks!

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
Most of them are fine, but there's just a couple problems. First, I decided to download Active Texture Management and TweakScale through the CKAN interface. It lists them as "Installed", but not as "Updated" even though it says that its KSP Version is 0.90. I'm not sure if it makes a difference what category it's under it just seemed confusing.

I can at least help with this one. Think of those checkboxes as a Yes/No toggle:

Check in the box under Installed: Mod is installed on your current KSP instance

No check in box under Installed: Mod not installed via CKAN

AD where check box should be under Installed: Auto-detected by CKAN, you probably manually installed these.

No box visible under Update, just a dash ( - ): No current update available for download

Box visible but not checked under Update: Update available, but not selected for installation

Check in box under Update: Update queued for install, click the "Go to Changes" button on top of the CKAN app to get to the update interface. From the update interface, click the "Apply" button on the bottom-right corner of the window to apply the update.

Once you UPDATE a mod, the box under the Update column will disappear and be replaced by a dash ( - ) signifying there is no longer an update to download.

Share this post


Link to post
Share on other sites
  • 0
I can at least help with this one. Think of those checkboxes as a Yes/No toggle:

Check in the box under Installed: Mod is installed on your current KSP instance

No check in box under Installed: Mod not installed via CKAN

AD where check box should be under Installed: Auto-detected by CKAN, you probably manually installed these.

No box visible under Update, just a dash ( - ): No current update available for download

Box visible but not checked under Update: Update available, but not selected for installation

Check in box under Update: Update queued for install, click the "Go to Changes" button on top of the CKAN app to get to the update interface. From the update interface, click the "Apply" button on the bottom-right corner of the window to apply the update.

Once you UPDATE a mod, the box under the Update column will disappear and be replaced by a dash ( - ) signifying there is no longer an update to download.

Well I'm still confused about that then. I put the two screenshots below to help show my case. In the Installed filter, I have the two mods I installed via CKAN, but am unable to make any changes to them. As you can see, they are both updated to 0.90, but aren't listed as updated. However, their folders have been installed into the GameData folder.

http://imgur.com/vgIxfmR,pFFDVHW

Share this post


Link to post
Share on other sites
  • 0

TweakScale and ATM have both been installed (Check in the Installed box) via CKAN, but there are currently no Updates to install, so there is a dash ( - ) in the Update column. Everything there looks like it's working properly. When an update becomes available for one of the mods you've installed with CKAN, that dash will turn to an empty checkbox. To then update, you put a check in the box and then "Go to Changes" and Apply the Update.

The other mods in your pictures have been installed outside CKAN and were "Autodetected" (hence the AD where the install checkbox should be, though I'm not sure why Kethane and RemoteTech don't have AD next to them...).

Share this post


Link to post
Share on other sites
  • 0
TweakScale and ATM have both been installed (Check in the Installed box) via CKAN, but there are currently no Updates to install, so there is a dash ( - ) in the Update column. Everything there looks like it's working properly. When an update becomes available for one of the mods you've installed with CKAN, that dash will turn to an empty checkbox. To then update, you put a check in the box and then "Go to Changes" and Apply the Update.

The other mods in your pictures have been installed outside CKAN and were "Autodetected" (hence the AD where the install checkbox should be, though I'm not sure why Kethane and RemoteTech don't have AD next to them...).

Oh ok thanks! I understand now!

Share this post


Link to post
Share on other sites
  • 0

Glad I could help.

Share this post


Link to post
Share on other sites
  • 0

Will CKAN update autodetected mods or do you have to uninstall them and reinstall them through CKAN for them to update properly? I currently have a few mods like rasterprop that do not have upgrade options even though new versions have come out

Share this post


Link to post
Share on other sites
  • 0
Will CKAN update autodetected mods or do you have to uninstall them and reinstall them through CKAN for them to update properly? I currently have a few mods like rasterprop that do not have upgrade options even though new versions have come out

CKAN will not touch Auto-detected mods. If you wish to have CKAN control the mods that have been auto-detected, I would suggest uninstalling any mods that have a dependency on that (I know RPM is a dependency for many mods, so be careful...ModuleManager is also a HUGE PITA to move to CKAN from Auto-detected, because so many other mods depend on it) which have been installed w/CKAN, then remove RPM manually, then refresh your CKAN and you should be able to install RPM via CKAN (and whatever other mods that depended on RPM). If you don't do this, sometimes the local CKAN metadata gets all messed up and you'll get stuck in a loop where you can't update w/out CKAN crashing or tossing exceptions. Sometimes it is even best to remove all your mods before trying something like this (certainly would be if your mod list is fairly small), just to be sure no "unintended consequences" occur.

Share this post


Link to post
Share on other sites
  • 0

Ferram says to install FAR and modular flight integrator since CKAN doesn't handle ModularFlightIntegrator properly on a FAR install. If you already knew this, sorry. :)

- - - Updated - - -

Ferram says to install FAR and modular flight integrator manually since CKAN doesn't handle ModularFlightIntegrator properly on a FAR install. If you already knew this, sorry. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this