NecroBones

[1.4.1] Color Coded Canisters 2.0.1 (2018-03-14)

Recommended Posts

Hi, again with the same texture problem... It's very weird since depending time I can have nice and silky texture, and sometime the one I posted before. I tried with a fully installed FTP and CCC to see if that was the problem but nope. My fresh install have the strip issue for all the fuel tanks now and I don't know what mess the mod :huh:

2n1wfhj.png

I will try deleting and reinstalling CCC and FTP.

 

Here my mod list, I don't see what could do this...

107kgo1.jpg

Edited by Vahal

Share this post


Link to post
Share on other sites
43 minutes ago, Vahal said:

Hi, again with the same texture problem... It's very weird since depending time I can have nice and silky texture, and sometime the one I posted before. I tried with a fully installed FTP and CCC to see if that was the problem but nope. My fresh install have the strip issue for all the fuel tanks now and I don't know what mess the mod :huh:

I will try deleting and reinstalling CCC and FTP.

 

Here my mod list, I don't see what could do this...

 

These days it's often caused by ActiveTextureManagement, which I'm starting to recommend people to stop using. But it looks like you don't have that in the list. So yeah, I'd try reinstalling both mods first and see how it goes. You can try deleting the ModuleManager.ConfigCache file as well, just in case it's getting confused about which mods are installed. But here's the troubleshooting I'm putting together so far for the failed texture reassignment problems:

 

1. Files may be missing, or not where the mod is expecting to find them.

   Fix: Make sure you've installed the mod correctly, in its entirety, and in the right location. Don't rename folders. You can try completely deleting the mod and reinstalling (which is the best way to update the mod anyway). Also make sure the mod's dependencies are installed (SpaceY Expanded requires SpaceY Lifters, for instance).

2. ActiveTextureManagement is goofing it up.

   Fix: Either remove ATM, or try deleting ATM's cache. ATM frequently has cache issues that cause problems for texture reassignment across folder boundaries. ATM doesn't help as much as it used to, now that stock KSP and most mods use DDS texture format. We've included configs to try to stop ATM from processing this mod's folder, but that may not be working either.

 

EDIT: We might also want to look at your log file and see if there's something in there to indicate the problem.

Edited by NecroBones

Share this post


Link to post
Share on other sites

I don't use ATM since it looks that now, it's just better to NOT use it (faster load and lighter memory usage, something like 300Mo for my regular install)

So... To be sure nothing fishy inmy install could be behind this problem, I made a clean install of KSP and then installed FTP, CCC, MRS, SpaceY, SpaceY EXpanded and LET. Just those ones... and nope. ;.;

about the KSP.log what can I do cause I guess just posting the log directly will just make the thread explode :sticktongue:

I use CKAN to install my mods.

Edited by Vahal

Share this post


Link to post
Share on other sites
1 hour ago, Vahal said:

I don't use ATM since it looks that now, it's just better to NOT use it (faster load and lighter memory usage, something like 300Mo for my regular install)

So... To be sure nothing fishy inmy install could be behind this problem, I made a clean install of KSP and then installed FTP, CCC, MRS, SpaceY, SpaceY EXpanded and LET. Just those ones... and nope. ;.;

about the KSP.log what can I do cause I guess just posting the log directly will just make the thread explode :sticktongue:

I use CKAN to install my mods.

I am having the same issue but I do not use CKAN or ATM. I tried taking out all mods except CCC and I still had the same issue. Still trying to solve it...

Edited by Courn Wallace

Share this post


Link to post
Share on other sites
2 hours ago, Vahal said:

I don't use ATM since it looks that now, it's just better to NOT use it (faster load and lighter memory usage, something like 300Mo for my regular install)

So... To be sure nothing fishy inmy install could be behind this problem, I made a clean install of KSP and then installed FTP, CCC, MRS, SpaceY, SpaceY EXpanded and LET. Just those ones... and nope. ;.;

about the KSP.log what can I do cause I guess just posting the log directly will just make the thread explode :sticktongue:

I use CKAN to install my mods.

OK, we'll get it figured out. In the picture, which tank and color scheme did you choose? Hard to tell with it not showing correctly. Is it the FL-T200?  EDIT: They look good in the icons, and I don't see the corrugation, so I'm assuming this is one of the alternate paint schemes.

There are a few file upload sites out there to share the log. Dropbox will work, for instance.

 

1 hour ago, Courn Wallace said:

I am having the same issue but I do not use CKAN or ATM. I tried taking out all mods except CCC and I still had the same issue. Still trying to solve it...

Yeah, it's probably good if I can see your log and maybe a screenshot too. CCC by itself shouldn't have any problems at all, since it'll only show the standard appearances for the tanks, and those textures are right there in one folder.

Edited by NecroBones

Share this post


Link to post
Share on other sites

EDIT: I'm working the problem. I just uploaded an update but it's only a partial fix. Will re-upload shortly.

 

Edited by NecroBones

Share this post


Link to post
Share on other sites

OK, the fix is posted. I found the problem. It was my fault this time, since changing the order of patching to make things work more nicely with Ven's Stock Revamp screwed up the patching order with FTP. I've corrected this.

 

1.4.1/1.4.2 (2015-12-20) - Bug fix.
 - Corrected a problem with alternate paint schemes from FuelTanksPlus not working properly.

 

Share this post


Link to post
Share on other sites

YAY! It worked! :D Thank you! tested on all fuel tanks and no more weird stripes textures.

I noticed something, the version listed on CKAN is the 1.4.

Edited by Vahal

Share this post


Link to post
Share on other sites

@NecroBones

The other day I noticed that the Color Coded Cans (with InterestellarFuelSwitch installed which activates Color Coded Cans fuel switch configs) seems to contain what I would consider the incorrect amount of liquid fuel when switched to the LiquidFuel tank setup. Curious if this was intentional or a minor bug that could be fixed in the future?

Specifically, the FL-T400 tank should be capable of holding 400 L of fuel. We know this because the stock tank can hold 180 L of LiquidFuel and 220 L Oxidizer. And of course we know that 180 L + 220 L = 400 L of fuel capacity.

If we compare the stock FL-T400 to the stock Mk1 Liquid Fuel Fuselage (which certainly seems to be of identical size to the stock TL-400) we see that it also has a capacity of 400 L as it contains 400 L of LiquidFuel by default.

Problem(?) - the Color Coded Cans config for making use of Interstellar Fuel Switch result in the FL-T400 having the options of 180 L FL + 220 L OX, 360 L LF, or 440 L OX. This doesn't seem right to me but perhaps it was intentional? I see in the CCC Fuel Switch config that the calculation used does indeed just double the LF volume in order to determine LF Only Fuel Volume and does the same for OX volume. I would have expected it to instead sum the stock LF and OX volumes and not just double them.

Thoughts? Were you perhaps trying to maintain ratios of the typical LF to OX mix such that a single OX fuel tank and a LF tank could be stacked (with OX on top of course like the real thing) and fuel a rocket without trying to figure out fuel balance? I agree that's a neat idea.

What is tempting me to correct mine locally (to sum the stock LiquidFuel and Oxidizer value, assuming I can do that the way I think I can by adding the MM variables together) is that the stock Mk1 Liquid Fuel Fuselage becomes attractive to use for its additional fuel capacity when ideally I wouldn't use it at all (because it doesn't have texture switching when I use FTP).

Share this post


Link to post
Share on other sites
1 hour ago, Black-Talon said:

Were you perhaps trying to maintain ratios of the typical LF to OX mix such that a single OX fuel tank and a LF tank could be stacked (with OX on top of course like the real thing) and fuel a rocket without trying to figure out fuel balance? I agree that's a neat idea.

 

Yep, it's exactly this right here. It's set up that way to allow easy mix-n-match of the tanks without thinking about the fuel ratios, rather than trying to be realistic about the volume or mass of the tanks.

Share this post


Link to post
Share on other sites
18 hours ago, NecroBones said:

Yep, it's exactly this right here. It's set up that way to allow easy mix-n-match of the tanks without thinking about the fuel ratios, rather than trying to be realistic about the volume or mass of the tanks.

I so love and hate this at the same time! I want both but don't even want both!

So, any thoughts of adding CCC to the fuselage parts? I basically want the textures on them. *sigh* This is a terribke waste of effort on your part and perhaps memory for the player (although I suppose it's all shared with what you already have).

I would probably be happiest if I just forgot I discovered this. My sense of 'right' has been torn in two directions. 360 L is basically the same as 400 L in a plane anyway! *puts head in the sand*

Thank you for the wonderful mod/parts and maintenance along with the helpful response to my question. This package is really wonderful imo. 

Share this post


Link to post
Share on other sites

 

You mean end-caps for the fuselage pars, or a total redesign like the other tanks? I dunno, they all look pretty nice with the new Porkjet art. :)

Share this post


Link to post
Share on other sites

I love this, and your other mods! I've been gradually working through a career game with most of your stuff and Nertea's too, since they all work comfortably together with each other and with stock parts.

Color is good. Too much flat grey is bad. Ugly spaceships are bad. Brighter colors can make for prettier spaceships, which is very good!

I know you're concerned about adding any more textures because of the memory issues... but I frequently find myself wishing for even more color choices with all these tanks. Specifically, I love the gold foil insulation and brushed aluminum Atlas textures available from Procedural Parts, and very much wish I could use these with your parts. Some more bright primary colors too; think equivalent shades of green and yellow to match the existing red, blue, and orange.

What are the chances of adding a few more textures to the mod collection? Maybe as a separate, optional download for people with the RAM to spare?

Share this post


Link to post
Share on other sites

Its certainly not out of the question. The good news is that KSP 1.1 is expected to be 64bit right out of the gate, and with more addressable memory, more textures won't be so much of a problem. Since they're super-efficiently used in FTP+CCC anyway, a little more under 64bit shouldn't be an issue.

Share this post


Link to post
Share on other sites
4 hours ago, DerekL1963 said:

Is there anything save breaking in here?   Or do they just drop in and replace existing stock tankage?

No save-breaking, it's a drop-in. You can delete it later too without breaking anything.

 

(FYI, I have extremely limited internet access through Sunday)

Share this post


Link to post
Share on other sites

CKAN lists this as 1.1 compliant, but when I had it installed I could not add fuel to stock tanks.  Right clicking brought up a UI with 2 buttons that said something about a fairing, if I remember right, instead of LF and OX levels.  Removed mod and fuels works now

 

Edit: The 2 buttons were for shroud enabled/disabled.  FTP tanks still have this and can't add fuel.

Edited by RiverRat2800

Share this post


Link to post
Share on other sites

 

Make sure you have the latest 1.1 version of ModuleManager (2.6.21), and if you're using InterstellarFuelSwitch, make sure that's on today's version (1.19). If you have firespitter, that's not updated yet, so it either needs to be removed, or add InterstellarFuelSwitch which FTP and CCC will prefer to use.

 

EDIT: Also, delete ModuleManager.ConfigCache, since MM can get confused about recent changes to your installed mods.

 

EDIT 2: Also are you using anything else that messes with tank capacities? ModularFuelTanks, for instance? Other mods could be influencing this.

 

Share this post


Link to post
Share on other sites

@NecroBones Just a heads up, it looks like today's 1.1 build release (1209) has broken Firespitter, InterstellarFuelSwitch, and mods dependent on them. Other mods with similar "switch" functionality, including RoverDude's USI and Karbonite, RealChute, TweakScale (Emerald had a functional update), are similarly impacted. Here's the relevant log, though I don't know if it's anything you can fix.

Spoiler

[ERR 19:31:27.803] AssemblyLoader: Exception loading 'Firespitter': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'Firespitter.customization.FSfuelSwitch' from assembly 'Firespitter, Version=7.1.5790.33347, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'Firespitter.customization.FSmeshSwitch' from assembly 'Firespitter, Version=7.1.5790.33347, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'Firespitter.customization.FStextureSwitch2' from assembly 'Firespitter, Version=7.1.5790.33347, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'Firespitter.cockpit.FSmonitorInterface' from assembly 'Firespitter, Version=7.1.5790.33347, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'Firespitter.customization.FStextureSwitch' from assembly 'Firespitter, Version=7.1.5790.33347, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'ButtonNames' from assembly 'Firespitter, Version=7.1.5790.33347, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'MainMenuItems' from assembly 'Firespitter, Version=7.1.5790.33347, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'SettingsMenuItems' from assembly 'Firespitter, Version=7.1.5790.33347, Culture=neutral, PublicKeyToken=null'.

[ERR 19:31:27.809] AssemblyLoader: Exception loading 'InterstellarFuelSwitch': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'InterstellarFuelSwitch.InterstellarFuelSwitch' from assembly 'InterstellarFuelSwitch, Version=1.19.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'InterstellarFuelSwitch.InterstellarMeshSwitch' from assembly 'InterstellarFuelSwitch, Version=1.19.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<>c__DisplayClass9' from assembly 'InterstellarFuelSwitch, Version=1.19.0.0, Culture=neutral, PublicKeyToken=null'.

The result is that all the textures for stock canisters get confused and try to display at the same time. It's mostly an aesthetics mod, so I can play without it, but I'll be looking forward to a fix, however that comes about.

Edited by danfarnsy
Additional information

Share this post


Link to post
Share on other sites

Yep, nothing I can do about it. We just have to wait for Firespitter and/or IFS to correct on their side.

Share this post


Link to post
Share on other sites

Hey Bones, I have some bad news about mod compatibility. Nertea decided to replace InterstellarFuelSwitch with B9PartSwitch for his mesh/texture/resource switching needs, and as a result only your fuel switch options show up on CCC and FTP fuel tanks, no hydrogen.

Share this post


Link to post
Share on other sites
1 minute ago, PickledTripod said:

Hey Bones, I have some bad news about mod compatibility. Nertea decided to replace InterstellarFuelSwitch with B9PartSwitch for his mesh/texture/resource switching needs, and as a result only your fuel switch options show up on CCC and FTP fuel tanks, no hydrogen.

 

My fuel switching rules should step aside if CryoEngines is installed at all, so that shouldn't matter.  So it's probably breaking in some other way. I might need to see your KSP.log. Do you have RealFuels and ModularFuelTanks installed? Or just CryoEngines?

 

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.