Youen

[old thread] Trajectories : atmospheric predictions

Recommended Posts

4 minutes ago, Ghosty141 said:

@Youen Add the new ModuleManager version to your downloads, sarbian alrady released .24

Indeed, I saw .23 as the latest release on github so I thought it was the correct one, but there is a link to his jenkins server where the .24 is. I've updated the zip file without changing the version number as it works with .23 as well (at least for KSP 1.1.1)

Share this post


Link to post
Share on other sites
19 minutes ago, Youen said:

@Andem Yep, just saw there is now KSP 1.1.2. Haven't downloaded it yet, so I don't know if it's compatible with Trajectories 1.5.0, but I think it is (since it's supposed to be just bugfixes).

I just tested, and it doesn’t appear to be working in 1.1.2.  Opening the settings shows the number of errors increasing, and no trajectory is displayed, regardless of Trajectories settings.  THANKS SQUAD

Share this post


Link to post
Share on other sites

They managed to break a surprisingly large amount of stuff... spaghetti code due to the pace of the final days of 1.1 dev and patching? 

Share this post


Link to post
Share on other sites

Just released version 1.6.0 for KSP 1.1.2. This version won't work for KSP 1.1.0 or 1.1.1, so be sure to download the correct one.

There was a small change in API for drag calculations (a result of the optimization stated in the change log I suppose)

Share this post


Link to post
Share on other sites

Heh—looks like you got it without my pull request. Thanks! Glad you were able to get the shader working. I pulled in the material from the latest RemoteTech, too, but couldn't quite work out what it is. I don't do graphics. :P

Share this post


Link to post
Share on other sites
2 minutes ago, Fishbreath said:

Heh—looks like you got it without my pull request. Thanks! Glad you were able to get the shader working. I pulled in the material from the latest RemoteTech, too, but couldn't quite work out what it is. I don't do graphics. :P

There's a weird thing in RemoteTech: they initialize a shader from a string (which is deprecated by Unity but still works), but after that they assign the KSP orbit shader, so I think the string shader is not actually used. I use the later method now (which is the one actually used in RemoteTech if I followed the code correctly). And this shader needs UVs because of the alpha gradient in the texture, otherwise it appears translucent. And there was an issue when zooming out because KSP changes the projection matrix to 2D. I don't like these graphics details either ^^ Tricky to get right, but no actual challenge in it.

Share this post


Link to post
Share on other sites

I repacked the 1.5.0 zip file (for KSP 1.1.0 and 1.1.1) because it needs ModuleManager version 2.6.23 (version 2.6.24 only works for KSP 1.1.2).

Everything should be fine now. If you downloaded the bad 1.5.0 file, just replacing the ModuleManager.dll file with the correct version will fix the issue. Symptoms are that Trajectories reentry profile is not saved (if you go to KSC and back to your vessel, it resets to default settings).

EDIT: and sorry for SpaceDock notification spam, I forgot to disable email notifications when re-uploading the fixed zip file.

Edited by Youen

Share this post


Link to post
Share on other sites

Hello here, and I came up with some bugreporting.
Just updated to 1.1.2 and grabbed this (with ton of other mods, yeah), and I get exceptions spam. I'm using Exception Detector and it shows that errors are from Trajectories, smth with navball overlay. No indicators on the navball no matter what, but Map overlays work as intended.
Tried removing other navball-interacting mods, no change.
Spam begins in middle of game boot, seems at the moment when plugin loads. Image here

Share this post


Link to post
Share on other sites

Yup, got the same. RCS and SAS dont show on the navbal. And 30 to 40 exceptions per second.

They are thrown by: trajectories.navballoverlay.setdisplayenabled

And trajectories.autopilot.update

Sorry to have to tell u... 

 

Share this post


Link to post
Share on other sites

The latest version of this mod floods my 64bit 1.1.2 KSP with null references. Sorry, I didn't think to save the log before I uninstalled it.

Share this post


Link to post
Share on other sites

I've found the issue, and fixed it somewhat. It won't spam exceptions anymore, but the navball indicators are still not visible (don't know why at this point).

I used NavBall enhancer source code to find how to hack the navball, but unfortunately it seems this mod is not maintained, so I don't have a ready-made method to draw stuff on the navball. I'll see if I can find out how to do it in KSP 1.1 myself... but not sure when.

Edited by Youen

Share this post


Link to post
Share on other sites

Getting massive NRE spam on 1.1.2. Same exceptions as @nebuchadnezzar. Will try and trace down a little better and post logs.

Edited by Razorfang

Share this post


Link to post
Share on other sites

It seems that version 1.6.1 is still creating constant NRE errors in the Steam, Windows 64 bit version of KSP.  Here are some samples:
 

Spoiler

[EXC 15:24:12.200] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[LOG 15:24:12.201] Load(Audio): KAS/Sounds/bipwrong
[EXC 15:24:12.211] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[EXC 15:24:12.215] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[LOG 15:24:12.215] Load(Audio): KAS/Sounds/broke
[EXC 15:24:12.218] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()

Lee

Edited by Leemon1

Share this post


Link to post
Share on other sites
14 minutes ago, Leemon1 said:

It seems that version 1.6.1 is still creating constant NRE errors in the Steam, Windows 64 bit version of KSP.  Here are some samples:
 

  Reveal hidden contents

[EXC 15:24:12.200] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[LOG 15:24:12.201] Load(Audio): KAS/Sounds/bipwrong
[EXC 15:24:12.211] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[EXC 15:24:12.215] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[LOG 15:24:12.215] Load(Audio): KAS/Sounds/broke
[EXC 15:24:12.218] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()

Lee

Are you sure you installed the right version? There is a 1.5.x branch for ksp 1.1.1 and a 1.6.x branch for ksp 1.1.2  

I just tested it and it worked without any exceptions in the log (Used Trajectories 1.6.1 on KS 1.1.2 installed through CKAN because I'm lazy <.<)

 

Edit: That is with a basic test from deorbiting and old probe from above kerbin. I haven't played with the settings and tested accuracy. Just happy that the last mod of my essentials to play is updated. Awesome work man :)

Edited by Galile0

Share this post


Link to post
Share on other sites
24 minutes ago, Galile0 said:

Are you sure you installed the right version? There is a 1.5.x branch for ksp 1.1.1 and a 1.6.x branch for ksp 1.1.2 

Yes, Trajectories v1.6.1, even if only Trajectories is installed as an add-on, generates constant NRE errors when the game loads and during gameplay. KSP v1.1.2 (x64).

Spoiler

[LOG 15:51:47.517] AddonLoader: Instantiating addon 'ModuleManager' from assembly 'ModuleManager'
[LOG 15:51:47.535] [ModuleManager] Adding ModuleManager to the loading screen 2

[LOG 15:51:47.549] AddonLoader: Instantiating addon 'AutoPilot' from assembly 'Trajectories'
[LOG 15:51:47.550] AddonLoader: Instantiating addon 'DescentProfile' from assembly 'Trajectories'
[LOG 15:51:47.551] AddonLoader: Instantiating addon 'MapGUI' from assembly 'Trajectories'
[LOG 15:51:47.561] Using stock toolbar for Trajectories GUI
[LOG 15:51:47.562] AddonLoader: Instantiating addon 'MapOverlay' from assembly 'Trajectories'
[LOG 15:51:47.563] AddonLoader: Instantiating addon 'NavBallOverlay' from assembly 'Trajectories'
[LOG 15:51:47.564] AddonLoader: Instantiating addon 'Trajectory' from assembly 'Trajectories'
[LOG 15:51:48.097] Load(Audio): Squad/Parts/Utility/landingLegLT-1/sounds/sound_servomotor
[EXC 15:51:48.112] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[EXC 15:51:48.244] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[EXC 15:51:48.246] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[LOG 15:51:48.247] Load(Audio): Squad/Sounds/editorLoop01
[EXC 15:51:48.258] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[EXC 15:51:48.445] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()


Lee
 

Edited by Leemon1

Share this post


Link to post
Share on other sites
14 minutes ago, Leemon1 said:

Yes, Trajectories v1.6.1, even if only Trajectories is installed as an add-on, generates constant NRE errors when the game loads and during gameplay. KSP v1.1.2 (x64).

  Reveal hidden contents

[LOG 15:51:47.517] AddonLoader: Instantiating addon 'ModuleManager' from assembly 'ModuleManager'
[LOG 15:51:47.535] [ModuleManager] Adding ModuleManager to the loading screen 2

[LOG 15:51:47.549] AddonLoader: Instantiating addon 'AutoPilot' from assembly 'Trajectories'
[LOG 15:51:47.550] AddonLoader: Instantiating addon 'DescentProfile' from assembly 'Trajectories'
[LOG 15:51:47.551] AddonLoader: Instantiating addon 'MapGUI' from assembly 'Trajectories'
[LOG 15:51:47.561] Using stock toolbar for Trajectories GUI
[LOG 15:51:47.562] AddonLoader: Instantiating addon 'MapOverlay' from assembly 'Trajectories'
[LOG 15:51:47.563] AddonLoader: Instantiating addon 'NavBallOverlay' from assembly 'Trajectories'
[LOG 15:51:47.564] AddonLoader: Instantiating addon 'Trajectory' from assembly 'Trajectories'
[LOG 15:51:48.097] Load(Audio): Squad/Parts/Utility/landingLegLT-1/sounds/sound_servomotor
[EXC 15:51:48.112] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[EXC 15:51:48.244] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[EXC 15:51:48.246] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[LOG 15:51:48.247] Load(Audio): Squad/Sounds/editorLoop01
[EXC 15:51:48.258] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()
[EXC 15:51:48.445] NullReferenceException: Object reference not set to an instance of an object
    FlightGlobals.get_ActiveVessel ()
    Trajectories.AutoPilot.Update ()


Lee
 

Ah you're right. I've found it in my log, but only 2-3 entries. Probably why i didn't notice it. But despite the Exception it worked just fine on a quick test :o

Share this post


Link to post
Share on other sites

@Leemon1 OK, indeed, I see the exception before accessing the main menu. However, it stops after that. I didn't spot it because my debugger was not attached yet this soon in the game initialization. I suppose one should not use FlightGlobals.ActiveVessel before the game is fully initialized (makes no sense anyway, there can't be an active vessel before loading one). This is mostly harmless though. This Update function is not even doing anything else, probably not worth a new release just to fix that bug.

However, can you double check if you see the exception "during gameplay" as you said? Because if that's the case I have no clue why that would be. I do not have this behavior with my install (KSP 1.1.2 x64 downloaded from the KSP store, with only Trajectories installed). To check that, you could look at the line number of the last occurrence in the log while in the main menu, then start playing, and see if it happens again with a bigger line number...

Edited by Youen

Share this post


Link to post
Share on other sites

Hello, I kinda forget how to install this again, do I copy the entire contents of the mods "gamedata" folder, which includes "trajectories" "modualmanager" and "MMLicense", over to KSP's gamedata folder, or do I just copy over the "Trajectories" folder?

Share this post


Link to post
Share on other sites
16 minutes ago, Youen said:

However, can you double check if you see the exception "during gameplay" as you said?

I checked again, and though they occur throughout the game load, the errors do not appear during gameplay.  Sorry for the false alarm about that.

Lee

Share this post


Link to post
Share on other sites

1.6.0 works fine but 1.6.1 causes ksp to freeze during loading, on OS X, ksp 1.1.2.

uninstalling trajectories could fix this.

log file : http://pastebin.com/F5UdNVYa

update: ok i checked the log file myself and it seems to be the vessel view plugin problem. removing vessel view also fixes the freeze.

Edited by naidis
update.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.