bac9

[1.0.2] B9 Aerospace | Procedural Parts 0.40 | Updated 09.06.15

Recommended Posts

Latest version is only compatible with KSP 1.0, the stock lift/drag system changed considerably between 0.90/1.0. This is the last 0.90 compatible version I believe

Why keeping the same version number ? This would make your job harder :/.

with the version given in your link, it still have issue.

EDIT: control surfaces are both ok, only wings have this issue, take a part from list, try to attach it (as soon as part is just put on another one, without actually attach it) => exception !

1st time I put a wing, it's ok, menu is there, but after remove and put a new proc. wing part, I got this on log:

InvalidCastException: Cannot cast from source type to destination type.

at WingProcedural.WingProcedural.CalculateAerodynamicValues () [0x00000] in <filename unknown>:0

at WingProcedural.WingProcedural.UpdateGeometry (Boolean updateAerodynamics) [0x00000] in <filename unknown>:0

at WingProcedural.WingProcedural.RefreshGeometry () [0x00000] in <filename unknown>:0

at WingProcedural.WingProcedural.Setup () [0x00000] in <filename unknown>:0

at WingProcedural.WingProcedural.Start () [0x00000] in <filename unknown>:0

deleting part B9.Aero.Wing.Procedural.TypeA

Menu don't show up anymore after that, 'J' key does nothing, but button in the toolbar still display the small window.

Edited by Justin Kerbice

Share this post


Link to post
Share on other sites

Do you have stockPatch.cfg in the B9_Aerospace folder? You'd need to remove that for KSP 0.90

Why keeping the same version number ? This would made your job harder :/.

What version number? The one in the OP is the last one Bac9 released, my version is just compatibility and bug fixes with the odd small improvement thrown in here and there because Bac9 has been unable to spend time on this and it's way too good to just leave it as it was.

I did add a .version file for the patch after KSP 1.0, but everything before that was just a Github link

Share this post


Link to post
Share on other sites
Latest version is only compatible with KSP 1.0, the stock lift/drag system changed considerably between 0.90/1.0. This is the last 0.90 compatible version I believe

I'm still in 0.90 due to many of the mods I use not being updated to 1.0 yet. I tried the version for 0.90 you linked and I can't get the J-key menu to pop up on the wing sections (regular and all-moving); control surfaces did work though.

Whenever I select one of the wings to place, this gets logged:

NullReferenceException: Object reference not set to an instance of an object
at WingProcedural.WingProcedural.CalculateAerodynamicValues () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.UpdateGeometry (Boolean updateAerodynamics) [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.RefreshGeometry () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.Setup () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.Start () [0x00000] in <filename unknown>:0

Full log here: https://onedrive.live.com/redir?resid=A34F6A17A7AF30E8%211949

This is for an older game version, so I'm not really expecting much support, if any, but maybe you can quickly tell me if I did something dumb, have the wrong version, or some other possibility. Otherwise, I'll just stick to the older bac9 version.

Share this post


Link to post
Share on other sites

Ok, so for 0.90 users:

1) Clean install of Bac9's files

2) Overwrite the plugin with this one (1.0 users should use the latest version from the link in my signature)

If that doesn't work there's not a huge amount I can do to help

Edited by Crzyrndm

Share this post


Link to post
Share on other sites
Do you have stockPatch.cfg in the B9_Aerospace folder? You'd need to remove that for KSP 0.90

What version number? The one in the OP is the last one Bac9 released, my version is just compatibility and bug fixes with the odd small improvement thrown in here and there because Bac9 has been unable to spend time on this and it's way too good to just leave it as it was.

I did add a .version file for the patch after KSP 1.0, but everything before that was just a Github link

yes.

Without it, it's works.

the plug-in library version (they're all set to 1.0.0.0, despite there is many version, so "1.0.0.0 not working" means which one ?).

All of this is very drafty, a few releases on github would have been better for everyone, especially you. Because it is like "get the files from github and overwrite but warning if you have KSP version X, do this, if KSP Y, do this, and if KSP Z, do this", can't imagine what it is for people without enough computer skills.

Share this post


Link to post
Share on other sites

Up until now there hasn't been any point (well that and it was originally just a couple of NRE fixes I was doing...). It was a single file. Now that there's 4, I will probably be shifting to a packaged format because it does get messy.

PS

To be blunt, if you want to use an older version of KSP I'm in no way obliged to make older versions readily available for that purpose. Downloading an update that specifically made it compatible with a newer KSP version was just asking for trouble.

Edited by Crzyrndm

Share this post


Link to post
Share on other sites
PS

To be blunt, if you want to use an older version of KSP I'm in no way obliged to make older versions readily available for that purpose. Downloading an update that specifically made it compatible with a newer KSP version was just asking for trouble.

I'll not be too much blunt but what about people who just want to catch up and want this or this ?

Are they be forced to upgrade KSP to just get some upgrades to the Bac9 work, just because you haven't sort things up in your github page ?

So it's quite "too bad for you guys you should have been there, following carefully this thread to get the update when I made them".

Share this post


Link to post
Share on other sites
I'll not be too much blunt but what about people who just want to catch up and want this or this ?

Are they be forced to upgrade KSP to just get some upgrades to the Bac9 work, just because you haven't sort things up in your github page ?

So it's quite "too bad for you guys you should have been there, following carefully this thread to get the update when I made them".

As far as I know, he never had to maintain the mod in the first place. I am happy this mod is around and will enjoy using it for as long as it is available. Thank you for the great work!

Edited by marzharkon

Share this post


Link to post
Share on other sites

Hello,

I installed this mod on a latest KSP (1.0.2) together with Crzyrndm patch, and some weird stuff is happening when I try to use it. I cannot modify the wing, J does nothing, I can only modify control surfaces. Furthermore, while in hangar it looks like this:

http://i.imgur.com/wFmeVpY.jpg

on runway it looks like this:

http://i.imgur.com/agDCC65.jpg

I pressed "S" to also show the levitating part.

Hope it can be fixed, this mod really looks like something that should be in KSP by default.

Share this post


Link to post
Share on other sites

Current version doesn't work with 1.0.2. I second to update this mod. Awesome mod, best mod out of all 35 others that i've used in 0.90 ;) Thanks for the great work. I hope to use it again.

Share this post


Link to post
Share on other sites

I need logs from those that aren't working as I can not replicate any errors

Share this post


Link to post
Share on other sites

I am having the same problem as Kvantovy in 1.0.2 KSP with NuFAR.

Share this post


Link to post
Share on other sites

aight, sounds like something changed with nuFAR recently that I'll have to check up on

Share this post


Link to post
Share on other sites
aight, sounds like something changed with nuFAR recently that I'll have to check up on

Yeah some kind of error pops up, unable to detect FAR module, or something like that.

Share this post


Link to post
Share on other sites

Hmm... I don't have any FAR version installed, I thought it's obsolete now, when the 1.0+ is out. Is there a version compatible with 1.0.2 that should be installed along the Procedural Parts?

Share this post


Link to post
Share on other sites
Hmm... I don't have any FAR version installed, I thought it's obsolete now, when the 1.0+ is out. Is there a version compatible with 1.0.2 that should be installed along the Procedural Parts?

The next version of FAR is experimental right now, though many people are using it even without a complete release. The new stock aero isn't even close to the level of detail and accuracy that the old version of FAR provided, let alone the new version (much better than old stock though).

As far as 1.0.2 stock aero compatibility goes, it should work but you need to replace the dll in the main download with Crzyrndm's patch (in his sig). You don't need the Procedural Parts mod for this to work.

Share this post


Link to post
Share on other sites

I probably didn't express myself clearly: the Procedural Parts mod is what I want to have working. My question was if I need FAR or anything else to achieve that?

Share this post


Link to post
Share on other sites
I probably didn't express myself clearly: the Procedural Parts mod is what I want to have working. My question was if I need FAR or anything else to achieve that?

It should work without it, as long as you have an updated dll.

Share this post


Link to post
Share on other sites

@Kvantovy

You need Module Manager installed as well. Also, current updates to the .dll you can grab here: https://github.com/Crzyrndm/B9-PWings-Fork/blob/master/GameData/B9_Aerospace/Plugins/B9_Aerospace_WingStuff.dll?raw=true

The release is a package that has all the extra compatibility files in one place, but it doesn't get updated as often.

@Hodo

I'm not having any major issues with the dev FAR build from about 6 hours ago. There's a couple of niggles when reverting to editor that insist on being persistent little annoyances, but I haven't encountered anything game breaking. Assuming you have both the necesary dependancies (MM, Modular Flight Integrator for FAR), I need a log and steps to produce your issue.

Edited by Crzyrndm

Share this post


Link to post
Share on other sites

Thanks man, Module Manager was the thing I needed, now it works like a dream! Also, thanks for the link to latest .dll, i'll check it and do some more tests later.

Share this post


Link to post
Share on other sites

@Hodo

I'm not having any major issues with the dev FAR build from about 6 hours ago. There's a couple of niggles when reverting to editor that insist on being persistent little annoyances, but I haven't encountered anything game breaking. Assuming you have both the necesary dependancies (MM, Modular Flight Integrator for FAR), I need a log and steps to produce your issue.

I will try and get you that information in the next couple of days. May not have time tonight but I will see what I can come up with.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.