bac9

[1.0.2] B9 Aerospace | Procedural Parts 0.40 | Updated 09.06.15

Recommended Posts

Second thing I come across is some kind of memory leaks as shown on album.

The memory leak is because of the temperature gauges, it's a known stock issue.

I am investigating the FAR issues.

Share this post


Link to post
Share on other sites
The memory leak is because of the temperature gauges, it's a known stock issue.

I am investigating the FAR issues.

Good to know that is stock issue for memory leaks, hopefully I could make some workaround of it.

And thanks for looking into FAR issues, if you need more craft files for comparison, you can find it in my craft exchange thread. Link is in signature.

I'm aware that FAR could be changed between versions, so stability derivates might not be the same as before, but stability derivates for other crafts made only from stock parts are not changed so much between old and new FAR versions.

Thanks.

Share this post


Link to post
Share on other sites
Other way you can tell is that the CoL/P blue marker disappears when it happens

Oh, so it's FAR that doesn't like it. Another thing for the list.

Good to know that is stock issue for memory leaks, hopefully I could make some workaround of it.

Toggle them off with f10(?) if they appear. They're nice to have, but the amount of memory more than a few churns through is just not worth it :/

Share this post


Link to post
Share on other sites

Also having problems with this and nuFAR - followed install instructions (0.90 version + latest patch) and then tried the latest dev version of nuFAR but also seeing CoL vector from the wing part. Control surface (fully moving and normal) do not cause the lift vector. They look to be interacting with FAR properly as the non-vector CoL shifts when I place those parts.

Share this post


Link to post
Share on other sites
Also having problems with this and nuFAR - followed install instructions (0.90 version + latest patch) and then tried the latest dev version of nuFAR but also seeing CoL vector from the wing part.

I have the same. The CoL/P marker has the arrow ferram usually disables

Share this post


Link to post
Share on other sites

New version on Github, resolves the CoL vector issue on the main wings. Can everyone other than funk who reported issues please verify they still exist because I'm not seeing them using this version (nullrefs for 0m wingtip, NaN wave drag area, odd analysis results)

EDIT

funk is right, the control surface doesn't appear to be doing anything in nuFAR, use other parts for now (all moving still works fine)

Edited by Crzyrndm

Share this post


Link to post
Share on other sites
New version on Github, resolves the CoL vector issue on the main wings. Can everyone other than funk who reported issues please verify they still exist because I'm not seeing them using this version (nullrefs for 0m wingtip, NaN wave drag area, odd analysis results)

EDIT

funk is right, the control surface doesn't appear to be doing anything in nuFAR, use other parts for now (all moving still works fine)

To confirm - CoL shows properly now, without arows.

And i was confused about later. If that is case, my craft could not fly at all. I created decent craft with B9PW. Still needs some fine tuning, but more/less fly nice.

I will re-upload craft shortly if you need it for testing.

About that stability derivates - it was FAR bug that is corrected now on gitgub release. One thing less to wory about for this mod.

Share this post


Link to post
Share on other sites

It is nice to see this maintained. We have procedural everything else (even decoupler for Pete's sake), why not wings and control surfaces? It has to be hard to balance Real Life with a hobby, but if not for your work crzyrndm we'd be without something very cool. It is appreciated. A LOT! We'll keep up the reports and praise, and I'm sure people like Ferram are ready to lend aid to making this play nice with his wonderful NuFAR.

Thanks again, man, for the work that most of us wouldn't have time or ability to do.

Share this post


Link to post
Share on other sites

Another day, another update. I found the cause of the low control surface responsiveness with FAR (probably), and there's a good chance it was affecting all wing types and could have a significant affect on craft behaviour. You may want to double check craft stability before launching.

It is nice to see this maintained. We have procedural everything else (even decoupler for Pete's sake), why not wings and control surfaces? It has to be hard to balance Real Life with a hobby, but if not for your work crzyrndm we'd be without something very cool. It is appreciated. A LOT! We'll keep up the reports and praise, and I'm sure people like Ferram are ready to lend aid to making this play nice with his wonderful NuFAR.

Thanks again, man, for the work that most of us wouldn't have time or ability to do.

Remember to thank Bac9 for doing all the hard work, I'm only repairing/polishing what was already there ;)

Share this post


Link to post
Share on other sites

Question about this, can it be made to work with wing-shaped wings? As in wings with an air-foil cross section and not flat on top. If possible, can someone make wings like that that match the Retro Future mod, seeing as it's held up by the other proc wings mod being thoroughly borked by the update, and once those wings are done the rest of the mod can be updated rather easily.

Share this post


Link to post
Share on other sites

Just grabbed latest build, with FAR 0.15.1 a wing tip width of 0.0 causes FAR to drop its spaghetti for me.

Here's the tip width at 0.5 and FAR's graph active, all good.

lvImTVEl.png

And here's the tip width at 0.0 and FAR's GUI breaking after trying to calculate stability derivatives. Graph wasn't turned off, it disappeared on its own and wave drag area is NaN.h4PKOenl.png

Has to be some wonky math going on somewhere. It's at least partially a bug in FAR.

Edit: Here's the Player.log from a bone stock KSP + B9 wings + FAR, loading a plane with wings that have the tip width set to 0.0. At line 22,078 there's this exception, if it helps any:

ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
at System.Collections.Generic.List`1[UnityEngine.MeshFilter].get_Item (Int32 index) [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.UpdateMaterials () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.RefreshGeometry () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.UpdateCounterparts () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.Update () [0x00000] in <filename unknown>:0

Edited by 6.forty

Share this post


Link to post
Share on other sites
Just grabbed latest build, with FAR 0.15.1 a wing tip width of 0.0 causes FAR to drop its spaghetti for me.

Here's the tip width at 0.5 and FAR's graph active, all good.

http://i.imgur.com/lvImTVEl.png

And here's the tip width at 0.0 and FAR's GUI breaking after trying to calculate stability derivatives. Graph wasn't turned off, it disappeared on its own and wave drag area is NaN.http://i.imgur.com/h4PKOenl.png

Has to be some wonky math going on somewhere. It's at least partially a bug in FAR.

Edit: Here's the Player.log from a bone stock KSP + B9 wings + FAR, loading a plane with wings that have the tip width set to 0.0. At line 22,078 there's this exception, if it helps any:

ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
at System.Collections.Generic.List`1[UnityEngine.MeshFilter].get_Item (Int32 index) [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.UpdateMaterials () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.RefreshGeometry () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.UpdateCounterparts () [0x00000] in <filename unknown>:0
at WingProcedural.WingProcedural.Update () [0x00000] in <filename unknown>:0

Nobody can help if you don't upload your WHOLE log to dropbox or something.

Share this post


Link to post
Share on other sites
Just grabbed latest build, with FAR 0.15.1 a wing tip width of 0.0 causes FAR to drop its spaghetti for me.

Can I get a copy of the craft please. For some reason I am unable to create this error just by reducing the tip to zero.

Share this post


Link to post
Share on other sites

Just realized why you can't reproduce it, it's something platform/arch specific. I'm on linux and on a hunch I fired up x86 and everything is fine there. It only happens on x64. Literally the first time I've ever had an issue with x64.

Share this post


Link to post
Share on other sites

I have no idea, I just made the "0" not actually equal to zero (it's 100um :D). If I had to guess, I'd be investigating some of the referenced material to see if they are x64 compatible before the code itself.

Edited by Crzyrndm

Share this post


Link to post
Share on other sites

when you say this will not work with KVV what is the issue? I do have KVV installed, and I need to know if it is game breaking or if it will just give me odd displays when I use the KVV on a craft with these parts on it.

Share this post


Link to post
Share on other sites

hu this was working with 1.0.2 but its not anymore... Ah just a few posts above I saw the P wing maintenance, ALL HAIL Crzyrndm!!!

Edited by etheoma

Share this post


Link to post
Share on other sites
when you say this will not work with KVV what is the issue? I do have KVV installed, and I need to know if it is game breaking or if it will just give me odd displays when I use the KVV on a craft with these parts on it.

I can't say for sure since I don't use KVV, but I'd be inclined to say that it will give very odd displays because of how the parts are retextured and reshaped.

Share this post


Link to post
Share on other sites

I've been noticing some weird interactions with ailerons that intersected with a vertical wingtips, and I've being encountering this issue since earlier build versions. That being said, being curious, I turned on the aero overlay in nuFar and discovered this:

Javascript is disabled. View full album

lift force for B9 control surface is calculated at the edges, while stock have it at the centre. I'm currently using the latest updated patch.

Share this post


Link to post
Share on other sites

Got CTD due to some kind of memory leak. Happened in SPH editor while I was attaching/reshaping control surfaces.

Don't know if it is related, but I have updated today crossfeed enabler trough CKAN. Also SETI mod is updated, but that one only arrange parts trough tech tree, so I doubt that is related.

Yesterday I have also made a lot of changes on planes inside SPH but didin' have memory CTD there, only with temperature gagues in flight, but that one is detected and solved.

I'm not sure if CTD it is related with B9 wings, crossfeed enabler or something else, here is part of log that could be usefull, let me know if you need whole log.

Anyway, I will try to see if I can reproduce it again or it is isolated case.



NullReferenceException: Object reference not set to an instance of an object
at RUI.Algorithms.ComponentListMaker.UpdatePartVertex (Boolean residual, .Part part, System.Collections.Generic.Dictionary`2 lookup) [0x00000] in <filename unknown>:0

at RUI.Algorithms.ComponentListMaker.GetStackFlowGraph (.ShipConstruct ship) [0x00000] in <filename unknown>:0

at EngineersReport.RunTests () [0x00000] in <filename unknown>:0

at EngineersReport+
.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Updating Space Plane Mk2 B9PW V100 08

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

Voxelization Time (ms): 90

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

NullReferenceException: Object reference not set to an instance of an object
at RUI.Algorithms.ComponentListMaker.UpdatePartVertex (Boolean residual, .Part part, System.Collections.Generic.Dictionary`2 lookup) [0x00000] in <filename unknown>:0

at RUI.Algorithms.ComponentListMaker.GetStackFlowGraph (.ShipConstruct ship) [0x00000] in <filename unknown>:0

at EngineersReport.RunTests () [0x00000] in <filename unknown>:0

at EngineersReport+
.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

deleting part B9.Aero.Wing.Procedural.TypeB

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

deleting part B9.Aero.Wing.Procedural.TypeB

Share this post


Link to post
Share on other sites
I've been noticing some weird interactions with ailerons that intersected with a vertical wingtips, and I've being encountering this issue since earlier build versions. That being said, being curious, I turned on the aero overlay in nuFar and discovered this:

Nice catch.

Got CTD due to some kind of memory leak. Happened in SPH editor while I was attaching/reshaping control surfaces.

Will have a look once I sort these control surfaces out

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.