SpaceTiger

[1.4.x] AutomatedScienceSampler - V1.3.5 - 28.04.2018

Recommended Posts

Read a few posts above :). There is an update coming that will hide these when this mod runs the experiments.

Oh, :sealed: I've got the common forum disease it appears - write first read later never. Will wait for the update then.

Share this post


Link to post
Share on other sites
*spamming F5 to check for update* Hehe :D
No need to break your F5 key anymore :).

Just pushed out a new release fixing some more issues with DMagic Orbital Science and dding options to "hide" the experiment result window.

As always: If you have any issues with this update or mod please report them here!

Edited by SpaceTiger

Share this post


Link to post
Share on other sites

If ForScienceContinued is the only KerboKatz mod installed, how does one remove that white square that shows up in the corner? Click settings, return, blank app icon in the top right corner. Same if I start a game.

aNsHLqK.jpg?1

Only things in GameData folder is /Squad and /KerboKatz, most recent version of ForScienceContinued, new install of KSP.

Share this post


Link to post
Share on other sites
If ForScienceContinued is the only KerboKatz mod installed, how does one remove that white square that shows up in the corner? Click settings, return, blank app icon in the top right corner. Same if I start a game.

http://i.imgur.com/aNsHLqK.jpg?1

Only things in GameData folder is /Squad and /KerboKatz, most recent version of ForScienceContinued, new install of KSP.

Thanks for reporting this. I just fixed this issues. Just download the KerboKatzUtilities from GitHub or KerbalStuff and install it just like ForScienceContinued.

Share this post


Link to post
Share on other sites
Thanks for reporting this. I just fixed this issues. Just download the KerboKatzUtilities from GitHub or KerbalStuff and install it just like ForScienceContinued.

Yep, that fixed it, thanks for the quick update. As a side note, will you include the updated KerboKatzUtilities.dll in ForScienceContinued?

Edited by veryinky

Share this post


Link to post
Share on other sites
Yep, that fixed it, thanks for the quick update. As a side note, will you include the updated KerboKatzUtilities.dll in ForScienceContinued?

With a new release of ForScienceContinued I'll use the new version but i don't think it's important enough to update the zip files everywhere.

Share this post


Link to post
Share on other sites

Not sure if this is a known bug or not but my ForScience keeps doing useless crew reports and temperature readings etc worth 0 Science when I'm on the runway or launchpad. My cutoff is set to 2.

Also, could you add functionality to auto-transfer science to capsule from Tarsier Space Tech?

Thanks for the mod, it's great!

Share this post


Link to post
Share on other sites
Not sure if this is a known bug or not but my ForScience keeps doing useless crew reports and temperature readings etc worth 0 Science when I'm on the runway or launchpad. My cutoff is set to 2.

Are you runing the newest version ? This glitch got fixed in the latest version.

Also, could you add functionality to auto-transfer science to capsule from Tarsier Space Tech?

Thanks for the mod, it's great!

I had a quick look at that mod and I'm guessing you mean from the hard drives. I could add an option to transfer science from other containers to the selected container.

Share this post


Link to post
Share on other sites

TST already has functionality for the hard drives, but for the space telescope (only module I've played with so far) I have to use ship manifest and it's quite a laborious job. :)

I'm using the latest version of your mod and admit it happens less frequently than before but still happens. I'll try to get as much info as I can for you and update.

So, I was relying on AVC to keep my mods up to date and for some reason it thinks 27.2 is the latest one? Odd. I'll let you know how I get on with 1.0.4 thanks. :)

Edited by Flukeshot

Share this post


Link to post
Share on other sites
TST already has functionality for the hard drives, but for the space telescope (only module I've played with so far) I have to use ship manifest and it's quite a laborious job. k_smiley.gif

I'm using the latest version of your mod and admit it happens less frequently than before but still happens. I'll try to get as much info as I can for you and update.

So, I was relying on AVC to keep my mods up to date and for some reason it thinks 27.2 is the latest one? Odd. I'll let you know how I get on with 1.0.4 thanks. k_smiley.gif

Ugh that thing isn't a "real" science experiment that's why ForScienceContinued doesn't detect it as such. Have to think about how i could do this the best way.

As for the version: probably cause i didn't update the version file in a while.

Share this post


Link to post
Share on other sites

Thanks for looking into it :)

I can confirm that new version is fixed for me. Sorry about not checking that version and trusting AVC before posting.

Share this post


Link to post
Share on other sites

I'm unable to retrieve science from non-reusable experiments manually - I can "review" the material study/goo observation, but my EVAing kerbals can't retrieve the data. I'm not sure this is a problem with this mod and not one of my others, but since this is the only one that should be affecting science experiments I was wondering if anyone else had encountered this?

Share this post


Link to post
Share on other sites
I'm unable to retrieve science from non-reusable experiments manually - I can "review" the material study/goo observation, but my EVAing kerbals can't retrieve the data. I'm not sure this is a problem with this mod and not one of my others, but since this is the only one that should be affecting science experiments I was wondering if anyone else had encountered this?

I just tried to reproduce this but failed at doing so. Maybe you weren't close enough ?

Share this post


Link to post
Share on other sites

I'm having it happen with science that has been loaded into pods; Once the science has been loaded, I can't have an EVAed Kerbal retrieve it.

https://dl.dropboxusercontent.com/u/4057920/Kerbal%20Space%20Program/v1.0/Screenshots/screenshot285.png

https://dl.dropboxusercontent.com/u/4057920/Kerbal%20Space%20Program/v1.0/Screenshots/screenshot286.png

I'm going to have to do some more experimentation and see if it might be something else.

Share this post


Link to post
Share on other sites
I'm having it happen with science that has been loaded into pods; Once the science has been loaded, I can't have an EVAed Kerbal retrieve it.

https://dl.dropboxusercontent.com/u/4057920/Kerbal%20Space%20Program/v1.0/Screenshots/screenshot285.png

https://dl.dropboxusercontent.com/u/4057920/Kerbal%20Space%20Program/v1.0/Screenshots/screenshot286.png

I'm going to have to do some more experimentation and see if it might be something else.

Again i can't reproduce this. Did you try it without ForScienceContinued? If so did it work ?

List of the mods you have installed might help to figure out which mod is causing this issue.

Share this post


Link to post
Share on other sites

The source appears to be mystifying. I can't routinely reproduce it on the pad, or when hyperedited into space. I've taken out and put in for science and antenna range, but it is starting to look like it may only be afflicting the depicted class of craft, which is rather strange indeed. A list of mods will be forthcoming when I get back to my computer. I'll also try testing the depicted spacecraft on the pad.

Share this post


Link to post
Share on other sites

Is it possible to use this mod on a per ship basis?

I have a research station orbiting I'd like to automate using this mod but I like doing the science myself sometimes.

Share this post


Link to post
Share on other sites
Is it possible to use this mod on a per ship basis?

I have a research station orbiting I'd like to automate using this mod but I like doing the science myself sometimes.

The settings are currently globally saved. But I'm sure its not hard to change this to a per ship basis.

Share this post


Link to post
Share on other sites
The settings are currently globally saved. But I'm sure its not hard to change this to a per ship basis.

how would I go about doing that?

(speak noob to me.. I'm not as young or as smart anymore as this crowd :sticktongue:)

Share this post


Link to post
Share on other sites
how would I go about doing that?

(speak noob to me.. I'm not as young or as smart anymore as this crowd :sticktongue:)

I meant it as in i would have to change the source code to have a per ship settings file.

Share this post


Link to post
Share on other sites
I meant it as in i would have to change the source code to have a per ship settings file.

whew!

I thought you were gonna throw code at me.

that's the best way to make this guy feel stoopit :confused:

I was originally asking if it was an existing option I was missing the option to activate.

I rarely ask a modder to change an already excellent creation

- so if it's something easy for you to accomplish,

can I request it?

If it turns into a migraine for you, forget it.

Thanks for a great mod!

Share this post


Link to post
Share on other sites
whew!

I thought you were gonna throw code at me.

that's the best way to make this guy feel stoopit :confused:

I was originally asking if it was an existing option I was missing the option to activate.

I rarely ask a modder to change an already excellent creation

- so if it's something easy for you to accomplish,

can I request it?

If it turns into a migraine for you, forget it.

Thanks for a great mod!

Already added to my to-do list. But it might take a while before i release an update.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.