SpaceTiger

[1.4.x] AutomatedScienceSampler - V1.3.5 - 28.04.2018

Recommended Posts

11 hours ago, secondcircle said:

Any idea why your change would be showing up as a virus on windows?

Anyone else used this? My windows virus detector is probably just acting dumb.

 

9 hours ago, NotTim said:

Windows Defender is flagging it for me as well.

Trojan: Win32/Spursint.A!cl

It does?

Huh, virustotal says nothing, so I don't really know why Windows defender would flag this.

But see yourself: https://www.virustotal.com/de/file/9c15cbde273e9713989c855baf2a3662f86121591c13cfc26b35ad3ea95859af/analysis/

 

Edit: wops didn't saw Loren Pechtel already answered that :P

I will add the virus total link to the update post

Apparently I cant delete my own posts

Edited by CptPonk
I did a stupid

Share this post


Link to post
Share on other sites
2 hours ago, MajorDonkey said:

Anyone know of a work-around for this windows virus crap?  Anyone tested the file downloaded?

Did you not see that two of us posted a VirusTotal report on the file?  Everyone, including Windows Defender, feels it's clean.  If you're having virus problems with it something else is going on.  Either your system is already compromised or you're getting it through an insecure channel that's infecting it before it gets to you.

One test you can do--take your infected file and send it to VirusTotal.  See what it says.

Also, in case it's a transport layer problem:

https://www.dropbox.com/s/bwgj6j98l0vjepm/ForScienceFix.rar?dl=0

That's the same stuff but I put a password of "notinfected" on it--that will make it much harder for a man-in-the-middle to mess with it.

Share this post


Link to post
Share on other sites
8 hours ago, Loren Pechtel said:

Did you not see that two of us posted a VirusTotal report on the file?  Everyone, including Windows Defender, feels it's clean.  If you're having virus problems with it something else is going on.  Either your system is already compromised or you're getting it through an insecure channel that's infecting it before it gets to you.

One test you can do--take your infected file and send it to VirusTotal.  See what it says.

Also, in case it's a transport layer problem:

https://www.dropbox.com/s/bwgj6j98l0vjepm/ForScienceFix.rar?dl=0

That's the same stuff but I put a password of "notinfected" on it--that will make it much harder for a man-in-the-middle to mess with it.

That one worked fine, I'm wondering if something was getting added in transit, in any case it was very strange.

Thanks for that.

Share this post


Link to post
Share on other sites
33 minutes ago, NotTim said:

That one worked fine, I'm wondering if something was getting added in transit, in any case it was very strange.

Thanks for that.

What is your internet connection situation?  (I'm trying to think of where the man in the middle might be.)

Share this post


Link to post
Share on other sites

Hey thank you Loren!  That download worked!  Thanks to everyone!  Umm as far as my internet connection, Time Warner Cable.  How concerned should I be?

Edited by MajorDonkey
My fingers suck.

Share this post


Link to post
Share on other sites
2 minutes ago, MajorDonkey said:

Hey thank you Loren!  That download worked!  Thanks to everyone!  Umm as far as my internet connection, Time Warner Cable.  How concerned should I be?

I wouldn't think they would be messing with your system, it's normally only the little guys that think they can get away with meddling.  (No US ISP is going to deliberately inject malware but the biggest source of malware these days is compromised ads.)  Do you still have the file that was flagged?

Share this post


Link to post
Share on other sites

No the system wouldn't even download it.  Thanks again for the fast reply!  KSP seriously has the best modding community of any game I've ever played.

Share this post


Link to post
Share on other sites
2 minutes ago, MajorDonkey said:

No the system wouldn't even download it.  Thanks again for the fast reply!  KSP seriously has the best modding community of any game I've ever played.

I'm not even a modder yet (I know the language, I've never played with the Unity engine, though), just a fairly new player to the game.

Share this post


Link to post
Share on other sites

Hi, i have a question for who can anwser me. When I do science with probes, I transmit it.

But with some experiments, just a percentage can be transmit, and in this case, the mod redo the experiment but to keep it. So when a new experiment is avaible, the mod isn't doing it because the experiment is already take by some previous keeped data.

Is there a way to prevent this mod to keep science when it have been transmitted or make it transmit science even it can be keeped? Or something like which can help me ?

Sorry for my english, i don't know if it's perfectly understandable

Have a nice day

Share this post


Link to post
Share on other sites
2 hours ago, iDInkeD06 said:

Hi, i have a question for who can anwser me. When I do science with probes, I transmit it.

But with some experiments, just a percentage can be transmit, and in this case, the mod redo the experiment but to keep it. So when a new experiment is avaible, the mod isn't doing it because the experiment is already take by some previous keeped data.

Is there a way to prevent this mod to keep science when it have been transmitted or make it transmit science even it can be keeped? Or something like which can help me ?

Sorry for my english, i don't know if it's perfectly understandable

Have a nice day

I'm not sure what you mean exactly. So here are two things that i think you want:

1. You want to ForScience to rerun the experiment after you transmit it.

2. You want single run experiments(Goo/Science Jr.) to be used again after you transfer the results from a previous run.

Edited by SpaceTiger

Share this post


Link to post
Share on other sites
14 minutes ago, SpaceTiger said:

I'm not sure what you mean exactly. So here are two things that i think you want:

1. You want to ForScience to rerun the experiment after you transmit it.

2. You want single run experiments(Goo/Science Jr.) to be used again after you transfer the results from a previous run.

Sorry ^^ Not exactly, i wanted to know how i can just perform transmittable science and prevent to keep data in science experiment parts. Because that forbid to automatically make science with these same parts if i don't reset them manually.

By example : ForScience run thermometer, the science is keeped by defaut, i transmit it but only the half (due to transmission efficiency). And several secondes after, as it remains a half of science which can be keeped, it rerun the experiment. Is there a way to avoid that ?

Thank you for your answer ;)

Share this post


Link to post
Share on other sites

Hey guys, first post and all that :)

Anyway, just wanted to share a quick note for 1.1 testers out there - it seems that the unofficial ForScienceContinued and DMagic1.1 update currently don't get on that well; when trying to run a DMagic experiment with some animations to deploy it seems to get stuck in a loop. (For example the mag. boom slides out and in (or snaps back, I forget which) constantly blocking any more science obtaining.)

 

[LOG 21:28:06.022] [ForScienceContinued] Deploying: magScan@KerbinSrfSplashed
Science: 2
[EXC 21:28:06.023] NullReferenceException: Object reference not set to an instance of an object
	KerboKatz.ForScienceContinued.createScienceDMagic (.ModuleScienceExperiment currentExperiment, .ScienceSubject currentScienceSubject, Single currentScienceValue)
	KerboKatz.ForScienceContinued.RunScience ()
	KerboKatz.ForScienceContinued.FixedUpdate ()

That looks like the problem area unfortunately :(

As the fix is unofficial and things are still in beta it is, of course, no big deal just thought I'd give people a heads up :)
(I'd take a shot at trying to fix it, as I'm a game coder by trade, but I figure with new and better things coming I can live with it for now ;) )

Looking forward to see what awesome stuff you've got planned SpaceTiger :)

 

Share this post


Link to post
Share on other sites

Just a small update on the above; having picked up the new install last night this seems to be fixed... the mag. boom now deploys sanely and science is collected - I'll double check later tonight just to make sure I'm not going crazy ;)

Share this post


Link to post
Share on other sites

Nice update. Tested and look fine, but there are some issues.

 Dmagic experiments look like are not triggering.  Also when is active make a huge spike lag on launch phase when some trigger start on low altitude. FPS drop dramatically and I prefer to launch any ship with mod disable to avoid lag spikes.

Share this post


Link to post
Share on other sites

Anyone having a problem where rightclicking the ForScience button doesn't bring up the settings menu?

Doesn't even write a line to the logfile, either.

Edit: Nevermind, sorry! Read through the thread more carefully. Maybe put the alt+mouse1 thing in the OP? Or at least take down the incorrect information temporarily?

Edited by JohnWittle

Share this post


Link to post
Share on other sites

I don't think I'm blind today (maybe a little stupid, though), but I'm not seeing anything in the Curse link or the GitHub repo.  I assume a little more patience would benefit me today?  Aka, is this something I should just check again in an hour or is something wrong?

Thanks

Share this post


Link to post
Share on other sites

We found a few issues that have to be fixed before release.
Stay tuned for more information in the next few hours.

Share this post


Link to post
Share on other sites

I just pushed AutomatedScienceSampler to GitHub and Curse.

I expect a few issues to pop up. Especially with DMagic Orbital Science so please if you experience weird/wrong behavior turn on debugging in the settings menu,reproduce the error and attach the log files here with detailed description so we can see whats going wrong.

Share this post


Link to post
Share on other sites

Darn, this mod looks like a clever idea. Like an expansion on science alert. Thanks, gonna try it!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.