Jump to content
  • 1

Slight freeze every 5 seconds (or so)


Question

In both vanilla installs and modded installs I encounter a constant and steady freezing for a fraction of a second every 5 to 7 seconds or so. It has become quite an annoyance as it also occurs on the VAB which makes assembly a task rather than a treat. I might also add that over time the freezes tend to give me a headache.

I am running a i5-4670k with a GTX 980

I use both standard launch and I also use OpenGL.

I am constantly experiencing this.

Is there a solution?

Link to post
Share on other sites

Recommended Posts

  • 0

I have tried memgraph, turning off AA, setting max prerendered frames to 1 in the nvidia control panel... DirectX, OpenGL... everything everyone on every forum I can find, has suggested, and this is still happening.  Seems to sometimes not happen, sometimes only a little, sometimes *a lot*.. cannot figure out what's affecting the rate, but.. if anyone has any suggestions other than what I just mentinoed.. please let me know :)
Note - only happens in flight to me, not in VAB/SPH.

Link to post
Share on other sites
  • 0
2 minutes ago, ss8913 said:

I have tried memgraph, turning off AA, setting max prerendered frames to 1 in the nvidia control panel... DirectX, OpenGL... everything everyone on every forum I can find, has suggested, and this is still happening.  Seems to sometimes not happen, sometimes only a little, sometimes *a lot*.. cannot figure out what's affecting the rate, but.. if anyone has any suggestions other than what I just mentinoed.. please let me know :)
Note - only happens in flight to me, not in VAB/SPH.

How much memory do you have on the machine? My best guess is a GC issue. I wold recommend MemGraph or GCMonitor to give a peek in what KSP and the mods are doing with the memory.

Link to post
Share on other sites
  • 0

It's a brand new pc.. i7 8700K, 1080ti with 11gb vram, 32gb ddr4 main memory, and ksp is installed on a Samsung evo ssd.. I was hoping the new rig would fix the problem. But no.  Framerates and such are of course much faster than the old box, but the stutter persists.

Link to post
Share on other sites
  • 0

It's hard to believe, but sometimes putting more RAM into the problem makes it worse. 

With more RAM to use, the GC usually is encouraged to "waste" more RAM before collecting the garbage - and when finally it does it, there're so much trash that it halts for far more time than before. Kind of "better halts 0.5sec each 2 secs than 4 secs each 10" issue.

But I'm just guessing. You need a run monitoring the heap using something like GCMonitor to be sure about what's happening.

It can be something inside Unity, for example.

 

 

Link to post
Share on other sites
  • 0
1 hour ago, ss8913 said:

It's a brand new pc.. i7 8700K, 1080ti with 11gb vram, 32gb ddr4 main memory, and ksp is installed on a Samsung evo ssd.. I was hoping the new rig would fix the problem. But no.  Framerates and such are of course much faster than the old box, but the stutter persists.

Man, I hope you can fix this. Please keep us updated.

Link to post
Share on other sites
  • 0

I've just started having this problem where it briefly (but noticeably and annoyingly) pauses every 3-4 seconds, even in the Spaceplane Hanger. I have run KSP with the task manager open and it doesn't go above 50% memory usage and is even less on the CPU and GPU. I have also tried forcing it to use opengl which didn't help.

Link to post
Share on other sites
  • 0
On 12/26/2018 at 4:57 AM, dxeh said:

Ill go for nr. 3!

 

On 11/5/2018 at 3:33 PM, Casper_83 said:

This is still a problem, I hoped they would fix this.

1. Fix freeze problem

2. Steam modsupport

3. include KAS, KIS and IR in the game!

They added IR into breaking ground

Link to post
Share on other sites
  • 0
On 7/19/2019 at 9:05 PM, TheEeveeLovers said:

 

They added IR into breaking ground

Finally 1/3 of 3 fixed I have not tried it yet, but maybe 1. is fixed also :)

On 7/19/2019 at 9:53 PM, Drinarii said:

Wow did they really add IR into breaking ground or are you joking?

Not really, they made their own, Still amazing, but missing a gantry type for making cranes in my opinion.

 

Link to post
Share on other sites
  • 0

Captain here. You may have too much RAM, Unity allocates too much, so it has to do big GCs. I decreased the problem until it became quite usable by creating a RAM disk, leaving just enough RAM (based on guess and experiencing) for Kerbal Space Program to run smoothly without swapping. This made GCs smaller, more frequent and faster. It is not perfect, but much better. Cheers.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...