girka2k

[1.4.*] [2.5.3] (2018-04-06) UbioZur Welding Ltd. Continued

Recommended Posts

Well, if you want the craft files, ok. But they're literally just four struts stacked on top of each other. lol

Oh, I tried it out in the VAB, just for schmidts and giggles and got the same result. I figured I would, but tested it just in case. :) More data never hurt when trying to solve a problem.

Here are the craft files.

TestPart1

https://app.box.com/s/jpscuy7m3s6qrx08r1hdsprhb2sntseh

TestPart2

https://app.box.com/s/vu36d4gz7wzib6ophohswc65kua1idom

Good luck! I hope you can figure it out!

Share this post


Link to post
Share on other sites
Well, if you want the craft files, ok. But they're literally just four struts stacked on top of each other. lol

Oh, I tried it out in the VAB, just for schmidts and giggles and got the same result. I figured I would, but tested it just in case. :) More data never hurt when trying to solve a problem.

Here are the craft files.

TestPart1

https://app.box.com/s/jpscuy7m3s6qrx08r1hdsprhb2sntseh

TestPart2

https://app.box.com/s/vu36d4gz7wzib6ophohswc65kua1idom

Good luck! I hope you can figure it out!

Yep that is right, the more data the better :)

Thanks for the files, we will look at it.

Share this post


Link to post
Share on other sites

I seem to be having a problem getting this to work. I used the module manager to install in and it seems to be installed correctly. The logs show it being loaded and I don't see any errors during load time, But I don't see the weld button in the VAB.

Here is a link to the log file after the game was started, loaded a save game, went into the VAB, left the VAB, then closed the game.

I really have no idea why it's not working.

Thanks.

Share this post


Link to post
Share on other sites
I seem to be having a problem getting this to work. I used the module manager to install in and it seems to be installed correctly. The logs show it being loaded and I don't see any errors during load time, But I don't see the weld button in the VAB.

Here is a link to the log file after the game was started, loaded a save game, went into the VAB, left the VAB, then closed the game.

I really have no idea why it's not working.

Thanks.

Hmm the first Thing I see is that you have multiple MM installed, one is enough, try only the latest version.


[EXC 11:24:44.188] NullReferenceException: Object reference not set to an instance of an object
UbioWeldingLtd.DatabaseHandler.initMMAssembly ()
UbioWeldingLtd.UbioZurWeldingLtd.Awake ()
UnityEngine.GameObject:AddComponent(Type)
AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
AddonLoader:StartAddons(Startup)
AddonLoader:OnLevelWasLoaded(Int32)

This one here tells me there is a problem with the preparing of MM at the loading of UbioWeldingLtd.

So cleaning all MM files and then installing the newest one should solve your problem.

Share this post


Link to post
Share on other sites
This one here tells me there is a problem with the preparing of MM at the loading of UbioWeldingLtd.

So cleaning all MM files and then installing the newest one should solve your problem.

I don't know how I didn't see that.:blush: I guess over time they just built up. Thanks, it's seems to be working now. Lesson here: watch your directories and remove any old, possibility conflicting, data.

Share this post


Link to post
Share on other sites
I don't know how I didn't see that.:blush: I guess over time they just built up. Thanks, it's seems to be working now. Lesson here: watch your directories and remove any old, possibility conflicting, data.

Glad I could help :)

Share this post


Link to post
Share on other sites

Another hint... don't weld multiple radial fins (even the low level fins) around a fuel tank and expect it to work sanely. The results were interesting. If you must reduce part counts on the initial stages, stick with linear RCS ports (the single nozzle type) or the vernier thrusters combined with a RCS wheel for roll stability.

One of the designs that I am happy with is a pair of FL-T800 tanks, a 1.25m RCS fuel tank, a 1.25m reaction wheel plus eight linear RCS ports (four at top, four at bottom). This gives the equivalent of a FL-T1600 tank with built-in stability control, but which counts as a single part.

Share this post


Link to post
Share on other sites

Question that has been probaley answered. Will this work in career mode? if not directly is there a way to get part you weled to be in career mode?

Thanks!

Share this post


Link to post
Share on other sites
Question that has been probaley answered. Will this work in career mode? if not directly is there a way to get part you weled to be in career mode?

Thanks!

Well you can select the technode that is required for the part, so I see no reason why It should not work in carrer.

Share this post


Link to post
Share on other sites
Question that has been probably answered. Will this work in career mode? if not directly is there a way to get part you welded to be in career mode?

Yes it works fine in Career mode.

Share this post


Link to post
Share on other sites
I'm thinking my problem might be down to having multiple air intakes in the same welding, are multiple intakes problematic does anyone know?

hmm good question, that case was not tested.

As it is not animated(in most cases) that should not give a problem and the module merging is designed to combine the values of each intake into a single module, so it should not cause any trouble.

Share this post


Link to post
Share on other sites

It seems to me, that this mod is completely incompatible with Active texture management. Am i right,or shoild i just wait longer till it loads?

Share this post


Link to post
Share on other sites
It seems to me, that this mod is completely incompatible with Active texture management. Am i right,or shoild i just wait longer till it loads?

That is not correct, it is totally compatible with ATM even with LoD.

Welding does not create new models or textures it only references the textures of the parts.

ATM does take long time to prepare all textures, but that has nothing to do with Welding

Share this post


Link to post
Share on other sites
That is not correct, it is totally compatible with ATM even with LoD.

Welding does not create new models or textures it only references the textures of the parts.

ATM does take long time to prepare all textures, but that has nothing to do with Welding

True, problem was in "database reload" function. ATM was perfectly fine.

Share this post


Link to post
Share on other sites

can wheels be welded or do they fall under the same as Landing legs/Lights .etc

Share this post


Link to post
Share on other sites
can wheels be welded or do they fall under the same as Landing legs/Lights .etc

To be safe I would say avoid them, but you can test it with one single wheel in the weldment.

Share this post


Link to post
Share on other sites
Will be bringing the old girl out of mothballs again for .90 or 1.0. Thanks for keeping this essential mod alive.

http://i1346.photobucket.com/albums/p685/jwt0bos/screenshot532_zpsjpzzk1e0.png

http://i1346.photobucket.com/albums/p685/jwt0bos/screenshot531_zpsixciivjx.png

Only one word can describe this, FAN :D

Well I'm more for the more scientific stories, but it is really a nice construction, you really got the shape great worked out. Which mods did you include, and where did you find the cockpit, or even your own construction?

Share this post


Link to post
Share on other sites
Winglet/wings/control surfaces/parachutes: they can/must work incorrectly after welding. (It needs more testing).

Do you have any more details on what happens when you welding wings (not control surfaces, just the stock wing parts)? I might try welding wings myself tonight, but is it known to be broken in particular ways? I'm assuming the result of welding two wings would be their lift is summed, and their center of lift is moved to the CoM of the wing or something.

(PS: Thanks for reviving this mod!)

Share this post


Link to post
Share on other sites

The cockpit is a mod, very beautifully done 3rd party by BONUS. However it has issues when I tried to use it. The view was inverted as was control. There are no internals either. It was suggested to modify the part cfg file of the Millennium Pod, so as to point to the Cupola visuals. I never got around to it and it made a lot of sense. I began to play with a cockpit using stock parts, with 4 seats for Kerbalnauts. I may revisit this, however, there is no in-flight view when controlling that way (I think?). Overall this model is probably slightly too flat, I will try to correct that. I may be forced to re-scale stock parts so they will look right.

"Millennium Pod by BONUS" have to google it this forum is not working at all with publishing http links like it used to.

The CRAFT I distributed used no mods (UbioZur is used during construction ONLY - not needed on target systems). I used the Apollo style capsule. In the future, I will distribute a several version" package possibly. Totally stock, Millennium Pod, and 4 Kerbalnaut version. Time will tell.

Edited by Space Cowboy

Share this post


Link to post
Share on other sites
Do you have any more details on what happens when you welding wings (not control surfaces, just the stock wing parts)? I might try welding wings myself tonight, but is it known to be broken in particular ways? I'm assuming the result of welding two wings would be their lift is summed, and their center of lift is moved to the CoM of the wing or something.

(PS: Thanks for reviving this mod!)

The aerodynamic values will be wrong and so will be the lift incorrect during flight.

You can edit the correct values after welding into the part manually.

Share this post


Link to post
Share on other sites

Confirmed problem and solution:

I am welding a semi complex structure that comprises a large high altitude engine. In the core are two rocket fuel tanks. In the editor I empty them. I have found once welded, they are full. I have gone in to the CFG file and entered zeros for the fuel and oxidizer. As I browse the welded part, it now shows empty and the weight has automatically been reduced to what I assume would be "empty"!

screenshot183_zpsgfkiujmb.png

Edited by Space Cowboy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.