Jump to content

[1.4.*] [2.5.3] (2018-04-06) UbioZur Welding Ltd. Continued


girka2k
 Share

Recommended Posts

In Honor Of All You Have Done For Krebal Kind, I have WeldithThee::

The "TrekLisias"

screenshot10.png

screenshot8.png

The newest in transport to other planets.

only 220 parts post weld and we have begun to assemble the finest of cargo.

Jammer-TD

 

 

Edited by Jammer-TD
added pic
Link to comment
Share on other sites

Hi guys, I successfully doing a lot of welding and getting a big reduce in part count, I love this mod!!...my only issue is that I have to move back and forth between KSP 1.4.2 and 1.5.2 versions...

But I also notice some strange behavior in some internal lights, like with the Mk1 Crew cabin, no matter what I do, after welding their lights are always On, the right click menu don't do anything on them and I already check that they are in fact On, when physics kick in they actually illuminate the surroundings, so it mean they are consuming resources...at least in my computer lights are a huge draw back in performance, so if this is the case I gaining on the part reduction but increasing load due the lights...

 

There is anyway to force those internal lights to be Off?, even is permanently Off will be Ok...hopefully I don't have to make again all my welding and I can do something with the cfg files...

 

 

Thanks!!

 

Mauricio

 

 

Link to comment
Share on other sites

On 2/25/2019 at 1:09 PM, buhochileno said:

Hi guys, I successfully doing a lot of welding and getting a big reduce in part count, I love this mod!!...my only issue is that I have to move back and forth between KSP 1.4.2 and 1.5.2 versions...

Are you using the "Standard" Welding tool? There's a fork (mine!) that (mostly) works for 1.6, so it should work for 1.5.1 (it's 1.5.1, right? Or Squad released an extra KSP on the 1.5 and I'm not aware? :P ).

 

On 2/25/2019 at 1:09 PM, buhochileno said:

But I also notice some strange behavior in some internal lights, like with the Mk1 Crew cabin, no matter what I do, after welding their lights are always O [cut by me]

This is a nut hard to crack. The lights are a Effect set up on Unity's (a "transition" on the texture used for the windows), and there're nothing saying what texture is the "on" and what texture is the "off" - just a setting telling KSP "this is a texture, this is another texture, this is a effect that changes from one to another. Use this one as default on launch". So you can set up the first as "on". And the Welding tool has no way to foresee this.

If I remember correctly the code (it's a long time already), the Welding tool just get the last texture on the pile and use it and that's it. The transitions are thrown away.

 

On 2/25/2019 at 1:09 PM, buhochileno said:

There is anyway to force those internal lights to be Off?, even is permanently Off will be Ok...hopefully I don't have to make again all my welding and I can do something with the cfg files...

Yes. Manually edit the texture on the resulting CFG file to pinpoint to the "off" one. You will need to open the original part's CFG to see who is who, but other than that, this is not exactly a hard nut to crack.

An automated way to do that (or even a way to preserve the effect) however, is a hard nut to crack. :) 

Edited by Lisias
yeah. typos. but you already knew it.
Link to comment
Share on other sites

5 minutes ago, Nicky21 said:

@Lisias Where is that fork? And why is your other stuff not on ckan?

this is the release of continuum, I could not get it to work even in a KSPe fresh install of 1.6.1 using only -squad,toolbar,mm3 or 4 and( u need) clickthrublocker( as it is a codependency for the toolbar).  

https://github.com/net-lisias-ksp/UbioWeldContinuum/releases

I would be interested if you get working. I have posted logs and pics. I can get the original "continued" version too work NP, but only as per @lisias using mm3 to do the welds(ps I have not tried it on other versions of KSP)

thanks

Jammer-TD

 

Link to comment
Share on other sites

  • 2 weeks later...

hi @Lisias, I've just got your fork from github, but I've got trouble to get it working.

I'm confused by the folders in the .zip, should I put .net.lisias in gamedata? or the actual mod name folder. Also, plugindata is in separate folder, where do I need to put it?

I'm on KSP 1.6.1, dependencies installed.

Thanks :)

Link to comment
Share on other sites

2 hours ago, kurgut said:

hi @Lisias, I've just got your fork from github, but I've got trouble to get it working.

I'm confused by the folders in the .zip, should I put .net.lisias in gamedata? or the actual mod name folder. Also, plugindata is in separate folder, where do I need to put it?

I'm on KSP 1.6.1, dependencies installed.

Unzip the thing on your KSP's root. The GameData goes to KSP\GameData , and the Plugindata to KSP\PluginData . The files ends up in the correct place by doing that.

Don't forget to install KSPe too - it's a hard dependency.

And yeah… I need to update the thing, it's still using my first attempt on packagings. :) (but this will take some time yet, I'm overwhelmed by now…)

Oh, and the thing is NON-MAINSTREAM. Even the naming is non-standard, it should be just "/L" and that's it. :D (the current maintainer is welcome to merge back anything he likes)

Edited by Lisias
warning.
Link to comment
Share on other sites

7 minutes ago, kurgut said:

Thanks!

Ah, what is KSPe mod.. ? can't find it

Forget about. This thing is so old than it doesn't use it yet. I really need to update this thing sooner or later. :P 

Please backup your savegames! :D 

Link to comment
Share on other sites

23 hours ago, kurgut said:

Thanks!

Ah, what is KSPe mod.. ? can't find it

Kerbal Space Program Enhanced edition.

and @Lisias it is worth the wait. take all the time you need. rushing things won't make you happy. we will wait! and still be thankful as the saying goes  "good things come to those who wait".

Edited by Jammer-TD
Link to comment
Share on other sites

  • 2 weeks later...
1 hour ago, Foxxonius Augustus said:

@Lisias at the risk of being The Guy What Asks for Mod Updates, do you have an estimated ETA for an update? I have a craft that is over 800 parts that could be less than 30. ;.;

Dude, last time I estimated a deadline for TweakScale, I borked so beautifully that my ears got burning for 3 months. :P 

The Welding tool is usable for 1.3 parts for sure (IIRC there was just one VARIANTPARTMODULE part on 1.4, and I missed it completely), and I don't know how this will behave on 1.6.1, as since December, all my sparing time for KSP is for TweakScale (and for good reasons). The good notice about this is that what I learnt form this stunt is directly useable on the Welding tool, so yeah, things will work for sure. Someday. :( 

On the short term, I remember someone using 1.5 for weldings and then moving things to 1.6 (or using 1.4 and moving to 1.5? I don't recall). As long you don't use any parts with new modules, everything will be ok. And by using a older KSP for welding, that parts will be eligible to be used on newer KSPs (as long they didn't changed the used textures, but you can always manually copy them back - or even create a MM patch to hot fix them, what I think would be a better solution!).

If it can be of any comfort, I'm really using all my spare time on it - I am not really playing for weeks. ;.; Real Life is a Sun on a Beach sometimes. :P 

Edited by Lisias
yeah. tyops.
Link to comment
Share on other sites

@LisiasFair enough. Thanks for the quick reply. I guess my project will have to go on the back burner for now but it will be ready to go once you have the time. I can understand and sympathize with the no free time aspect. I hope real life starts treating you better.

Edited by Foxxonius Augustus
Link to comment
Share on other sites

  • 2 weeks later...
2 hours ago, Lisias said:

Humm… Thinking on it, I think ReStock would render some problems for welded parts. Someone tried it already?

I wouldn't know for sure but from what I understand ReStock is purely a graphics mod. Nothing about the parts are modified apart from how they look.

Link to comment
Share on other sites

10 minutes ago, Foxxonius Augustus said:

I wouldn't know for sure but from what I understand ReStock is purely a graphics mod. Nothing about the parts are modified apart from how they look.

The Welding tool "hijacks" the textures of the parts being welded (beautifull algorithm!), and ReStock patches the Stock Parts to use new textures.

I wondering how this will cope with tje welding tool, I.e., what happens to your welded parts when you install ReStock after welding, and what happens when you uninstall it

 

Link to comment
Share on other sites

Hi! Using 1.4.5 RO/RSS. Weldjng Button doesn't seem to show up on either toolbar using your fork. I installed into PluginData and GameData. Any fix?

Edited by suzuki
Link to comment
Share on other sites

29 minutes ago, suzuki said:

Hi! Using 1.4.5 RO/RSS. Weldjng Button doesn't seem to show up on either toolbar using your fork. I installed into PluginData and GameData. Any fix?

I need your KSP.log file. This behaviour hints me that the DLL is not being loaded, or are borking on the loading/initialization phases.

In a way or another, the log should tell me what's happening. 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...