Jump to content

[1.4.*] [2.5.3] (2018-04-06) UbioZur Welding Ltd. Continued


girka2k
 Share

Recommended Posts

I haven't been around here for a few versions.  Working on updating my game to 1.12.3.  Could someone tell me what the latest buzz is with the welding mod?  Is the "Continued" one in this thread still the correct version to use?  What are the issues when trying to plunk it into 1.12.x?  Is there some kind of workaround with an earlier or custom version of ModuleManager?

Also what does "KSPe 2.4 series" refer to?  KSPAPIExtensions?

Edit: @Lisias the links on your https://github.com/net-lisias-ksp/UbioWeldContinuum/ page (e.g. Latest Release, Binaries, etc) are broken and need updating from UbioWeldingLtd --> UbioWeldContinuum.

Edited by Fwiffo
Link to comment
Share on other sites

OK I managed to sort out the colossal mess this mod's dependencies have devolved into, and got this thing to load in KSP 1.12.3.  For the benefit of anyone else trying to figure it out, here's what worked for me:

UbioWeldContinuum-2.6.0.8
https://github.com/net-lisias-ksp/UbioWeldContinuum/releases/tag/RELEASE%2F2.6.0.8

KSPAPIExtensions-2.3.0.4 (Lisias' custom build "/L")
https://github.com/net-lisias-ksp/KSPAPIExtensions/releases/tag/RELEASE%2F2.3.0.4

ModuleManager-4.2.1.1 (Lisias' custom build)
https://github.com/net-lisias-ksp/ModuleManager/releases/tag/RELEASE%2F4.2.1.1

ClickThroughBlocker-1.12.0-0.1.10.17
https://github.com/linuxgurugamer/ClickThroughBlocker/releases/tag/0.1.10.17

ToolbarControl-1.12.0-0.1.9.6
https://github.com/linuxgurugamer/ToolbarControl/releases/tag/0.1.9.6

I tried the more recent KSP API Extensions /L 2.4.1.7 and ModuleManager 4.2.1.2 but they produced an error which prevented KSP from loading (which I unfortunately neglected to screenshot).  It was a fresh installation of the game and UbioZur Welding was the only mod I added (plus its dependancies).

Thanks to Lisias and others for their efforts to keep this great mod held together.  I hope someone tackles overhauling the codebase to work more seamlessly with the most recent versions of KSP and adds support for part variations.  I'd be happy to make a substantial donation toward that end (PM me if interested and be patient if I'm slow to reply).

Here's the result of a simple weld.  I haven't conducted any more thorough testing at this point.

FSf1JrW.png

Edited by Fwiffo
Link to comment
Share on other sites

20 hours ago, Fwiffo said:

OK I managed to sort out the colossal mess this mod's dependencies have devolved into, and got this thing to load in KSP 1.12.3.  For the benefit of anyone else trying to figure it out, here's what worked for me:

UbioWeldContinuum-2.6.0.8
https://github.com/net-lisias-ksp/UbioWeldContinuum/releases/tag/RELEASE%2F2.6.0.8

KSPAPIExtensions-2.3.0.4 (Lisias' custom build "/L")
https://github.com/net-lisias-ksp/KSPAPIExtensions/releases/tag/RELEASE%2F2.3.0.4

ModuleManager-4.2.1.1 (Lisias' custom build)
https://github.com/net-lisias-ksp/ModuleManager/releases/tag/RELEASE%2F4.2.1.1

ClickThroughBlocker-1.12.0-0.1.10.17
https://github.com/linuxgurugamer/ClickThroughBlocker/releases/tag/0.1.10.17

ToolbarControl-1.12.0-0.1.9.6
https://github.com/linuxgurugamer/ToolbarControl/releases/tag/0.1.9.6

I tried the more recent KSP API Extensions /L 2.4.1.7 and ModuleManager 4.2.1.2 but they produced an error which prevented KSP from loading (which I unfortunately neglected to screenshot).  It was a fresh installation of the game and UbioZur Welding was the only mod I added (plus its dependancies).

Thanks to Lisias and others for their efforts to keep this great mod held together.  I hope someone tackles overhauling the codebase to work more seamlessly with the most recent versions of KSP and adds support for part variations.  I'd be happy to make a substantial donation toward that end (PM me if interested and be patient if I'm slow to reply).

Here's the result of a simple weld.  I haven't conducted any more thorough testing at this point.

FSf1JrW.png

Wow, thanks for your guide. A few weeks I just used an older KSP version to weld some crafts and cpy them into the latest KSP.

I also really hope someone picks this up and updates it properly. :)

Link to comment
Share on other sites

  • 2 weeks later...
  • 5 weeks later...
On 1/4/2022 at 9:21 AM, Fwiffo said:

I tried the more recent KSP API Extensions /L 2.4.1.7 and ModuleManager 4.2.1.2 but they produced an error which prevented KSP from loading (which I unfortunately neglected to screenshot).  

ah, yeah, i'm getting that same error now even with the versions you suggested installing

Link to comment
Share on other sites

16 hours ago, Mythical said:

ah, yeah, i'm getting that same error now even with the versions you suggested installing

Hi.

I just fired up a test bed using the latest KSPe, MM/L and UbioWeldingContinuum after updating it to the latest version of KSPe, and apparently it's working fine. The latest KSPe has some fixes, better memory footprint and slightly better performance, so perhaps this would be the issue for you guys?

Anyway, I did a quick update on the thing:

  • Theoretically it still aims KSP 1.4.x, use it on newer KSP at your own risk :P  - i.e., I didn't added any support for Parts with Variants, your mileage will vary.
  • Handling configuration files are slightly more convenient now.
    • Doesn't affects current installments, don't worry.
  • I didn't bored to check if this stunt would work with canonical ModuleManager
    • I remember doing some changes on the MM support once, but don't recollect what I did.
  • You will need the latest KSPe version - this DLL will not work with older releases.
  • It's still a interim, non-official fork intended to fill a gap while someone else doesn't takes it properly. ;)

Links:

If even with this last release you have problems, please publish your KSP.log on dropbox, google drive or something and send it to me for inspection.

Ping @Fwiffo - sorry being so late!

Edited by Lisias
ping
Link to comment
Share on other sites

6 hours ago, Lisias said:

Hi.

I just fired up a test bed using the latest KSPe, MM/L and UbioWeldingContinuum after updating it to the latest version of KSPe, and apparently it's working fine. The latest KSPe has some fixes, better memory footprint and slightly better performance, so perhaps this would be the issue for you guys?

Anyway, I did a quick update on the thing:

  • Theoretically it still aims KSP 1.4.x, use it on newer KSP at your own risk :P  - i.e., I didn't added any support for Parts with Variants, your mileage will vary.
  • Handling configuration files are slightly more convenient now.
    • Doesn't affects current installments, don't worry.
  • I didn't bored to check if this stunt would work with canonical ModuleManager
    • I remember doing some changes on the MM support once, but don't recollect what I did.
  • You will need the latest KSPe version - this DLL will not work with older releases.
  • It's still a interim, non-official fork intended to fill a gap while someone else doesn't takes it properly. ;)

Links:

If even with this last release you have problems, please publish your KSP.log on dropbox, google drive or something and send it to me for inspection.

Ping @Fwiffo - sorry being so late!

Ping @Lisias , my ksp fourm acc got wiped so I cant pm you.  Opened github issue on KspE The type initializer for 'KSPe.1O.Hierarchy' threw an exception

Link to comment
Share on other sites

4 hours ago, Pokemoncrusher1 said:

Ping @Lisias , my ksp fourm acc got wiped so I cant pm you.  Opened github issue on KspE The type initializer for 'KSPe.1O.Hierarchy' threw an exception

I think you installed the wrong DLL, the new version only works on KSPe 2.4 and newer due some changes on the API.

I redowloaded the ZIP from the github release pages, and it's really the latest one I uploaded this morning - and it works on KSPe 2.4.x.y...

(next time, please publish the whole KSP.log so I can be sure)

Anyway, if you manage to get it working, don't change anything and keep going. Other than small, non functional changes, nothing really changed.

Link to comment
Share on other sites

15 hours ago, Lisias said:

I think you installed the wrong DLL, the new version only works on KSPe 2.4 and newer due some changes on the API.

I redowloaded the ZIP from the github release pages, and it's really the latest one I uploaded this morning - and it works on KSPe 2.4.x.y...

(next time, please publish the whole KSP.log so I can be sure)

Anyway, if you manage to get it working, don't change anything and keep going. Other than small, non functional changes, nothing really changed.

Sorry about the log, I had the right one on my desktop ,  I just uploaded the right log file. After reinstall module manager doesnt warn me anymore but newest KspE still crashes. 

As you said, if it works it works! , I uploaded the log incase you want to take a look but you are not obligated too and I thank you for your continued work in the community!

Link to comment
Share on other sites

On 2/13/2022 at 2:34 AM, Lisias said:

Hi.

I just fired up a test bed using the latest KSPe, MM/L and UbioWeldingContinuum after updating it to the latest version of KSPe, and apparently it's working fine. The latest KSPe has some fixes, better memory footprint and slightly better performance, so perhaps this would be the issue for you guys?

Anyway, I did a quick update on the thing:

  • Theoretically it still aims KSP 1.4.x, use it on newer KSP at your own risk :P  - i.e., I didn't added any support for Parts with Variants, your mileage will vary.
  • Handling configuration files are slightly more convenient now.
    • Doesn't affects current installments, don't worry.
  • I didn't bored to check if this stunt would work with canonical ModuleManager
    • I remember doing some changes on the MM support once, but don't recollect what I did.
  • You will need the latest KSPe version - this DLL will not work with older releases.
  • It's still a interim, non-official fork intended to fill a gap while someone else doesn't takes it properly. ;)

Links:

If even with this last release you have problems, please publish your KSP.log on dropbox, google drive or something and send it to me for inspection.

Ping @Fwiffo - sorry being so late!

i'll give this a shot this evening, i'll let you know if it's still not working - i'm really gonna need this mod for some of the things i'm doing in this save

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
On 2/26/2022 at 3:17 PM, tgk_0072 said:

so... any version for ksp 1.12.3?

Yes, latest version working. @tgk_0072

https://github.com/net-lisias-ksp/UbioWeldContinuum/releases/tag/RELEASE%2F2.6.0.9

https://github.com/net-lisias-ksp/KSPAPIExtensions/tree/RELEASE/2.4.1.12

https://github.com/net-lisias-ksp/ModuleManager/tree/RELEASE/4.2.1.3

these dependencies, maintained by Lisias. 

Just don't download mm with -122 at the end of the .zip for 1.12

Edited by Pokemoncrusher1
Link to comment
Share on other sites

  • 4 months later...

Got a log for you to look at @Lisias

Noticed that after welding 2 or 3 different craft together, when I try and use it again, I basically don't get the popup for the craft name when I click weld. It just sits there with the craft highlighted but I can't weld it. A restart of KSP fixes it.

Log file is here: https://share.kopjet.com/app/open/BrX7VJLoDCf-GUn5RYQ9JB6-1T8TYv3sMt4-62A9MoHJuVo?view=1

Link to comment
Share on other sites

Is there a way to make this mod play with the popular ReStock mod?

I tried welding, but UbioZur Welding spazzes out and has problems displaying the correct texture/mesh variant for any submodel in the part-tree of the welded part.

As you can see, only the root part of the ReStock Panel has the base texture, every part below the root part tries to display all texture/mesh variants at the same time, resultung in severe Z-fighting.

 

aL3gQ5w.png

 

Edited by NippyFlippers
Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...
  • 2 months later...

@Pokemoncrusher1 thanks for your post, it inspired me to give the latest builds a whirl.  I can confirm the following now work (at least at first glance):

  • UbioWeldContinuum-2.6.0.9 (Lisias) (release) (zip)
  • KSPAPIExtensions-2.4.2.4b (Lisias' custom build "/L") (release) (zip)
  • ModuleManager-4.2.2.4b (Lisias' custom build, and not the "-122" one) (release) (zip)
  • ClickThroughBlocker-2.1.10.18 (release) (zip)
  • ToolbarControl-1.12.0-0.1.9.8 (release) (zip)

Few questions / things I noticed...

  1. Why is there a copy of ModuleManager.dll in both the GameData directory and the GameData\ModuleManager\PluginData directory?  This seems WRONG.  I deleted the seemingly-redundant GameData\PluginData folder (not to be confused with the PluginData folder in the KSP root directory, which was left intact).
  2. New weldments are being placed in GameData\__LOCAL\net.lisias.ksp instead of GameData\UbioWeldingLtd\Parts where I'd prefer them.  What's with the __LOCAL garbage?
  3. Note config has moved to PluginData\net.lisias.ksp\UbioWeldingLtd (I think it previously was PluginData\UbioWeldingLtd which is more intuitively understandable - I'm certainly not worried about collisions with other mods).

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...