shaw

[1.6.x--1.7.x] TextureReplacer 3.7 (25.1.2019)

Recommended Posts

@GreeningGalaxy The download link for your Kerbal Heads is down. It's a shame, I'd really like to get the Serious variant.

I've also noticed that many other textures are outdated or also down, while the income of new textures is at an all-time low(the only reliable pack is the Renaissance mod, and it adds too many things I don't care for). I'd just like a good-looking pack of Kerbal heads for either gender(prefferably with non-bearded males, and females without makeup).

Also, @Cosmic_Farmer I really like some of the IVA suits in this image showcasing your head mod - specifically the ones from the first and fourth Kerbals(though mostly the foruth) from left to right. It resembles casual clothes which astronauts do wear while within a space station or in a ship idling as it's more comfortable than an IVA suit. Could you or anyone else point out where to download those suits, and possibly to find a pack with more casual clothes like those?

286r7fs.png

Edited by Commissioner Tadpole

Share this post


Link to post
Share on other sites

@shaw @RangeMachine

It seems that Texture Replacer is interfering with a mod I've written to control the stock toolbar.  I'm using a Rect for the new toolbar, and multiple Rect's inside for each button,  and GUI.Button. When Texture Replacer is installed, it just isn't displaying.  I see from my debugging that my code is being executed properly.  When I remove Texture Replacer, it works.  This happens on all screens.

Any ideas?

 

Share this post


Link to post
Share on other sites
26 minutes ago, linuxgurugamer said:

@shaw @RangeMachine

It seems that Texture Replacer is interfering with a mod I've written to control the stock toolbar.  I'm using a Rect for the new toolbar, and multiple Rect's inside for each button,  and GUI.Button. When Texture Replacer is installed, it just isn't displaying.  I see from my debugging that my code is being executed properly.  When I remove Texture Replacer, it works.  This happens on all screens.

Any ideas?

 

 

So i did some more digging, and found that the following code is causing the problem for me.  This is in Loader.cs, around line 294:

            foreach (GameDatabase.TextureInfo texInfo in texInfos)
            {
                Texture2D texture = texInfo.texture;

                if (texture == null || !texInfo.isReadable)
                    continue;

                // Unload texture from RAM (a.k.a. "make it unreadable") unless set otherwise.
                if (isUnloadingEnabled.Value && !keepLoaded.Any(r => r.IsMatch(texture.name)))
                {
                    try
                    {
                        texture.GetPixel(0, 0);
                    }
                    catch (UnityException)
                    {
                        continue;
                    }

                    memorySpared += textureSize(texture);

                    texture.Apply(false, true);
                    texInfo.isReadable = false;

                    Util.log("Unloaded {0}", texture.name);
                }
            }

 

Share this post


Link to post
Share on other sites

Ok.  So I'm assuming that the problem is that you are unloading textures from RAM after the game has loaded.

So this is causing  a problem for me.

Since buttons are very small, how about adding the following line to the code:

                if (texture == null || !texInfo.isReadable)
                    continue;
// Following is added line
                if (texture.width <= 38 && texture.height <= 38)
                    continue;

This solves the problem for me, and still allows you to unload most of the textures.

 

Share this post


Link to post
Share on other sites
13 hours ago, linuxgurugamer said:

Ok.  So I'm assuming that the problem is that you are unloading textures from RAM after the game has loaded.

So this is causing  a problem for me.

Since buttons are very small, how about adding the following line to the code:


                if (texture == null || !texInfo.isReadable)
                    continue;
// Following is added line
                if (texture.width <= 38 && texture.height <= 38)
                    continue;

This solves the problem for me, and still allows you to unload most of the textures.

 

Accepted pull request and recompiled project.

https://github.com/RangeMachine/TextureReplacer/releases/tag/v2.5.4

Share this post


Link to post
Share on other sites

Hello Fellow Cosmo-Astro-Taiko-nauts!

I want to give my appreciation and sincere thank you to all modders that make "TextureReplacer" such a great mod for KSP.

I have the following issue and have attempted to research it within the 60+ pages within this topic but I am unable to find a solution:

I am running KSP v1.2.0 with the following mods:

KSPRC_-_Renaissance_Compilation_artworks_remake-0.7_PreRelease_3 by Proot

with updated versions of:

"Texture Replacer" by shaw (MIT license / Copyright © 2013-2015 Davorin Učakar, Ryan Bray)
"Environmental Visual Enhancements" by Rbray89 (MIT license / Copyright © 2013 Ryan Bray)

"Scatterer" by blackrack (GPLv3 / Copyright © 2015 Ghassen Lahmar)

"Kopernicus" by Thomas P. with NathanKell and KillAshley (GNU GPL / Created by BryceSchroeder and Teknoman117)

"Distat Object Enhancement" by MOARdV (Creative Commons [cc-by] / Created by RInsert other media ubber Ducky)

"PlanetShine" by Valerian (Apache license 2.0 / Copyright 2014, Valerian Gaudeau)

 

But I have the following effects with the Kerbal suit helmet visors:

1 - The visors are not semi-transparent

2- There are "skybox" anomalies within the reflections on certain angles

I am using the "REAL" option ( reflectionType = real) instead of the "STATIC".

Your expertise and assistance on a solution in this matter is appreciated.

Respectfully,

THX-1138

full-544-130064-screenshot4.pngfull-544-130065-screenshot8.pngfull-544-130066-screenshot6.png

 

Share this post


Link to post
Share on other sites
6 hours ago, THX-1138 said:

Hello Fellow Cosmo-Astro-Taiko-nauts!

I want to give my appreciation and sincere thank you to all modders that make "TextureReplacer" such a great mod for KSP.

I have the following issue and have attempted to research it within the 60+ pages within this topic but I am unable to find a solution:

I am running KSP v1.2.0 with the following mods:

KSPRC_-_Renaissance_Compilation_artworks_remake-0.7_PreRelease_3 by Proot

with updated versions of:

"Texture Replacer" by shaw (MIT license / Copyright © 2013-2015 Davorin Učakar, Ryan Bray)
"Environmental Visual Enhancements" by Rbray89 (MIT license / Copyright © 2013 Ryan Bray)

"Scatterer" by blackrack (GPLv3 / Copyright © 2015 Ghassen Lahmar)

"Kopernicus" by Thomas P. with NathanKell and KillAshley (GNU GPL / Created by BryceSchroeder and Teknoman117)

"Distat Object Enhancement" by MOARdV (Creative Commons [cc-by] / Created by RInsert other media ubber Ducky)

"PlanetShine" by Valerian (Apache license 2.0 / Copyright 2014, Valerian Gaudeau)

 

But I have the following effects with the Kerbal suit helmet visors:

1 - The visors are not semi-transparent

2- There are "skybox" anomalies within the reflections on certain angles

I am using the "REAL" option ( reflectionType = real) instead of the "STATIC".

Your expertise and assistance on a solution in this matter is appreciated.

Respectfully,

THX-1138

full-544-130064-screenshot4.pngfull-544-130065-screenshot8.pngfull-544-130066-screenshot6.png

 

About trasparency: check your alpha channel in texture. About artifacts: this is probably conflict with Scatterer.

Share this post


Link to post
Share on other sites
14 hours ago, RangeMachine said:

About trasparency: check your alpha channel in texture. About artifacts: this is probably conflict with Scatterer.

 

Hello RangeMachine,

Where do I locate the "alpha channel" within TexureReplacer?  Thank you for the prompt response.

Respectfully,

THX-1138

Share this post


Link to post
Share on other sites

I have a little question about the reflections on EVA helmets. I've noticed that on EVA (when near some craft) I get quite bad drops in FPS, but that makes sense as it's set on real reflections. I tried to set it to static from the GUI but if I click static it just jumps to none. So I can only select real or none.  It appears that there isn't anything in the EnvMap folder so I guess static mode doesn't have anything to reflect.  What should I put in there? Is there a default set of textures that should belong in there.

Share this post


Link to post
Share on other sites
5 minutes ago, katateochi said:

I have a little question about the reflections on EVA helmets. I've noticed that on EVA (when near some craft) I get quite bad drops in FPS, but that makes sense as it's set on real reflections. I tried to set it to static from the GUI but if I click static it just jumps to none. So I can only select real or none.  It appears that there isn't anything in the EnvMap folder so I guess static mode doesn't have anything to reflect.  What should I put in there? Is there a default set of textures that should belong in there.

Hello katateochi,

I am on learning curve but I believe that you do need files there.  You need to have the following files within TextureReplacer\EnvMap folder:

NegativeX.dds

NegativeY.dds

NegativeZ.dds

PositiveX.dds

PositiveY.dds

PositiveZ.dds

 

Share this post


Link to post
Share on other sites

@THX-1138 Thanks! but (and excuse my texture replacer noobishness) but where do I get those files from? I installed texture replacer via CKAN as part of the install for SVE and those files are not in the ckan download, and they don't seem to be in this link from the initial post of this thread.  Do I need to get them from somewhere else?

Share this post


Link to post
Share on other sites

@katateochi:

 

I found the files within the "TextureReplacer" folder found within PROOT's latest version of "The Renaissance Compilation" (KSPRC):

I hope that helps you!

Respectfully,

THX-1138

Share this post


Link to post
Share on other sites

@THX-1138 Awesome! Thanks for tracking that down for me. 
I still can't select static as an option in the GUI and I've tried setting it manually in @Default.cfg but that doesn't seem to make any difference.  Maybe static has been disabled? 
Thanks for your help anyways though!

Share this post


Link to post
Share on other sites

@katateochi

You are welcome!  Maybe there is a conflict somewhere with some other mod.  Are you only using the default config (@Default.cfg) and you have set the following option?

reflectionType = static

If so or not, let me know.  I know how it feels when you wish that all looks perfect within KSP.

Share this post


Link to post
Share on other sites
On 14/09/2016 at 3:08 PM, Poodmund said:

I've whipped up another at the special request from forum user @Errol who wrote a very heartfelt plea to try to create something that he would like to see in game.

The result was the merging of the Milky Way skybox at an angled tilt with the Deep Star Map skybox layered over to increase the star field density with a few extra bits dotted here and there. I think I have achieved what Errol requested, so I'll let him try it out and respond. :D

3oz8xG2SoeEJvJBRWo.gif

Obviously the gif doesn't do it true justice. Download link: https://www.dropbox.com/s/hkfkqy3c2hgta0d/PoodsTiltedMilkyWay.zip?dl=0

I strongly advise the use of...

... when using the skyboxes and adjusting the "Dynamic Skybox Brightness" to suit your liking as to whether you like it bright or dark in certain situations as you ascend etc.

 

Just wanted to bump this post and give pood a shout out.

Something neat that I've noticed while playing with this skybox is that since I run at reduced resolution and without AA enabled (because I'm on a laptop and love mods (and to torture myself and my machine apparently)); with the tiny pin point stars I get a bonus "twinkling" effect due to aliasing as the camera moves. I really like it.

Edited by Errol

Share this post


Link to post
Share on other sites
2 hours ago, Errol said:

Just wanted to bump this post and give pood a shout out.

Something neat that I've noticed while playing with this skybox is that since I run at reduced resolution and without AA enabled (because I'm on a laptop and love mods (and to torture myself and my machine apparently)); with the tiny pin point stars I get a bonus "twinkling" effect due to aliasing as the camera moves. I really like it.

Hey, this is nicely done.  I like it a lot.

... unfortunately if you're on a 4K monitor like me, you will find it blurry and out-of-focus seeming.  It's actually rather jarring to have pin-sharp foreground detail and OOF background detail.  But I'm pretty into the content - maybe there are 4K base textures to recombine in the same way?

Share this post


Link to post
Share on other sites

I can only dream of using 4K textures. I have to use the low res SVE pack too.

Share this post


Link to post
Share on other sites
On 11/24/2015 at 3:26 PM, Cetera said:

I've been searching for suit packs that fit my picky needs for some time, and have always leaned heavily on GregroxMun's and Bentley's suit packs. However, after seeing Shaymes' efforts, due to a simple conversation with GregroxMun that suddenly helped me understand a bit of graphics editing, I've made my own suit pack.

The suits in this pack level up with your Kerbalnaught. Levels are represented by stars on the back of the helmet, similar to Shaymes pack. The EVA suits also start out very plain and white, and level up every-other-level with your Kerbal, adding more color similar to Bentley's pack, and then becoming almost full color. IVA suits do not level, and are only slightly modified versions from Bentley's pack, adjusting the shoulder patches.

Role/profession emblems are on the backs of helmets, front chest pieces, and left arms of EVA suits, and left arms of the IVA suits.

Suit variants:
Orange Pilot (rocket)
Orange Engineer (wrench)
Orange Engineer (gear)
Orange Scientist (flask)
Blue Scientist
Purple Scientist
Red Pilot
Pink Pilot
Yellow Engineer (both wrench and gear variants)
Green Engineer (both wrench and gear variants)

Imgur Album here: http://imgur.com/a/pCwNy

Also be aware, there is minor inconsistency in the screenshots from the final package. I was experimenting with the possible star patterns in the screenshots, and decided on having level three be three stars straight across, not in a triangle. In a couple of pics, an incorrect normal map was used on EVA backpacks, that has since been corrected, and one has a level 1 suit from KSPRC as a placeholder.

Download

A very, very, special thank you to GregroxMun, Proot, Green Skull, Scart91, JFull, Bentley, and Shaymes for their inspiration, suit packs, and for making my KSP adventures a little more delightful and colorful over the last couple of years. Very special thanks to GregroxMun for the discussion and willingness to assist me. Thank you Shaw for this great mod and allowing all of this to happen.

If I've missed anyone, please let me know. If I have, I do apologize. If I've missed any licensing info, also please let me know, and I'll update it accordingly.

 

1.1 Update:

I updated my suit pack for 1.1, reverting the helmet textures back to .png files.  There was some texture unpleasantness with the compression to .dds textures for 1.0.5 and earlier that I felt were pretty apparent, but necessary for the memory savings.  The textures should be a bit cleaner now, and the posted screenshots more representative of what you actually get.  

The suit textures remain .dds, as the issue was much less apparent on them, and in 1.1 with the engine upgrade, it is very difficult to zoom in the suit to the level the texture would be noticed, without having the suit removed as you start to see through the model.  Plus, if you aren't likely to notice, there is no sense in taking up additional load time and memory converting the .pngs when the game loads.


-----------------------------------------
Licence for this pack is CC BY-NC-SA
-----------------------------------------

Install instructional video here:

https://www.youtube.com/watch?v=EqjCOkMXb1Y

 

 

This is one of my favorite textures since it's not only stylish, but very functional.

Share this post


Link to post
Share on other sites

Cant seem to get texturereplacer working in latest version of KSP. The toolbar button doesn't show up and the skybox I used to use in 1.1.3 doesn't show up either. Is the mod to outdated or is it a community updated version I've missed?

Share this post


Link to post
Share on other sites
3 minutes ago, Zefnoly said:

Cant seem to get texturereplacer working in latest version of KSP. The toolbar button doesn't show up and the skybox I used to use in 1.1.3 doesn't show up either. Is the mod to outdated or is it a community updated version I've missed?

Nevermind! I downloaded the unofficial (with working visors) which is the one I was going to download in the first place. Now it's working again!

Share this post


Link to post
Share on other sites

Anyone have valid links to 4K textures like in the discussion just above?  Everything I'm finding is outdated, dead, or just not quite to my taste.  I really like the feel of the layered real Milky Way and Deep Sky maps.

Share this post


Link to post
Share on other sites
On 12/18/2016 at 5:07 PM, fourfa said:

Anyone have valid links to 4K textures like in the discussion just above?  Everything I'm finding is outdated, dead, or just not quite to my taste.  I really like the feel of the layered real Milky Way and Deep Sky maps.

 
 

https://drive.google.com/file/d/0B9jz_KKFCaKcc011RTN5SjRkQVE <--zip of the skybox (6 4096x4096 jpgs) and installation instructions

http://imgur.com/gallery/n4WIF if you want to see what they look like 

 

Edited by TheRagingIrishman
wrong Imgur link

Share this post


Link to post
Share on other sites
On 15/12/2016 at 1:53 AM, THX-1138 said:

[...]
"Environmental Visual Enhancements" by Rbray89 (MIT license / Copyright © 2013 Ryan Bray)

[...]

Sorry for the delay, but I've noticed just now that the link you posted for EVE is old.

You should be using this one now: 

 

Share this post


Link to post
Share on other sites

I'm starting to get together an updated list of all the texture packs which are available for this mod, and will be putting them all into a single Github repo so they won't be lost again.

If you have any of the texture packs which are no longer available, please let me know and get them to me.  I know that the packs made by @GreeningGalaxy are beautiful, but his server seems to have gone away;  it looks like it was at a university, and classes ended for him.  So, if you have any/all of his texture packs:

GreeningGalaxy's Diverse Kerbal Lasses
Serious Lasses
Gothy Lasses
Lass GIMP File

Please get them to me.

As soon as I start getting in packs which are unavailable, I'll get it up in Github and post a page with all the links.

I know that many others aren't available.  Please check your disks and send me them.

 

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.