shaw

[1.6.x] TextureReplacer 3.7 (25.1.2019)

Recommended Posts

I'd love to know how to change the mun to our moon? Not interested in resizing it etc, I'd just love to be able to have it in my game.

Share this post


Link to post
Share on other sites
I'd love to know how to change the mun to our moon? Not interested in resizing it etc, I'd just love to be able to have it in my game.

If i understand this right.You would like to change texture of the current moon?

If you read OP,you can do exactly that.

General Textures

General replacement textures are of the form

Code:

GameData/TextureReplacer/Default/<internalName>where `<internalName>` is the texture's internal name in KSP or path of a texture inside `GameData/` (plus .dds/.png/.jpg/.tga extension, of course).

where `<internalName>` is the texture's internal name in KSP or path of a texture inside `GameData/` (plus .dds/.png/.jpg/.tga extension, of course).

Examples:Code:

GameData/TextureReplacer/

Default/NewMunSurfaceMapDiffuse // Mün

Default/NewMunSurfaceMapNormals // Mün normal map

Note that all texture and directory names are case-sensitive!

regards

Edited by sebi.zzr

Share this post


Link to post
Share on other sites
Quick preview to my upcoming texture pack, class based suits will be included too as well as something for the VIP passengers.

http://i.imgur.com/X7EJHJO.jpg

Good Gracious, YES please yes!!!!

Not meant to sound sexual... but yesss....

How is it coming along?

Cant wait myself, would you consider sharing those Val textures to pair with your old kerbal heads for now? >.<

Share this post


Link to post
Share on other sites

I'm having some problems with texture replacer. The only textures I am adding are oinker's skybox. However, when I load the game, a quadrant of the sky is missing (white), even on the main menu. It goes away if I set texture compression option to never, however if I do this than I cannot use EVE mod simultaneously as the game crashes on loading, even with low res clouds and using no other graphical/part mods. It seemed to be working perfectly fine with 1.0.0, this bug seems to have just cropped up.

Share this post


Link to post
Share on other sites
I'm having some problems with texture replacer. The only textures I am adding are oinker's skybox. However, when I load the game, a quadrant of the sky is missing (white), even on the main menu. It goes away if I set texture compression option to never, however if I do this than I cannot use EVE mod simultaneously as the game crashes on loading, even with low res clouds and using no other graphical/part mods. It seemed to be working perfectly fine with 1.0.0, this bug seems to have just cropped up.

Does it look like this:

I have a bug with this mod, I don't know if anyone is still around that maintains it. I use this mod because I don't have a beefy computer that plays KSP 1.0.2

The problem is when I launch game, go to VAB load say Kerbal Stock X craft, launch it and when I am on the pad, I hit "M" to go to map mode and this is what I see:

KSP%202015-05-03%2015-23-45-38_zpskekexmru.jpg

KSP%202015-05-03%2015-23-41-27_zpsa60qqpnt.jpg

I revert flight and it is still there, the only way to make it go away is restart KSP. When I come back from KSP if I go to tracking station it is fine but if I load a craft and I am on launch pad, that visual error shows up.

Here is my log files:

http://www./download/58he6us0hyuj9g4/KSP_Logs.zip

And here is a Google Doc on what mods I use:

https://docs.google.com/document/d/1dwITtAoPPUeFB5tnT_q3rAPEGE1iTiLc-8p9zfh6j_M/edit?usp=sharing

I figured it was this mod because when I looked in log files a lot of things kick up from NavBallTextureExport, so when I took that mod out it works fine. So I don't know if its a mod conflict or just this mod needs updated.

Its related to that mod in that thread, I take it out and its fine. Some people say in EVE take out the citylights.dll and it works fine.

Share this post


Link to post
Share on other sites

That started happening because the city lights textures were TGA files. The problem goes away if you convert them to PNG.

Share this post


Link to post
Share on other sites
Does it look like this:

Its related to that mod in that thread, I take it out and its fine. Some people say in EVE take out the citylights.dll and it works fine.

I am already not using city lights, and EVE works fine on its own. This is what it looks like:

kySSi7Zl.jpg

- - - Updated - - -

That started happening because the city lights textures were TGA files. The problem goes away if you convert them to PNG.

Not using city lights, only clouds module. All the textures in BoulderCo and EVE folders are all PNG.

Share this post


Link to post
Share on other sites

I've got a feature request. Not sure if this a good time, what with the update and all, but I thought I'd throw it out there anyway.

Seasons via replacement of the grass textures used on kerbin. It would be set up so that the effect is opposite on the north and south hemispheres. I know there is no axial tilt in the game, but this is just to add some extra visual variety to the player during launches and low orbits. So the idea is to use a de-saturated white/gray version of the grass textures for winter, a slightly red shifted one for fall, and a slightly blue shifted one for spring. Then divide kerbin's orbit into four areas, and rotate the textures around the planet according to the position in the orbit.

I have created my own custom .cfg for RSS which maintains the stock system with added simulated axial tilt via relative inclination of the entire kolar system by 24 degrees. The means all the planets and moons gain an axial tilt of 24 degrees relative to the ecliptical in the ksp frame of reference. I maintained the maintained the variety in the inclinations of all the bodies, and the diversity in the LAN, while keeping a "stock" feel. This will add navigational, planning, and visual diversity from the stock experience, to coincide with the update to 1.0.2. It would be amazing to synchronize this effect with that RSS .cfg so that you actually have seasons...

  • Like 1

Share this post


Link to post
Share on other sites
I am already not using city lights, and EVE works fine on its own. This is what it looks like:

http://i.imgur.com/kySSi7Zl.jpg

- - - Updated - - -

Not using city lights, only clouds module. All the textures in BoulderCo and EVE folders are all PNG.

Log, please.

- - - Updated - - -

I've got a feature request. Not sure if this a good time, what with the update and all, but I thought I'd throw it out there anyway.

Seasons via replacement of the grass textures used on kerbin. It would be set up so that the effect is opposite on the north and south hemispheres. I know there is no axial tilt in the game, but this is just to add some extra visual variety to the player during launches and low orbits. So the idea is to use a de-saturated white/gray version of the grass textures for winter, a slightly red shifted one for fall, and a slightly blue shifted one for spring. Then divide kerbin's orbit into four areas, and rotate the textures around the planet according to the position in the orbit.

I have created my own custom .cfg for RSS which maintains the stock system with added simulated axial tilt via relative inclination of the entire kolar system by 24 degrees. The means all the planets and moons gain an axial tilt of 24 degrees relative to the ecliptical in the ksp frame of reference. I maintained the maintained the variety in the inclinations of all the bodies, and the diversity in the LAN, while keeping a "stock" feel. This will add navigational, planning, and visual diversity from the stock experience, to coincide with the update to 1.0.2. It would be amazing to synchronize this effect with that RSS .cfg so that you actually have seasons...

No, I cannot replace terrain texture like other textures. This requires messing with PQS database and there are specialised mods for this, like Kittopia and RSS, maybe Kopernicus.

Share this post


Link to post
Share on other sites
No, I cannot replace terrain texture like other textures. This requires messing with PQS database and there are specialised mods for this, like Kittopia and RSS, maybe Kopernicus.

Thank you, perhaps I'll ask in those mod's threads.

Share this post


Link to post
Share on other sites
I am already not using city lights, and EVE works fine on its own. This is what it looks like:

http://i.imgur.com/kySSi7Zl.jpg

- - - Updated - - -

Not using city lights, only clouds module. All the textures in BoulderCo and EVE folders are all PNG.

Yes, that's exactly what has been happening to me with Oinker's skybox. Now I've downloaded the newest TR and instead of gray thing I get original skybox. One of the texture files simply doesn't want to load.

Share this post


Link to post
Share on other sites

Ahh I just realized oinker's skybox textures are TGA's, not PNG's. Could that be the problem?

Share this post


Link to post
Share on other sites

Not sure if it's a bug or something I did wrong or what, but I'm having some anomalies with TR and ATM. I don't even know if it's TR or ATM that's causing the issues.

I had my suits all set up for Bob, Bill Val, and Jeb, as well as job specific suits for hired Kerbals. Everything was fine when I loaded up with ATM for the first time. Now, when I launch the game again some suit textures are reverted to something else. It's not every suit either. Bill's suit it fine, but every other main Kerbal's EVA suit gets reverted back to default including the helmet. All but one of the job suits displays this behavior as well. The one suit stays 100% correct.

By deleting the cached suit textures and letting ATM do its thing, everything comes out correct until I relaunch the game.

Share this post


Link to post
Share on other sites
Ahh I just realized oinker's skybox textures are TGA's, not PNG's. Could that be the problem?

Yes, TGAs are broken from KSP 0.24 or 0.25 on and sometimes don't load and sometimes crash KSP. Don't use them.

Share this post


Link to post
Share on other sites
Ahh I just realized oinker's skybox textures are TGA's, not PNG's. Could that be the problem?

You should be able to use KSP4DDS (on Windows) or img2dds (on Linux) to easily convert them to DDS format.

Share this post


Link to post
Share on other sites

I downloaded this mod but how can you replace the heads and space suits of the kerbals? I opened up the mod ingame but I didn't found any new options to customize. Do I have to download a texture pack?

Sorry for the noob question.

Share this post


Link to post
Share on other sites
I downloaded this mod but how can you replace the heads and space suits of the kerbals? I opened up the mod ingame but I didn't found any new options to customize. Do I have to download a texture pack?

Sorry for the noob question.

Yes, you need to download a texture pack - or several. There's a list in the OP.

Share this post


Link to post
Share on other sites

I'm looking for a suit pack that features a green suit.

Erm, not a completely green one, just green highlights. (Replacing the original red)

Share this post


Link to post
Share on other sites

Okay, everything seems working except the loading icon in the lower right corner is just a pink box atm. Do I have to download a new file for that?

Share this post


Link to post
Share on other sites
I'm looking for a suit pack that features a green suit.

Erm, not a completely green one, just green highlights. (Replacing the original red)

http://forum.kerbalspaceprogram.com/threads/60961-BROKEN-0-90-TextureReplacer-2-1-2-(20-12-2014)/page178?p=1642482#post1642482

OR

http://forum.kerbalspaceprogram.com/threads/60961-BROKEN-0-90-TextureReplacer-2-1-2-(20-12-2014)/page179?p=1643285#post1643285

Both are included in the list on the first page of the thread, by the way.

- - - Updated - - -

Okay, everything seems working except the loading icon in the lower right corner is just a pink box atm. Do I have to download a new file for that?

That can happen if you replace a sharedassets file. Are you using KSPRC, Better Atmospheres or one of Astronomer's packs? They include replacement sharedassets9.assets files for 0.90, but they won't work in 1.0. You'd need to restore the original sharedasset9.assets file to get it working again.

If you're not using one of those packs, then I'm not sure what could cause it.

Share this post


Link to post
Share on other sites

Is there a texture pack which includes female kerbal heads designed for the new female models of 1.0?

Share this post


Link to post
Share on other sites

I replaced the sharedassets9.assets from the downloaded game client and it's worked, thanks!

Share this post


Link to post
Share on other sites
I replaced the sharedassets9.assets from the downloaded game client and it's worked, thanks!

Cool. Feel free to hit that rep button :cool:

- - - Updated - - -

Is there a texture pack which includes female kerbal heads designed for the new female models of 1.0?

Not yet, I don't think. Scart91's working on one, though.

Share this post


Link to post
Share on other sites

Sir,

Sorry if this has been covered - but I need to ask - does your mod have a way to "reduce stock textures" in a way that increases frame-rate?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now