allista

[1.4.5] Throttle Controlled Avionics

Recommended Posts

when I select a mode(lets say land) how do I know if its on!

would it be possible that you change the yellow color to RED when that mode is active? its a very counter intuitive UI.

I love your mod! and your coding skills are epic but just saying you could improve on the UI a bit :)

 

edit: also nowhere here: https://github.com/qfeys/ThrottleControlledAvionics/blob/master/GameData/ThrottleControlledAvionics/INSTRUCTIONS.md does it say anything what 'engines unoptimized' is, what it does, and how I can fix it :)

 

FYI sorry to be such a pain in the ass but maybe it helps making the mod better and easier to understand for other people :D

Edited by BelgarionNL

Share this post


Link to post
Share on other sites
10 minutes ago, BelgarionNL said:

when I select a mode(lets say land) how do I know if its on!

would it be possible that you change the yellow color to RED when that mode is active? its a very counter intuitive UI.

I love your mod! and your coding skills are epic but just saying you could improve on the UI a bit :)

 

edit: also nowhere here: https://github.com/qfeys/ThrottleControlledAvionics/blob/master/GameData/ThrottleControlledAvionics/INSTRUCTIONS.md does it say anything what 'engines unoptimized' is, what it does, and how I can fix it :)

 

FYI sorry to be such a pain in the ass but maybe it helps making the mod better and easier to understand for other people :D

Well, yellow means "disabled" and "green" means enabled: https://github.com/qfeys/ThrottleControlledAvionics/blob/master/GameData/ThrottleControlledAvionics/INSTRUCTIONS.md#button-switches

"Engines unoptimized" status means that the optimization algorithm failed to solve the current torque request and put the engines into zero-torque state. And I wonder now what would be best: to add this explanation to the manual, or to remove this status completely, as it is indeed an internal state over which a user has no real control. The reason it's there is that this message may warn you against some maneuvering that your engine system cannot perform.

Share this post


Link to post
Share on other sites

well excrements now I get why I don't understand this. I don't see a difference between yellow and green... 

Share this post


Link to post
Share on other sites
Just now, BelgarionNL said:

well excrements now I get why I don't understand this. I don't see a difference between yellow and green... 

Oh boy! =^_^=

Then I just make the colors an option in the TCA.glob file for you to change :blush:

Share this post


Link to post
Share on other sites

sweet thx! I also see the colors defined on github so I could compile them but I'd prefer a ckan install :D

Share this post


Link to post
Share on other sites
2 minutes ago, BelgarionNL said:

sweet thx! I also see the colors defined on github so I could compile them but I'd prefer a ckan install :D

Are you using KSP-1.1 or 1.0.5 now?

Share this post


Link to post
Share on other sites
5 minutes ago, BelgarionNL said:

1.1 ofcourse :)

In any case, here's the dlls for both versions with red-green buttons instead of yellow-green ones :rolleyes:

https://www.dropbox.com/s/z0upmbp8wjgk8h3/TCA-red-green-buttons.zip?dl=0

Just as a quick fix. Rename the one for KSP-1.1 and replace the old one in the ThrottleControlledAvionics/Plugins folder.

Edited by allista

Share this post


Link to post
Share on other sites

ow yea this makes more sense :) thx! I am sure I will be able to use this properly now :D

Houston we got liftoff

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, allista said:

@N'Matale Nwakanzagolo

With the dedicated engine mode it looks like this. Although with it you will get all the trouble of balancing things by hand in Editor.

 


Awesome thanks, yeah that's what I was trying to do, but using just the thrust vectoring instead of RCS and keeping CoM by moving fuel around. I may try again eventually but for now I just made a fully balanced 4 engine "X Wing" that can only VTOL and it works much better lol. Insanely good mod, works perfectly, thanks heaps!

Share this post


Link to post
Share on other sites

When it says the RCS is automatic, does that mean you don't have to enable TCA for it to work? I want to use only the RCS balancing for rockets.

Thanks

Share this post


Link to post
Share on other sites
5 hours ago, PortableGoogle said:

When it says the RCS is automatic, does that mean you don't have to enable TCA for it to work? I want to use only the RCS balancing for rockets.

Thanks

No, if TCA is disabled it is completely inactive. If it's enabled and all autopilots are off (including VTOL Assist and Flight Stabilizer), two functions will work: RCS balancing and engine balancing. They cannot be switched on/off, but if you don't want the engine balancing you may set the engines to Manual mode. Then, only the RCS balancing is left.

Share this post


Link to post
Share on other sites

I know this has probably ask but is it possible to change your landing speed. 400mm/s is really too slow

Share this post


Link to post
Share on other sites
2 hours ago, stali79 said:

I know this has probably ask but is it possible to change your landing speed. 400mm/s is really too slow

400mm/s = 4m/s = 14.4km/h, is that really too slow for vertical landing? O_O

There is a way to globally increase the maximum allowed vertical speed (in the TCA.glob file), but not the current speed, which is calculated in real time depending on many factors and ship characteristics. If you want to land quicker, just use the Altitude Control manually: set the relative altitude way below zero, descend, then set it to zero at some point to land softly.

Share this post


Link to post
Share on other sites
9 hours ago, pixelstuffs said:

How do you control horizontal speed while in vtol mode? The engines on mine cut out.

First, I'll try to mimic the verbosity and informativity of your question, by answering:

With keyboard, of course! Mine don't.

Then you take your time and try to reformulate the question, including in it all the information you can, so that I could have a chance to really help you, which I what to do.

And by the gods, people, you're forcing me to follow other developers and add explicit rules for getting help here. You know, all these "No logs -- no help!", etc. ;.;

Share this post


Link to post
Share on other sites

What is the best way to maximize thrust while retaining attitude control with throttle? Setting engines to "main engine", turning OFF vertical speed control and enabling T-SAS+Killrot still causes throttle to jump around wildly between about 40% and 100% several times a second.

Is it possible to keep engines at 100% and only reduce throttle at some of the engines if attitude adjustment is needed?

Share this post


Link to post
Share on other sites
2 hours ago, Corovaneer said:

What is the best way to maximize thrust while retaining attitude control with throttle? Setting engines to "main engine", turning OFF vertical speed control and enabling T-SAS+Killrot still causes throttle to jump around wildly between about 40% and 100% several times a second.

Is it possible to keep engines at 100% and only reduce throttle at some of the engines if attitude adjustment is needed?

What you're asking -- to hold engines at ~100% and only decrease thrust on user input -- is the intended behaviour of Main engines. It should work like that. If it doesn't, there's either a bug in TCA, or some unaccounted peculiarities of ship construction. Could you post some screenshots of the ship and of what happens? Or a craft file (if it's stock).

EDIT: What happens if you disable T-SAS and enable stock SAS? Or if you disable any stabilization?

Edited by allista

Share this post


Link to post
Share on other sites

This is awesome but was wondering if I may get some help please? :)

 

here is my ship

E6NGNdI.jpg

If I set a way point and press go to it does not move.

 

If I use the default KSP Rocket power thing it all works as expected

 

Thanks in advance :)

 

 

Edited by stk2008

Share this post


Link to post
Share on other sites
2 hours ago, stk2008 said:

This is awesome but was wondering if I may get some help please? :)

If I set a way point and press go to it does not move.

If I use the default KSP Rocket power thing it all works as expected

Thanks in advance :)

It is already flying/hovering and just won't go to a waypoint, or are you trying to start from the ground? If so, are your engines enabled in the active profile?

Share this post


Link to post
Share on other sites

Hi thanks for replying.

Yep i start engines up and set it to hover above ground which works but compared to using the stock vtol mine is not working right at all.

It wont go to waypoints etc.

I shall do more testing tomorrow with more detail as im off pc now.

Any way thanks for replying :)

Share this post


Link to post
Share on other sites

TCA v3.1.0 for KSP 1.0.5 (2016.04.30)

AND

TCA v3.1.0-KSP-1.1.2 for KSP 1.1.2 (2016.04.30)

ChangeLog:

Spoiler
  • Added bearing controls to main GUI and keyboard. Works independently of CruiseControl, e.g. you may set the bearing in Stop or Level mode.
  • Added UnBalanced engine mode which is a mix of Main and Manual: like Main it responses to altitude/vert.velocity controls, but like Manual it is not used for controlled torque generation. Like Manual engine it may be balanced with other engines in Main, Maneuver or Balanced modes. The main use: to make single-engine balanced-by-design VTOLs and rocket landers.
  • Added configurable button colors. See the top of the TCA.glob file for details.
  • Settings in TCA.glob could (and should) now be overwritten in GameData/ThrottleControlledAvionics/TCA.user file. Read the manual for details.
Edited by allista
  • Like 1

Share this post


Link to post
Share on other sites

Damn that was fast gonna grab this when i get home for sure.

So many mod makers update there mods so fast damn we are so lucky.

Respect to all ksp contributers your are awesome

Share this post


Link to post
Share on other sites

Hey, I'm having some trouble with the toolbar. The toolbar only shows the manual no matter what combination of engines/capsules I have. I've tried normal and 64 bit and made sure I have the 1.1.2 version. I'm wondering if any of the mods I have are screwing something around.

Mods:

MJ2, All near future, DmagicOrbitalScience, Kerbal joint re-inforcement, Pilot assistant, KAS

Edit - None of the capsules or control units are showing that they have TCA. Even after re-installing and having no other mods.

Edited by novahike999

Share this post


Link to post
Share on other sites

Hi,

 

The 1.12 patch still makes the mk 1 cockpit slide through the rocket, downwards, on the launchpad.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now