allista

[1.8-1.9] Throttle Controlled Avionics

Recommended Posts

7 hours ago, ChrisXDization said:

What do I need to disable to get only the basic thrust balance? Without any Autopilots? 

By default only the VTOL Assist and Flight Stabilizer autopilots are active; you can disable them in "advanced" pane. After that the only thing left is engine/RCS balancing. And if you have used the vertical speed slider, you need to set it to the maximum to turn off.

Share this post


Link to post
Share on other sites
15 hours ago, DeepSlayLP said:

http://imgur.com/m4tkA6f

That is the craft. It has two vtol engines at the back of the main fuselage and two on the wings one one each also more to the center of the main fuselage. At the back are three stock engines used to balance the craft.

Nothing seems wrong to me with the craft, and the behaviour you've described does not make sense :confused:

Does TCA lower engine thrust limits at 105m, or something else happens? To what extent does the craft descents from 105m? Does it stop and hover or lands/crashes?

I'm sorry, but you have to describe the situation much more verbosely, or make a video of it. Otherwise I just have no clue as to what happens.

Share this post


Link to post
Share on other sites

Well, Its a Shuttle, either it starts vertically, and doesnt steer at all (actually MechJeb 2 is steering, Ascent Autopilot.) or it begins to Hover and eventually crashes because it flips upside down..

Share this post


Link to post
Share on other sites
8 hours ago, allista said:

Nothing seems wrong to me with the craft, and the behaviour you've described does not make sense :confused:

Does TCA lower engine thrust limits at 105m, or something else happens? To what extent does the craft descents from 105m? Does it stop and hover or lands/crashes?

I'm sorry, but you have to describe the situation much more verbosely, or make a video of it. Otherwise I just have no clue as to what happens.

The plane lowers the thrust to almost zero so roughly 2-5 % and it just crashes into the ground. I will also provide a video in a few days.

-Jag

Share this post


Link to post
Share on other sites

Tried to make pentacopter from USI parts (Honeybadger + radial turbines), seems like this plugin bad at stabilizing with engines that don't change their thrust instantly (moving them higher makes job easier, but still it stabilizes slowly). How can I make it to not try to stabilize with engines and use just reaction wheel(s)?

Share this post


Link to post
Share on other sites
31 minutes ago, TAImatem said:

Tried to make pentacopter from USI parts (Honeybadger + radial turbines), seems like this plugin bad at stabilizing with engines that don't change their thrust instantly (moving them higher makes job easier, but still it stabilizes slowly). How can I make it to not try to stabilize with engines and use just reaction wheel(s)?

I figure you're trying to fly it manually; then set your lifting engines to Balanced Thrust mode. And while they're in Main mode you may wish to try the waypoints navigation to see how TCA really copes with such engines.

 

@Logan.Darklighter, is that what you were asking? :wink:

Also: do you see the descriptions of the control widgets in the video? Because I don't :confused:

Edited by allista

Share this post


Link to post
Share on other sites

Well, with these videos you've convinced me to give this a try.

Since I'm not physically sitting in the craft, myself, things tend to get pear shaped pretty quickly when I try to VTOL.

Share this post


Link to post
Share on other sites

I was wondering if you can use this to only balance engine thrust for a classic space shuttle launch with boosters etc. and have mechjeb do the ascend?

I tried just enabling it but then It will force it to say vertical.

 

basically this: (but updated and all in 1 awesome mod made by you )

 

Edited by BelgarionNL

Share this post


Link to post
Share on other sites

 

21 minutes ago, BelgarionNL said:

 

 

Okay, but i really want to automate launches, so i need TCA, because it controlls the engines in real time..

Share this post


Link to post
Share on other sites
5 hours ago, allista said:

I figure you're trying to fly it manually; then set your lifting engines to Balanced Thrust mode. And while they're in Main mode you may wish to try the waypoints navigation to see how TCA really copes with such engines.

Tried it and indeed it works as miracle, thanks :)

I think you should put it into Q&A/Manual, though

Edited by TAImatem

Share this post


Link to post
Share on other sites

Hi guys! I downloaded TCA using CKAN plugin, with all its recommendations; i watched the videos, read the manual. I, however, still can't use TCA. Whenever i click on the TCA sign, just the manual appears on the screen. I'm using the latest KSP, 1.1. in case you may ask.

Need suggestion. Thanks in advance!

Share this post


Link to post
Share on other sites
10 hours ago, Burak said:

Hi guys! I downloaded TCA using CKAN plugin, with all its recommendations; i watched the videos, read the manual. I, however, still can't use TCA. Whenever i click on the TCA sign, just the manual appears on the screen. I'm using the latest KSP, 1.1. in case you may ask.

Need suggestion. Thanks in advance!

1) is ModuleManager installed and working?

2) if it does not work in Career but does in Sandbox, you haven't purchased the TCA Subsystem in R&D.

3) otherwise, publish the output_log.txt (Player.log on Linux) that is generated after you launch the game and observe the problem.

Share this post


Link to post
Share on other sites
18 minutes ago, allista said:

1) is ModuleManager installed and working?

2) if it does not work in Career but does in Sandbox, you haven't purchased the TCA Subsystem in R&D.

3) otherwise, publish the output_log.txt (Player.log on Linux) that is generated after you launch the game and observe the problem.

I replaced my old module manager with the up-to-date one, everything work better now. Thanks! I guess i'm going to blame CKAN for this inconvenience .:(

Share this post


Link to post
Share on other sites
17 hours ago, BelgarionNL said:

I was wondering if you can use this to only balance engine thrust for a classic space shuttle launch with boosters etc. and have mechjeb do the ascend?

I tried just enabling it but then It will force it to say vertical.

basically this: (but updated and all in 1 awesome mod made by you )

 

17 hours ago, Chri_XD_XD_XD said:

Okay, but i really want to automate launches, so i need TCA, because it controlls the engines in real time..

Frankly, I don't see a problem here :cool:

 

 

Share this post


Link to post
Share on other sites

I still catch myself trying to grab onto people's videos (and photos) and trying to rotate them...

Share this post


Link to post
Share on other sites
25 minutes ago, Mahnarch said:

I still catch myself trying to grab onto people's videos (and photos) and trying to rotate them...

Same thing, every time! :D

Share this post


Link to post
Share on other sites

I really have no idea what I'm doing wrong but every time I try to VTO TCA just limits the throttle to zero and the craft sits there doing nothing. I've unlocked VTOL module long ago in R&D and I've tried just enabling, level mode, hover mode, kill rotation, none of it's working for me :(. I've got my lifting engine set to balanced thrust and I can VTO the craft manually but VL is another story so I was really looking forward to using this mod. I've read the documentation and couldn't find any answers and as far as I could tell I was doing everything correct. Any help would be really appreciated, looks like an awesome mod, I hope I'm just doing something wrong.

Edit - Tried it with an older 4 engine "hovercraft" I made and it worked, I guess it just doesn't like single engine vtol.

Edited by N'Matale Nwakanzagolo
More info

Share this post


Link to post
Share on other sites
3 hours ago, N'Matale Nwakanzagolo said:

I really have no idea what I'm doing wrong but every time I try to VTO TCA just limits the throttle to zero and the craft sits there doing nothing. I've unlocked VTOL module long ago in R&D and I've tried just enabling, level mode, hover mode, kill rotation, none of it's working for me :(. I've got my lifting engine set to balanced thrust and I can VTO the craft manually but VL is another story so I was really looking forward to using this mod. I've read the documentation and couldn't find any answers and as far as I could tell I was doing everything correct. Any help would be really appreciated, looks like an awesome mod, I hope I'm just doing something wrong.

Edit - Tried it with an older 4 engine "hovercraft" I made and it worked, I guess it just doesn't like single engine vtol.

Yup, can confirm, had the same frustration. It's just how the mod works, it balances thrust so you need multiple engines, even just a small secondary can work. 

Share this post


Link to post
Share on other sites
5 hours ago, N'Matale Nwakanzagolo said:

I really have no idea what I'm doing wrong but every time I try to VTO TCA just limits the throttle to zero and the craft sits there doing nothing. I've unlocked VTOL module long ago in R&D and I've tried just enabling, level mode, hover mode, kill rotation, none of it's working for me :(. I've got my lifting engine set to balanced thrust and I can VTO the craft manually but VL is another story so I was really looking forward to using this mod. I've read the documentation and couldn't find any answers and as far as I could tell I was doing everything correct. Any help would be really appreciated, looks like an awesome mod, I hope I'm just doing something wrong.

Edit - Tried it with an older 4 engine "hovercraft" I made and it worked, I guess it just doesn't like single engine vtol.

 

1 hour ago, CatastrophicFailure said:

Yup, can confirm, had the same frustration. It's just how the mod works, it balances thrust so you need multiple engines, even just a small secondary can work. 

In fact, as it is apparently a popular problem, I will try to figure something out to handle this scenario. Maybe another engine mode that explicitly prevents balancing but allows v-speed/altitude control?

Share this post


Link to post
Share on other sites
6 hours ago, allista said:

In fact, as it is apparently a popular problem, I will try to figure something out to handle this scenario. Maybe another engine mode that explicitly prevents balancing but allows v-speed/altitude control?

Sounds like it would be useful, also for single-engine landers & such, even something as simple as just attitude control. The mini-VTOL I was farting around with, just keeping it stable was the biggest challenge.

Share this post


Link to post
Share on other sites
18 minutes ago, CatastrophicFailure said:

Sounds like it would be useful, also for single-engine landers & such, even something as simple as just attitude control. The mini-VTOL I was farting around with, just keeping it stable was the biggest challenge.

@N'Matale Nwakanzagolo

With the dedicated engine mode it looks like this. Although with it you will get all the trouble of balancing things by hand in Editor.

 

Share this post


Link to post
Share on other sites

I haven't tried out the new version yet, but is there a way to disable the tech tree requirements if I wanted to?

Share this post


Link to post
Share on other sites
19 minutes ago, smjjames said:

I haven't tried out the new version yet, but is there a way to disable the tech tree requirements if I wanted to?

Yep! At the top of TCA.glob set the IntegrateIntoCareer option to false.

Share this post


Link to post
Share on other sites
9 minutes ago, allista said:

Yep! At the top of TCA.glob set the IntegrateIntoCareer option to false.

Cool, thanks.

Also going to check out testing of it and stuff. :)

Multiple craft shouldn't cause lots of lag anymore.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.