Jump to content

[1.9-1.10] Throttle Controlled Avionics


Recommended Posts

I guess 1.4.5 broke TCA? Not sure if it's the toolbar or the UI that doesn't work.. or both. Works in the editor, broken in flight. This is in a game with only TCA and its dependencies.

Spoiler
[EXC 22:11:35.760] MissingMethodException: Method not found: 'UnityEngine.Texture2D.LoadImage'.
	ThrottleControlledAvionics.ControlTab.SetupTab (ThrottleControlledAvionics.TabInfo info)
	ThrottleControlledAvionics.TCAGui.create_fields ()
	ThrottleControlledAvionics.TCAGui.init ()
	ThrottleControlledAvionics.TCAGui+<init_on_load>d__62.MoveNext ()
	UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)
[EXC 22:11:35.767] MissingMethodException: Method not found: 'UnityEngine.Texture2D.LoadImage'.
	ThrottleControlledAvionics.ControlTab.SetupTab (ThrottleControlledAvionics.TabInfo info)
	ThrottleControlledAvionics.TCAGui.create_fields ()
	ThrottleControlledAvionics.TCAGui.init ()
	ThrottleControlledAvionics.TCAGui+<init_on_load>d__62.MoveNext ()
	UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)

 

 

Link to post
Share on other sites
  • 2 weeks later...

Hey, I have the issue that I can not press the TCA button in the toolbar while in "Flight mode" in Sandbox mode! Didn't came as far as I needed yet to test TCA in Career mode! But I can press the button and add things to the "Software" in the VAB for example. But I can't press it when I have my "vehicle on the runway". I know I have to check the line 'TCA Software installed' in the right mouseclick menu. Already deleted the 000_AT_Utils and ThrottleControlledAvionics folders and reinstalled them from a fresh download.. Didn't help I have no clue! Please help

The logfile

The mod list and KSP Version via AVC:

Spoiler

KSP: 1.4.5 (Win64) - Unity: 2017.1.3p1 - OS: Windows 10  (10.0.0) 64bit
000_AT_Utils - 1.5
ClickThroughBlocker - 0.1.6.7
Toolbar - 1.7.17.11
ToolbarControl - 0.1.6.13
Adjustable Mod Panel - 1.5
Astronomer's Visual Pack - 3.7.4
Aviation Lights - 4.0.5
B9 Part Switch - 2.3
B9 Aerospace Procedural Parts - 0.50
BD Animation Modules - 0.6.5.4
CritterCrawlerRetractingVectoringEngines - 1.3.3.1
Bluedog Design Bureau - 1.1.6
Chatterer Extended - 0.6.2
Chatterer - 0.9.95.2110
Community Category Kit - 3.0
Community Resource Pack - 0.10
CommunityTechTree - 3.3.2
ConfigurableContainers - 2.4.3.1
Contract Configurator - 1.25
Contract Pack: RemoteTech - 2.1.4
Crew Light - 1.15
CriticalTemperatureGauge - 1.4.5
DecouplerShroud - 0.5
DSCore - 3.0.2
ThorTech - 0.9.6.3
AGExt - 2.3.3.6
DistantObjectEnhancement - 1.9.1
DMagic Orbital Science - 1.3.0.12
DynamicBatteryStorage - 1.3.2
EditorExtensionsRedux - 3.3.19.5
Environmental Visual Enhancements - 1.4.2.2
Ferram Aerospace Research - 0.15.9.3
Firespitter - 7.9
FMRS (Flight Manager For Reusable Stages) - 1.2.7.2
FShangarExtender - 3.5.3.2
FuseBoxContinued - 0.1.16.5
HideEmptyTechTreeNodes - 1.0.4
Interstellar Fuel Switch - 3.6.4.1
JanitorsCloset - 0.3.4.1
RasterPropMonitor - 0.30.5
Kerbal Engineer Redux - 1.1.5.3
Kerbal Foundries - 2.2.6.16
KerbalKonstructs - 1.4.5.4
KerbinSide-Complete - 1.4.5
<b><color=#CA7B3C>Kopernicus</color></b> - 1.4.5.4
KSP-AVC Plugin - 1.2.0.2
KSPWheel - 0.11.9.27
LoadingScreenManager - 1.2.5
Modular Rocket Systems - 1.13.2
ModularFlightIntegrator - 1.2.5
NavBallTextureChanger - 1.6
Docking Port Alignment Indicator - 6.8.2
NearFutureElectrical - 0.10.2
NearFutureProps - 0.3.3
NearFuturePropulsion - 1.0.2
NearFutureSolar - 0.8.12
NearFutureSpacecraft - 0.7.10
PatchManager - 0.0.16
PlanetShine - 0.2.6.1
Precise Maneuver - 2.4.1
Procedural Parts - 1.3.15
RCS Build Aid - 0.9.7.2
Recovery Controller - 0.0.3.2
ReentryParticleEffect - 1.3
RemoteTech - 1.8.12
ResearchBodies - 1.9.7
<b><color=#9B59B6>Sigma Replacements: SkyBox</color></b> - 0.2.2
SmartActuation - 1.1.1
Stock Visual Terrain - 2.1.4.1
TAC Fuel Balancer - 2.20
TarsierSpaceTechnology - 7.3
ThrottleControlledAvionics - 3.5
Tracking Station Evolved - 1.0.3
Trajectories - 2.2.1
Kerbal Alarm Clock - 3.9.1
Transfer Window Planner - 1.6.3
TweakScale - 2.3.12
Waypoint Manager - 2.7.2
[x] Science! - 5.16

 

Link to post
Share on other sites
On 8/25/2018 at 6:59 PM, Trigant said:

Hey, I have the issue that I can not press the TCA button in the toolbar while in "Flight mode" in Sandbox mode! Didn't came as far as I needed yet to test TCA in Career mode! But I can press the button and add things to the "Software" in the VAB for example. But I can't press it when I have my "vehicle on the runway". I know I have to check the line 'TCA Software installed' in the right mouseclick menu. Already deleted the 000_AT_Utils and ThrottleControlledAvionics folders and reinstalled them from a fresh download.. Didn't help I have no clue! Please help

The logfile

The mod list and KSP Version via AVC:

  Hide contents

KSP: 1.4.5 (Win64) - Unity: 2017.1.3p1 - OS: Windows 10  (10.0.0) 64bit
000_AT_Utils - 1.5
ClickThroughBlocker - 0.1.6.7
Toolbar - 1.7.17.11
ToolbarControl - 0.1.6.13
Adjustable Mod Panel - 1.5
Astronomer's Visual Pack - 3.7.4
Aviation Lights - 4.0.5
B9 Part Switch - 2.3
B9 Aerospace Procedural Parts - 0.50
BD Animation Modules - 0.6.5.4
CritterCrawlerRetractingVectoringEngines - 1.3.3.1
Bluedog Design Bureau - 1.1.6
Chatterer Extended - 0.6.2
Chatterer - 0.9.95.2110
Community Category Kit - 3.0
Community Resource Pack - 0.10
CommunityTechTree - 3.3.2
ConfigurableContainers - 2.4.3.1
Contract Configurator - 1.25
Contract Pack: RemoteTech - 2.1.4
Crew Light - 1.15
CriticalTemperatureGauge - 1.4.5
DecouplerShroud - 0.5
DSCore - 3.0.2
ThorTech - 0.9.6.3
AGExt - 2.3.3.6
DistantObjectEnhancement - 1.9.1
DMagic Orbital Science - 1.3.0.12
DynamicBatteryStorage - 1.3.2
EditorExtensionsRedux - 3.3.19.5
Environmental Visual Enhancements - 1.4.2.2
Ferram Aerospace Research - 0.15.9.3
Firespitter - 7.9
FMRS (Flight Manager For Reusable Stages) - 1.2.7.2
FShangarExtender - 3.5.3.2
FuseBoxContinued - 0.1.16.5
HideEmptyTechTreeNodes - 1.0.4
Interstellar Fuel Switch - 3.6.4.1
JanitorsCloset - 0.3.4.1
RasterPropMonitor - 0.30.5
Kerbal Engineer Redux - 1.1.5.3
Kerbal Foundries - 2.2.6.16
KerbalKonstructs - 1.4.5.4
KerbinSide-Complete - 1.4.5
<b><color=#CA7B3C>Kopernicus</color></b> - 1.4.5.4
KSP-AVC Plugin - 1.2.0.2
KSPWheel - 0.11.9.27
LoadingScreenManager - 1.2.5
Modular Rocket Systems - 1.13.2
ModularFlightIntegrator - 1.2.5
NavBallTextureChanger - 1.6
Docking Port Alignment Indicator - 6.8.2
NearFutureElectrical - 0.10.2
NearFutureProps - 0.3.3
NearFuturePropulsion - 1.0.2
NearFutureSolar - 0.8.12
NearFutureSpacecraft - 0.7.10
PatchManager - 0.0.16
PlanetShine - 0.2.6.1
Precise Maneuver - 2.4.1
Procedural Parts - 1.3.15
RCS Build Aid - 0.9.7.2
Recovery Controller - 0.0.3.2
ReentryParticleEffect - 1.3
RemoteTech - 1.8.12
ResearchBodies - 1.9.7
<b><color=#9B59B6>Sigma Replacements: SkyBox</color></b> - 0.2.2
SmartActuation - 1.1.1
Stock Visual Terrain - 2.1.4.1
TAC Fuel Balancer - 2.20
TarsierSpaceTechnology - 7.3
ThrottleControlledAvionics - 3.5
Tracking Station Evolved - 1.0.3
Trajectories - 2.2.1
Kerbal Alarm Clock - 3.9.1
Transfer Window Planner - 1.6.3
TweakScale - 2.3.12
Waypoint Manager - 2.7.2
[x] Science! - 5.16

 

you're sure you have the latest TCA installed?  I suppose it might be a mod conflict although I don't see any on your list that I'd think would conflict.. I have most of those (and quite a few more) myself.  I'm not able to reproduce your problem.... oh wait.. waaait... stock visual terrain.  It changes the height maps for Kerbin and may make TCA think you are underground... I vaguely recall having a similar problem with SVT.

Link to post
Share on other sites
6 hours ago, ss8913 said:

you're sure you have the latest TCA installed?  I suppose it might be a mod conflict although I don't see any on your list that I'd think would conflict.. I have most of those (and quite a few more) myself.  I'm not able to reproduce your problem.... oh wait.. waaait... stock visual terrain.  It changes the height maps for Kerbin and may make TCA think you are underground... I vaguely recall having a similar problem with SVT.

Ok thanks for the hint! I'll try sorting this one out and call back!

Edit: Nope that's not the solution. Still a green TCA Button that's not clickable, while having a cockpit with TCA ACTIVE: True. Do I have to use the AT_Utils version provided by the zip file or should I install the newest one of GITHub? I think there's a 1.6 version sitting, while your download offers a 1.5 variant. Could the fact that there was once the 1.6 version installed before killed the funcionality of TCA afterall? I admit, I tried the 1.6 version. As this wasn't helping aswell I deleted AT_Utils and TCA and reinstalled the untouched version of TCA found in the OP (and wrote my first support request here)

Edited by Trigant
Link to post
Share on other sites
8 hours ago, Trigant said:

your download offers a 1.5 variant

I think you're installing an out-of-date version of TCA; I've only ever installed it from the current download and my version of AT_Utils is 1.6, nothing else I have installed uses it so nothing else would have updated it. ETA: Confirmed, the current version of the download installs AT_Utils 1.6, so if you're seeing 1.5 then you're not installing the latest version of TCA.

Silly question: you mention choosing the various software in the Editor scene, but are you enabling TCA there as well? Command pods can show TCA active, but if it's not been switched on before launch then you can't use it to control anything on the vehicle anyway.

Edited by JH4C
double-checking
Link to post
Share on other sites
6 hours ago, JH4C said:

I think you're installing an out-of-date version of TCA; I've only ever installed it from the current download and my version of AT_Utils is 1.6, nothing else I have installed uses it so nothing else would have updated it. ETA: Confirmed, the current version of the download installs AT_Utils 1.6, so if you're seeing 1.5 then you're not installing the latest version of TCA.

It was this one tagged with latest release

Quote

Silly question: you mention choosing the various software in the Editor scene, but are you enabling TCA there as well? Command pods can show TCA active, but if it's not been switched on before launch then you can't use it to control anything on the vehicle anyway.

Take a look for yourself. Maybe I'm blind or something:

n0q9f2Z.jpg

ZHqahNU.jpg

Link to post
Share on other sites
5 hours ago, Trigant said:

It was this one tagged with latest release

The latest version is 3.5.2.1. Use the SpaceDock link. (It's also in the GitHub link but it's hidden, in the block above the 3.5.0 link for some reason.)

Edited by JH4C
Link to post
Share on other sites
4 hours ago, JH4C said:

The latest version is 3.5.2.1. Use the SpaceDock link. (It's also in the GitHub link but it's hidden, in the block above the 3.5.0 link for some reason.)

This helped! Now it's working ( I think ) But it seems to not being able to control the ship and keep it stable. When I press for example 100m in the upper left corner at alt(m), then it pushes the ship with 100% thrust rotating aorund its own axis in the ground. I am pretty sure, it's the pilot's fault not the modder's, but maybe you can help?

Here a screenshotA8sniw4.jpg

BTW if the GitHub version could've been the issue, you could've easliy prevented this with a little text like "Newest version only in SpaceDock" or something like that :/

Link to post
Share on other sites

Yay! I'm glad you're having better luck with it now. Unfortunately, you're having more luck than I ever have... While I can get the dialogues to appear, I've never once managed to get something to fly using this. I've kind of given up on being able to use VTOL for now; I was originally hoping it would help me avoid the horrors of trying to fly a proper landing, but I managed four successive grasslands/icecap landings and take-offs on the same flight yesterday, so my VTOL experiments are going on the back burner - no pun intended ;)

Link to post
Share on other sites
25 minutes ago, JH4C said:

Yay! I'm glad you're having better luck with it now. Unfortunately, you're having more luck than I ever have... While I can get the dialogues to appear, I've never once managed to get something to fly using this. I've kind of given up on being able to use VTOL for now; I was originally hoping it would help me avoid the horrors of trying to fly a proper landing, but I managed four successive grasslands/icecap landings and take-offs on the same flight yesterday, so my VTOL experiments are going on the back burner - no pun intended ;)

But, but... This was my only hope aswell as my intention to use this mod! You broke all my dreams right now ;-( how can I ever use a vtol ssto ship without any vtol help? :O

Link to post
Share on other sites

Some tips regarding VTOLs:

- in atmosphere, limit vertical speed up to 10 m/s. Even 10 m/s of vertical velocity can be too high on some crafts, aerodynamic forces can easy tip over your craft, engine thrust balancing may not be enough to keep your craft stable

- consider using kOS or similar autopilot. Simple script that use PIDs to control is more/less easy to create and you can learn a lot and have fun with those when creating your crafts. You may use it along with TCA, not necessary without TCA.

 

Link to post
Share on other sites
13 hours ago, kcs123 said:

Some tips regarding VTOLs:

- in atmosphere, limit vertical speed up to 10 m/s. Even 10 m/s of vertical velocity can be too high on some crafts, aerodynamic forces can easy tip over your craft, engine thrust balancing may not be enough to keep your craft stable

It doesn't matter, even 1 m/s destabilizes the aircraft till it crashes. TCA doesn't seem to care at all to balance VTOL out. Nothing like the videos in the OP! It would be great if allista could say a word about it!

Quote

- consider using kOS or similar autopilot. Simple script that use PIDs to control is more/less easy to create and you can learn a lot and have fun with those when creating your crafts. You may use it along with TCA, not necessary without TCA.

what means PIDs? Besides, please don't misunderstand me, but the fun in the game comes when something works, not how deep I have to dig myself into even more complex mods... Scripting is definitely something I don't call "fun"

Link to post
Share on other sites
13 hours ago, Trigant said:

It doesn't matter, even 1 m/s destabilizes the aircraft till it crashes. TCA doesn't seem to care at all to balance VTOL out. Nothing like the videos in the OP! It would be great if allista could say a word about it!

what means PIDs? Besides, please don't misunderstand me, but the fun in the game comes when something works, not how deep I have to dig myself into even more complex mods... Scripting is definitely something I don't call "fun"

You are more probably set engines in a wrong way, so it could not change properly thrust. Check out alistas videos, I'm pretty sure that at least one explains meaning and usage of additional TCA engine thrust options.

As for PIDs, it is thing used quite a lot in automatization. If you are not much for reading documentation of it, here is short video that explain it in easy way:

 

And here is link for wikipedia too, if you sometime find it interesting to read and learn more about it: https://en.wikipedia.org/wiki/PID_controller

For some people there is more than half of fun to learn new stuff along with playing this game, including scripts, real life math behind ti etc. But, yes not all folks around is for it, some just play the game and learn by trial and error. Everyone has it's own representation of fun, it is understandable if you just want "all in one" solution where you just click and everything "just work".

Link to post
Share on other sites

Of course discussing those problems over days here are a proof of not having the will to learn something new and the expectation to that excrements works right away! This is not help, this is making fun of me and others like me. BTW I didn't understand excrements in this video you psoted. Not my topic and that's fine. Not everybody has to be interested in higher mathematics, coding and such things!

And even when this kind of topic keeps being to complex for my simple being, the mod implies something very different! Being automatic, stabilizing ships with asymmetric engines, (first video in OP, yes I watched them!) even flying with it from point a over b to c, magically with a click of a button! Why should I learn after a video like that how to use scripting languages and what PIDs and are and I don't know what else you could come up with? It functions without them as long as we trust those vids!

Link to post
Share on other sites
On 8/29/2018 at 1:18 AM, Trigant said:

This helped! Now it's working ( I think ) But it seems to not being able to control the ship and keep it stable. When I press for example 100m in the upper left corner at alt(m), then it pushes the ship with 100% thrust rotating aorund its own axis in the ground. I am pretty sure, it's the pilot's fault not the modder's, but maybe you can help?

Here a screenshotA8sniw4.jpg

BTW if the GitHub version could've been the issue, you could've easliy prevented this with a little text like "Newest version only in SpaceDock" or something like that :/

What parts on there are even engines? I only see a downward pointing engine on the tail. TCA can't help if there's no way to adjust throttle to balance the engines. Show the TCA panel with the engine settings, in a VAB view with the thrust and CoM markers.

Link to post
Share on other sites
On 9/6/2018 at 8:25 PM, Johould said:

What parts on there are even engines? I only see a downward pointing engine on the tail. TCA can't help if there's no way to adjust throttle to balance the engines. Show the TCA panel with the engine settings, in a VAB view with the thrust and CoM markers.

In the first video the ship hasn't stabilized symmetric engines either and flies like a charm. Besides, I reworked this thing and built it with 98% stability according to TCA. But it still flips around itself and crashes afterwards when it hits the 100m mark (I filled in the alt(m) before). How come?

Link to post
Share on other sites
17 minutes ago, Trigant said:

In the first video the ship hasn't stabilized symmetric engines either and flies like a charm. Besides, I reworked this thing and built it with 98% stability according to TCA. But it still flips around itself and crashes afterwards when it hits the 100m mark (I filled in the alt(m) before). How come?

I'm a bit late, sorry.

But this 100m mark seems awfully familiar. Don't you have the Astronomer's Visual Pack installed by any chance, do you? There's a known incompatibility with this mod that causes a whole lot of wired issues.

That aside, what really matters for TCA to be able to balance the thrust is the number of distinct engine parts on different sides of the CoM. For example, that VTOL engine on your plane's tail have two nozzles, but it's still a single part; and TCA cannot (that's a technical limitation of KSP itself) control those nozzles separately. So if you have, say, two such engines -- one in front, one aft -- you actually have just a single lever with two points to apply force to. It's enough for 2D, but is unstable in 3D without additional torque providers for other axis.

So to have a stable VTOL craft you need at least three engine parts to have two axis (pitch and roll) controlled by thrust differential.

Edited by allista
Link to post
Share on other sites

Is it possible to give a big ship more TCA modules in flight by launching a ship with more modules enabled and physically attaching it to the other ship by docking or with KAS? It didn't seem to work.

4 hours ago, allista said:

It's enough for 2D, but is unstable in 3D without additional torque providers for other axis.

So to have a stable VTOL craft you need at least three engine parts to have two axis (pitch and roll) controlled by thrust differential.

Wouldn't it also work with two engines throttled to control pitch and enough reaction wheel torque to control roll? I've seen both axes controlled by thrust or both controlled by wheels, but I don't know if I've mixed it up like that.

Link to post
Share on other sites
11 hours ago, Johould said:

Is it possible to give a big ship more TCA modules in flight by launching a ship with more modules enabled and physically attaching it to the other ship by docking or with KAS? It didn't seem to work.

Wouldn't it also work with two engines throttled to control pitch and enough reaction wheel torque to control roll? I've seen both axes controlled by thrust or both controlled by wheels, but I don't know if I've mixed it up like that.

Hmm... that's an interesting scenario, I haven't thought about it. When ships are docked (or otherwise changed with respect to their part content) the active TCA instance is re-elected as the simply the instance of the first part in vessel.Parts list that has TCA installed. This unfortunately means that not only you can "switch" from the more advanced instance to less advanced, but, because the configuration is synchronized among TCA instances of the same vessel, the former may become "reprogrammed" by the latter. What we need is 1) a proper election mechanism that selects the "best" TCA available and 2) a way to retain configuration between docking/undocking.

Yea, that would work alright.

Link to post
Share on other sites
12 hours ago, allista said:

Hmm... that's an interesting scenario, I haven't thought about it. When ships are docked (or otherwise changed with respect to their part content) the active TCA instance is re-elected as the simply the instance of the first part in vessel.Parts list that has TCA installed. This unfortunately means that not only you can "switch" from the more advanced instance to less advanced, but, because the configuration is synchronized among TCA instances of the same vessel, the former may become "reprogrammed" by the latter. What we need is 1) a proper election mechanism that selects the "best" TCA available and 2) a way to retain configuration between docking/undocking.

Hmm, I hadn't thought that much about the difficulties. Now that you mention it, both parts have further complications. "best" might not be clear if different parts were have different subsets of the TCA modules installed. "retain configurations" would be especially tricky if that could include settings for engines across the docking port from the TCA part, maybe a ship is leaving a station and never coming back, or maybe it's an apollo-style lander+command module with the only TCA part in the lander and lots of settings meant for the combined ship.

It's hardly a complete answer, but maybe it would make it easier for us players to understand if some settings respected the new stock mechanism for preserving vessel names across docking.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...