raidernick

[1.6.x, 1.7.x] US Rockets (For use with US Probes - Old and New) - 5-22-19

Recommended Posts

I did most of the texturing on the first stage, no normal maps yet, bolts are missing and a few other details:

JjPO69C.png

Edited by raidernick

Share this post


Link to post
Share on other sites
24 minutes ago, raidernick said:

I did most of the texturing on the first stage, no normal maps yet, bolts are missing and a few other details:

JjPO69C.png

Do you do any sort of Normal/Specular mapping on your parts? I noticed an extreme improvement on the Titan tanks when I did so. And Titan IV really is that tan color? I will have to bring it back in BDB.

Share this post


Link to post
Share on other sites
27 minutes ago, CobaltWolf said:

Do you do any sort of Normal/Specular mapping on your parts? I noticed an extreme improvement on the Titan tanks when I did so. And Titan IV really is that tan color? I will have to bring it back in BDB.

On small parts I model everything, bolts and all. On very large parts like this I normal map most of the stuff as because of the size of the part, when you zoom out all the tiny details become less than 1 pixel and end up flickering and z-fighting, or you just don't see them. Using a normal map for the little details fixes that. Yes I use the KSP bumped specular shader for everything I do.

Yes the tanks are really that color. Actually, every titan iv tank, especially on the older ones had different colors. There was no uniform style for the tanks. It ranged from an orangeish-brass to a goldish color, to a greyish, to a more brownish. I am using one specific reference picture for this color scheme but almost every one you find will be different. I even cut out snips of the texture from the reference tanks to match these exactly in color. The texture itself I made myself from scratch because I couldn't find a good weathered, buffed brass texture I liked. Once I normal map and apply specular shader to it, it will "glow" like the original. I don't want it to reflect though the tanks did not have a gloss finish.

Edited by raidernick

Share this post


Link to post
Share on other sites
1 hour ago, CobaltWolf said:

Do you do any sort of Normal/Specular mapping on your parts? I noticed an extreme improvement on the Titan tanks when I did so. And Titan IV really is that tan color? I will have to bring it back in BDB.

There were never one single color scheme for the Titan IV tanks. Depending on what image you are looking at, they range from a metallic grey to a light brown-ish gold color. I went with this style for my tanks :)

Share this post


Link to post
Share on other sites

These are looking great so far! I never knew the Titan used that color scheme but its really neat! Do you think you might add a texture switch to put in different tanks? Just a thought.

Edited by Jall

Share this post


Link to post
Share on other sites
4 hours ago, Jall said:

These are looking great so far! I never knew the Titan used that color scheme but its really neat! Do you think you might add a texture switch to put in different tanks? Just a thought.

yes i had already planned on doing that

Share this post


Link to post
Share on other sites

Looks great! Can't wait to try it out!

Share this post


Link to post
Share on other sites

Titan-IVA with no upper stage and IUS upper stage done. I still need to make the centaur and the newer booster for the B version.

I also fixed the weird shader problems on the bottom of the booster, you can see this problem in the other pics above this post.

GbrzkHD.png

Share this post


Link to post
Share on other sites

Titan IV-B variant is done with the upgraded SRMU boosters. I still need to do the 2 centaur versions then I can release.

EWxDVhh.png

Share this post


Link to post
Share on other sites

051019launch7.jpgThose look really nice! You did a great job on them. Just tossing out an idea for the future: perhaps launch towers for the titans?

Edited by Jall

Share this post


Link to post
Share on other sites

Finished the Centaur-T. I will be testing everything and making minor adjustments and will have something to release in a day or two. I might also add some more fairing sizes before release, if I decide to do that it might delay the release by another couple days.

 

0II5RGA.png

Edited by raidernick

Share this post


Link to post
Share on other sites
14 hours ago, raidernick said:

Finished the Centaur-T. I will be testing everything and making minor adjustments and will have something to release in a day or two. I might also add some more fairing sizes before release, if I decide to do that it might delay the release by another couple days.

 

0II5RGA.png

looks really good! is it based off the real scale, i want to know so i can size my  Titan IV Pads for Real launch sites :)

Share this post


Link to post
Share on other sites
1 hour ago, Tristonwilson12 said:

looks really good! is it based off the real scale, i want to know so i can size my  Titan IV Pads for Real launch sites :)

All of my stuff is based 100% on the real life parts in size and proportion.....I'm not sure what you mean. It is scaled down to 80% size for stock but for RO it's all 1:1.

Share this post


Link to post
Share on other sites

This is awesome!! Can't wait to test it out!

Share this post


Link to post
Share on other sites
1 minute ago, Jall said:

This is awesome!! Can't wait to test it out!

I'd like to point out I didn't do extensive testing in stock since I only use RO. I just copied values from other stock packs with similar engines and stages like FASA and Launchers Pack. If you find anything that isn't balanced properly please make a PR on the git to fix it.

Share this post


Link to post
Share on other sites
3 hours ago, raidernick said:

All of my stuff is based 100% on the real life parts in size and proportion.....I'm not sure what you mean. It is scaled down to 80% size for stock but for RO it's all 1:1.

ok that answers my question, thanks!

Share this post


Link to post
Share on other sites

How did you install it to RO? Whenever I try, the Titan parts come up as non RO parts. I apologize in advance if it is a really easy fix I did not notice.

Edited by Jall

Share this post


Link to post
Share on other sites
5 minutes ago, Jall said:

How did you install it to RO? Whenever I try, the Titan parts come up as non RO parts. I apologize in advance if it is a really easy fix I did not notice.

well since RO hasn't been updated yet the configs aren't available in the current release obviously. If you want the most updated version of RO always download from here, which contains all the commits, even ones not yet officially released: https://github.com/KSP-RO/RealismOverhaul/archive/master.zip

Edited by raidernick

Share this post


Link to post
Share on other sites

Trying something new for a change. I decided to revisit launch clamps and make the tower and booster supports for the titan iv.

xMeOGhT.png

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.