Agathorn

[1.2.2] TestFlight - v1.8.0 - 01 May 2017 - Bring Flight Testing to KSP!

Recommended Posts

On 4/22/2016 at 1:27 PM, garwel said:

Ok, I ran the beta 2. Overall it appears ok, but the HUD in flight scene is just an small empty square window (I don't know what it was like in previous versions). It also looks like the Mk-55 "Thud" engine is not tracked by the mod.

The Flight HUD only shows parts that have failed, so if nothing has failed it indeed will just be a small empty square.  Its purpose is to be as unobtrusive as possible while still conveying the most important information (IE what has broken).

Share this post


Link to post
Share on other sites
9 hours ago, Agathorn said:

The Flight HUD only shows parts that have failed, so if nothing has failed it indeed will just be a small empty square.  Its purpose is to be as unobtrusive as possible while still conveying the most important information (IE what has broken).

Ok, thanks. It'd be better if it didn't appear at all until something breaks, though.

I've been playing with TestFlight for some time now and enjoyed it a lot. The only issue I encountered was that sometimes (and it only happens with batteries and some tanks) it displays a huge figure and "unlim" as MTBF. I guess it may be a rounding error for very small failure rates.

Oh, and I wanted to ask you something about the mod's configs. I wanted to allow test data collection to last much longer to achieve much better reliability. Did I edit it correctly (in Squad_Tanks.cfg, for example)?

    MODULE
    {
        name = TestFlightCore
        maxData = 100000
    }

...

    MODULE
    {
        reliabilityCurve
        {
            key = 0 0.00015
            key = 10000 0.00002
            key = 100000 0.000002
        }
        name = TestFlightReliability
    }

 

Share this post


Link to post
Share on other sites

Bug Report for: 1.5.4.4 for 1.0.5 (both my version and your's):

- TACLS has Life Support containers that contain 3x resources: Food/Water/Oxygen.

I have a small hexcan of lifesupport on a vessel with a failure to Water, it drained completely. I'm currently struggling with a re-entry, so I'm reloading the game a lot, but everytime I reload, it reapplies the failure to one of the remaining resources. Second load, the Food resource portion of the Life Support container went; next load, Oxygen. And the GUI says the containers are fine (there are other failures too that aren't being registers after loading, like to my heat shield). Below is the patch I made to apply it to the life support containers.

Did I screw something up in the patch or...?

Cheers.
 

Spoiler

 


@PART[*Life*Support*]:NEEDS[TestFlight]:AFTER[TestFlight]
{
@description ^= :(.)\s*$:$0 Test Flight Life Support Added!:
MODULE
{
	name = TestFlightInterop
}

MODULE
{
	name = TestFlightCore
	maxData = 100000
}

MODULE
{
	flightDataEngineerModifier = 0.25
	name = FlightDataRecorder_Resources
	flightDataMultiplier = 2.5
}

//---------------------RELIABILITY CURVE-----------------------//
MODULE
{
	reliabilityCurve
	{
			key = 0 0.0002
			key = 100000 0.00008
	}
	name = TestFlightReliability
}


//------------------------FAILURES--------------------//
MODULE
{
	REPAIR
	{
		canBeRepairedInFlight = True
		canBeRepairedOnSplashed = True
		canBeRepairedByRemote = True
		repairChance = 65
	}
	name = TestFlightFailure_ResourceLeak
	weight = 32
	resourceToLeak = random
	failureType = mechanical
	failureTitle = A LIFE SUPPORT CANISTER IS SLOWLY LEAKING!
	initialAmount = 2.5%t
	duRepair = 50
	duFail = 25
	perSecondAmount = 0.5%c
	severity = failure
}

MODULE
{
	REPAIR
	{
		canBeRepairedInFlight = True
		canBeRepairedOnSplashed = False
		canBeRepairedByRemote = False
		repairChance = 15
	}
	name = TestFlightFailure_ResourceLeak
	weight = 2
	resourceToLeak = random
	failureType = mechanical
	failureTitle = A LIFE SUPPORT CANISTER HAS CRACKED WIDE OPEN!
	initialAmount = 50%c
	duRepair = 500
	duFail = 350
	perSecondAmount = 2.5%c
	severity = major
}

MODULE
{
	failureTitle = A LIFE SUPPORT CANISTER HAS EXPLODED!
	name = TestFlightFailure_Explode
	weight = 2
	duFail = 500
	failureType = mechanical
	severity = major
}


}

 

 

 

 

 

Edited by Deimos Rast

Share this post


Link to post
Share on other sites

Found this mod a little while ago, and now with 1. 1 I'm going it a go... It's really cool,  and I love how I will have to build backup and redundancy into your designs...i turned the mod on while I had my first tourist in orbit and very quickly my one and only furl tank started leaking... Stranding my mission in orbit... So cool! 

 

Quick question... What other mods besides RO have build in config that u are aware of? 

 

Thx for the mod really enjoying it! 

Share this post


Link to post
Share on other sites

I note that with the stock config, the FL-100 fuel tanks always have a MTBF of 111.11 minutes, regardless of the data gathered on them. Is this just a shortcoming of the config file? Is there notes somewhere on how to write my own?

EDIT: found the wiki. More info there than I had, but less than I was hoping for. Is there a description somewhere on the reliability curve? what shape it is, what the keys mean?

EDIT: so I found that info also. Is there a minimum value for reliability/Failure Rate? I see why the tanks have that MTBF now, the config file basically defines their MTBF against data gathered as essentially a flat line.

Edited by blu3wolf

Share this post


Link to post
Share on other sites
6 hours ago, Commandodiamond said:

Where is the RO config for Testflight? I'm unable to find it.

In RO. :)

Share this post


Link to post
Share on other sites
On 12.5.2016 at 8:53 AM, NathanKell said:

In RO. :)

Speaking of RO configs, is there some problem with configs being applied? I've looked around in that folder, and apparently e.g. the RD253 has two configs for its two variants. But ingame it doesn't show the rated burn time or anything (ven part). Also, are these configs complete? I wonder if I could help in that regard, TestFlight looks super fun, but there are far to few engines with - visible - configs to support a playthrough.

Ingame i've found inconsistencies as well. E.g. the RD-1070/8 from SSTU and Ven Stock Revamp do show the symbols and share the tech level. But the KWO rocketry and SXT equivalents don't show the time rating. When hovering over they also don't show a name like 'RD-108_8D75PS', but the partname like 'KW2mengineGriffonG8D'.

EDIT: Wait, the RD253 shows time values, not in the part menu, but in context. But it still misses the rated burn time, also in context! Config got a burn time of 148/129 tho (engine got 3 variants tho)?? Also, it shows 2 different R&D options. Anyway, engine does not seem to fail at all.

EDIT2: Oh, seems like they need to be switched up to use an engine template? Doesn't seem like the culprit...

Edited by Temeter

Share this post


Link to post
Share on other sites

I'll check the RD-253 ingame. Regarding the RD-107/8, my SXT clones do work fine. As for the KW variant, it's possible it doesn't use the global engine configs yet...

Share this post


Link to post
Share on other sites
2 minutes ago, NathanKell said:

I'll check the RD-253 ingame. Regarding the RD-107/8, my SXT clones do work fine. As for the KW variant, it's possible it doesn't use the global engine configs yet...

Please do and tell your findings, might also help me figuring some stuff out. The more I know, the more I might do some stuff as well! Currently super motivated to dable in RO stuff.

Edited by Temeter

Share this post


Link to post
Share on other sites
21 hours ago, NathanKell said:

I'll check the RD-253 ingame.

Some configs are set up wrong, our outdated. The testflight context menu says the part is called RO-RD-252 (having the stock 111mbtf). While InsaneDruids Proton mod has a working RD-253, which shows 'RD-253' as its name and a working burn time.

There is a 275m config to stock RD253, that is missing in general config tho. Also no enginetype in the single moduleengines it seems.

Edited by Temeter

Share this post


Link to post
Share on other sites

FYI TestFlight is available for KSP 1.1.X, I just haven't yet updated this thread.  You can find TestFlight 1.6 on GitHub releases which does support KSP 1.1.2.  I'll get this thread updated...soon.  I hope.

Share this post


Link to post
Share on other sites

What do you think. Will there be integration of

1) Real Fuels dependend Tech levels

2) Procedural parts

3) more than engines?

Share this post


Link to post
Share on other sites

Newbie question: while it's obviously moot for engines, do other failure modes (e.g., fuel leaks) happen only while the vessel is loaded, or can they happen in the background?

Share this post


Link to post
Share on other sites

Hm, I currently got a bit of an issue where the Testflight symbols on the taskbar multiply (only the newest one works), also seeming to make the game a bit more laggy and take longer on transitions. Is that a known issue or some probably cause?

Gotta take a closer look, might be an issue with my installation, but if anyone can explain the behaviour, that's even better.

On 19.5.2016 at 7:06 AM, NathanKell said:

@Temeter aaaah, ok. Yeah, if the -275 or M doesn't use the global config system then a lot of that stuff will fail.

It's a late answer, but no, i've just been stupid and incorrectly installed it.^^

Edited by Temeter

Share this post


Link to post
Share on other sites

What would the general thoughts be on installing this mod on an already existing save? I'm not very far into the save as I've just finished setting up full relay coverage of the Kerbin system (I use RemoteTech) but I've setup this same relay network about 4 times already as I keep finding new mods that warrant a save restart and I'm just sort of getting bored of setting up the same relay network over and over again. If I were to install this into an already existing save what would happen to the satellites that are already in orbit? If anything?

EDIT: Alright I've restarted my save just in case and I'm also experiencing the TestFlight button duplication that @Temeter is experiencing, I'm also noticing that the game seems a bit more laggy as well, especially on transitions. (Note the right side of the image)

C33D63C40934C7D5C5CAC0FB7065C7C962856FE3

EDIT: Alright so I've found that going back to the last release (version 1.6.0.3) has fixed the issue with the duplicating buttons and lag on transitions, so I think something in the latest release is causing the issues.

On a side note I've been playing with this mod all day and while I love the idea of this mod... I've found that unfortunately I just can't do it. I'm the type of person who compulsively reverts/quickloads the moment something goes wrong, as it optimizes my time spent in-game and as you could imagine that type of playstyle mixed with a mod that intentionally makes things go wrong just doesn't really mix that well, as I end up just sort of getting nowhere. Earlier today I got stuck at a sort of roadblock while trying to setup my RemoteTech relay network, as all of my batteries were constantly blowing up due to the large timescales involved with keo-stationary orbits, along with a lack of part testing as I much prefer to go unmanned instead of manned. (Which meant I needed the relay network very early) So with all that being said, as much as I want to use this mod, I'll sadly have to drop it as it doesn't fit my playstyle.

I do love the concept of the mod though and hope to see it's continued development in the future. Who knows, maybe eventually my playstyle will change enough that I'll give this mod another go, but for now it's a no go. @Agathorn you're doing a great job with the mod, keep up the good work! :)

Edited by CoriW

Share this post


Link to post
Share on other sites
On 6/1/2016 at 0:28 PM, CoriW said:

What would the general thoughts be on installing this mod on an already existing save? I'm not very far into the save as I've just finished setting up full relay coverage of the Kerbin system (I use RemoteTech) but I've setup this same relay network about 4 times already as I keep finding new mods that warrant a save restart and I'm just sort of getting bored of setting up the same relay network over and over again. If I were to install this into an already existing save what would happen to the satellites that are already in orbit? If anything?

EDIT: Alright I've restarted my save just in case and I'm also experiencing the TestFlight button duplication that @Temeter is experiencing, I'm also noticing that the game seems a bit more laggy as well, especially on transitions. (Note the right side of the image)

C33D63C40934C7D5C5CAC0FB7065C7C962856FE3

EDIT: Alright so I've found that going back to the last release (version 1.6.0.3) has fixed the issue with the duplicating buttons and lag on transitions, so I think something in the latest release is causing the issues.

On a side note I've been playing with this mod all day and while I love the idea of this mod... I've found that unfortunately I just can't do it. I'm the type of person who compulsively reverts/quickloads the moment something goes wrong, as it optimizes my time spent in-game and as you could imagine that type of playstyle mixed with a mod that intentionally makes things go wrong just doesn't really mix that well, as I end up just sort of getting nowhere. Earlier today I got stuck at a sort of roadblock while trying to setup my RemoteTech relay network, as all of my batteries were constantly blowing up due to the large timescales involved with keo-stationary orbits, along with a lack of part testing as I much prefer to go unmanned instead of manned. (Which meant I needed the relay network very early) So with all that being said, as much as I want to use this mod, I'll sadly have to drop it as it doesn't fit my playstyle.

I do love the concept of the mod though and hope to see it's continued development in the future. Who knows, maybe eventually my playstyle will change enough that I'll give this mod another go, but for now it's a no go. @Agathorn you're doing a great job with the mod, keep up the good work! :)

A couple of things here I want to mention, even though you have decided not to use TestFlight at this time.

1) The toolbar duplication is only an issue in the latest DEV release, which is a beta release.  Use the latest full release (IE not beta) and you won't have that issue.

2) Based on the fact that you have batteries exploding, I am going to guess you are playing Stock.  Sadly the stock configs for TestFlight are pretty crap, and more sadly are going to remain there until a Stock player steps up and does better ones.  I play RealismOverhaul so that is where my attention ts focused.  Sorry you had this issue though!

Share this post


Link to post
Share on other sites
8 hours ago, Agathorn said:

A couple of things here I want to mention, even though you have decided not to use TestFlight at this time.

1) The toolbar duplication is only an issue in the latest DEV release, which is a beta release.  Use the latest full release (IE not beta) and you won't have that issue.

2) Based on the fact that you have batteries exploding, I am going to guess you are playing Stock.  Sadly the stock configs for TestFlight are pretty crap, and more sadly are going to remain there until a Stock player steps up and does better ones.  I play RealismOverhaul so that is where my attention ts focused.  Sorry you had this issue though!

On the note of the configs.. Am I right to assume that "TestFlight_Generic_Engines.cfg" is the TestFlight config file in the RealismOverhaul download? I'm willing to take a shot at re-doing the stock configs, but just looking at the aforementioned file in the RealismOverhaul download for reference I'm super confused. I can see what you mean by the stock ones being crap in comparison. What sort of behavior does the mod have in RealismOverhaul? Based on what you've said, I'm imagining that my issue of batteries exploding left and right is something that shouldn't really be happening; Or wouldn't happen in RealismOverhaul? How hard would you say it'd be to bring the Stock configs up to par?

EDIT: Also is the information provided HERE outdated, or am I just missing something? I really do want to try my hand at getting these configs into a better state, as I really would like to use the mod.

Edited by CoriW

Share this post


Link to post
Share on other sites

@CoriWthe specific .cfg file is only a patcher (formatting the reliability parameters into the TF modules). The TF parameters themselves are part of the global engine configurations. This is a custom RO setup since we need to patch a ton of different mods that provide the same engines.

RO currently has TF configs only for the engines (and even then only for some of them). Other parts are not yet supported.

Share this post


Link to post
Share on other sites
8 minutes ago, Phineas Freak said:

@CoriWthe specific .cfg file is only a patcher (formatting the reliability parameters into the TF modules). The TF parameters themselves are part of the global engine configurations. This is a custom RO setup since we need to patch a ton of different mods that provide the same engines.

RO currently has TF configs only for the engines (and even then only for some of them). Other parts are not yet supported.

Oh I see, that'd probably explain why it looks so confusing then. Does anyone know where I would find the patched version of the TestFlight config for RealismOverhaul? It would be immensely helpful so that I can see what exactly the differences are between the Stock and RealismOverhaul configs.

EDIT: I think the first thing I'll have to do is either remove or significantly alter the stock configs for fuel tanks... As I've already seen what kind of problems that can cause with my whole exploding batteries issue.

Edited by CoriW

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.