Jump to content

[0.90] Lazor System v35 (Dec 17)


Romfarer
 Share

Recommended Posts

What is the full path to Romfarer.dll?

Are you sure you don't have multiple Romfarer.dll in your gamedata folder?

What OS?

And please upload your output_log.txt file.

Path is C:/CLGames/KSP.22/GameData/Romfarer/romfarer.dll, just as it came in the download, I put it right in Gamedata after DL.

It's just the romfarer.dll and the sunbeam lazor plugins.

My OS is Windows 8 Pro

KSP .22, Lazor system V31

output log is here: http://pastebin.com/16uBm5fK

Edit: Apparently Google Chrome thinks that my output log is in Romanian. LOL

Edited by mrluckypants96
Link to comment
Share on other sites

If it help:

I've got the same problem.

Path: Users/standar/Downloads/KSP_osx-1/GameData/Romfarer

Os: mac OS X 10.8

I have the version 0.22 of KSP, the version 31 and I don't havr multiple Romfarer.dll in my game data folder.

Output log is here: http://pastebin.com/VYpQhXNp

(it well expire in one month, if you think you need more time just tell so and I will repost it).

EDIT: I don't know if it help, but here's what I did (in KSP) before posting the log:

-start the game(it help playing the game)

- making a craft consisting of the non-inline main lazor system and the inline cockpit

- "flying" it on the launchpad

- Activating the lazor system by using the GUI(the one you get by clicking on the part)

-Pitching down the cockpit(so it "fall" on the launchpad)

-Revert the mission(back to the VAB)

Edited by goldenpeach
Link to comment
Share on other sites

Of course!

The debris only have to be within loading distance(you cam change it in the settings of this mod).

PS: I don't recommend you to use the missiles: I once suot my (small) space station and it create more debris than it detroy.

I suggest you to use the sunbeam lazor: it's slower but more effective!

Link to comment
Share on other sites

That's exactly what happened in the real ASAT launches, too. :) Yeah, firing missiles at spaceborne objects does add a great amount of debris, both in KSP and IRL.

Link to comment
Share on other sites

I know you were talking about junks, but the events aren't going to change: a lot of debris will be created.

All depend on the size and the missile you use: if you shoot at some spend stage with nothing more than a fuel tank and some engines, you shouldn't have a lot of debris, even if I never checked that.

By the way, if you shoot at a debris consisting of a single part, you won't have any debris(but it would be more practical to use the lazor).

Link to comment
Share on other sites

I am using just the Lazor Docking Camera mod, problem I get is the Lazor GUI takes over other mod. It turns the Chatterer mod GUI into the one from Lazor. Another thing I notice when I am in KSP option menu, on top of screen in back there is a Lazor thin GUI up there. I can't click on it, it just appears there as if bugged out.

Link to comment
Share on other sites

Ah ok, will do i guess i'll look into this and start making the craft to house the laser. But i might just try a few missiles for the lawls.

The lazor isn't that heavy, you won't need to make a new craft.

PS: I can tell you that destroying a debris(or anything else) is very funny, even if it's still on Kerbin!

Link to comment
Share on other sites

The lazor isn't that heavy, you won't need to make a new craft.

PS: I can tell you that destroying a debris(or anything else) is very funny, even if it's still on Kerbin!

I know it will not be large, I just would like to make something Military like to fire the laser from that's all. I might even attempt to remake the M270 M.L.R.S. for a missile based launcher, but that would need dammed robotics for the launcher part to move up and side to side. But i think i can remake it after all it was what i worked on in the army heh.

Link to comment
Share on other sites

@mrluckypants96

I went through your output log and to me it looks like everything is in order. The plugin, textures etc seems to be loaded properly. It would help if you fired up a vessel with the mod parts on them though.

So im not quite sure what makes it break. I did notice some iddities on the log though. I can see that you are trying to load up a LazorBomb, perhaps from one of my older packages.


Romfarer/Parts/Romfarer_BombSmall/Romfarer_Bomb
PartLoader: Compiling Part 'Romfarer/Parts/Romfarer_BombSmall/part/Romfarer_BombSmall'
PartCompiler: Cannot find Part of type 'LazorBomb'

So i'd try removing the plugin and parts completely and copy them over again. And run the game an save a log where you try to launch a vessel with the lazor system module on it.

Link to comment
Share on other sites

Target location was not implemented, tbh im not quite sure why it's even in there ;-)

As for the bomb, let me explain how the lazor weapon system works.

The lazor missile S, M and L has the following partmodule in the config file. (below is the partmodule on the cruise missile "Romfarer_Missile_L")


MODULE
{
name = LazorControlT2
maxTorque = 2.5
maxThrust = 60
ejectionForce = 10
burnTime = 300
}

MODULE
{
name = LazorWarhead
blastRadius = 2500
destructionRadius = 1500
}

If you want a bomb, set max thrust to 1 and it will fall down just like a bomb.

If you want more bang for you buck, set blastRadius and destructionRadius to whatever you want. The numbers are in meter.

blastRadius is the range of the kinetic effect, the one that sends stuff flying.

destructionRadius is the range of the "nuke" effect, everything within this range will be vaporized.

Link to comment
Share on other sites

oh well thats okay i guess.. i mean ive been using it since i got ksp (.20) and the "target location".. has never done anything..! just figured id ask since its written on the first page and included in the lazor system, but i thats fine mechjeb can tell me which direction to go!(i use both)

i adore the mod otherwise, i use the resource transfer part the most...and those handy blue lazors :D

Link to comment
Share on other sites

This mod gave me another few thousand hours of KSP. It works fine so far, haven't had any bugs or glitches. Sometimes it lags my comp a bit, but that could be because of my settings and the amount of ships I have active. Thanks for this awesome mod!

Link to comment
Share on other sites

@mrluckypants96

I went through your output log and to me it looks like everything is in order. The plugin, textures etc seems to be loaded properly. It would help if you fired up a vessel with the mod parts on them though.

So im not quite sure what makes it break. I did notice some iddities on the log though. I can see that you are trying to load up a LazorBomb, perhaps from one of my older packages.


Romfarer/Parts/Romfarer_BombSmall/Romfarer_Bomb
PartLoader: Compiling Part 'Romfarer/Parts/Romfarer_BombSmall/part/Romfarer_BombSmall'
PartCompiler: Cannot find Part of type 'LazorBomb'

So i'd try removing the plugin and parts completely and copy them over again. And run the game an save a log where you try to launch a vessel with the lazor system module on it.

Alright, fresh DL, it worked, I don't know why the old one didn't work, I didn't do anything different. *sigh*

Link to comment
Share on other sites

I can't even get it to show up in the VAB. I tried every folder and it won't work. Can someone help me?

Just copy the GameData folder from the zip file into your KSP directory and overwrite.

And if you are trying some of my other mods, they all require Lazor System installed.

Link to comment
Share on other sites

@Romfarer: Can we get a version of the docking cam that has the same high-def, full-colour display as the camera module? The grainy, low-res, low-contrast greyscale image we current;y get certainly looks authentic, but it's bloody hard to see your target in anything but ideal lighting conditions.

Link to comment
Share on other sites

Okay, what am I missing about the Red Lazor system? I had just taken off with my spaceplane, turned on the Lazor system to control attitude and bearing. I had set my bearing (heading) for 90 degrees and for a climb to 21000 meters. At about 15000 and over Mach 1.2, I wasn't on course anymore and I had stopped climbing, in fact I was starting to pendulum, but actually the swing was increasing. I've had no problems with getting the craft to altitude before, and thought the Lazor system would help me to perform some long range flights, without me having to babysit.

I have also had instances, where I had no keyboard control when I tried to recover.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...