Jump to content

[0.90] Lazor System v35 (Dec 17)


Romfarer
 Share

Recommended Posts

Okay, what am I missing about the Red Lazor system? I had just taken off with my spaceplane, turned on the Lazor system to control attitude and bearing. I had set my bearing (heading) for 90 degrees and for a climb to 21000 meters. At about 15000 and over Mach 1.2, I wasn't on course anymore and I had stopped climbing, in fact I was starting to pendulum, but actually the swing was increasing. I've had no problems with getting the craft to altitude before, and thought the Lazor system would help me to perform some long range flights, without me having to babysit.

I have also had instances, where I had no keyboard control when I tried to recover.

Did you try this with one of the planes that comes with my mod?

Link to comment
Share on other sites

Yes, I tried out the Vampire, and I used the lazor configuration on my craft. My craft still oscillated about +/- 12 degrees from my chosen bearing making it difficult to climb to the altitude I wanted. Putting in desired altitude and bearing into the interface is an adventure in itself, as I can't just type in the values I desire, as I have to activate these settings to change them, then backspace and hit keys so I hopefully end up with the heading I want, not 10 or 220, while I'm trying for 90 degrees. I can't seem to break 7000m altitude under the Lazor system while I have had my spaceplane in orbit before.

I think the red lazor interface needs a separate execute button, instead of the crapshoot I get when I try to adjust anything.

I have enough TWR that I can climb to altitude, but I just need something to control roll and unwanted lateral movement. Just give me pitch control and I'll be circumnavigating.

Edited by Darkeldar
Link to comment
Share on other sites

Is it possible to get a lazor to point to coordinates on the ground? I have entered a location as target and don't need to have the auto-pilot land for me. Just need a marker at the location I wanna land at. I am trying with a red lazor, maybe I am missing something. Blue?

Link to comment
Share on other sites

Hey Jim, since you've already got a target feature that can make a rocket (in my case an ICBM) crash into the ground at a chosen coordinate, how about making it able to also target vessels? The guidance would work just like the normal guidance, but it would try to hit the vessel instead of the coordinates.

Link to comment
Share on other sites

Romfarer/anyonewillingtoanswer, quick question + suggestion... Is there a way to fire missiles rapidly without destroying my space bar? Like a Lazor System section that would activate certain things rapidly or at a certain time/place. Example: point at orbital debris and activate X missile at 30,000 m. above Kerbin. (Is this a MechJeb thing? If not, Romfarer, can you add it? MechJeb is lethal to my PC...)

Link to comment
Share on other sites

Romfarer/anyonewillingtoanswer, quick question + suggestion... Is there a way to fire missiles rapidly without destroying my space bar? Like a Lazor System section that would activate certain things rapidly or at a certain time/place. Example: point at orbital debris and activate X missile at 30,000 m. above Kerbin. (Is this a MechJeb thing? If not, Romfarer, can you add it? MechJeb is lethal to my PC...)

You could use action groups, but you've only got 10 of them. I agree that a function to "launch missiles in set order every 0.5 seconds" would be very cool, especially for videos.

Link to comment
Share on other sites

@Romfarer: Can we get a version of the docking cam that has the same high-def, full-colour display as the camera module? The grainy, low-contrast grey-scale image we currently get certainly looks authentic, but it's bloody hard to see your target in anything but ideal lighting conditions.

Link to comment
Share on other sites

Mr. Romfarer-

First off, thanks you for such a great series of mods that are greatly increasing the KSP gameplay.

However, I have encountered quite a few problems-

1. The Mod system has a large problem when I'm using it- the boxes of which the info is seen in is not there on my screen, leaving all the works, pictures and option free floating and quite confusing. This is annoying, yes, but also, I can't X out any of the tabs I open from the menu in the right side of my screen. So Once I activate the system, and I have all the options (EX: subsystems, target cam, config, main panel, targets, achievements) once I click and open one, I can't get rid of it.

2. THE MORE PRESSING PROBLEM: The entire subsystems tab does not work. WHen I open the subsystem tab, (keep in mid there aren't any boxes, so just floating words) It lists all the different lazor colors I have equipped. However, I get no option to click, which means no meun of options to open, which means NOTHING works in my laser system. PLEASE help!

Link to comment
Share on other sites

Mr. Romfarer-

First off, thanks you for such a great series of mods that are greatly increasing the KSP gameplay.

However, I have encountered quite a few problems-

1. The Mod system has a large problem when I'm using it- the boxes of which the info is seen in is not there on my screen, leaving all the works, pictures and option free floating and quite confusing. This is annoying, yes, but also, I can't X out any of the tabs I open from the menu in the right side of my screen. So Once I activate the system, and I have all the options (EX: subsystems, target cam, config, main panel, targets, achievements) once I click and open one, I can't get rid of it.

2. THE MORE PRESSING PROBLEM: The entire subsystems tab does not work. WHen I open the subsystem tab, (keep in mid there aren't any boxes, so just floating words) It lists all the different lazor colors I have equipped. However, I get no option to click, which means no meun of options to open, which means NOTHING works in my laser system. PLEASE help!

As there have been minimal responses, here are some screen shots to refere to.

Screen_Shot_2013-12-04_at_3.24.50_PM.png

Screen_Shot_2013-12-04_at_3.25.13_PM.png

Link to comment
Share on other sites

I couldn't find a bug report link on the first post so I'm putting this here.

The plugin seems to block the quicksaving and space center. After some invetigation if think i found the sourec of the problem.

The inability to save happens only when a new subsystem has been created with the config tab.

only tried with tractor beam:

-I load a ship on the launchpad with laz sys onbard, can save just fine.

-go to config, unassign one of the group, still can save

-make the unassigned laser group a new subsystem, can't save anymore.

-Unassign the newly created subsys, saving ability is back.

Is this a bug or an incompatibility between the plugin and the way ships are saved ?

Hi!

Same issue here.

Here my output log txt:

++++++ onFlightStateSave ++++++

(Filename: C:/BuildAgent/work/7535de4ca26c26ac/Runtime/ExportGenerated/StandalonePlayer/UnityEngineDebug.cpp Line: 54)

ArgumentException: An element with the same key already exists in the dictionary.

at System.Collections.Generic.Dictionary`2[system.String,KSPParseable].Add (System.String key, KSPParseable value) [0x00000] in <filename unknown>:0

at Romfarer.Util.SaveKSPParseableRect (System.Collections.Generic.Dictionary`2 partDataCollection, System.String i, Rect r) [0x00000] in <filename unknown>:0

at Romfarer.CFG.onFlightStateSaveX (System.Collections.Generic.Dictionary`2 partDataCollection, System.String identifier) [0x00000] in <filename unknown>:0

at Romfarer.CFG_magenta.onFlightStateSave (System.Collections.Generic.Dictionary`2 partDataCollection) [0x00000] in <filename unknown>:0

at Romfarer.Config.onFlightStateSave (System.Collections.Generic.Dictionary`2 parsedData) [0x00000] in <filename unknown>:0

at Romfarer.LazorSystem.onFlightStateSave (System.Collections.Generic.Dictionary`2 partDataCollection) [0x00000] in <filename unknown>:0

at ProtoPartSnapshot..ctor (.Part PartRef, .ProtoVessel protoVessel) [0x00000] in <filename unknown>:0

at ProtoVessel..ctor (.Vessel VesselRef) [0x00000] in <filename unknown>:0

at Vessel.BackupVessel () [0x00000] in <filename unknown>:0

at FlightState..ctor () [0x00000] in <filename unknown>:0

at Game.Updated () [0x00000] in <filename unknown>:0

at GamePersistence.SaveGame (System.String saveFileName, System.String saveFolder, SaveMode saveMode) [0x00000] in <filename unknown>:0

at VesselRecovery.onVesselRecoveryRequested (.Vessel v) [0x00000] in <filename unknown>:0

at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0

at VesselRecoveryButton.recoverVessel () [0x00000] in <filename unknown>:0

at ScreenSafeUIButton.OnMouseUp (Boolean rightClick) [0x00000] in <filename unknown>:0

at ScreenSafeUIButton.OnMouseUp () [0x00000] in <filename unknown>:0

at SSUICamera.DoMouseEvents () [0x00000] in <filename unknown>:0

at SSUICamera.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Edited by PeekRun
Link to comment
Share on other sites

@Romfarer: Can we get a version of the docking cam that has the same high-def, full-colour display as the camera module? The grainy, low-contrast grey-scale image we currently get certainly looks authentic, but it's bloody hard to see your target in anything but ideal lighting conditions.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...