Jump to content

Youen

Members
  • Posts

    348
  • Joined

  • Last visited

Posts posted by Youen

  1. 1 hour ago, Geonovast said:

    The French version of the game behaves normally with an English keyboard layout.

    So my problem is solved, but just in case it could help with any further debugging or whatever, I just realized now that I'm not using the french version of the game. I'm using the english version, but with the french layout (physical french keyboard, linux french layout, and in-game french layout). In this config, it appears the default keybindings are incorrect, but once you know it, easy to fix by reassigning warp keys.

  2. Yes, right shift + F12 opens the console with the cheat menu. Also works in the VAB for duplicating a part etc.

    But when flying, in space, right shift + ":" does nothing (without holding right shift, it increases "normal" warp speed). When I'm in atmosphere, I can control physics warp just fine (with the GUI or with the keyboard), but I can't force it when in space.

    (":" is the key that increases warp speed on my keyboard, which is a french keyboard. Maybe there is a bug related to the french layout?)

  3. I'm pretty sure that when I played KSP a while ago, on Windows, I could hold ALT while enabling time warp to force use of physics warp even when I was in space (the default being "on rail" warp). Is this still a thing?

    I'm now playing on Linux (version 1.12.3), and neither ALT nor RIGHT SHIFT work. I only get "on rail" warp. Am I doing something wrong, or did that feature get removed?

    It's really a most needed feature since it allows to accelerate burns that take a long time (if I remember correctly?)

  4. 20 minutes ago, Rudolf Meier said:

    I'm using this part of TweakScale (Scale_Redist.dll)... and I don't know if this could cause conflicts with the "real" TweakScale... its a pretty old file.

    CKAN installs a file 999_Scale_Redist.dll at the root of GameData, and Infernal Robotics also has a (different) version in its own folder. Don't know which one is used in the end, also don't know if that was changed in 3.0.7? There must be some change in 3.0.7 that triggers the issue.

  5. 2 hours ago, Lisias said:

    So I moved directly into 1.12.3 with IR 3.0.7. AND YES, the problem was reproduced.

    So, to be absolutely sure, I reverted back to IR 3.0.1 and redid the test. Unsurprisingly, it worked fine again.

    So I conclude it's a bug on IR 3.0.7 , probably introduced on IR 3.0.6 - it was a huge change set No!! IR 3.0.6 works fine too!!!

    Thanks a lot for your testing! I have installed IR 3.0.6 (by hand because CKAN does not know this version) and, as you've found out, this solved the problem :-) I've noticed however that I can't scale actuators any more, don't know if that was a feature introduced in 3.0.7. Not a big problem anyway.

    I can finally put the final touch on my Moon mission :-) This mod rocks!

  6. Hello, I have a weird bug: as soon as I add a robotics part on a vessel, it breaks all other parts that have been scaled with TweakScale. More precisely, attach nodes become misplaced on the scaled parts (but parts already attached on these nodes remain correctly placed).

    I can confirm this happens on a clean install of KSP 1.12.3, on which I only add Infernal Robotics v3.0.7 and TweakScale v2.4.6.12 (installed with CKAN). I have tested on linux (debian 11), 64 bits version of KSP.

    This happens in the VAB, but only after saving/reloading the vessel. Removing all robotics parts and then saving/reloading the vessel again fixes the issue (even parts that were already scaled work correctly after reloading).

    It's easy to reproduce with a minimal setup: in the VAB, just add a fuel tank, scale it with TweakScale, attach any InfernalRobotics part to it, save, reload, and the attachment nodes are now misplaced on the tank. Here is a short video showing it more clearly than a long talk

    And if that helps, here is the log

    Is this a known issue? I haven't found other reports of this issue.

  7. During plugin development, it's useful to have the game automatically load a save file and start the flight scene with a specific vessel, each time the game is started.

    I had some code that did just that, I think it was borrowed from the AutoLoadGame mod (https://github.com/allista/AutoLoadGame) but maybe it was from somewhere else. Anyway, it worked on old KSP versions, but it doesn't work on 1.7. When I call, from the main menu HighLogic.LoadScene(GameScenes.SPACECENTER), it does display the space center, but something is broken and I can't click on any building or do anything.

    Does anyone know how to do this kind of thing in a recent KSP version?

  8. I know this thread is old, but if anyone reads this interesting discussion like I did after landing it from your favorite search engine, I'd like to add an existing solution that wasn't mentioned : the Konstruction mod allows to weld* docking ports. The process is then:

    1. design your ship/base/space station in VAB as you like
    2. cut it in manageable blocks for launch, and add docking ports and RCS/probe cores as needed
    3. Launch the blocks
    4. Dock the blocks together in orbit
    5. Separate unneeded RCS/probe cores (KAS can help here)
    6. Then you can right-click each docking ports and select the option to collapse them. This will remove both docking ports, and attach the corresponding parts together, exactly as if it was done in the VAB.

    Beware, this is an irreversible process, no undocking after welding (the docking ports are completely removed from the ship)

    This has the advantage of looking nice, and reduce the part count (and reduce wobble if you don't already use a mod for that).

    Now about practical aspects if someone is interested:

    • Konstruction can be installed with CKAN or from here (the thread says KSP 1.3 but it works fine in 1.6)
    • (optional) I'm trying to avoid getting too many parts in my KSP install, so I've just kept Konstruction.dll (and the dependency USITools.dll), and added ModuleWeldablePort to stock docking ports using a Module Manager config file. I've deleted all other parts from the Konstruction mod. Maybe I could release that as a stand-alone mod.
    • If you need to precisely adjust roll when docking, while there are options for that in Konstruction, I've found it doesn't work so well for precision work. So I do it manually, right before docking, which feels more "role play" actually. I use the Docking Port Alignment Indicator mod, which, among other things, adds a roll angle (visual and numerical) indicator, making it easy to dock with sub-degree accuracy. When done right, you don't feel the "magnetic" attraction, your block just clicks into place seamlessly. Beware, as of Konstruction version 1.2.0.0, there is a bug with the "Compress Parts (Rotate)" option which is supposed to adjust roll when welding, but actually increases it. But if that bug gets fixed, it would probably be the best way to go.

    I still have to put all this into practice to get my Mun base assembled and landed, but from the few tests I've made it should work well.

    Happy assembling !

     

    * the term "weld" here just means the parts get attached together, exactly like when you do so in the VAB, it won't merge parts into a single one.

  9. Hi,

    Does anyone know if there is a combination of mods that would allow playing with RSS and clouds with KSP 1.2.2 ? It doesn't seem environmental visual enhancements is compatible with RSS, and I can't find a recent version of RVE that would work with KSP 1.2.2. I'd appreciate any pointer if such a thing is at all possible.

    Thanks.

  10. On 23/09/2017 at 6:12 AM, theSpeare said:

    Hey love the mod but I'm getting an issue where I'll set a node to get the perfect trajectory after an aerobrake, but as my ship turns around to do its usual alignment stuff the trajectory will start changing. I tried pressing the "Retro" button it still doesn't stop the trajectory from waving around while I change attitude.

    This is normal if your ship has steering fins: when you change attitude, they move, which changes the drag of the ship. Not sure that's the explanation, but maybe it is. If you have different results depending on your ship attitude, even when it is static (not steering, not rotating), then it's something else.

  11. On 24/07/2017 at 9:42 AM, Kobymaru said:

    I'm less worried about multiplication performance, but more worried about accuracy, since the acceleration does change over these simulation steps

    I'm not sure it's an issue, when you use RK4 integration you do not feed it with different accelerations for each 0.04s time step. The force varies very slowly, that's also the assumption used for the cache system. To be more precise, you could adjust the force depending on velocity, by assuming it varies with squared velocity (that would still be faster than going through the whole force computation stuff).

    On 24/07/2017 at 11:08 AM, Kobymaru said:

    I ran the same descent 2 times, once at 1x physics acceleration and 4x physics acceleration.

    I think it would make sense to only give accurate predictions for 1x time warp. Or maybe a prediction somewhere in between. Or ultimately give players the option to choose which one they want, but that's a bit far fetched... Also I'm not sure if using 4x warp means KSP time steps are multiplied by 4, or if it depends on the computer CPU power. In any case, if even the KSP simulation can't be reproduced with high precision, it won't be possible to predict it with a greater precision... I also remember that at some point I made tests and noticed that saving/loading could change the landing spot.

  12. 5 minutes ago, Kobymaru said:

    But that, of course, will lead to performance problems.

    Not necessarily. If I remember correctly the default KSP timestep is 0.04 (you can see it in the game settings). If you just use the same acceleration multiple times (we are trying to solve integrator accuracy, but not to increase force computation frequency), it should be fine, as it's just a bunch of multiplications and additions (you would have about 10 "sub-steps" for each simulation step? That means 20 additions and 10 multiplications). You can even pre-compute acceleration*time_step. I can't guarantee without testing, but I don't think it will have a big impact on performances.

  13. Do you get the same result as with the previous integrator? That could mean either you did not implement it right (but I don't think so, chances are you would get completely wrong results in that case), or more likely it just proves that precision issues do not come from the integrator, or, even worse, that getting more "precise" results will diverge more from what KSP does. Because KSP does naive integration (with a small time step, but that might only increase numerical errors). That's just a quick thought, maybe I'm wrong :P

    Maybe integrating with the same time step as KSP would make it better? For performances, you could use the same force in multiple integration iterations (assuming it wouldn't vary too much over a short time). And then try with a naive integrator instead of Verlet.

  14. 5 hours ago, Kobymaru said:

    That's something that only @Youen can do, so we'll have to wait for him.

    That's a bit of an overstatement... Unless you mean my code is so awful that no one can understand it ;-)

    Unfortunately, I've lost interest in KSP in general for quite some time now, and I don't really want to reinstall the latest version just to fix bugs and upgrade code for the latest version, which is precisely the part I dislike about modding.

    Maybe I'll get back to it later, but no ETA nor promises.

    In the meantime, I can at least update the opening post inform people of what works or not, and on which version of the game. I think the most problematic issue is that prediction is not accurate, but I don't know what is the last version of KSP for which it worked correctly?

    Also, despite what @Kobymaru says, I'm sure there are a lot of people around here that are able to improve the mod (starting with himself). And I'd be happy to release the work of anyone who would like to fix the issues / improve the mod. I can also give direct access to spacedock and AVC, and I think moderators can transfer the opening post ownership, or failing that we could create a new thread, if someone wants to maintain the mod.

    I'm really sorry to "let down" the current users of the mod, but fixing this kind of issue can be cumbersome, and I don't want to force myself to do it if I'm not even going to play the game after that.

  15. 8 hours ago, Jestersage said:

    Is ModuleManager required?

    EDIT: NVM. Tried it myself afterward. Just don't put .dll in there.

    Module manager is used to inject a module in all command parts that will store your descent settings (angle of attack, etc.) so that you don't loose them when switching vessel or saving/loading a game. I have never tested the behavior without it, so you could expect issues. As a side note, I don't see why you would want to remove it ; it's just a tool to standardize how mods add or remove modules to parts, so that they remain compatible with each other (most of the time).

  16. @Cdw2468 It's supposed to work and predict lift of your wings (you have a settings window to indicate how you intend to fly, either by setting the angle of attack (angle relatively to your velocity vector), or the angle above/under the horizon. Since you can adjust with a plane during your descent, it's usually possible to make it to the runway. Actually, the mod was designed exactly for this purpose (I couldn't land my shuttles without it), though it's useful for other kind of manoeuvers (aerobraking, etc.)

    However, recent player reports (read above) indicate that there are bugs with the latest version of the game/mod, and that the prediction does not work as expected. I haven't the time to look into this issue at the moment though :(

    1 hour ago, V8jester said:

    In orbit it will show you where it will land like a brick. As you enter the atmosphere it will update and continue updating the lading prediction.

    I don't know why you say that ? Unless there is a bug, you should get a prediction as soon as you enter the SoI of the planet. So when you are orbiting Kerbin (for example), it should predict the trajectory with drag and lift.

    As stated above, however, it appears there is a bug with the current version of the mod and KSP.

    6 hours ago, Raptor9 said:

    @Youen, I just wanted to say thanks for the continued support of this mod. :)

    Thanks, my pleasure :) Even though I don't have time to work on the last reported bug :-/

  17. On 02/02/2017 at 10:14 AM, Kobymaru said:

    Well, IRL we have the problem of wind, varying atmospheric densities/temperatures, inaccurate pitch/yaw control, and the significantly more complicated fluid dynamics :wink:

    So I think in the game we can hope for more precise predictions :wink:

    And also, IRL the planet is ten times bigger :) which means one should multiply in-game imprecision by ten before comparing with real life.

×
×
  • Create New...