Jump to content

Anonymous Bug Reporter

Members
  • Posts

    466
  • Joined

  • Last visited

    Never

Everything posted by Anonymous Bug Reporter

  1. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: Processor 13th Gen Intel(R) Core(TM) i7-13700KF, 3400 Mhz, 16 Core(s), 24 Logical Processor(s) | GPU: NVIDIA RTX 4070 | RAM: 16 GB DDR6 3200MHz at random whenever I'm trying to explore space, my trajectory lines just go missing. i cant find a way to get them back so I'm always forced to restart game, and sometimes fully remake the vessel. before the trajectory lines reappear. i also cannot access the maneuvering options as there is no line to click on first. *note that it seems to happen whenever I perform a stage separation. *side note, i have a brand new, stock Alienware Aurora R15, and this game is MAXING out my ram during most launches (on minimum graphics settings) Included Attachments: .ipsImage { width: 900px !important; }
  2. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 10 Pro Build: 19045.3448 | CPU: Intel(R) Pentium(R) Gold G5420 CPU @ 3.80GHz | GPU: AMD Radeon 5500XT | RAM: 16GB I just made my first aircraft and the ocean looks like the texture might be missing? Included Attachments:
  3. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Win 11 | CPU: AMD 5900HX | GPU: RTX 3080 | RAM: 32GB DeltaV for initial stages is calculated correctly Once we get to the third stage (Hydrogen engines) it reads out zero (0) dV and zero thereafter despite setting it as "vacuum" - this gives an incorrect reading of only ~4400 dV despite the craft having 10k dV in orbit Included Attachments: 12kmohofinalalmost.json .ipsImage { width: 900px !important; }
  4. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: Intel 13th Generation Core i5 | GPU: NVIDIA GeForce RTX 3050 | RAM: 512GB While reloading several quicksaves, I noticed that the orbital lines kept disappearing. This only seemed to occur with quicksaves done in Flight view, quicksaves in Map view were unaffected. Included Attachments: .ipsImage { width: 900px !important; }
  5. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: 3700X | GPU: RTX 3070 | RAM: 32 GB On a 2560x1080 screen, the UI for research and development cuts off, shown in the attached image. I feel this could be easily fixed with a UI scaling script but then again, what do I know about game development. Included Attachments: .ipsImage { width: 900px !important; }
  6. Reported Version: v0.2.1 (latest) | Mods: commnext | Can replicate without mods? Yes OS: windows 11 family | CPU: Intel 14700k | GPU: 4080 super | RAM: 32go Hello, the French text says you need a "conserve d'atterrissage". The French translation for the Small pod is "conserve", while the medium one is "boîte de sardines". you need the medium one, the "boîte de sardines", please correct it. (I learned it the hard way after 3 successfully Small pods land-on and more than 15 hours of gameplay... I decided to watch a YT guide and immediately notice that the French text for the missions was mismatching) Spicat Edit: I am also French so I can get my view on this. "Tin Can" can be confused by "Landing Can" even in English (both are "Can" but both are different for the mission). But it's even worse in French: The "Tin Can" is translated to just "Conserve" instead of "Boite de conserve" (Like it is with the translation of "Tun Can" which is "Boite de sardine"), it's not really incorrect per se, but it adds to the confusion so consider changing it to "Boite de conserve". It's like if in English, it was "Can" Mk1 instead of "Tin Can" Mk1 It's maybe the same in other languages but I can't confirm. This problem is also relevant for English though.
  7. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 10 | CPU: Ryzen 7 5700X | GPU: MSI RTX 3060 | RAM: GSkill 32GB When deselecting fuel tanks in the fuel transfer window the tank doesnt get deselected in the transfer window and the fuel tank is added to the fuel tank list, causing multiple instances of the fuel tank in the list. -Grusio Included Attachments: 2024-03-2714-05-53.mp4 .ipsImage { width: 900px !important; }
  8. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: win 11 | CPU: ryzen 7700x | GPU: radeon 6750 xt | RAM: 32gb When switching the mode between afterburner and cruise for the panther engine, the thrust is locked in place. you can abuse this behavior by switching the mode constantly to allow the engine to function at full throttle even when you leave the atmosphere completely. This obviously can only be useful for leaving kerbin or laythe. I am not sure whether it uses fuel or not. there may be other engines that have mode switching features that take time and might have this problem too. I believe the RAPIER is fine since it's an instant switch. suggested fix: when the mode switch animation plays, set thrust to 0, when the animation is finished, reset thrust to the expected level I recorded a 3 minute video of me sending a plane on escape trajectory out of kerbin and posted it to reddit. https://www.reddit.com/r/KerbalSpaceProgram/comments/1bnzvlh/how_to_get_to_space_with_just_airbreathing_engines/ rapidsave.com_how_to_get_to_space_with_just_airbreathing_engines-pybjle3k2mqc1.mp4
  9. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows | CPU: ntel(R) Core(TM) i5-8600 CPU @ 3.10GHz 3.10 GHz | GPU: Geforce rtx 2070 | RAM: 32.0 GB So, I was building a f16 I tried it out and then the gear clipped into the runway. Included Attachments: Desktop2024_03.26-13_55_52_01.mp4 .ipsImage { width: 900px !important; }
  10. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: I7 9700 | GPU: RTX 2060 | RAM: 32GB Discord tag - aski0m I was able to play normally this whole time, until I logged off yesterday. After trying several times to load into my save (see file below) it got stuck at the "creating Vessel" part of loading. I came, along with others who helped, to the conclusion that my file somehow corrupted. Ive heard that this might have to do with the 70 years of ingame time though Im not so sure about that being true. Included Attachments: autosave_1.json
  11. Although I think the UI in Ksp 2 has great potential, with its art style and revised components(in comparison to Ksp 1), it suffers from being difficult to use and as a functional downgrade from its legacy counterpart. I understand some elements of the maneuver node are forthcoming such as the precise maneuver tool featured in the first game, but it is still incredibly difficult to carry out a long form mission with the current tool. The hud element displayed after creating a maneuver node, although charming in design, lacks information that was present in the first game---This should not be the case. Interacting with the map in Ksp 2 is in a word, frustrating, as trying to click on what you wish is hard. Interacting with your conic line in another sphere of influence is not an option which whether a bug or not should be altered. One specific frustration when interacting with the map is the various iconography that can appear such as: Ap and Pe markers, An Dn nodes, names of bodies/ships, etc. It simply never works as a fluid and cohesive experience. That's not to say these icons don't look good but rather it is difficult when they are not where they are supposed to be (literally appearing separate from my orbit line) or unrequested(I had the ap and pe indicators show up for a ship I wasn't controlling. If you click on a body its name will pin; I don't think this should be a feature. There have been countless times where I've accidentally clicked on a body and its nametag has cluttered my screen. There are just a lot of UI quirks and bugs and the UI needs to be revised functionally. My final point of feedback is the parts manager. As much as I think I understand its intent, it is just inferior to the system found in Ksp 1. The parts manager is, for whatever reason, slow and clunky and I would feel much better with individual tabs for parts I pick. One possible solution would be to have tabs more similar to the ones in Ksp 1 but have it additionally offer other parts in the same category in drop down menus like the current parts manager. I feel like the parts manager created more issues than solutions as it necessitates the kerbal manager and the resource manager which are just bulk. The resource manager is actually a great concept and it should absolutely remain in the game but I wonder if it could be integrated into the parts manager system or whatever it becomes. I went down this rabbit hole of thought become I had fuel tanks I needed to monitor the fuel level of and I went to the parts manager which had no information. Why have parts that offer no information or options in the parts manager? I want apologize if any of these seems harsh. None of my criticism is directed at the dev team, whom I know are absolutely passionate about this project. I think this project is a behemoth of an undertaking and I admire all of the hard work done so far. I look forward to the future of Ksp 2 because I know it's bright. Thank you to whoever read this!!!
  12. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: Ryzen 5 7600x | GPU: Nvidia 4070 | RAM: 32gb I expected to land but i phased through the ground. To replicate try to land on the top the cliff on the location shown. I was going at low speed with aerobreaks on and wheels extended Included Attachments: Untitledvideo-MadewithClipchamp(3).mp4 .ipsImage { width: 900px !important; }
  13. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: windows 11 | CPU: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 2.59 GHz | GPU: nvidia gforce gtx 1060 max-q | RAM: crucial DDR4 CL19 16GB×2 Bottle Rocket does not work even if you operate the keys set in the action group. Other parts set to the same key (such as separators) will work normally. Bottle rockets work normally on stage. Included Attachments: .ipsImage { width: 900px !important; }
  14. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: windows 10 | CPU: AMD Ryzen 5 6800H | GPU: Nvidia Geforce RTX 3060 | RAM: 16 GO 4800 MHz DDR5 when i come back on Kerbin, my parachute disappear suddenly, whereas everything's well. And my vessel crashes everytime. It's begun during a mission in the science part, when I came back from the Mun. Included Attachments: KerbalSpaceProgram22024-03-1923-53-08.mp4 .ipsImage { width: 900px !important; }
  15. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 10 | CPU: I7 12700KF | GPU: NVIDIA GeForce RTX3070 | RAM: 32 I have noticed that in the ACTION GROUP function in the VAB, there is a group of the reserved that is displayed with {DISPLAYNAME}, I guess because there is an error in calling the variable for that name. It happens in almost all languages (at least I checked English, Italian and French). I attach a screenshot. Included Attachments: .ipsImage { width: 900px !important; }
  16. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 10 | CPU: 11th gen intel core i7-11800H | GPU: NVIDIA 4060 RTX | RAM: 64.0 GB I built a small testing vehicle because I wanted to make sure the launch abort system would work. I put the decoupler and the “bottle-rocket” engine in the same stage yet when I took off with the rocket and pressed abort the decoupler fired but the rocket did not. I had to press the button again for the engine to work. Included Attachments: .ipsImage { width: 900px !important; }
  17. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: Intel i7 | GPU: Intel iRISxe | RAM: 32gb I had several engines explode on my craft for no reason. I had 4 rhino engines on detachable fuel tanks that surround a central core that had 1 tuba engine. All but 1 of the rhino engines randomly heated up and exploded, both while the central tuba was running and when it wasn't. Included Attachments: Spicat Edit: Video Evidence: 2024-03-18 22-07-38.mp4
  18. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: WINDOWS | CPU: core i7-13620H | GPU: RTX4060 | RAM: 16MB 1.在训练场时,点开章节下的详细介绍,详细介绍的标题中的汉字紧缩在一起(When on the training ground , the Chinese characters in the titles detailed under the chapter are compressed) 2.任何地方的径向的“径”字被打错了,“径”字的那一捺画不出头(The radial "diameter" character anywhere is typed incorrectly , and the storke of the "diameter" character cannot be drawn)
  19. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: Intel i7 | GPU: Intel iRISxe | RAM: 32gb I planted a flag on Duna, but it gave me Mission completed for planting a flag on Pol Included Attachments: .ipsImage { width: 900px !important; }
  20. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Win11 | CPU: i7-12700K | GPU: RTX 3060 12GB | RAM: 64GB Center of pressure is not centered left-to-right on planes. It will favor whichever wing I place first in symmetry mode. For example, if I place the right wing first, the center of pressure will be off-center to the right. Vice versa for the left wing. It appears to be causing my plane to wobble left-right when my plane gets up to speed on the runway. CAS is turned off. Included Attachments:
  21. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: Intel core i5 12400F | GPU: NVIDIA Geforce RTX 4060 | RAM: 16GB 4800 Mhz DDR5 Fairings are not protecting the payload from the heat, its so bad that i had to mount a nose cone on my truss launch to not overheat the docking port. Included Attachments: .ipsImage { width: 900px !important; }
  22. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Win 11 | CPU: Yes | GPU: Yes | RAM: Yes I went to Vall with a u-dunkit and the science points for all the experiments as well as crew observations and surface samples while splashed down in the Well were way less than other areas of Vall. Also generally the u-dunkit is really poor science points considering how far along the tech tree and the craft design needed to use it Included Attachments: .ipsImage { width: 900px !important; }
  23. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows | CPU: i5-9600k | GPU: NIVIDIA GeForce GTX 1060 6gb | RAM: 16.0 Have had issues with docking since day one w/ KSP2 and while I think you have fixed most I encountered a new one while building a station. While trying to dock a resupply/module I would get a weird sling shot effect were either one or both vessels would suddenly launch away from the other right before docking was complete. I was moving bellow 0.2m/s on the two attempts this happened. I also had one attempt where my resupply jumped to about 3k away from the station. All there attempts happened when in control of the resupply. I am pretty sure sas was enabled on all three attempts on both vessels with thrusters on the resupply being active only. I did get it to end up working thought I think the only condition that may have changed was sas was off on the station and the station itself had to target dock to rotate to. I rotated it manually to be close. I should still have the save file and can try to replicate again if you want pictures and video.
  24. Reported Version: v0.2.1 (latest) | Mods: none | Can replicate without mods? Yes OS: Windows 11 | CPU: 12th Gen Intel(R) Core(TM) i7-12700F 2.10 GHz | GPU: RTX 3070 | RAM: 16.0 GB One side of the mountain on the island in the middle of Kerbin's crater has a sheer and unnatural cliff. Included Attachments: .ipsImage { width: 900px !important; }
  25. Reported Version: v0.2.1 (latest) | Mods: BepInEx 1.9.4, Flight Plan 0.10.5, Node Manager 0.7.3, Orbital Survey 0.9.4, Patch Manager 0.11.1, Premonition For SpaceWarp 0.2.0, SpaceWarp 1.9.4, UITK for KSP 2 2.4.2 | Can replicate without mods? Yes OS: Windows 10 Family | CPU: AMD Ryzen 5 5600X 6-Core | GPU: NVIDIA GeForce RTX 4060 | RAM: 15,93 Go Specs: https://drive.google.com/file/d/1Zr-V06B3CVGDxAv0h5NqbSklzgtiq78P/view?usp=drive_link Severity: low Description: In exploration mode, the mission "mauvais signal" ("bad signal" in english I guess ...) was fullfilled as soon as I was in orbit around Minmus. My inclination was between 0 and 5° whereas the objective is 45°, so it should not have been the case. Spicat edit:
×
×
  • Create New...