Jump to content

blackheart612

Members
  • Posts

    2,640
  • Joined

  • Last visited

Posts posted by blackheart612

  1. On 8/26/2020 at 2:55 PM, TranceaddicT said:

    @blackheart612

    There are a few instances where the directory reference to some of the Squad textures you reference is inaccurate.

    Example shortboom & shortboom2 both have this:

        texture = placeholder , Squad/Parts/Aero/cones/Cones

    the current Squad folder is     texture = placeholder , Squad/Parts/Aero/cones/Assets/Cones

     

    One other thing, (I've changed) the folder name for Structure and Fuel to Structure_and_Fuel because it eliminates a BUNCH of TweakScale logflood due to the spaces in the name.  (And yes, I traced all references to the folder name and changed those as well. I'm ADHD like that.) Don't know if you care to or not, but thought you should know about the "unholy characters" as they are called. (Yeah, I know it doesn't matter in the long run because of the internal conversion to dots (.)

    As for the first part, that should already be fixed, are you using the one from github? Also if you've changed the folder name and all of the parts that reference to it as well as textures on other parts that could possibly reference to it, you can post a change on github. Only I'd like you to double check if you're using the latest version first.

  2. On 8/13/2020 at 8:57 AM, theonegalen said:

    Having done some more testing: the wheels aren't going to take too much work. The cfg code for moduleWheelMotor has switched to being based on "maxRpm" and "driveResponse" from "maxSpeed" and... something else? I can't really remember.

    Anyway, it's not going to require any remodeling or re-importing of the models; a simple copy/paste from the new moduleWheelMotor code in the stock wheels fixed it for now. You might want to look at it just to see what kind of RPM or torqueCurve you want to do for yourself; I'm not sure what the original performance of your wheels was intended to be.

    I've actually tested my wheels before checking the configs, I tested them on a base 1.10 install. They seem to be working fine? And the consumption is still pretty much as much I wanted them to be... Do you happen to have other mods installed that might affect this instead?

  3. On 8/3/2020 at 12:54 PM, pdrZoox said:

    Hi, love your mod, it's really one of my favorites of all time.
    But is there any other mod, or plan to make IVA's for your cockpits? With the RPM, ASET and other interactive tools for IVA-only flight?
    If there isn't would you give permission to a second party to make them?

    Thank you very much for your mod and your support!

     

    On 8/3/2020 at 1:51 PM, sturmhauke said:

    The license in the OP allows for someone else to add IVAs if they want, as long as they follow the other terms. Here's another link: https://creativecommons.org/licenses/by-nc-sa/4.0/

    Go ahead! If you want I can link it here in the OP if you've done one

  4. On 7/28/2020 at 11:30 PM, I likeOxidizerrfuel said:

    Does this mod work with 1.10? 

    The mod will always work unless there's a fundamental change in the way parts work in game like the sad sad landing gears ;.; But yeah, there's only one dependency, which is firespitter, and if FS doesn't work on the most recent version, you'll experience some weirdness around the propellers, that might not work properly

    6 hours ago, Starhelperdude said:

    are the engines of example ww2 piston planes and ac-130's expected to have very low thrust so that the planes have a TWR of always 0.10-0.14? the jet engines work, and strangely the 0.625m prop with 5 blades works as well

    The TWR depends a lot on the speed and altitude of the aircraft, the curves behave differently to turboprops and turbofans. If you're checking out the game sheet's data, try it in practice if you haven't yet.

  5. On 4/16/2020 at 11:24 AM, dud said:

    for some reason when i download this mod, the only parts i get are the mk3 cargo cockpit and the propellors. does anyone know how to fix this?

    Very likely that you installed it incorrectly, the AirplanePlus folder must be inside GameData, and GameData must be in the same folder as where the exe of KSP is. Kindly check again and see if that fixes it.

  6. On 4/13/2020 at 2:46 AM, Techgamer68 said:

    Can you please make a config file for use with raster prop monitor? That would be very kind off you.

    Keep up the good work!!! ;)

    I've never done the patches as they were made here by the users.

    Also, I'd like to inform people that I don't know when I'll exactly come back to actively developing since I said before that I'm focused on 2D commissions, I've done both before but since my income is from 2D art I naturally focus there compared to here. Though I actually keep playing KSP so this mod will always be kept up to date constantly.

    18 hours ago, SirLanceQuiteABit said:

    Absolutely love your mod, cant KSP without it. Im running into a conflict issue though between Airplane+ and DangIt Cont. It seems that when both are installed on post 1.8 builds, the game hangs on initialisation on the "bigwing" part. Have you encountered this before? I imagine other parts may hang as well if it could get past this particular one. Any suggestions on how to correct this?

    If these are your only two mods, then it might be a conflict, which has never been reported before. But hangs like this could be caused by an entirely different mod. Sometimes removing Airplane Plus for example, would cause it to just hang on another part til the mod in question is removed.

  7. On 3/8/2020 at 10:37 PM, Horus said:

    Nice to see this mod still alive :)

    All rotor engines (those used for helicopters) are somewhat upside down in VAB\SPH and their attachment nodes are also turned 180°

    Is it a known issue or have I installed something wrong?

    This was actually really old so I forgot the reason why, they are meant to be surface attached as opposed to attached with a node, that is at least sure to me. Usually they are things I copy from firespitter which I studied for the modules that these engines use are the reason why.

    On 3/29/2020 at 4:25 PM, moguy16 said:

    i am an encountering an issue where a plane with stationary biplane gear will start to drift around upon coming out of time warp, and if i try to counter it stuff get funky,
    i tried reapplying the gear to make sure it wasn't a rotation thing and it was still there,

    i tried building an entirely new aircraft, still drifts

    i had a friend try and change the configs for me, still drifts

    however the gear works okayish when not timewarping, 

    the only thing that fixed this was switching the gear entirely 

    here is an image of the plane (sorry for the over qualification it's the only one i could find)

    -snip-

    here are the configs my friend sent me (they still won't work)

    -snip-

    Ever since a few patches ago, landing gears have been through a hellish amount of changes. Wheels are one of the most difficult, least documented parts of KSP. And this is as far as my understanding goes. It just happens despite the wheels working. :( On my recent play through actually, even without wheels, the anti-roll landing skids still slide despite being just an object basically. So I guess it's also a KSP ground mechanic problem, I'm not sure... I'm sorry

    4 hours ago, siklidkid said:

    The tail rotors are broken. Whenever i use a helicopter with them, even the helicopters you made, The helicopters spin out of control. Please help me.

    Ive been using helicopters on career mode and they are fine, assuming you did everything right, the problem I would guess is it's attached on the right side of the craft. As far as I know firespitter module tail rotors should be attached on the left side (refer to all sample crafts). That's on me if that's the problem as I wasn't clear on that...

  8. 4 hours ago, Corax said:

    FYI, don't use ":FOR[something]" in your user patches. It actually means you define something to extend that mod, not that you require that mod to be installed. This causes MM to see "something" as if it was installed, even if it isn't, and may cause unwanted side effects with other patches that trigger when they shouldn't.

    Use ":NEEDS[something]" or ":AFTER[something]" if you have to. In this case, you don't even need to specify that, because the patch only applies to the part if the part exists in the first place.

    Of course, the mod's author doesn't even need any of this, as they can and should directly edit the part definition itself.

    That said, I came here to report that exact same solution ; )

    
    @PART[shortboom,shortboomb]{
      @MODEL{
        // original:
        //texture = placeholder , Squad/Parts/Aero/cones/Cones
        // fix:
        @texture = placeholder, Squad/Parts/Aero/cones/Assets/Cones
      }
    }

    ...works for me.

    As said on thread title, the github version is the most up to date so this is fixed there. I merged this fixed to the files 9 days ago so hopefully it's fine there for other people if they check.

  9. On 3/7/2020 at 4:21 AM, TK-313 said:

    @blackheart612, I'm sorry if it isn't in your plans, but could you add blue to the colors and (maybe) a half-D-sized platform? Because, well, being able to build the likes of these crew and lander search and recovery trucks would be super cool.

    068efa6d114fff296aacc11dd40b2e93.jpg

    1280px-%D0%97%D0%98%D0%9B-49065_%22%D0%A1%D0%B8%D0%BD%D1%8F%D1%8F_%D0%9F%D1%82%D0%B8%D1%86%D0%B0%22_(14844209041)_(2).jpg?uselang=ru

    If anyone's curious, these are Soviet (and later Russian) ZIL Bluebird AATVs designed with this very purpose in mind. So far I've managed a couple of almost-lookalikes:

    yNM8Dc6.png

    But still, blue (and smooth sides) would be really nice :)

    Hmmm, this could be done relatively easily, I'll have to think about it since, really generally the colors I use are stockalike so I'm not too inclined to include it for design purposes...

  10. Hmmm, there's a lot of things going on it seems but I can't understand the picture. Wrong steering direction (must be wrong axis on unity)? Does it bounce? This happens a lot on stock wheels, I don't know the fix for this, but it is significantly more bouncy if the wheels are oriented wrong. Use this to check if things are REALLY what they seem. A mesh is a mesh, and colliders sometimes beg to differ so you should check how they look:

    Be sure to compare to stock set up too to get a better understanding of things. Since I can't understand the pictures too well, if you could elaborate it, I'll try to see if I can help.

  11. 22 minutes ago, Ruedii said:

    As of textures, the only ones left still not working are the short tails. 

    I may need to check if there are any recent updates that I haven't grabbed.

    I was playing and tested if APP works for 1.9, after updating all of my mods. All is well, I haven't updated the 2 main mirrors but I just confirmed a merge on github right now to fix that issue. This should work for 1.9 too as long as you have the right fs plug-in.

  12.   

    20 hours ago, Beetlecat said:

    hey everyone and @blackheart612, here's a quick config to fix the short tailboom A and B that are currently defaulting to a blank white placeholder texture.

    Squad changed the texture directories for the cones between 1.7.3 and 1.8, which made the squad textures unreachable by the part.cfg files.

    
    @PART[shortboom,shortboomb]:FOR[AirplanePlus]
    {
    	@MODEL
    	{
    		@texture = placeholder , Squad/Parts/Aero/cones/Assets/Cones
    	}
    }

    For some reason, this was mentioned *many* times in this thread, but somehow missed by me during my hiatus. :)  But at least it's here now in a patch form.

    Next little thing to fix is the DDS file for the skid not loading due to being an incorrect format.

    I'll get to this once Im free. Thanks. 

    7 hours ago, siklidkid said:

    Compatibility with textures unlimited?

    i wanna make a police helicopter

    Also, fenestron rotors!

    The compatibility patches are really mostly user made, as I can't spare the time to do them myself. Firespitter has a fenestron rotor, actually. I had planned to make them previously, but it got me thinking and the reason I didn't make them at the time was half that it exists on FS already, and half that it was complicated for me to understand at that time. But I used the fenestron to study how tail rotors work for the fs module.

  13. 13 hours ago, Rodger said:

    I can confirm the download in that post fixed it for me too.

    I also found some parts referencing the cone texture from the base game were still using an old file path, with some cfg editing you can fix those too before the next update. They were the tiny nose cones in Areo, and the short booms in structural.

    The paths in the configs should be “Squad/Parts/Aero/cones/Assets/Cones“ instead of “Squad/Parts/Aero/cones/Cones”

    ...I forgot about this. But I updated the missing textures after you contacted me, github has it right though (I checked my local copy), I think I mistakenly put the wrong files on the zip. So busy on other things I forget stuff and become confused :confused: I'm thankful people where know what to do and just answer how to temporarily fix the problems.

  14. On 12/27/2019 at 7:24 AM, AirShark said:

    Well there is the Predator engine which is a pusher-type engine. Not exactly the same, but close.

     

    -

     

    On a side note, it would be nice to someday see a Fenestron tail rotor added to KSP, and a folding rotor blade like that found on the SH-60 or AW101 Merlin. 

    FS actually has fenestrons. I think that's one of the reasons why I didn't make one, aside from the fact that it was probably a lot of stuff to do under the hood due to the amount of blades. I studied the FS fenestrons though.

    On a side note, I saw jacksepticeye has AirplanePlus installed in his recent video. That's pretty cool!

×
×
  • Create New...