Jump to content

Impossible to create or edit ships after reinstall with copied saves

Recommended Posts

KSP Version: v1.0.2.842 Windows 62-bit


One day i could not get in to KSP, the system got stuck after loading data and mods, would not start even after 10 minutes.

(I had one mod installed at that time, MechJeb2-, but this do not seem to be the issue)

I have this version saved if any logfiles are of interest

What Happens:

After my issues in History i did the following

Downloaded the latest version of KSP - test started, seams to work

Copied my old saved data to the new installation

Now i can start KSP without issues (all progress seams to be there)

Go to assembly building or hangar

Cant select new parts to create anything, and if opening old craft impossible to change them

Mods / Add-Ons: All Stock in this re-install (see history)

Steps to Replicate:

1. Re-install

2. Copy in my old save files

3. Start KSP and open old carrier

4. Go to assembly building

5. Try to create or edit ship

Result: impossible to create or edit ships


Have not been able to find any workaround

Other Notes/Pictures/Log Files:

System data, out putlog and savefiles on dropbox


Link to comment
Share on other sites

My first thought is that either some permissions went wonky when you copied things over, or the location you've installed to isn't cooperative. Please try copying the installation to a different location -- the Desktop is sometimes a very problematic location for KSP to be run from, so try copying the folder to C:\KSP or something similar.

Other than that, the other possibilities to eliminate are:

1. You're missing folders for the SPH and/or VAB to save files into. Ensure that within your save folder there is a Ships folder that should contain the SPH and VAB folders. If not, create any missing folders.

2. The permissions on the folder(s) themselves. Check that you have ownership of the folder and full read/write permissions.

Link to comment
Share on other sites

Are your parts visible? I recently had this happen to me after removing an addon, the editor would not show parts and some text was doubled up.

I fixed it by reinstalling KSP over the top of the existing install, though as you say you are using a new install, you can't rule out a bad file.

Also, don't run KSP from your desktop, it can break the game if KSP is forbidden from writing to the game folder, re-install to a non-Windows folder.

And test a new save, if the new save is working the old one may be broken, it may be looking for Mechjeb.

Your log says "Ship file error!" so I think you may just have one bad craft file, you'll need to remove them one by one until you find it.

Just before that error there is this "[shipConstruct]: Trying to load cricket - No AvailablePart found for mumech.MJ2.AR202" so yeah, you are using a moded save on a stock game, you are missing files.

Link to comment
Share on other sites

Moved files to C:\KSP - no success

Tried to check several of the ships to see what have the MechJeb2 on them so i can remove the files, that resulted in one rocket was opened on the old one, so i had 3 rockets open on each other, messy :-)

Checked permissions - cant find any issue there

All the folders exist


*Folder Ships

** SPH

*** all created

** VAB

*** all created

*Folder Subassemblies

*Save files

Now tried removing all saved ships and planes from the structure - no success, still have issues with construction

Can a issue in the save files be the problem? how do i find that file? can i remove save files without causing issues?

I still have the old problematic KSP installed on another drive but if i understand KSP, this will not matter.

Link to comment
Share on other sites

I have one random suggestion,

check your saved files for an incorrectly named file extension or a file that's not a KSP created file, I know I had a similar problem once and I had a .rar file in the save ships directory and that was the issue.

Link to comment
Share on other sites

Sorry no you can't move the KSP folder, you have to copy it or reinstall, Windows can prevent programs from writing to folders even if moved.

Once you have copied or reinstalled KSP, try starting a new savegame, if it works then the issue is a broken save, and yes save files will contain references to all parts on the vessels in flight in that save, including mod parts.

Link to comment
Share on other sites

I have now tried going back to an earlier save, dident work.

Installing the mod again to see if that helped- nope

In addition the tech tree i now see is empty.

The issue clearly seems to be in a save, but how do i solve that?

I have no problem in scrapping all ships but i would like my progress back?!

Saving new files or creating new carriers work - but that do not help me at the moment

- - - Updated - - -

And if i start over i have the same risk of my saved games cant be copied into a new re-installation if the problem comes up again

That would make me not happy so to speak

Link to comment
Share on other sites

If Windows is preventing KSP from writing files properly due to data execution prevention then just using an earlier save may not help, I can load your save and have uploaded it [here] so you can see if that has fixed it, but if you run KSP from the desktop, or an install of KSP that was moved from the desktop, you increase your chances that this will happen again.


As I just found out today with my own saves, if you had module manager installed and it changed your tech tree, and you remove it or reinstall KSP and transfer your saves, your editor and R&D will be broken in your old saves.

Even if you didn't use any addons in that save, just having module manager installed will affect it.

You need to open your persistent.sfs and find the following line:

TechTreeUrl = GameData/ModuleManager.TechTree

Delete it and save your file, then start KSP.

Thread moved to modded support as this issue was caused by an addon.

Edited by sal_vager
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...