Jump to content

Did the new update brake my rover?

Recommended Posts

I have build a rover from stock parts, but also mechjeb and kerbal engineer. Before the 1.03 update I launched the rover to the Mun and it drove alright.

Because of another mission fail I reverted to an early savegame and had to launch the rover again. But now it is uncontrollable. Its like driving on soap. No steering or mostly it turns in the wrong direction. No braking and so on. It can't even drive straight when not on 100% flat terrain.

I have other mods installed but no other than the above mentioned is used in the rover build.

I have tried to change steering, brake and motor configuration in different setup, but nothing helps.

What is wrong?

Link to comment
Share on other sites

Little update after having landed the rover on the Mun again again.

When I use Q and E I can make the rover turn. The wheels are not turning, but the rover does turn. Before the update I could use A and D and it was the wheels that made the rover turn.

Q and E turns the rover regardless of stability assist (T) being on or off. I do have reaction wheels mounted near the center of the rover.

When I drive the same rover on Kerbin, it is very stable and can turn easy and safe, also at speeds around 15 m/s. Going faster and making tighter turns will flip the rover.

Link to comment
Share on other sites

I found out it was the inline reaction wheels. Turning them off made the rover drive as on Kerbin. Sort of.

Must have turned the reaction wheels off without knowing on my first landing.

Thanks for the reply though.

EDIT: Maybe it was a bug. Turning the inline reaction wheels off and on again solved the problem. Now the rover is stable regardless of the state of the reaction wheels.

Edited by kludermor
Link to comment
Share on other sites

  • 1 month later...

I'm having rover issues as well when using the MechJeb2 autopilot. I thought it was perhaps the version of MechJeb, so I made sure to install the latest version, but it doesn't seem to have fixed the issue.

Basically, my navball shows as if it's pointed straight up at the sky (no horizon line as I used to have), and no matter if I set waypoints or a fixed heading, the rover just drives around aimlessly. It also does not stick to the requested speed-- not normal small variations, but running at 16 m/s when I'm trying to get it to stick to 10 m/s, and so forth.

I took the rover back into the VAB to ensure that the MechJeb unit is installed pointing the right way (i.e., on the left side of the rover box) and it is. I'm not sure why the autopilot worked at one time and now doesn't; I haven't installed any mods (other than the MechJeb update) in the meantime. I'm running mostly vanilla KSP, 1.0.4, but with MechJeb, ScanSat, and Asteroid Day.

(ETA: Spacecraft do not seem to be behaving abnormally, so I'm thinking it's either the specific rover design or the rover autopilot. I'm going to test a couple of rover designs to see if it makes a difference)

Edited by MaxwellsDemon
Additional comment
Link to comment
Share on other sites

@maxwellsDemon: I don't think the orientation of the Mechjeb Unit matters. I make sure I have a "horizontal control point" (docking port, Probodobodyne or similar) and select control from here. This will orient the navball to the horizon. I sometimes install multiple docking ports in different directions, so I can switch control to the one giving me "correct" navball orientation.

Link to comment
Share on other sites

Update: The autopilot works correctly when I have a Kerbal sitting in the external command seat; it does not work correctly when it's un-Kerballed.

Further thought: I've been building my rovers in the VAB; maybe building them in the SPH would affect things? Must try that out.

Edited by MaxwellsDemon
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...