Jump to content

KSP 1.1 Public Release graphic glitches on Mac

Recommended Posts

On 1.0.5 I had no issues, it is only with a fresh install of 1.1 did the graphic glitches show up. I tried turning up/down anti aliasing, both fantastic and beautiful render quality, fixing directory permissions, removing the saved application state in Library, etc...

Here are some screenshots of the glitching floors, walls, and flag of the SPH (happens in the VAB as well).




To test to see if was just on my machine, I copied the KSP_osx directory from my MacBook onto an SD card and had my coworker run it on his MacBook and the glitch is not present. The differences are:

My MacBook: Mid-2014 Retina MacBook Pro with Iris Pro GPU and 16GB of memory

His MacBook: 2012 MacBook with Intel integrated GPU and 8GB of memory

I am thinking the Retina display may have something to do with it. I also tested with the low resolution option (right click the KSP executable and select "Open in Low Resolution") but got the same results.

Link to comment
Share on other sites

Currently I can compare two MacBook models side-by-side.

I experienced the glitches described by OP on a MacBook Pro (Retina, 15-inch, Mid 2015), Intel Iris Pro 1536 MB, OS X El Capitan 10.11.4.

In the VAB and the SPH the flag shows oscillating glitches, in the SPH the lines on the ground as well.


These glitches do not appear on another MacBook Pro (15-inch, Mid 2012), Intel HD Graphics 4000 1024MB, OS X Yosemite 10.10.5.

(This one doesn't like activated PPFX, KSP then crashes when loading a savegame and has to be force-quit.)


KSP is the same on both: Build 01230, no mods, fresh install, nothing transfered from other installs.

The graphics options are equal on both:

Scenery options max

Rendering options max, everything active

Video is windowed 1280x800, 2xAA, V-Sync every V-Blank, FrameLimit Default, PixelLightCount 16, ShadowCascades 4


Experimenting with the settings doesn't remove the glitches on the Retina-Iris-Mac.

I will attach logs from both machines soon.


I pasted logs, both from the Retina Macbook showing the glitches.

KSP.log http://pasted.co/4fc7275b

Player.log http://pasted.co/c8c55b37


If you need additional information, let me know

Edited by c_space
Link to comment
Share on other sites

I have this issue too.  The lines on the floor of the VAB and the SPH and the banners hanging from the walls are broken.  All graphics settings have the same result, ditto on setting the game to low resolution in OS X.  

Macbook pro mid-2014, 13" with retina, 8 gb RAM.

Link to comment
Share on other sites

Same issue for me, on an early-2015 Macbook Pro 13", 8GB RAM, and the Intel Iris 6100 graphics. Fiddling with the settings doesn't change a thing, and I hope it's not the machine because I was running 1.05 just fine literally days ago.

Link to comment
Share on other sites

Same here I also notice ksp is not showing any clouds or city lights when I install EVE or KSPRC both clean install no other mods everything worked on 1.0.5 scatterer works planet shine works my MB retina 15'' late 2013 2gh core i7 8Gb memory Intel pro 1536mb has anyone else experiencing the same with these mods could it be this glitch thats causing this to happen?

Link to comment
Share on other sites

I also sent this question in to KSP support and their response was:

Have you tried not using -force-gfx-st? Or also the -force-glcore option?

I did not think executable options were supported on the Mac version thought. Thoughts?

Edited by geralddarden
Link to comment
Share on other sites

13 hours ago, 2001kraft said:

Same problem. Tried changing all settings, to no avail. Please report this to Squad constantly as it is a very sad and game-ruining glitch :(

Especialy considering how many crashes it has caused

Link to comment
Share on other sites

Have this problem as well, but iMac 2011. Did some testing and it seems that setting the pixel light count to 1 or 0 in the graphical settings "fixes" the issue. No more glittering lines in the SPH, but a wee bit dark.

It's also on the bug tracker here: http://bugs.kerbalspaceprogram.com/issues/7644

I'm guessing an OpenGL issue or some shader specific to the SPH got tweaked with the update. I can provide logs if needed, but I don't see any errors popping up.

Doesn't really stop me from using the SPH though. However, my CPU usage triples from the space center view and I'm thinking long exposure to that flickering is going to give me headaches.

Link to comment
Share on other sites

Guys i may have found something.
Because of the upgrade to Unity 5 the requirements for what can run it have changed. 

Based on that its possible that for us its because our mac's software is out of date.
I my self am running 10.7.5 so its possible that if I update it to 10.8+ it will work again.
Now of course this is just me spewing ideas out so i might be wrong.
With that being said i wouldn't change this thread to answered yet.

KSP 1.1.2 does load and play it just has that awful graphic error we are all facing.

To bad i have neither the time nor money to test this by updating.
It really wouldn't hurt to do it but like i said no time or money.

If any of y'all are running 10.8 and are still having this issues we can rule out my theory


Edited by War Eagle 1
Link to comment
Share on other sites

KSP version 1.1-1.1.2 (its been consistent. really anything past 1.0.5)

Mac OS X Lion 10.7.5 (11G63b) 
 Intel HD Graphics 3000 384 MB
4 GB 1333 MHz DDR3
2.7 GHz Intel Core i7

Graphics bug that has been persistent even back to 1.1 pre release
Some one did ask this and put it in the bug tracker under Macbook issues however some on windows said they were having the same issue.  When the windows guy got his issue fixed the devs checked it off as fixed but the macbook guy was still having the issues.
The public releases have fixed it for windows but have left it in for MacBooks.

This bug has caused the SPH/VAB to grind to a craw and cause game crashes.
The issue is only happening in anything post 1.0.5

This question has been asked numerous times and is one of the most up-voted issues on the non modded tech support.

A simple acknowledgment to this problem would make me happy.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...