Jump to content

Most text not displaying (and some graphics, too)

Recommended Posts

Hi everyone! I have a very strange problem: I upgraded to 1.1.3, and many texts don't appear on the screen (you'll see the problem in the screenshots below). I tried both updating from my older version (1.0.4) with all the mods, and also installing from scratch in a new folder. In other words: a fresh, "virgin" installation also fails.

This happens both in full-screen and "windowed" mode.

I'm posting the details and screen captures below.

Can anyone please help? Did anybody have the same problem?

Thanks in advance,



KSP Version: Linux 64 bits (purchased, not demo; also, I'm not a Steam user).

What Happens: Many texts and graphics are not shown.

Mods / Add-Ons: None (fresh installation).

Steps to Replicate: Install the game from scratch, run it.

Result: Many texts and graphics are not shown.

Fixes/Workarounds: None.

Other Notes/Pictures/Log Files:

OS: Linux 4.4 LinuxMint 18 64bit
CPU: AMD FX(tm)-4300 Quad-Core Processor (4)
RAM: 15996
GPU: Gallium 0.4 on AMD TURKS (DRM 2.43.0, LLVM 3.8.0) (2048MB)
SM: 30 (OpenGL 3.0 [3.0 Mesa 11.2.0])
RT Formats: ARGB32, Depth, ARGBHalf, Shadowmap, RGB565, ARGB4444, ARGB1555, Default, ARGB2101010, DefaultHDR, ARGBFloat, RGFloat, RGHalf, RFloat, RHalf, R8

You can find the screenshots in the link below:


NOTE: I took the screenshots using my update with all mods and saved games to have more data to show, but the problem is EXACTLY THE SAME with the totally fresh installation.

A few comments on the screenshots:

1.- This is the "Settings" menu, accessed directly from the welcome screen.

2.- I put my two saved games in the "saves" folder before starting the game; however, they don't appear. But if you click on the empty space where the savegame should be, you can actually load it (that's how I could go to screenshot #3).

3.- As you can see, some of the texts do appear. For example, in the KSC screen everything looks normal.

4.- At the VAB, the enhanced picture of the selected element is missing. Also, the "More info" text (right mouse button) is also missing.

5.- I cannot see the KSPedia at all. However, there is something over there, because clicking at random places changes the title bar.

6.- The Science Tree is totally empty. Hovering the mouse over it, however, shows the flyover texts, so the tree is actually loaded. You can also click on the nodes (if you find where they are!)


Edited by Tirs
Adding comments to screenshots
Link to comment
Share on other sites

Hello @Tirs

This is a known issue, and seems to be a bug with Unity3D and some graphics drivers, specifically all Linux open source drivers.

If you start KSP from the command line with "./KSP.x86_64 -force-glcore" it should work properly, and you can use a shell script to start KSP with this line for you.


#! /bin/sh
cd "~/path/to/Kerbal Space Program/"
./KSP.x86_64 -force-glcore

Hope this helps.

Link to comment
Share on other sites

Hi @sal_vager!

Well, thank you very much! It works! I was suspecting something about the graphics drivers, but I was at a loss about what to do, or what the problem exactly was...

I added "-force-glcore" to my starting script, but I had to remove the LC_ALL=C in order to get it to work. My starting script was:

cd /home/tirs/Kerbal
cp saves/TirsCareer/persistent.sfs saves/TirsCareer/persistent.sfsbackup
LC_ALL=C ./KSP.x86_64

This LC_ALL=C was suggested by someone at Squad support staff, back in version 0.22, when I was unable to start the game, and it has been here since then. Now, when I added the -force-glcore option, the screen went all black. Before complaining again, I tried removing the LC_ALL, and now everything seems to work fine (I will do a few hours of testing, though) :rolleyes:

So my script is now like this, very similar to the one you suggested (except for the "catastrophe recovery" line) :wink::

cd /home/tirs/Kerbal
cp saves/TirsCareer/persistent.sfs saves/TirsCareer/persistent.sfsbackup
./KSP.x86_64 -force-glcore

Again, thank you very much for your help, and best regards!


Edited by Tirs
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...