Jump to content

[1.12.x] Smartstage, intelligent VAB reset button


linuxgurugamer

Recommended Posts

@linuxgurugamer

Sorry to bother you again. After reinstalling some mods I encountered my original problem. With the mods Rational Resources, b9 part switch, and Cryogenic engines. It seems like Smart Stage is having trouble with handling tanks with mod fuel in previous stages. This is causing the same behavior as the previous post.

Steps to reproduce
1. Add a fuel tank
2. Change fuel type to anything not vanilla fuel type
3. Use corresponding engine and add decoupler
4. Copy/paste stage a few times and use smart stage.

 

Player log: https://drive.google.com/file/d/12svJdMaZ5Hh8_x-3in7i8RZ4ag533u5c/view?usp=sharing

Mod list: https://drive.google.com/file/d/1WXpoIuScy6rgdKQVbqKkE6xp3RiHHAno/view?usp=sharing

Craft showing situation: https://drive.google.com/file/d/19FQe7uD34nXaZeqF3dLvl08KrBVcXJ6x/view?usp=sharing

Thank you again for your work, really appreciate it.

Link to comment
Share on other sites

4 hours ago, lilzkiller said:

@linuxgurugamer

Sorry to bother you again. After reinstalling some mods I encountered my original problem. With the mods Rational Resources, b9 part switch, and Cryogenic engines. It seems like Smart Stage is having trouble with handling tanks with mod fuel in previous stages. This is causing the same behavior as the previous post.

Steps to reproduce
1. Add a fuel tank
2. Change fuel type to anything not vanilla fuel type
3. Use corresponding engine and add decoupler
4. Copy/paste stage a few times and use smart stage.

 

Player log: https://drive.google.com/file/d/12svJdMaZ5Hh8_x-3in7i8RZ4ag533u5c/view?usp=sharing

Mod list: https://drive.google.com/file/d/1WXpoIuScy6rgdKQVbqKkE6xp3RiHHAno/view?usp=sharing

Craft showing situation: https://drive.google.com/file/d/19FQe7uD34nXaZeqF3dLvl08KrBVcXJ6x/view?usp=sharing

Thank you again for your work, really appreciate it.

I’ll look, I normally don’t use alternative fuels

Link to comment
Share on other sites

On 5/21/2022 at 12:39 PM, lilzkiller said:

@linuxgurugamer

Sorry to bother you again. After reinstalling some mods I encountered my original problem. With the mods Rational Resources, b9 part switch, and Cryogenic engines. It seems like Smart Stage is having trouble with handling tanks with mod fuel in previous stages. This is causing the same behavior as the previous post.

Steps to reproduce
1. Add a fuel tank
2. Change fuel type to anything not vanilla fuel type
3. Use corresponding engine and add decoupler
4. Copy/paste stage a few times and use smart stage.

 

Player log: https://drive.google.com/file/d/12svJdMaZ5Hh8_x-3in7i8RZ4ag533u5c/view?usp=sharing

Mod list: https://drive.google.com/file/d/1WXpoIuScy6rgdKQVbqKkE6xp3RiHHAno/view?usp=sharing

Craft showing situation: https://drive.google.com/file/d/19FQe7uD34nXaZeqF3dLvl08KrBVcXJ6x/view?usp=sharing

Thank you again for your work, really appreciate it.

It actually has nothing to do with the alternative fuels, that was a rabbit hole.  I modified one of the engines to use Liquid fuel, just like stock, and had the same issue, so it looks like another issue with the part models.  I also tried replacing the model (.mu file) , and it worked, so it's definitely something with the .mu file

No idea yet, will keep digging

Link to comment
Share on other sites

  • 5 months later...

@linuxgurugamer

Returning to KSP after several years, and for the first time playing with the DLC, I have discovered that Engine Plates and SmartStage do not want to play nice. Specifically, SmartStage will lump all Engine Plates (and their associated engines) into one stage, and for good measure include the next decoupler up as well. Ironically, the stock Reset button will, at least for the craft I used for testing, produce staging that is less wrong and easier to sort out manually.

Replacing Engine Plates with decouplers fixes all staging issues on test craft.

Craft file (a stripped-down version of the craft that led to the discovery):
https://pastebin.com/pwGKdLrr

Log file, in two parts:
https://pastebin.com/NingbDVB
https://pastebin.com/nFpVfCUD

Relevant actions performed:
Load craft; use stock Reset; use SmartStage calculation; manually fix staging.

Edited by Albedo039
figuring out this @ thingamajig…
Link to comment
Share on other sites

20 hours ago, Albedo039 said:

@linuxgurugamer

Returning to KSP after several years, and for the first time playing with the DLC, I have discovered that Engine Plates and SmartStage do not want to play nice. Specifically, SmartStage will lump all Engine Plates (and their associated engines) into one stage, and for good measure include the next decoupler up as well. Ironically, the stock Reset button will, at least for the craft I used for testing, produce staging that is less wrong and easier to sort out manually.

Replacing Engine Plates with decouplers fixes all staging issues on test craft.

Craft file (a stripped-down version of the craft that led to the discovery):
https://pastebin.com/pwGKdLrr

Log file, in two parts:
https://pastebin.com/NingbDVB
https://pastebin.com/nFpVfCUD

Relevant actions performed:
Load craft; use stock Reset; use SmartStage calculation; manually fix staging.

There are other problems with SmartStage, thanks for the report, not sure when it's going to be fixed

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...