Jump to content

[KSP >= 1.3.0] TweakScale - Under Lisias' Management - 2.4.8.3 - 2024-0525


Lisias

Recommended Posts

21 minutes ago, Lisias said:

It's a terrible idea, because KSP has another bugs that shoving my DLLs into PluginData works around.

There's a lot of weird rules on DLLs, some of them I used on TweakScale, and the reason for these weird rules is to prevent KSP from screwing with us.

Well do note that moving the dlls did actually work when moved. KSP did see them and I could use TweakScale in the SPH and in the craft worked in scene, but I have very little modding experience so I don't know how that could cause issues elsewhere.

Link to comment
Share on other sites

28 minutes ago, Anth12 said:

Well do note that moving the dlls did actually work when moved. KSP did see them and I could use TweakScale in the SPH and in the craft worked in scene, but I have very little modding experience so I don't know how that could cause issues elsewhere.

You didn't fixed TS, you moved the problem to another point in which TS is not able to detect it.

It may work for some time and then you get screwed, or it may work forever - who knows? It's a roulette game every time you change something on the GameData.

Take as example: until 1.8.0, it was usual to have many ModuleManager DLLs shoved on the GameData. This was a terrible practice, as on the very best ModuleManager ends up on a different AppDomain than KSP and them everything is slower due RPC calls.

But yet, people still did that.

And then on 1.8.0 they solved the performance problem by allowing only ONE DLL to be loaded no matter what (and so, there's no more different AppDomains running on KSP) - and then everybody started to use the OLDEST MM on the system due the way KSP load things (by alphabetical order). And so suddenly things that were working suddenly stop working if by accident the user install an older add'on with an older ModuleManager embedded on it.

It's your GameData, it's up to you to decide the best way to solve things - but I can't support you if you don't fix things in a way I can guarantee TS will not get screwed (or, worst, ends up screwing up something else).

Link to comment
Share on other sites

2 hours ago, ColdJ said:

Nooooooooooo, Don't go into the light. Come back, we need you. :)

Seriously though, nobody should be using the launcher to play their game, unless they like things breaking.

The PDLauncher is being distributed on a different depot, number 1998022 .

Problem - it apparently is not working on MacOS. There's no ".app" folder, and it doesn't runs under dotnet:

lisias@macmini62 ~/Applications/Games/Steam/steamapps/common/Kerbal Space Program/PDLauncher
> /usr/local/share/dotnet/dotnet LauncherPatcher.exe
Cannot use file stream for [/Users/lisias/Applications/Games/Steam/steamapps/common/Kerbal Space Program/PDLauncher/LauncherPatcher.deps.json]: No such file or directory
A fatal error was encountered. The library 'libhostpolicy.dylib' required to execute the application was not found in '/Users/lisias/Applications/Games/Steam/steamapps/common/Kerbal Space Program/PDLauncher/'.
Failed to run as a self-contained app.
  - The application was run as a self-contained app because '/Users/lisias/Applications/Games/Steam/steamapps/common/Kerbal Space Program/PDLauncher/LauncherPatcher.runtimeconfig.json' was not found.
  - If this should be a framework-dependent app, add the '/Users/lisias/Applications/Games/Steam/steamapps/common/Kerbal Space Program/PDLauncher/LauncherPatcher.runtimeconfig.json' file and specify the appropriate framework.
lisias@macmini62 ~/Applications/Games/Steam/steamapps/common/Kerbal Space Program/PDLauncher

or mono:

> /Library/Frameworks/Mono.framework/Commands/mono LauncherPatcher.exe
Cannot open assembly 'LauncherPatcher.exe': File does not contain a valid CIL image.
lisias@macmini62 ~/Applications/Games/Steam/steamapps/common/Kerbal Space Program/PDLauncher

Anyone on Linux or MacOS was able to run it?

Link to comment
Share on other sites

18 minutes ago, Lisias said:

It's your GameData, it's up to you to decide the best way to solve things - but I can't support you if you don't fix things in a way I can guarantee TS will not get screwed (or, worst, ends up screwing up something else).

Chill please. I am only here to help. I don't actually use the mod at all. In fact I don't even use steam for KSP usually. Its only purpose is so I can copy it out to another folder.

My only goal was to figure out why mods aren't working with 1.12.4 when there's nothing in the patch notes that indicate any mod related changes.

I have 20 or mods. None of them were affected by bypassing the launcher as far as I can tell.

There are multiple people complaining about issues with 1.12.4 which appear to be mod related. I was just trying to figure out what was going on so I could get a bug report out asap.

Lets hope that KSP2 modding wont be as annoying as you have been experiencing.

1 minute ago, Lisias said:

Anyone on Linux or MacOS was able to run it?

Not sure if this is relevant because I only run on PC but I have KSP on GOG (minus the DLCs) as well as steam. On GOG the pdlauncher is missing from 1.12.4.

Link to comment
Share on other sites

1 hour ago, Anth12 said:

Chill please. I am only here to help. I don't actually use the mod at all. In fact I don't even use steam for KSP usually. Its only purpose is so I can copy it out to another folder.

I'm not mad, but I needed to make a point. You don't have the slightest the huge amount of krap I have to deal due rogue DLLs scattered on the system. On my first 2 to 3 years on TS tenure, virtually 50% of all my modding time were giving support for problems that affected TS, but weren't TS's fault at first place. And a considerable amount of these problems were due rogue DLLs.

 

1 hour ago, Anth12 said:

There are multiple people complaining about issues with 1.12.4 which appear to be mod related. I was just trying to figure out what was going on so I could get a bug report out asap.

I understand that, and I grateful for the help.

My current guess, and it's only a guess as I can't run the damned thing myself, is that they are forgetting to chance the Default Directory to the KSP's root (the same directory in which ksp_x64.exe lies on).

Spoiler

huge lot of add'ons relies on the current directory to find themselves on the KSP's file system, and if you fail to set it correctly you will se add'ons creating files on the wrong place (or failing to find them). And this is also a source of problems.

In Linux, for example, Steam uses a lot of symlinks and since Mono's "unreparse" the symlinks into absolute pathnames, you ends up having part of the system using the absolute pathname and part of the system using the pathname the user used to start the game, two different pathnames pinpoint to the same place (hopefully). Not to mention that some <piiiiiii> on Steam found a good idea to do symlinks into protected areas of the system (as the UEFI system partition) on the user - creating situations that are impossible on a standard installation. 

I spent some time working on these problems on KSPe, and it's the reason TweakScale have a bit of it embedded. And it's also the reason TweakScale is resilient on most problems related to the file system. But as new problems happens, I need to work them on KSPe...

I juts checked your entry in https://github.com/net-lisias-ksp/TweakScale/issues/269 .

Please attach to it the full KSP.log of the event, I need to check why the icons are not being found and I'm pretty sure the answer can be found on the KSP.log.

 

1 hour ago, Anth12 said:

Lets hope that KSP2 modding wont be as annoying as you have been experiencing.

Well, this is not the best first impression, no doubt! :D

 

1 hour ago, Anth12 said:

Not sure if this is relevant because I only run on PC but I have KSP on GOG (minus the DLCs) as well as steam. On GOG the pdlauncher is missing from 1.12.4.

on Steam, the thing is called PDLauncher and as far as I understood, it will be the Launcher that PD will use on KSP2 too.

It's a new artefact, with its own depot, and this depot were injected on all KSP1 packages if I understood correctly SteamDB: https://steamdb.info/depot/1998022/

It appears to be wrote on C#, but the executable is signed and appears to work only on Windows.

Edited by Lisias
brute force post merging
Link to comment
Share on other sites

Y'all have to pardon my ignorance on this stuff. Just putting my last few cents here (for now).

Looked through my most recent log. The vast bulk of things seem nominal. There's a few things here or there, namely some warnings about texture/jpg compression, but I get the feeling these have been issues before. It seems to recognize all the important mod folders and dlls.

I've been doing random tests of various parts mods and such, everything seems fine. I could easily be misremembering the number of patches modulemanager applied, tbh. I'm gonna call this issue closed on my end for the time being. I will keep you guys posted if something else comes up. In any case, I appreciate the input here.

Anyway I'm potentially planning on buying a new pc (feel like SSD's and 32gb ram would be at least a little helpful for load times and multitasking) long term.

And back to me making things from AI generated pictures and my own nerdy/mildly offensive imagination.

Edited by Blufor878
Link to comment
Share on other sites

46 minutes ago, Lisias said:

Please attach to it the full KSP.log of the event, I need to check why the icons are not being found and I'm pretty sure the answer can be found on the KSP.log.

For some reason KSP.log isn't generated while the launcher bypass is in place.

I added player.log instead and indicated the line where it mentions the icon issue.

16 minutes ago, Blufor878 said:

Looked through my most recent log. The vast bulk of things seem nominal. There's a few things here or there, namely some warnings about texture/jpg compression, but I get the feeling these have been issues before. It seems to recognize all the important mod folders and dlls.

Texture/jpg compression issues are typical entries in the KSP log for some reason even without mods. No idea why or if they are a real issue or not.

Link to comment
Share on other sites

1 hour ago, Anth12 said:

For some reason KSP.log isn't generated while the launcher bypass is in place.

I added player.log instead and indicated the line where it mentions the icon issue.

HUmm… I'm guessing the KSP.log is being generated, but on the wrong place...

Give a peek inside the PDLauncher directory.

I did a peek on the Player.log, and things are not making too much sense, by the way. The DLLs are not being loaded correctly as it appears.

I also found something that may suggest they are patching the game at runtime, with KSP_x64.exe maybe having a backdoor or something that is used by the PDLauncher somehow :

Environment Info
Win32NT 7FFFFFFFFFFFFFFF  Args: KSP_x64.exe D:\Steam\steamapps\common\Kerbal Space Program\PDLauncher\launcherpatcher.exe

Oh, crap. I think I will need to borrow my son's Windows machine to check this one...

— — POST EDIT — — 

Well, I decided to try a stunt:

[LOG 05:38:08.026] ******* Log Initiated for Kerbal Space Program - 1.12.4.3187 (OSXPlayer) en-us *******
Kerbal Space Program - 1.12.4.3187 (OSXPlayer) en-us

<...>

Environment Info
Unix 7FFFFFFFFFFFFFFF  Args: KSP PDLauncher/LauncherPatcher.exe

Just to see what happens - probably nothing, but it worths the try.

Unsurprisingly, nothing different happened. Whatever is being done by the LaunchePatcher, it's being done on Windows only.

[LOG 05:38:19.615] [WatchDogForScaleRedist] DETAIL: System is good to go.
[LOG 05:38:19.618] [KSPe.Light.TweakScale] Version 2.4.1.21 /L for TweakScale /L
[LOG 05:38:19.755] [TweakScale] Version 2.4.6.16 /L
[LOG 05:38:23.482] [KSPe.Binder] Hooked.
[ERR 05:38:23.491] ADDON BINDER: Cannot resolve assembly: Scale.PartDB.19x

[LOG 05:38:23.493] [KSPe.Binder] Looking for Scale.PartDB.19x.dll on GameData/TweakScale/Plugins/PluginData/...
[LOG 05:38:23.493] [KSPe.Binder] Found it on GameData/TweakScale/Plugins/PluginData/Scale.PartDB.19x.dll.
[LOG 05:38:23.614] [TweakScale] Support for KSP 1.9.0 to 1.12.3 Version 2.4.6.16 /L

 

Edited by Lisias
post edit
Link to comment
Share on other sites

47 minutes ago, Anth12 said:

Texture/jpg compression issues are typical entries in the KSP log for some reason even without mods. No idea why or if they are a real issue or not.

It's not. To tell you the true, it's a deleterious message.

Images with a width with a multiple of 2 are mipmapped, and then if the user needs to lower the texture quality to save memory, these images will get blurred. This is not bad if you are using the image for texturing meshes, but it's terrible if you are using the image to do UI things.

 

17 hours ago, TameTheKraken said:

Can confirm the post above about Scale.PartDB.19x.dll.

I had downloaded your KSP.log and found what follows:

[LOG 07:15:54.021] ******* Log Initiated for Kerbal Space Program - 1.12.3.3173 (WindowsPlayer x64) en-us *******
Kerbal Space Program - 1.12.3.3173 (WindowsPlayer x64) en-us

<....>
  
************************************************************************

Environment Info
Win32NT 7FFFFFFFFFFFFFFF  Args: KSP_x64.exe C:\Games\SteamLibrary\steamapps\common\Kerbal Space Program\PDLauncher\launcherpatcher.exe

You are running he launcherpatcher on KSP 1.12.3, and not on 1.12.4.

And since TweakScale is known to run for on 1.12.3 for an year already, it's conclusive that the problem is on the launcherpatcher.exe itself. Somehow, it's mangling the KSP_x64.exe's runtime and changing things.

The alternative is the DLL being really missing from your rig, but by so we would not have the problem solved by not using the launcher...

[LOG 07:16:37.824] [TweakScale] Version 2.4.6.16 /L
[LOG 07:16:37.855] [KSPe.Binder] Hooked.
[ERR 07:16:37.857] ADDON BINDER: Cannot resolve assembly: Scale.PartDB.19x

[LOG 07:16:37.858] [KSPe.Binder] Looking for Scale.PartDB.19x.dll on GameData\TweakScale\Plugins\PluginData\...
[LOG 07:16:37.861] [TweakScale] ERROR: System.IO.FileNotFoundException: Could not load file or assembly 'Scale.PartDB.19x' or one of its dependencies
File name: 'Scale.PartDB.19x'
  at System.AppDomain.Load (System.String assemblyString, System.Security.Policy.Evidence assemblySecurity, System.Boolean refonly) [0x00016] in <9577ac7a62ef43179789031239ba8798>:0

  at System.AppDomain.Load (System.String assemblyString) [0x00000] in <9577ac7a62ef43179789031239ba8798>:0
  at (wrapper remoting-invoke-with-check) System.AppDomain.Load(string)
  at KSPe.Util.SystemTools+Assembly.LoadAndStartup (System.String assemblyName) [0x00005] in <36f55e6817764b8cbb675f9c0dfeaf9e>:0
  at KSPe.Util.SystemTools+Assembly+Loader.LoadAndStartup (System.String assemblyName) [0x00000] in <36f55e6817764b8cbb675f9c0dfeaf9e>:0
  at TweakScale.Startup.Start () [0x0008b] in <b608a5e0fb114a86ba977162d3858879>:0  at error:0

I'm sourcing a Window machine to do some tests myself - but the evidences at hands suggests the PDLauncher is changing how things works inside KSP.  Such patches apparently will only be available for Steam users using Windows, as MacOS and Linux users can't run the patch, and GOG wasn't updated with it.

Link to comment
Share on other sites

42 minutes ago, Lisias said:

It's not. To tell you the true, it's a deleterious message.

Images with a width with a multiple of 2 are mipmapped, and then if the user needs to lower the texture quality to save memory, these images will get blurred. This is not bad if you are using the image for texturing meshes, but it's terrible if you are using the image to do UI things.

I hope KSP2 is clear of such errors.

59 minutes ago, Lisias said:

Give a peek inside the PDLauncher directory.

Added new KSP.log files. to the github.

  • Added log file with tweak scale which I had moved the dlls (Bypassing Launcher)
  • Added log file with tweak scale installed from official download (Bypassing Launcher)
  • Added log file with tweak scale installed from official download (With Launcher running as intended)

 You were right they were in the PDLauncher folder.

Edited by Anth12
Link to comment
Share on other sites

32 minutes ago, Anth12 said:

You were right they were in the PDLauncher folder.

Oww crap. This is going to break some addons that are trusting the current directory is one level up.

This is a somewhat serious problem, it should not had being allowed to be published as it is. If KSP itself is getting confused about where to put the KSP.log...

 

Link to comment
Share on other sites

This may sound silly but does downloading the 1.12.3 version of KSP VIA steam and then copying the game from the steam folder to a different directory and then creating a shortcut to the ksp 64bit exe bypass the new launcher there for removing the issues mentioned above?.

I see the new launcher even in the older 1.12.3 versions but as long as I dont use it to start the game and just use the ksp 64bit exe am I safe? or has the old exe been tweaked as well?

 

Thanks

Link to comment
Share on other sites

25 minutes ago, stk2008 said:

This may sound silly but does downloading the 1.12.3 version of KSP VIA steam and then copying the game from the steam folder to a different directory and then creating a shortcut to the ksp 64bit exe bypass the new launcher there for removing the issues mentioned above?.

I see the new launcher even in the older 1.12.3 versions but as long as I dont use it to start the game and just use the ksp 64bit exe am I safe? or has the old exe been tweaked as well?

Using the executable via a shortcut should work fine. I haven't had the same issues when using it separately to steam.

Link to comment
Share on other sites

1 hour ago, stk2008 said:

This may sound silly but does downloading the 1.12.3 version of KSP VIA steam and then copying the game from the steam folder to a different directory and then creating a shortcut to the ksp 64bit exe bypass the new launcher there for removing the issues mentioned above?.

I see the new launcher even in the older 1.12.3 versions but as long as I dont use it to start the game and just use the ksp 64bit exe am I safe? or has the old exe been tweaked as well?

 

Thanks

Using the KSP_x64.exe directly is the way to go, but from experience, don't create a shortcut to it, that can go funny on Windows. Just open the Kerbal Space Program folder and open/run it directly. That is what I do and have never had any problems that way.

Link to comment
Share on other sites

10 minutes ago, stk2008 said:

Oh really?

Creating a short cut can cause issues....I use the short cut so I can use the force dx11 and no popup window command what sort of issues can happen from using shortcuts

Not shorcut plural. Just for KSP. I have tried in the past and it would regularly stop midway and go back to desktop. I think it is something related to the same reason I have KSP on the main drive, rather than in program files, so Windows permissions don't fool with it. I have 4 different KSP installations from 1.9 to 1.12.2

I make mods so I am in and out of 1.12.2 all the time testing. All my installs work fine. If I wasn't making mods that need to work on the latest I would happily stick with 1.10.1, because everything I like doing worked well in that version.

Link to comment
Share on other sites

4 hours ago, stk2008 said:

This may sound silly but does downloading the 1.12.3 version of KSP VIA steam and then copying the game from the steam folder to a different directory and then creating a shortcut to the ksp 64bit exe bypass the new launcher there for removing the issues mentioned above?.

Yes. Just make sure to set the Current Directory to the rigtht place (this is manually set on Linux and MacOS - don't remember Windows)

 

4 hours ago, stk2008 said:

I see the new launcher even in the older 1.12.3 versions but as long as I dont use it to start the game and just use the ksp 64bit exe am I safe? or has the old exe been tweaked as well?

I have a bug report from a 1.12.3 user, so we can assume the new Launcher will screw up all KSPs from 1.12.0 to now, perhaps older too - but this I will only be able to check later, once the Windows machine I source is available.

 

2 hours ago, ColdJ said:

Using the KSP_x64.exe directly is the way to go, but from experience, don't create a shortcut to it, that can go funny on Windows. Just open the Kerbal Space Program folder and open/run it directly. That is what I do and have never had any problems that way.

So you probably need to set the Current Directory manually too on Windows! :)

 

2 hours ago, stk2008 said:

Oh really?

Really!!! :)

 

2 hours ago, stk2008 said:

Creating a short cut can cause issues....I use the short cut so I can use the force dx11 and no popup window command what sort of issues can happen from using shortcuts

Be sure to set the Current Directory (of Default Directory? really forgot Windowns lingo…) and you will be fine.

Additionally, KSPe has a check for this problem and it will warn you about. Had I been able to push it into the wild sooner, we would not be having this crapstorm over our heads now. humm.. Well, we would, but it would be a lot easier to work around it. :/

 

2 hours ago, ColdJ said:

I make mods so I am in and out of 1.12.2 all the time testing. All my installs work fine. If I wasn't making mods that need to work on the latest I would happily stick with 1.10.1, because everything I like doing worked well in that version.

My favorite KSP is still 1.7.3 - I know all the bugs on it, and I know how to workaround most of them - as well how to keep performance in check.

I agree KSP 1.9 to 1.10 are sensibly more performatic, but they also introduced some "undocumented features" (aka bugs they will not fix) that are pretty annoying to me!

6 hours ago, Anth12 said:

I hope KSP2 is clear of such errors.

I'm not anymore. It's almost as Squad had done it… Oh, wait! :sticktongue:

 

6 hours ago, Anth12 said:

Added new KSP.log files. to the github.

  • Added log file with tweak scale which I had moved the dlls (Bypassing Launcher)
  • Added log file with tweak scale installed from official download (Bypassing Launcher)
  • Added log file with tweak scale installed from official download (With Launcher running as intended)

Thank you. These confirmed the problem (by not showing differences, so the only option is really the current directory stunt).

I already concocted a quick hack to keep (my) add'ons working. As long as I lay my dirty pawns on a Windows machine to confirm the fix, I will publish a hot patch for everything.

Link to comment
Share on other sites

NOTAM

TweakScale (and some other mods) are borking due PDLauncher changing how things are started up on KSP.

On reddit, it was found the copying everything (but Squad and SquadExpansion) from <KSPROOT>/GameData to <KSPROOT>PDLauncher/GameData will "fix" the problem.

Problem: what happens with the settings.cfg? The savegames? KSP.log surelly is there now.

I will have an answer to it soon.

In a way or another, using PDLauncher is highly not advisable with or without Mods. 

— — POST EDIT — — 

The whole ordeal was a mess. PD Launcher is not a problem. POINT. TweakScale was the one reporting something wrong, not the victim nor the cause of the problem. POINT.

Some dude tried to accomplish something on Steam Launcher, made a mistake, and then a lot of people started to shoot the messenger (TweakScale) and I got involved on the shooting without a gun.

 

Edited by Lisias
post edit
Link to comment
Share on other sites

I'm so confused

Is this for people that still want to run the game through steam.

Again I copy my install to the root of C drive and dont Launch ksp using any thing but a shortcut created from the ksp64.exe.

 

Though saying that since the last update I have seen more issues with mods even doing it this way

Link to comment
Share on other sites

1 hour ago, stk2008 said:

I'm so confused

Is this for people that still want to run the game through steam.

Again I copy my install to the root of C drive and dont Launch ksp using any thing but a shortcut created from the ksp64.exe.

People do what people do - they just want the game running, and they rarely are willing to take any extra effort to do that. And sometimes some developers use them to force their weight over others developers - it's how Microsoft used to push their stunts in the past (or nowadays, but at a lesser extension).

Of course, this can also be explained by a marvellous bork from some less-than-experienced developer that shoved a KSP2 designed artefact into KSP1's eco-system without proper testing.

As I had read on somewhere else:

Quote

Everybody has a testing environment. Some people are lucky enough to have a totally separate environment to run production in.

Source.

But in a way or another, the ending results are usually the same - huge breakage disrupting the eco-system, followed by some black-magic from someone that would instantaneously fix this problem. And since most people really don't care for anything else as long they have the game running in the most convenient way, you have a "rebalance of power" on the eco-system - usually at the expenses of the Publisher's stakeholders, as they are the ones paying for the party.

Edited by Lisias
Yep. Still more bad grammars - including from the quote! :D
Link to comment
Share on other sites

I dont know if this means anything or not. It seems related, so, i decided to just launch directly through the KSP_x64.exe. Well the good news is that, on windows, i no longer have a showstopper error and its not yelling at me anymore. Only thing it is telling me is that the Tweakscale version is outdated. Everything works as it did before. 

In summary, my question now, does this relate to the PDlauncher in anyway? If so, launching from the KSP_x64.exe directly seems to have temporarily managed this, for me at least. 

Link to comment
Share on other sites

1 hour ago, Lisias said:

My favorite KSP is still 1.7.3 - I know all the bugs on it, and I know how to workaround most of them - as well how to keep performance in check.

I agree KSP 1.9 to 1.10 are sensibly more performatic, but they also introduced some "undocumented features" (aka bugs they will not fix) that are pretty annoying to me!

I started on a 1.9.1, that was a present from a friend, from GOG. So I never saw what came before. Except for converting some old .dae to .mu for a friend :)

Just had a random thought. In the movie "The Bourne Legacy" they kill off all the agents they have been training by swapping their pills, so they can clean house. Maybe the update is the pill to kill off KSP1 in prep for KSP2. Just a random conspiracy theory. :)

Is it any wonder I install directly and make all the decisions on what gets changed. I know what I won't be updating to.

 

Edited by ColdJ
Link to comment
Share on other sites

People are having that issue because they are trying to bypass the launcher by adding an extra command line option in steam to start a different executable than the launcher.
This is what I have seen suggested :

"C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_x64.exe" %command%

This doesn't work because the executable working directory will still be set to the "PDLauncher" subdirectory, causing cascading issues all around.

A workaround is to make a shortcut to KSP_x64.exe, let's say I'm renaming it "KSP_x64_Steam". Then in the steam command line options, point to that shortcut :

"C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Steam" %command%

This will launch the shortcut instead, with the correct working directory

Said otherwise, the only issue here is people making a mess on their own by following random bad advice on the internet.

Link to comment
Share on other sites

On 11/5/2022 at 3:02 PM, Gotmachine said:

Said otherwise, the only issue here is people making a mess on their own by following random bad advice on the internet.

Yeah, PD screws up royally the KSP launching, and the problem is people scrambling around the world trying their best to fix the mess the way they can with the little to no knowledge about what's really happening.

This could be easily avoided by just changing the PWD back to KSP root after what appears to be a patch being applied inside the t2gp_launcher_pd-a5d3559.zip file.  Assuming, of course, that there's nothing else also screwed up.

Damn it, boy, even the KSP.log is now on the wrong place, what can be understood that things are moving inside to PDLauncher now - and you still think the problem are the people trying to figure out their way of this mess?

Had I pinpointed your lack of judgment this month? No? Now I had.

— — POST EDIT — — 

I'm EATING MY WORDS on this one.

The whole ordeal was a mess. PD Launcher is not a problem. POINT. TweakScale was the one reporting something wrong, not the victim nor the cause of the problem. POINT.

Some dude tried to accomplish something on Steam Launcher, made a mistake, and then a lot of people started to shoot the messenger (TweakScale) and I got involved on the shooting without a gun.

Worst. I threw stones on someone that was knowing better. DAMN, I was the jerk this time.

Edited by Lisias
POST EDIT
Link to comment
Share on other sites

So what's the final take away from this.

There is no real solid way to bypass the new launcher and play with mods in a way that causes no issues?

Have they also messed with the original. EXE Files because I dont launch from the new launcher nor do I run ksp from steam dir But still feel some how they have messed with the original ksp64.exe file

Edited by stk2008
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...