Jump to content

KSP won't load after update completed

Recommended Posts

I run KSP via Steam, and today when I launched Steam I saw an auto update for KSP in progress. It's now at 1.12. After it completed I tried to launch KSP and it just sits at "Loading Part Upgrade" message, and the progress bar doesn't move, while the scenes and witty expressions change. All I can do is terminate the process via Task Manager. I've tried restarting my computer without success.

Any suggestions on how to fix this? Either removing the update, or running KSP from another source?

<next day>

I uninstalled KSP entirely and reinstalled it, and it ran just fine. So I started/stopped it multiple times, each time adding a single mod. Here's what I came up with:

The following three mods stop the load at the "Loading Part Upgrade" message I described originally:

  • Surface Lights
  • KIS
  • Warp Plugin - even after downloading the latest version, I received multiple file errors while trying to install it. 

MechJeb2 didn't stop the load, but did generate the 'incompatible mod' warning. 

B9Switch didn't interfere with the game loading when I first added it, but after I added Station Parts Expansion Redux I received a fatal error message related to B9Switch while the game was loading, and the game stopped on it's own, rather than allowing to quit normally. 

I'd be curious if others are experiencing the same issues. I figure I just need to be patient for each of those mods to be updated before I can continue my career game.

Edited by maddog59
Added information re: testing of various mods with 1.12
Link to comment
Share on other sites

  • 1 month later...
On 6/28/2021 at 12:32 PM, Starslinger999 said:

Im having the same loading problem and I dont have any of those mods you listed

Me too... 

I still kept Mechjeb2 in the CKAN Installed list and OK'd the message "Incompatible mods detected"... "These mods are incompatible with KSP 1.12.1:"... Mechjeb2

At least I could finally get a vessel on a path to Duna, by loading the mod version of Kerbal Alarm Clock.   Using the porkchop display it plotted a perfect low DeltaV transfer- leaving in 4 days from Kerbin orbit (which the new 1.12 maneuver feature would not generate).   

Hopefully before too long a version will be loaded up so CKAN will pull in in and it wont throw that message.   The incompatible version of Mechjeb2 executed the transfer orbit almost flawlessly (only had to do a minor correction burn.   Rendezvous will be the next thing I try... still being dependent on Mechjeb for those.  At least the time have played without mechjeb2, I learned to land pretty well now with out Smart A.S.S. help :)



Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...