Jump to content

What did you do in KSP2 today?


Recommended Posts

Somehow a portion of my last mission was in the autosave, albeit the Kraken got its hands on it, but I got it back to where I left it.


Did a new mission to launch a habitation hub. Wobble rocket was in full effect but after some strutting we got there. Although after cutting loose the SRB stage, I got the uncontrolled craft bug and lost my orbit lines. Basically eyeballed in a decent enough orbit.





Enough dV for some playing around, and parachutes to save Bill on the trip back.

Link to comment
Share on other sites

My Kerbals have decided to go fully ballistic with their newest space refueling station. They declared to launch a fully fueled, close to 1500 metric ton heavy, peak performance epiphany of Kerbal space faring ... madness.

Jebediah is very enthusiastic and confident to survive the launch. How little he knows one might say, but hey, he is actually immortal in early access. No problem here.


And this thing is well balanced with the center of mass along the main truss, however, i am eager to see how my Kerbals solve the issue with drag during ascend... 

Clearly, it will be launched vertically, and it might end in desaster...


Solar panels will be retracted, no worrys...

Link to comment
Share on other sites

Due to real bad weather i had time to do some working stuff in KSP2

Ha, another one!


This Shuttle is now docked to Alpha-1, and my Kerbals are relentlessly running around the station with their new magboots... :D

Edited by Mikki
Link to comment
Share on other sites



This is a continuation of the flat winged buggy I pushed through the "Garage Tops" race course. The base was stable enough that I was fairly certain I could make enough modifications to be flight ready.

It's "Frame" is a beam and three pairs of wings. It was essential to spam enough lift to have a stall speed low enough for the wheels to be useful- by engaging the brakes upon landing the wheels act like soft anchors (I don't know how else to explain it, but landing is very satisfying).

It fits in an XL cargo bay carried by enough RAPIERS and fuel to be an SSTO, but that's for the next update on this mission.

Link to comment
Share on other sites

On 10/15/2023 at 6:43 PM, Socraticat said:

but that's for the next update on this mission.

I made it to Laythe!

I feel like I need to jot down some notes because I just went through a lot, lol. I want to share it in detail tomorrow.

First I wanted to deliver the buggy in a cargo bay, but it lost drag after decoupling. That was the failed test that got me on Origin Island. Next, I decided to make an SSTO so I could more or less "drag" the cargo into orbit since I'm also not convinced the Cargo Bay completely negates drag from parts inside, then I would refuel and go. Laythe was too far of a target for this method even if I used a drop tank, which I tried twice (once with the wrong size decoupler on the Fuel Buddy- the pain was real on the bounce). I did technically make it with my second drop tank, but it left me without fuel at Low Laythe Orbit.

Then I decided to brute force it with a 2XL Hydrogen ball, 8 XL Hydrogen tanks, 4 Swervs, 8 DIY LF Boosters and only a handful of struts. I did as @Mikki reminded and did a completely vertical launch until escaping the atmosphere at 70K. It's not my favorite method, but if you're trying to get out of Kerbin SOI, who cares how you exit Atmo anyway... It worked perfectly. It's really hard to state how OP (not complaining) the SWERV engine is.

At Laythe my SSTO had enough fuel to pinpoint land anywhere- the cargo is intended to be dropped, but I encountered a dragless buggy after decoupling- this time it affected the buggy, not the Cargo Bay. More investigation is needed.

Then I had a soft crash where every save loaded kaleidoscope polygon madness until I rebooted the game.

I take it as a sign that it's time to log off. Until tomorrow! (or later this week, because life gets busy)

Link to comment
Share on other sites

Today I fired up KSP2 for the first time in months.  With the patch in place, and with another patch and For Science! coming, I figured I would give the game a shot.  And failed miserably.

I created a craft specifically to go to, land on, and return from Moho.  I built a 2 Kerbal lander that sits atop a 4 Kerbal command pod, with a transfer stage made of hydrogen and a lifter stage made of methalox.  Launch...and I don't have enough TWR to get off the ground.  Oh, and I don't have any RCS on it either (which will be key for docking).  And I should probably add some struts because it looks like the thing is wobbly.  Just in case, I'm going to alter the physics file to increase joint rigidity a bit.

Inside the VAB after revert, and I add some struts to keep the middle section from wobbling everywhere.  I add a couple of monoprop tanks and a bunch of RCS thrusters, and then I go to increase the lifter stage symmetry from 4 to 6 boosters.  I add the boosters...and I get only 5 of them instead of 6.  The 6th one decides it's going to stay stuck in my hand, and I can't place it on the craft at all.  I also can't delete it other than putting it in the trashcan, so now I've got 5 tanks and not 6.  Hmmm, I'll just pick up one of them and restick it...but I can't pick up any of the 5 boosters and the craft won't launch.  Ugh.  Bug report submitted, game exited.  And yes, I tried everything (revert and retry, reload craft, reload save, exit/reload game).

Sigh.  I really wanted to play today too.

Link to comment
Share on other sites

1 hour ago, Scarecrow71 said:

Today I fired up KSP2 for the first time in months.  With the patch in place, and with another patch and For Science! coming, I figured I would give the game a shot.  And failed miserably.

I feel your pain. I tried to drive a rover around in the local area (other than the KSC)

  • Every minute or so, the rover would spontaneously flip over. The game would then violently try to correct it.
  • Sometimes the rover would sink into/through the scenery
  • The rover on the runway was not the rover I built - discombobulated parts right out of the box

Apparently Anth reported on these issues which seem to be related to readjusting the origins of the rover coordinates every 1000m travelled. My fear is that it's these kind of bugs that will remain unsolved, when patching decaying orbits and wobbly rockets will be heralded as "we fixed ALL the bugs"

Link to comment
Share on other sites

Sent a Rescue craft for Valentina in Orbit only to realize 2/3rds of the way there her orbit is clockwise (vs. counter clockwise of the rescue vessel). Now doing a dV calc to determine if I have the dV to correct the trajectory or fly back to Kerbin and relaunch to the left...

Link to comment
Share on other sites

Rebuilt my Moho rocket and launched.  18,000 m/s of dV on launch, and ~14,000 while in LKO before the transfer.  Had to make MULTIPLE correction burns to get into Moho's SOI, and when I finally arrived I had ~10,000 m/s of dV remaining.  I have no idea how it took more than 4,000 m/s of dV to get from LKO to Moho, other than the calculations are not correct (which is going to make For Science! really painful).  Attempted to circularize at the Pe of ~350km, and was given a burn estimate of nearly 9,000 m/s of dV to circularize.  I had almost no fuel left to land, even though I started with 18,000 m/s of dV at launch.

I'm done with KSP2 for today...but I'm going to go into KSP1 sandbox and rebuild the same ship (sans the hydrogen tanks/engines) and see what happens.  That ship should have had more than enough fuel to get from Kerbin to Moho, detach the lander, land on the surface, get back into LMO, dock with the ship, and return to Kerbin.  I'm at a loss as to how 18k isn't enough, and I'm going to use KSP1 to prove it is.

Link to comment
Share on other sites

5 minutes ago, cocoscacao said:

@Scarecrow71 Maybe it's worth documenting the steps? Time warp used?


  1. Create vessel
  2. Go to launchpad
  3. Warp on launchpad until phase angle of 108.1 is reached
  4. Launch to LKO at ~100km
  5. Circularize (or, mostly; I think I was within 2 or 3 km here)
  6. Create node to transfer to Moho
  7. Burn
  8. Leave Kerbin's SOI
  9. Perform multiple correction burns to get an intercept with Moho
    1. This is the single-most annoying thing left in the game for me.  I can create nodes with my eyes closed in KSP1 and get intercepts.  In KSP2, it's like pulling teeth out of a bedbug while wearing a welder's mask with both hands tied behind your back.  There has to be an easier way to do this.
  10. Get into Moho's SOI
  11. Create node to circularize at Pe.  Or, rather, create node at Pe to attempt circularization

I never warp under thrust; it's not something I want to do.  I probably won't even do this when interstellar gets here, but rather will just let the 20 minute burns happen while I run off to wash dishes or something.  So, then, the only warping was between nodes (and then after the last Kerbolar correction burn, warping to get to Moho's SOI).

Link to comment
Share on other sites

14 minutes ago, Scarecrow71 said:

I have no idea how it took more than 4,000 m/s of dV to get from LKO to Moho, other than the calculations are not correct

I've definitely encountered this as well, and It does seem to be a calculation error. I do have a documented vid of burning for an interplanetary transfer and only getting 1/2 of the DV that was originally calculated. I had 2 Swerv engines mounted radially with XL tanks.

I'm loading up .5 now- going to test some frames with an old high part vessel, then maybe I'll try to get some data for this new mystery of "missing DV".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...