Jump to content

KSP 2 and Proton

Recommended Posts

On 11/3/2023 at 5:57 PM, farelinho said:

Patch 0.1.5 works fine with me, performance improved a lot! No sound issues.

I tracked the issue down. It only is happening when the new player experience is selected and the i use parts from the favourite menu in VAB. If i use the same parts in the normal menu i got sounds.


Link to comment
Share on other sites

Ok here is some detailed instructions on how to run mods:

Basic Mod Setup:

1. Download:

https://spacedock.info/mod/3277/Space Warp + BepInEx

https://spacedock.info/mod/3363/UITK for KSP 2

2. Unzip first Space_Warp__BepInEx-1.5.4.zip then UITK_for_KSP_2-2.1.1.zip

Now copy everything to:

<your steam path>/Steam/steamapps/common/Kerbal Space Program 2/

see: https://ibb.co/syhz85B

3. Activate the mod insertion:

install protontricks and dependencies:


yay -S python-vdf protontricks

see: https://docs.bepinex.dev/articles/advanced/proton_wine.html

protontricks --gui

4. Start the game once

Now no mods are actually installed yet just the basic mod supporting structure.

5. Install mods

Use CKAN for better experience.

Link to comment
Share on other sites

  • 3 weeks later...

The most supported way to run KSP2 on Linux as of 2023-11-21 (YMMV)


Ubuntu 22.04 & Proton 8 with these launch options:

PROTON_NO_XIM=1 '/home/username/.local/share/Steam/steamapps/common/Proton 8.0'/proton waitforexitandrun  '/home/username/.local/share/Steam/steamapps/common/Kerbal Space Program 2/KSP2_x64.exe' #%command%

Full Story

I finally decided to update to a newer Linux, so I thought I'd share my experience in getting KSP2 running from scratch.

I installed Ubuntu 22.04 on a fresh SSD.  Previously, I had been running 20.04.

FWIW, I chose this Linux distribution after finding the following on the Steam Client Troubleshooting on Linux page.



Currently, Steam for Linux is only supported on the most recent version of Ubuntu LTS with the Unity, Gnome, or KDE desktops.

When I installed Ubuntu I made sure to check the box labelled "Install third-party software for graphics and Wi-Fi hardware and additional media formats".

I obtained Steam via the green install button at the top of steampowered.com.  That ultimately links to https://cdn.cloudflare.steamstatic.com/client/installer/steam.deb.  Which yields a Debian package named steam_latest.deb.

I installed that from the command line like so:

sudo apt-get install ~/Downloads/steam_latest.deb

After that I launched Steam from the "Show Applications" thingy in the corner.

Initially the KSP2 install button was greyed out.  In order to make it installable I had to go into the properties of KSP2 and select Compatibility.  From there I checked the "Force the use of a specific Steam Play compatibility tool" and I then selected the latest non-experimental version of Proton.  That's Proton 8.0-4 at the moment.

The game installed fine, but the launcher would crash every time I tried to play it.

I added the following to KSP2's launch options within it's properties in order to directly launch the KSP2 game executable.

'/home/username/.local/share/Steam/steamapps/common/Proton 8.0'/proton waitforexitandrun  '/home/username/.local/share/Steam/steamapps/common/Kerbal Space Program 2/KSP2_x64.exe' #%command%

That was enough to get the game running.

Beyond that I found that an input issue I ran into on Ubuntu 20.04 persists on Ubuntu 22.04.  I reported this in the past here.

In order to work around this specific issue I added PROTON_NO_XIM=1 to the beginning of the game's launch options.  Here's the resulting launch options:

PROTON_NO_XIM=1 '/home/username/.local/share/Steam/steamapps/common/Proton 8.0'/proton waitforexitandrun  '/home/username/.local/share/Steam/steamapps/common/Kerbal Space Program 2/KSP2_x64.exe' #%command%

I hope this helps my fellow Linux users.  Solidarity comrades!

My System Specs

  • CPU: AMD Ryzen 5 3400G
  • GPU: Nvidia GeForce GTX 1080 Ti
  • RAM: 16GB DDR4
Edited by Davidian1024
Added my system specs
Link to comment
Share on other sites

Thanks for your tip!

Tried your suggestion, but I always get the same error message when using Proton 8:

Failed to initialize graphics.
Make sure you have DirectX 11 installed, have up to date
drivers for your graphics card and have not disabled
3D acceleration in display settings.
InitializeEngineGraphics failed


I can only run the game on Proton 7.

If I add PROTON_USE_WINED3D=1 , it does run on Proton 8, but with terrible performance.

Link to comment
Share on other sites

Hmm... not sure what to say about that DirectX error.  I know I've seen it in the past with other games running under Proton.  I don't think I've ever run into that one with KSP2.  Overall, Proton seems to just keep getting better.  After running under the new OS for a few days it seems like things are running great.  I had issues with a number of games.  Now, it seems like nearly everything is working flawlessly.  Performance seems better across the board too.  I think KSP2 is the only one where I'm still having to set launch options.

I added my system specs to my post.  Maybe you're just unlucky enough to have a particular hardware combo that's triggering that.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...