Jump to content

Lights Turned Off Electric Charge Drain Persists


Recommended Posts

It seems that turning the lights off doesn't cause their drain on the batteries to stop.  Once I've turned any lights on that I've added to a craft, they place a drain on the batteries.  Turning them off doesn't stop this.  This is particularly bad when doing very long time warps as even a tiny rate of drain will empty the batteries very quickly.

Note: this is about the parts that are exclusively a part that provides light.  This does not seem to include pods.  The built-in lighting that pods have doesn't seem to put any drain on the batteries at all.


KSP Version:
Operating System and version: Ubuntu 20.04.5 LTS
CPU and GPU models, any other system information which could be relevant
- AMD Ryzen 5 3400G
- NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1)
Description of the bug: see above
- Expected Behavior: once additional lights (as opposed to pod lighting) is turned on, electric charge from them is permanent
- Observed Behavior: turning off the lights should stop their drain on electric charge
Steps to Replicate: turn lights on, then turn off lights and everything that could be draining electric charge, sas for example, observe continuous drain on electric charge
Fixes / Workarounds (if known..)
- none
A list of ALL mods.  If the list is long, please consider using a spoiler window.
- No mods.
Other Notes / Screenshots / Log Files (if possible..)

Edited by Davidian1024
providing clarification
Link to comment
Share on other sites

the lights on the pods don't drain the batteries.  but the lights that you can attach to add additional exterior lighting do.  the issue i'm reporting here is that once you turn them on they start draining the batteries, but turning them back off doesn't stop this, the batteries just keep draining forever once they were turned on once.

Link to comment
Share on other sites

Just for clarification, does your vessel have any probe cores?  I ask because the probe cores also use electricity, and as far as I know that can not be turned off at present.

In KSP1 it was possible to put probe cores in 'hibernation' mode, which drastically reduced their EC drain, but I am not aware of a way to do this in KSP2 yet.


Link to comment
Share on other sites

  • 2 weeks later...
  • Create New...