Jump to content

Custom input settings not loaded at game start, requires workaround every play session.


Recommended Posts

Reported Version: v0.1.3.2 (latest) | Mods: none | Can replicate without mods? Yes 
OS: Win 10 | CPU: i7 9700 | GPU: RTX 2070S | RAM32Gb

Every time the game loads it uses default input settings and fails to load custom input settings, including reversed pitch and other commands like numpad / for staging instead of space bar.

I can get it to load all custom settings by tweaking one of them, I usually reenter pitch.

Expected behaviour would be to remember and load custom input settings at game start, like KSP1 did... pls!

EDIT to say this is still happening in the For Science! update.  v0.

Edited by boolybooly
Link to comment
Share on other sites

  • 1 month later...

Reported Version: v0.1.4 (latest) | Mods: none | Can replicate without mods? Yes 
OS: Windows 10 22H2 (build 19045.3324) | CPU: AMD Ryzen 9 5950X | GPU: Asus ROG Strix GeForce 1080 Ti OC 11gb | RAM32 gb 3200MHz DDR4


As the title says:

Changing the hotkey for staging only works until the game is restarted. This may apply to other hotkeys too, but I've not tested that.


I have previously observed this behavior between game loads without restarting the game, but I was not able to reproduce those conditions this time.


How to reproduce:

  1. From the settings menu, go into the input menu and change the hotkey for "Activate Next Stage" to right shift.
  2. Optionally place a rocket on the launch pad, but this can also be done after the next step.
  3. Save and quit the game.
  4. Reload the latest (or any) save and launch anything using the staging key that was set.
  5. It will not work and only responds to its default key (spacebar).
  6. Open the input settings menu again and observe that the setting does in fact read "Right Shift" as set key for staging.


To make right shift work for staging again, one needs to go back into the input settings and bind it to spacebar again, then rinse and repeat to bind it back to right shift (which is a little tedious).


Edited by Anth12
Link to comment
Share on other sites

  • 2 weeks later...

Reported Version: v0.1.4 (latest) | Mods: none | Can replicate without mods? Yes 
OS: W10 | CPU: i5-13600kf | GPU: RTX 4070 Ti | RAMDDR5 32GB


Hey guys! Thanks for the greatness of KSP 2.

Bug report: I changed the keybindings of docking. They work. After closing and opening the game again, the controls in the options menu are saved, but ingame they are reset to default.

Greetings from Germany!

Edited by Anth12
Link to comment
Share on other sites

  • Create New...