Jump to content
  • 33

More often than not parts are still blocked after fairings are jettisoned


QwertyHpp

Bug Report

Reported Version: v0.1.4 (latest) | Mods: none | Can replicate without mods? Yes 
OS: Windows 11 | CPU: Intel i9-9750H | GPU: RTX3060 | RAM32GB

 

I've found that a lot of the time when a part is initially covered by a fairing - it still won't deployed due to it being blocked after the fairing has been ejected. Has had this happen with landing gear, ladders, solar panels etc..

Attached one ladder example with the original craft file

 

Included Attachments:

ladders.png.0c26511522e276ea55a71e3f600afa2f.png

DAV-01.json

Edited by The Space Peacock
Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

I too encountered this weird bug.  Was getting it with a commsat network I was trying to create around Mun.  Simple devices, a couple antenna, rcs and solar panels and an octo with fuel.  They could be stacked with decouplers.  If I test these on the launch pad, they work as intended.  Once packed up with fairing, the top Sat will suffer the same fate you have...cannot deploy the solar panels or one of the antenna.  I tried using engine plates as separators to see if that fixed it.  Nope.  I create one craft, copy and paste it 2 times and stack them, the top commsat will fail but the other two will operate normally.  If I include a 4th craft instead of just 3, then the 4th one is messed up and the other 3 are fine.

I switched up with one of those tri-stack couplings inverted and placed them all individually instead of stacked.  That seemed to fix this strange problem.  Fairings had no impact here, just slightly wider.  This doesn't mean the problem is fixed IMO, could be a stacking thing still.

Link to comment
Share on other sites

  • 0

Reported Version: v0.1.5 (latest) | Mods: none | Can replicate without mods? Yes 
OS: windows 10 | CPU: Intel(R) Core(TM) i7-9700K CPU @ 3.6GHz | GPU: NVIDIA GeForce RTX 3060 | RAM31.94 GB

severity: Med

Frequency: High 

deployable parts housed within faring's are not deployable upon faring separation, specific examples directly observed include both versions of the new grid fin parts failing to deploy upon escaping a faring and both regular and drogue parachutes failing to deploy upon escaping a faring, all parts work as expected when never encased within a faring

Included Attachments:

heavydeliveryvehicle.json

Link to comment
Share on other sites

  • 0

Reported Version: v0.1.5 (latest) | Mods: not relevant | Can replicate without mods? Yes 
OS: W10 | CPU: i7-9700k | GPU: nVidia 1080Ti | RAM128GB

It never happend to me till 0.1.5.0, the satellite was earlier under a fairing and maybe the game still thinks it's there?

Included Attachments:

Link to comment
Share on other sites

  • 0

Reported Version: v0.2.0 (latest) | Mods: none | Can replicate without mods? Yes 
OS: Windows 10 | CPU: I9- 10900KF | GPU: GeForce RTX 3070 | RAM32 GB

I expected that when in orbit around Kerbin I would be able to extend solar panels and antenna on my satellite.

Instead when I go to open them up, they state that they are "blocked" 

One flight I had the solar panels working perfectly fine and then I reloaded in VAB and changed NOTHING at the top (where the solar panels were (They were locked away in a fairing) but at the bottom I added a small booster which I separate in the atmosphere. However, when I reached orbit the solar panel now states its blocked though the ONLY thing I changed were the boosters on the bottom of the rocket. This is also true for an antenna piece I had on the rocket. 

Steps to replicate

 

1. Create a spaceship where the satellite is in a fairing with solar panels and antenna ( ox-4l solar panel ) ( DTS-m1 antenna) 


2. launch said spaceship into orbit and release the fairing

3.try to extend the solar panels / antenna 

4. return to vab and change anything ?? 

5. try again 

 

PS 

It appears that the fairing might be the culprit because you can extend the parts in the VAB and change nothing but they wont extend in orbit 

Included Attachments:

Link to comment
Share on other sites

  • 0

Reported Version: v0.2.0 (latest) | Mods: none | Can replicate without mods? Yes 
OS: win 11 | CPU: i7 | GPU: rtx 3080 | RAM32

 

starting: I had 2.5m fairing, deployed it. I had 4 deployable solar panels within it.

1) deployed fairings

2) now solar panels are not obeying extract command, i cant do anything about them.

3) Timewarping just a second forward

4) now solar panels works as intented.

 

 

Included Attachments:

Edited by Spicat
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this report...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...