Jump to content

Recommended Posts

I have several craft of identical type flying around the solar system. When i switch to control between *some* of them... they are spinning out of control.
I have had a hard time tracking down specific solutions... or if this is a bug. 

If i have come to the wrong place please delete this comment, but i dont really understand. Nothing i can do will snap it out.
Initiate Small thrust with auto gimbaled vectoring,
SAS on / off,
RCS on / off,
Switching between active maneuver nodes,
losing game,
its always the same.

Once it starts.. its over.
I can link pics if wanted, but i have run over a dozens flights with the exact same build and it only happens on some (between the vast time frames of interstellar distances).
Is there something i can do to salvage the time invested in these missions?

Link to comment
Share on other sites

I had this happen once, when I rendezvoued with a ship it was in a crazy spin.

I can't remember if time warp stopped it from spinning, or F5/F9 re-engaged the reaction wheels, but I do remember that I WAS able to regain control.

Link to comment
Share on other sites

  I have tried systematically engaging reaction systems in various combinations.. all on to all off and everything in between.  

  Time warping will stop it, but like the Station Chatter bug from KSP1 it starts up again.

Immediately Post Timewarping

  The craft does not respond to inputs 

   Engaging SAS will not stop when moving over indicated maneuver icon. [ Other craft do ]

   Instead small oscillations begin and increase cycle / dissonance with every NAV ball rotation.

Wanted to Describe "phenomena" more accurately

Plenty of MP & EC to spare with Solar in excess of consumption

I am very glad someone else has encountered the issue with success at remedy. Thanks for the encouragement.

Link to comment
Share on other sites

  • 4 weeks later...

I'm having this now, too, which is making docking impossible. On top of that, right-clicking parts in Flight view no longer brings up the Part Manager (nor are they highlighted) and I can't target other vessels. F5/F9 makes most of the issues go away for a moment, but as soon as I start trying to control from docking ports or anything it starts back up again.

I've got a whole pile of mods installed, but I suspect K2-D2 is heavily involved as it's the only thing I have that really tries to assume control of the vehicle. Gonna try running with that disabled and see what happens.

Link to comment
Share on other sites

It happened to me yesterday too and I don't have K2 installed.  As I was getting closer to my target, I was wondering why my target icon on the Navball kept moving around funky.  As I got within 100m of the craft I could see it spinning and the navball target was going around and around the nav ball.  Had to reload a save, took control of the vessel that was previously spinning, and made sure that SAS lock was on. That seemed to stop it from spinning thereafter.

Link to comment
Share on other sites

Yeah, I noticed no difference after disabling K2. I've had the "vessel randomly spinning when switching to" issue previously, but doing what you said (or flicking time warp on briefly) has resolved it. When I try controlling a station from anything other than its anchor assembly, it seems, even having SAS lock on seems to start triggering an accelerating spin and no amount of input will reign it in.

Link to comment
Share on other sites

I had a similar issue, to me it usually happened when i had different SAS Systems in different orientations. The systems seem to work against each other.

Disabling some of the stabilizers or inverting their direction sometimes worked well. But that's not how it is supposed to work.

A deep-dive with various testing scenarios might help, figuring out hats really causing the problem - but most of the time i got the problem under control.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...