• 0
Sign in to follow this  
Creat

Suddenly missing Speed-Milestone (Contract)

Question

While doing an early orbital mission in my new career game, somehow the "Speed Record"-contract for 2500 m/s vanished. I did reload a quicksave (or two) during the mission, but otherwise it was nothing special. I surely didn't cancel it, it was just suddenly gone after loading a quicksave.

I even have a screenshot of me going faster than the required speed, with the goal not completed. The screenshot was taken (relatively deep) in atmo, but I also reached a high enough speed outside / in space. Also note that it's a prograde orbit, so the displayed "surface" velocity is lower than the orbial velocity would be.

I had to reload a quicksave, and the contract (or goal) was just gone. I checked mission control, it's not in the archives (speed records ends at 1050 m/s), it's not available or active, and when manually checking the savegame files (both various quicksaves and the persistent file) this entry is also nowhere to be found.

So all in all I'm just mostly confused now. What could've possibly happened that vanished this entry? As far as I know you can't manually cancel them or even fail them. I don't know how important that goal is, but the larger milestones usually have a significant payout (which I wouldn't mind)

I do have a couple of mods installed, mostly GUI-stuff or tools though: kerbal engineer, PlaneMode, WaypointManager, Enhanced NavBall, ContractsWindow Plus, Alternate Resource Panel KSP-AVC and Module Manager. Everything is up to date as of noon CEST today.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I sort of replied to this on the Contracts Window + thread:

Anyway, playing around with it, I didn't see anything that would explain the behaviour of the contracts not completing (I assume that has nothing to do with the auto-accept nature). I'm fairly certain that it kicks off based on the various ProgressTracking events, which would either be OnProgressAchieved, OnProgressReached or OnProgressComplete. There would *have* to be discrete steps at which those fire, maybe the steps for the contracts and progress tracking are out of sync? That's my best guess....

Anyway, nothing really conclusive - maybe Arsonide will see this and fill us in. :)

Share this post


Link to post
Share on other sites
  • 0

There is also a mention of this contract not completing in the [thread=117365]hotfix thread[/thread]; it might be necessary to be out of the atmosphere.

I've seen the disappearing problem too though, this is the only contract it's happened to so far.

Share this post


Link to post
Share on other sites
  • 0
There is also a mention of this contract not completing in the [thread=117365]hotfix thread[/thread]; it might be necessary to be out of the atmosphere.

I've seen the disappearing problem too though, this is the only contract it's happened to so far.

For at least one of my attempts I was outside of the atmosphere, it still didn't complete. At the time I wasn't much over the required speed, but I was over (both for Orbit and for Surface readings). I wasn't much outside of the atmo either, but still outside (71 km or so). So after that try I basically gave up and reentered (where I took the screenshot), and I went over by a whole lot and it still didn't complete.

It was just confusing, but this whole thing makes it much more unlikely that it has anything to do with ContractsWindow+, which is the only mod I use that has anything to do with contracts... I'm having a look at the 1.0.1 thread now.

Share this post


Link to post
Share on other sites
  • 0

Hello.

I just wanted to let you know that the issue is still there (v1.0.2.842). I had the speed record contract for 2500 m/s vanish as well.

I had a rocket go straight up and down, so that it met the three contracts for 70 km altitude, escape the atmosphere and (on the way back down) 1050 m/s speed respectively. After having clicked around the KSC and entered the mission control building I noticed the contract had vanished. Ten new contracts had appeared as available and one of them was a visual survey (don't know what information will help debug the issue).

I exited KSP, started KSP again, loaded a save from before the rocket launch and did the mission exercise again, so that the three contracts (70km, escape and 1050m/s) completed. This time the 2500 m/s contract stayed. On this occasion 'only' eight new available contracts appeared and not the visual survey one.

Is it possible there is some mix-up in the random contract generation that can make the world record contract disappear?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this