• 0
Sign in to follow this  
Sivonen

Joystick rudder axis not detected

Question

Using 1.2.2. x64, Windows 10.

I can set my joystick controls alright, except KSP does not recognize my joystick's rudder and throttle axis. Other axis' are working well (finally!).

My joystick controller is Arduino Pro Micro.

In other games and in windows control panel joystick settings the axes are working well.

I think it's axis 1.2.

 

I found a workaround to set the potentiometer to use axis called "Y-axis" instead of throttle/rudder, but the problem persists, there's two axes that I can't use.

 

My TM HOTAS 4 works perfectly in KSP.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Does Windows itself recognise your controller?
In other words, does the Arduino advertise all the axes properly?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this