Jump to content
  • 0

Failing to load on Xbox one


Evergood
 Share

Question

I have just downloaded and installed kerbal space program enhanced edition from the Microsoft app store. When launched it stays on the initial screen and the Xbox goes very unresponsive. I have tried a restart and removal.of power with restart. I have also uninstalled and reinstalled and repeated above after that as well, but same result .. it just sits on the initial screen.

Can anyone provide a resolution please.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...