Jump to content

Recommended Posts

I know there was some weirdness with using these in the past, but I had previously worked it out for a couple parts I use/made.

After this last update I've run into an interesting problem. The part is question is cylindrical and in 3 sizes. Before I used separate models, textures, and configs. In those configs I ended up using plain scale and left rescaleFactor alone. This still works, but I was trying to consolidate everything down into a single folder/file. For ease of use I figured I would try using rescaleFactor to move the nodes around, and that's where I ran into troubles.

When I first select a part from the menu it appears in its "raw" size. IE a standard cylinder modeled at 80cm, which would normally be 1m in game, appears 80cm in game. However, if I leave the VAB and return the part shows at the proper size. The workaround is just to do it how I was before with scale... But I am kind of curious if there is a way to get around this problem and still use rescaleFactor?

Link to post
Share on other sites

I've never experienced this but I've also never worked with a non-1:1:x part. You should try correcting the model in Unity or earlier so your actual model file is the size of your 'normal' sized part and then you get simple rescaleFactors to the other sizes you want without having to involve scale, which generally speaking should always equal 1 (and always be declared) unless you modeled something in the wrong scale and can't be asked to fix it or don't have the raw assets anymore (ie, certain old stock parts)

Now, if you're using MODEL{} and a necessary because of that MODEL{ scale }, it has a whole different set of glitches which don't sound like what you're experiencing, but suffice to say the value of MODEL{scale} and rescaleFactor must multiply to equal 1 or refactorScale has to be the square of what you want, but don't quote me on the later.

Link to post
Share on other sites

The original part is modeled at 80cm, which ends up 1m if I don't use rescale at all (Default seems to be 1.25?).

All 3 sizes are set to scale = 1.0, 1.0, 1.0; is that what I want, or are you saying I have to play around with a combination of the two?

I am also just going to make the original bigger. Main thing I am trying to do is just use the one model and set of textures rather than 3 like I had been before. It sounds kind of like I'd be better off just doing what I had done before and altering scale then calculating the new nodes myself. Not a big deal, but cuts down on how lazy I can be if I decide I want a bigger or smaller part later, lol. Thanks.

Link to post
Share on other sites

scale = x,x,x means you're using MODEL{} and it's screwy, read more about it here http://bugs.kerbalspaceprogram.com/issues/1123

Short of it is, if you use MODEL{},



scale = X,X,X


scale = 1

rescaleFactor = X

X*Y = 1

Else bad stuff happens

If you want to make the model different, set rescaleFactor = the-scale-you-want and MODEL{scale=1/rescaleFactor}

If you want it to be the raw scale, set all three to 1.

Be warned, I've only tested this with a limited number of values for rescaleFactor but I can tell you rescaleFactor is what nodes scale by so you want it to be the actual scale that you desire in the end or you'll have to reset your nodes for every part, which should be math but it's still work.

Edit: Wait a minute, I may have just thought of something, let me go make sure I'm not an idiot.

Edit2 Nope, nevermind, I'm only as stupid as I thought I was, all of this continues to be accurate to the best of my understanding.

Edited by Greys
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...